The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  вход/выход  слежка  RSS
"Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от opennews (ok) on 08-Дек-16, 09:45 
Разработчики дистрибутива openSUSE сообщили (https://lizards.opensuse.org/2016/12/07/amdati-catalyst-fglr.../) о прекращении поддержки rpm-пакетов с классическим драйвером AMD Catalyst (fglrx), который не обновлялся компанией AMD с декабря (https://www.opennet.ru/opennews/art.shtml?num=43551) прошлого года и  поддерживает работу только с X-server 1.17 и ядрами Linux до 3.19. Пакеты для ныне развиваемого в AMD гибридного проприетарного драйвера AMDGPU-PRO (https://www.opennet.ru/opennews/art.shtml?num=44698), построенного на базе модуля AMDGPU, поддерживать  не планируется. Пользователям современных графических карт AMD на базе архитектуры GCN, рекомендуется перейти на использование открытых драйверов AMDGPU/RadeonSI, для работы со старыми сериями GPU AMD можно применять открытые mesa-драйверы radeon и r600 в связке с drm-модулем ядра radeon.

URL: https://lizards.opensuse.org/2016/12/07/amdati-catalyst-fglr.../
Новость: https://www.opennet.ru/opennews/art.shtml?num=45637

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –2 +/
Сообщение от Zenitur (ok) on 08-Дек-16, 09:45 
Я надеюсь что в платной версии оставят? А то мне надо.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору
Часть нити удалена модератором

6. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Zenitur (ok) on 08-Дек-16, 09:54 
Поясню. В коммерческом SLED, когда вводишь серийник (в т.ч. триал на 60 дней) сразу появляется окошко "добавляем репозитории NVIDIA и ATi". http://www2.ati.com/suse/ и нам сразу ставят проприетарный драйвер. Это типа убунтовская фишка с "Менеджером проприетарных драйверов" без ручной возни, но в убунте - бесплатно.

Если щас репо пропадёт, мне будет печально. Ну хоть рабочее место уже настроено.

Ответить | Правка | Наверх | Cообщить модератору

16. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от АНГЫВНАГЫНВАШЩ on 08-Дек-16, 11:20 
До следующего обновления SLE не должны.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

50. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +3 +/
Сообщение от Аноним (??) on 08-Дек-16, 17:31 
> Я надеюсь что в платной версии оставят? А то мне надо.

Чтобы специально ради тебя тянули старые ядра и иксы или реанимировали разработку древнего проприетарного драйвера - надо быть или очень состоятельным человеком, или очень крутым разработчиком.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

68. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Аноним (??) on 08-Дек-16, 20:16 
А вот этому что помешало? "Пакеты для ныне развиваемого в AMD гибридного проприетарного драйвера AMDGPU-PRO, построенного на базе модуля AMDGPU, поддерживать не планируется".

Состояние нестояния у разрабов Суси?

Ответить | Правка | ^ к родителю #50 | Наверх | Cообщить модератору

69. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –2 +/
Сообщение от Аноним (??) on 08-Дек-16, 20:21 
> Состояние нестояния у разрабов Суси?

Смысла в этом все меньше и меньше. Vulkan чувак из RH запилил, OpenCL амд откроет. Что там у каталиста в плюсах? Мифический GL 3.x и новее в compat context? Это надо только на воркстэйшнах полутора программам на всю планету. В общем ИМХО открытый стэк FTW.

Ответить | Правка | ^ к родителю #68 | Наверх | Cообщить модератору

76. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –2 +/
Сообщение от Аноним (??) on 08-Дек-16, 23:27 
> Это надо только на воркстэйшнах полутора программам на всю планету.

та-та, а вообще, чего уж стесняться: кому нужны пользователи с 1% рынка, да?

Ответить | Правка | ^ к родителю #69 | Наверх | Cообщить модератору

83. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +1 +/
Сообщение от Аноним (??) on 09-Дек-16, 00:24 
> та-та, а вообще, чего уж стесняться: кому нужны пользователи с 1% рынка, да?

АМД видимо нужны, раз пилят. А так - знаешь, есть такая фигня как топ500 суперкомпьютеров. И там 1% далеко не линухов. Наверное АМД и туда метит. А почему не должны? Вычисления на GPU традиционно сильная область и я не понимаю как они так пробакланили HPC. Но сейчас они это могут и поднаверстать наверное, переманив на свою сторону developers, developers и причастных :)

Ответить | Правка | ^ к родителю #76 | Наверх | Cообщить модератору

72. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Онаним on 08-Дек-16, 20:50 
В openSUSE не поддерживают закрытые драйвера. Для Leap нвидия собирает пакеты.
Нужно качать инсталлятор с сайта и ручками устанавливать.
Ответить | Правка | ^ к родителю #68 | Наверх | Cообщить модератору

91. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +1 +/
Сообщение от Дмитрий Марков email on 10-Дек-16, 10:10 
фигню городишь, есть репо с блобами для nvidia на opensuse прямо на серверах nvidia
Ответить | Правка | ^ к родителю #72 | Наверх | Cообщить модератору

3. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от anonymous (??) on 08-Дек-16, 09:47 
Я, конечно, понимаю, что у невидии всё плохо, но тут вообще ужас.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от fdgergfaewfdghsdgaertg on 08-Дек-16, 09:51 
Помимо проблем с конфигурацией интегрированная+дискретная насколько там все плохо?
У самого Gtx750ti, жаловаться вообще не на что. Может, я чего-то не замечаю? Да, есть проблемы с 2d ускорением. Такое ощущение, что оно работает наполовину, но я привык винить иксы.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

7. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –2 +/
Сообщение от Zenitur (ok) on 08-Дек-16, 09:57 
> Я, конечно, понимаю, что у невидии всё плохо, но тут вообще ужас.

У NVIDIA только одна проблема - в 361.xx некоторые конигурации с Оптимусами отвалились. Например 740M работает, а 650M - нет. Решается патчем на X-Server, который я нашёл в убунтовском DEB-SRC.

А в остальном всё вообще шикарно. Я поднял KMS на дискретке. Я сделал Glvnd на Оптимусе (теперь Intel и NVIDIA работают одновременно). Прикольный конструктор. Два дня долбался.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

12. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –5 +/
Сообщение от AlexYeCu_not_logged on 08-Дек-16, 10:31 
Вот если б на десктопах так можно было сделать.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

18. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +5 +/
Сообщение от th3m3 (ok) on 08-Дек-16, 11:42 
Долбанный optimus на десктопе? Боже упаси!
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

65. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от AlexYeCu (ok) on 08-Дек-16, 19:01 
> Долбанный optimus на десктопе? Боже упаси!

Одновременная работа дискретки и интеграшки, причём вторая — в полном, а не урезанном варианте.

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

70. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 08-Дек-16, 20:24 
> Одновременная работа дискретки и интеграшки, причём вторая — в полном, а не
> урезанном варианте.

А что, если в систему с APU воткнуть вторую видеокарту - желаемое не получится? Минус геморрой с энергосбережением и переключениями  - менее актуально в системах подеключенных к розетке. Да и извращения с тяганием DMA картинки из безголового GPU не требуются - можно мониторы к выходам видях прицепить.

Только нафиг тебе на десктопе интеграт? Чтобы GPU гонял сотни гигз по системной шине памяти, просаживая CPU? Даже GDDR5 - быстрее обычной памяти на графических задачах раз в 10. А если HBM вспомнить... ух...

Ответить | Правка | ^ к родителю #65 | Наверх | Cообщить модератору

74. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –2 +/
Сообщение от AlexYeCu (ok) on 08-Дек-16, 22:43 
>А что, если в систему с APU воткнуть вторую видеокарту - желаемое не получится?

Нет. По крайней мере в связке intel + nvidia. Причём проблема эта не на уровне оси.  AMD + AMD, вроде как, могут и работать.

>Только нафиг тебе на десктопе интеграт?

Во-первых, он уже есть на всех современных x86 матерях. Во-вторых, было б не лишним пробросить оный в виртуалку. К сожалению, запустить интеграшку одновременно с дискреткой можно только в сильно урезанном варианте и с неродным драйвером, что делает идею с пробрасыванием бессмысленной.

Ответить | Правка | ^ к родителю #70 | Наверх | Cообщить модератору

78. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +1 +/
Сообщение от Аноним (??) on 08-Дек-16, 23:30 
> Во-первых, он уже есть на всех современных x86 матерях.

здрасьти! — он не на матерях, а в ЦПУ

Ответить | Правка | ^ к родителю #74 | Наверх | Cообщить модератору

86. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от AlexYeCu_not_logged on 09-Дек-16, 11:45 
>здрасьти!

Привет! Это детали. О чём речь — ты понял

Ответить | Правка | ^ к родителю #78 | Наверх | Cообщить модератору

92. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 11-Дек-16, 00:38 
детали, не детали, но особенностью современных систем как раз является интеграция всего что ни попадя в ЦПУ, это типа «рывалюцея» в современной ВТ
Ответить | Правка | ^ к родителю #86 | Наверх | Cообщить модератору

93. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 11-Дек-16, 03:49 
А нехрен брать АПУ вместо ЦПУ.
Ответить | Правка | ^ к родителю #92 | Наверх | Cообщить модератору

80. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 08-Дек-16, 23:35 
> Нет. По крайней мере в связке intel + nvidia. Причём проблема эта не на уровне оси.

Это скорее всего проблема на уровне интеграции с осью. Что у нвидии традиционно в ауте, поскольку они все такие из себя независимые ядерщики. И их драйвер с системой не интегрируется от "никак" до "хреново". Что ты хотел? Чтобы там продвинутые конфиги нормально работали? Да еще mixed сетапы? Может еще и без глюков? А для этого надо нормально взаимодействовать с остальными разработчиками, а не как нвидия.

> AMD + AMD, вроде как, могут и работать.

И даже amd + intel наверное. А воткнуть красную печку вместо зеленой и проверить? А какие предпосылки чтобы это не работало? По логике вещей будут две видяшки. Сам по себе DRM/KMS нормально к такому относится.

Еще может в BIOS есть нечто про init GPU first или как там его ... и если там приоритет у PCI-E девайса, интеграт может и не инициализироваться. И вот тут я не знаю что сделает интелский драйвер и тем более нвидиевский. У меня есть системы с несколькими красными печками, амдшный открытый драйвер нормально к этому относится. BIOS не инициализирует вторичные девайсы. Драйвер это замечает, пинает POST девайса уже своими силами и secondary девайс(ы) идут на взлет.

> Во-первых, он уже есть на всех современных x86 матерях. Во-вторых, было б
> не лишним пробросить оный в виртуалку.

Вот с этим наверное сложно т.к. он память ту же использует. Вот дискретку пробросить - номер катит. Отцепляешь в хосте, отдаешь виртуалке, и когда там стартанет драйвер - он увидит PCI девайс и проинициализирует как обычно.

> К сожалению, запустить интеграшку одновременно с дискреткой можно только
> в сильно урезанном варианте и с неродным драйвером, что делает идею с пробрасыванием бессмысленной.

Именно интеграшки? Это вообще извращение какое-то. А поставить несколько железных и часть пробросить по виртуалкам - так делают, недавно амдшники даже чинили баги характерные для таких сетапов.

Только это.. в системе для таких развлекух IOMMU должен быть (включен в bios setup и загружен драйвер в ОС). Без iommu девайс вынесет системе мозг первым же DMA запросом который угодит совсем не туда куда предолагалось - iommu должен подхачить обращения к памяти со стороны девайса в этот момент. А вот как это для интеграта должно выглядеть при том что там системная память используется... говоря за амдные gpu в apu они более тесно с процом взаимодействуют чем отдельный PCI-E девайс с процом, там бывает память видимая обоим и проч (zero-copy пересылка текстур и проч).

Ответить | Правка | ^ к родителю #74 | Наверх | Cообщить модератору

88. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от AlexYeCu_not_logged on 09-Дек-16, 11:54 
> Это скорее всего проблема на уровне интеграции с осью.

Разные идентификаторы карт при разных настройках в биосе и залоченый в том же биосе объём доступной рамы для разных настроек — это проблемы «интеграции с осью»? Ок.

>А воткнуть красную печку вместо зеленой и проверить?

Что проверить: работает ли в этот раз выделение в blender при включённом АА? Увы, с АМД-шными картами всё ещё встречаются презанятные проблемы. А проверять каждую новую модель и каждую версию драйвера в надежде, что уж с ней-то всё ок — удел энтузиастов.

>Еще может в BIOS есть нечто про init GPU first или как там его

Там всё хитрее. Если GPU First, то интеграшки нет.
Если multiGPU, то есть, но с другим идентификатором и подрезанной памятью.
CPU First Не устраивает по понятным причинам.

>А поставить несколько железных и часть пробросить по виртуалка

Можно. Но, будь возможность пробросить интеграшку, это было б куда удобней, нет? Она уже есть, она не занимает слот, её охлаждение обеспечивает кулер CPU.

Ответить | Правка | ^ к родителю #80 | Наверх | Cообщить модератору

77. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 08-Дек-16, 23:29 
> Вот если б на десктопах так можно было сделать.

мсье является идеологическим последователем маркиза де-Сада?

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

29. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Sunderland93 (ok) on 08-Дек-16, 13:11 
>>Я поднял KMS на дискретке.

Я тоже. Чел, объясни, что это даёт? Высокое разрешение в консоли один хрен не работает с fbdev, нужен efifb.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

34. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 08-Дек-16, 14:25 
У меня работает. Ты сделал options nvidia-drm modeset=1?
Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

53. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 08-Дек-16, 17:34 
> У меня работает. Ты сделал options nvidia-drm modeset=1?

Вот как-то так нвидия и "работает". Единственная компания у которой установка и запуск драйвера такой же гемор как и виндовые блобы.

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

85. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от ryoken (ok) on 09-Дек-16, 11:18 
> У меня работает. Ты сделал options nvidia-drm modeset=1?

ПОдскажите, а это куда надо вкрутить? В /etc/default/grub про modeset уже написано, а вот nvidia-drm..?

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

54. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +2 +/
Сообщение от Аноним (??) on 08-Дек-16, 17:36 
> отвалились. Например 740M работает, а 650M - нет. Решается патчем на
> X-Server, который я нашёл в убунтовском DEB-SRC.

Нвидия - очень дружественные к пользователям видеокарты :)

> А в остальном всё вообще шикарно. Я поднял KMS на дискретке.

Теперь еще попробуй им попользоваться и чтобы это все не глючило по черному.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

79. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +2 +/
Сообщение от Аноним (??) on 08-Дек-16, 23:32 
#нажифорсахпраблемнет!!111

Ответить | Правка | ^ к родителю #54 | Наверх | Cообщить модератору

73. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +2 +/
Сообщение от электронщег on 08-Дек-16, 21:47 
> У NVIDIA только одна проблема

Не только лишь не одна проблема, есть ещё их.

Например, последний на данный момент релиз 304.132 вообще нафиг сломан (OpenGL не работает), половина дистров уже откатилась на предыдущий (131).

https://devtalk.nvidia.com/default/topic/968892/geforce-7300...

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

51. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +1 +/
Сообщение от Аноним (??) on 08-Дек-16, 17:32 
> Я, конечно, понимаю, что у невидии всё плохо, но тут вообще ужас.

У амд в отличие от - с открытыми дровами работает DRM/KMS, а у нвидии он до сих пор урезанный и с кучей глюков. Поэтому нвидиафаны наслаждаются всем чем могут - от расколбасов при переключении режимов до тиринга в видео.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

87. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Denis email(??) on 09-Дек-16, 11:48 
А я вот ровно вчера купил AMD вместо NVIDIA. Достали тиринг на проприетарных или мертвое зависание без них. С амд поставил открыте драйвера и все работает. Наконец можно не ждать проблем при обновлении ядра и нормально федорой пользоваться.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

8. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +3 +/
Сообщение от Аноним (??) on 08-Дек-16, 09:58 
"рекомендуется перейти ..." на другой дистрибутив.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

14. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +2 +/
Сообщение от J.L. on 08-Дек-16, 10:52 
> "рекомендуется перейти ..." на другой дистрибутив.

не они первые выкинули, сабайон уже несколько месяцев как удалил из репа проприетарные дрова (вроде модули для всех ядер вообще, а не только для новых/будущих)

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

23. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +1 +/
Сообщение от анн on 08-Дек-16, 12:03 
кто все эти люди?
Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

38. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Аноним (??) on 08-Дек-16, 15:25 
Пфе. В федоре уже оно два года как не работает. В общем, если у вас ATI/AMD, то сидите на Debian Jessie и не тявкайте.
Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

56. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 08-Дек-16, 17:39 
> Пфе. В федоре уже оно два года как не работает. В общем,
> если у вас ATI/AMD, то сидите на Debian Jessie и не тявкайте.

Удачи там что-нибудь на основе GCN запустить. AMD - это GCN как раз, а VLIW-ы это наследие ATI.

Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

55. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +2 +/
Сообщение от Аноним (??) on 08-Дек-16, 17:37 
> "рекомендуется перейти ..." на другой дистрибутив.

На другой глобус. Классический каталист более никто не разрабатывает.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

94. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 11-Дек-16, 03:51 
А чем этот ваш котоглист лучше свободных дров?
Ответить | Правка | ^ к родителю #55 | Наверх | Cообщить модератору

9. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –2 +/
Сообщение от Аноним (??) on 08-Дек-16, 10:03 
Открытые драйверы это конечно здорово, но у них в крайнем релизе ядро 4.4 и меза старая, которые вышедшие летом карточки АМД не поддерживают в принцципе, и никакого решения этого вопроса не планируется. Десктопный дистр, чо. Только не рассказывайте мне про репозиторий X11:Xorg, он даже отдаленно на хорошее решение проблемы свежих драйверов не похож.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

11. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +4 +/
Сообщение от Аноним (??) on 08-Дек-16, 10:27 
"Пакеты для ныне развиваемого в AMD гибридного проприетарного драйвера AMDGPU-PRO, построенного на базе модуля AMDGPU, поддерживать не планируется."

Почему?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

15. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +2 +/
Сообщение от Аноним (??) on 08-Дек-16, 10:53 
> "Пакеты для ныне развиваемого в AMD гибридного проприетарного драйвера AMDGPU-PRO, построенного
> на базе модуля AMDGPU, поддерживать не планируется."
> Почему?

AMD распространяет пакеты только в формате deb и бывший мэйнтейнер fglrx в openSUSE не намерен больше горбатиться на проприетарщину без какой-то обратной отдачи (речь про помощь в решении проблем и в сопровождении).

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

26. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 08-Дек-16, 12:41 
Плюсую. У меня всё никак не получалось поставить этот DEB в Gentoo. Теперь добрые люди написали ebuild - хрен знает, работает ли.

Я советую всем, кто хочет ставить amdgpu-pro на не-Ubuntu, использовать пакеты из SteamOS. Там модуль ядра - отдельным DKMS-модулем. В то время как официальный DEB-пакет для Ubuntu требует ядра, в составе которого есть этот модуль.

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

27. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Анончик on 08-Дек-16, 12:49 
> Плюсую. У меня всё никак не получалось поставить этот DEB в Gentoo.
> Теперь добрые люди написали ebuild - хрен знает, работает ли.
> Я советую всем, кто хочет ставить amdgpu-pro на не-Ubuntu, использовать пакеты из
> SteamOS. Там модуль ядра - отдельным DKMS-модулем. В то время как
> официальный DEB-пакет для Ubuntu требует ядра, в составе которого есть этот
> модуль.

По-моему всё правильно, не включил amdgpu в ядре - ССЗБ. Ну а использовать дистры в которых оно не включено - это надо быть мазохистом наверное.

Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

35. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +1 +/
Сообщение от Аноним (??) on 08-Дек-16, 14:26 
>> Плюсую. У меня всё никак не получалось поставить этот DEB в Gentoo.
>> Теперь добрые люди написали ebuild - хрен знает, работает ли.
>> Я советую всем, кто хочет ставить amdgpu-pro на не-Ubuntu, использовать пакеты из
>> SteamOS. Там модуль ядра - отдельным DKMS-модулем. В то время как
>> официальный DEB-пакет для Ubuntu требует ядра, в составе которого есть этот
>> модуль.
> По-моему всё правильно, не включил amdgpu в ядре - ССЗБ. Ну а
> использовать дистры в которых оно не включено - это надо быть
> мазохистом наверное.

В SteamOS просто Linux 4.1. Они один раз бампнули ядро с 3.18 (дефолт в Debian 8.0) а потом их достало ради одного драйвера обновлять целое ядро. И они просто сделали DKMS-модуль отдельным пакетом.

Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

57. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +1 +/
Сообщение от Аноним (??) on 08-Дек-16, 17:40 
> AMD распространяет пакеты только в формате deb и бывший мэйнтейнер fglrx в
> openSUSE не намерен больше горбатиться на проприетарщину без какой-то обратной отдачи
> (речь про помощь в решении проблем и в сопровождении).

Нехай рулит открытый драйвер :)

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

21. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +2 +/
Сообщение от анонимус (??) on 08-Дек-16, 12:00 
Потому-что на подходе мерж DAL в открытый драйвер. А когда его смержат от AMDGPU-pro останется только реализация OpenCL. Которую кстати энтузиасты уже перенесли на сусе.
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

58. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +1 +/
Сообщение от Аноним (??) on 08-Дек-16, 17:42 
> Потому-что на подходе мерж DAL в открытый драйвер. А когда его смержат
> от AMDGPU-pro останется только реализация OpenCL. Которую кстати энтузиасты уже перенесли на сусе.

Они работают над открытием реалиации OpenCL из каталиста. И единственный смысл проприетари останется вообще только в профессиональных рабочих станциях где GL 3.x и новее доступен не только в core-profile, но и в compatible.

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

13. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от J.L. on 08-Дек-16, 10:50 
кто знает - подскажите куда писать чтоб была реакция если дискретка амд в ноуте при попытке включения питания (DRI_PRIME=1) сыпет ошибками в лог и активной остаётся интеграшка (амд) онли (временами падает в сегфолт при этом)
а при попытке стартовать иксы в конфиге "только дискретка" видеовывод или виснет нафиг (экран отключается, управление с клавиатуры остаётся, можно перейти в текстовую консольку, даж графическую консольку (видимо рисуемую интеграшкой)) или опять не стартует с ошибкой
на этапе загрузки ядра тоже что-то ошибочное про видеокарту
карточке уже года три, и года 1,5 назад свободные дрова умели один раз включить дискретку и если не выключать то так и работала
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

17. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +2 +/
Сообщение от АНГЫВНАГЫНВАШЩ on 08-Дек-16, 11:25 
> подскажите куда писать

сюда https://bugs.freedesktop.org/

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

59. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +2 +/
Сообщение от Аноним (??) on 08-Дек-16, 17:43 
> сюда https://bugs.freedesktop.org/

Только там надо не
> на этапе загрузки ядра тоже что-то ошибочное про видеокарту

указать а точную копипасту все-таки.

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

19. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Аноним (??) on 08-Дек-16, 11:59 
А что у амд все так плохо? Они же там грозились все открыть и взяться за линукс...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

22. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +7 +/
Сообщение от анонимус (??) on 08-Дек-16, 12:02 
Именно это они и сделали. Они написали открытый драйвер AMDGPU, а старый Catalyst забросили. Вот его поддержку и прекратили.
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

24. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Аноним (??) on 08-Дек-16, 12:06 
> Драйвер сформирован только для Ubuntu 16.04
Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

25. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Аноним (??) on 08-Дек-16, 12:34 
Вот только открытый драйвер AMDGPU (не путать AMDGPU-PRO) составе самого свежего релиза дистрибутива, openSUSE 42.2, очень старый, и не поддерживает целую кучу видеокарт. И его обновление не предвидится до следующего релиза.
Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

28. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Анончик on 08-Дек-16, 12:55 
> Вот только открытый драйвер AMDGPU (не путать AMDGPU-PRO) составе самого свежего релиза
> дистрибутива, openSUSE 42.2, очень старый, и не поддерживает целую кучу видеокарт.
> И его обновление не предвидится до следующего релиза.

Это проблема всех СТАБИЛЬНЫХ дистров и дистров с жёсткими релизами. В этом плане разве что убунта выделяется с регулярным бекпортированием свежих ядра и мезы в текущий релиз.

Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

37. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +3 +/
Сообщение от Sluggard (ok) on 08-Дек-16, 14:46 
> Это проблема всех СТАБИЛЬНЫХ дистров и дистров с жёсткими релизами. В этом
> плане разве что убунта выделяется с регулярным бекпортированием свежих ядра и
> мезы в текущий релиз.

В Сусе можно подключить репы Kernel и X11 и будет тебе самый свежак ядер и Месы даже в стабильной версии дистра.

Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

44. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 08-Дек-16, 15:56 
kernel это еще куда ни шло, но X11 подключать категорически не рекомендуется, там с завидной регулярностью оказываются сломанные пакеты, а все потому, что этот реп для разработчиков openSUSE, а не для его пользователей.
Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

46. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Sluggard (ok) on 08-Дек-16, 16:26 
Категорически не рекомендуется кем? А то я два года с ним живу, и всё хорошо. А может и дольше, не помню, был ли он подключен на старом ноуте. Откуда ты взял, что это какой-то там «реп для разработчиков» — без понятия.
Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

41. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Аноним (??) on 08-Дек-16, 15:48 
Раньше такой фигни в openSUSE небыло, при релизе всегда были актуальные ядра и меза, а то, что сейчас там уже было окаменелостью еще до выхода первой беты.
Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

32. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 08-Дек-16, 13:18 
А аналога backports debian'а в opensuse нет?
Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

36. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +1 +/
Сообщение от Sluggard (ok) on 08-Дек-16, 14:45 
Речь про драйвер xf86-video-amdgpu, как я понимаю? Так в Leap 42.2 вроде версия 1.2.0 в репах, это самый последний релиз (от 17 ноября 2016), где ты новее нашёл?
Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

40. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Аноним (??) on 08-Дек-16, 15:46 
Сам по себе он бесполезен, без относительно свежего ядра и мезы.
Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

45. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Аноним (??) on 08-Дек-16, 16:13 
Нет, про комплект драйверов, где xf86-video-amdgpu лишь малая его часть, причём заменяемая на xf86-video-modesetting теоретически без потерь функционала и скорости.
Драйвер ещё состоит из модуля ядра radeon/amdgpu, libdrm и state tracker'а мезы.
Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

47. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +1 +/
Сообщение от Sluggard (ok) on 08-Дек-16, 16:28 
То есть подразумевается относительная старость ядра и месы. Где взять новые я писал выше, было бы желание.
А можно вообще на Перекати-поле перекатиться.
Ответить | Правка | ^ к родителю #45 | Наверх | Cообщить модератору

20. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Аноним (??) on 08-Дек-16, 12:00 
"proprietary crap", ога, ничего не изменилось.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

31. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –6 +/
Сообщение от Прист email on 08-Дек-16, 13:17 
И bash в Win10 уже есть... и не только.
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

64. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +1 +/
Сообщение от AlexYeCu (ok) on 08-Дек-16, 18:59 
И bash в Win10 уже есть... а толку?
FIXED.
Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

90. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Michael Shigorin email(ok) on 09-Дек-16, 19:01 
> И bash в Win10 уже есть... а толку?

А ещё там есть замечательный шрифт Segoe UI, как сегодня выяснилось.
Вот его бы дезигнеров с манагерами отправить на потеху "умеренной оппозиции".
Потому как профилактическое вырывание рук из ж**ы и втыкание их обратно другим концом в случае ТАКОГО явно не поможет.

(тем, чьим глазам посчастливилось: оно расплывается, причём в принципе -- а "настройки" предлагают выбрать между нескольких вариантов смеси мыла с г-ном)

Боюсь, ближайшие дни пытающимся поагитировать за некрософт будет особенно больно.

Ответить | Правка | ^ к родителю #64 | Наверх | Cообщить модератору

60. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +5 +/
Сообщение от Аноним (??) on 08-Дек-16, 17:55 
> AMD решил умирать?

Напротив - это единственный нормальный вендор видях под линь, у которого видеокарты не затычки для слота и при том открытые дрова есть и они не приводят к традиционным для проприетари факапам. Когда обновил систему - ядерный модуль отпал - обана, черный экран.

> А тратить 12 тыр. на новую карту при наличии не самой слабой "старой" (HD7970 3Gb DualX)?

Так это ж GCN?! Для него AMDGPU вот прямо сейчас активнейше запиливают как раз. В ядре 4.9 (релизнется буквально через несколько дней) - модуль AMDGPU уже умеет SI, к которым относится и HD7970 IIRC. Единственное что подхватывает ли AMDGPU или Radeon - зависит от конфига ядра. Это уже к майнтайнерам дистра.

И таки да, с ним будет работать AMDGPU-PRO с их вулканом и opencl. К тому же OpenCL они собираются открыть, чувак из редхата (Dave Airlie) на пару с сторонним коммитером запилили опенсорсный вулкан (RADV). В общем амд как раз все делает правильно. Но медленнее чем следовало бы, особенно с SI.

> Win10 купить за эти деньги, где проблем с этим нет.

Это уже дело хозяйское что "покупать". Только винду для начала невозможно купить: это у них такая аренда по цене покупки, на весьма интересных условиях. Описанных в EULA.

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

62. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Аноним (??) on 08-Дек-16, 18:10 
> В ядре 4.9 (релизнется буквально через несколько дней) - модуль AMDGPU уже умеет SI

экспериментальная поддержка, которая будет выключена по умолчанию.

Ответить | Правка | ^ к родителю #60 | Наверх | Cообщить модератору

71. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 08-Дек-16, 20:41 
> экспериментальная поддержка,

Ну разумеется она экспериментальная - ее только что накодили! Ядро 4.9 с ней вот-вот релизнется, ИМХО в пределах нескольких дней, если не случится ничего экстраординарного требующего еще один -RC выпускать.

> которая будет выключена по умолчанию.

А еще экспериментальные лекарства не продают в аптеке, блин. А может на экспериментальной модели самолета покатать?

...народ вокруг DRM/KMS решил что для GCNов в перспективе будет AMDGPU и на него так или иначе смигрируют. Но это будет попозже. Сначала мыши должны откушать таблеток, тестовые пилоты обкатают самолет. А потом ты сможешь прийти в аптеку или к трапу самолета. И никак не наоборот.

Ответить | Правка | ^ к родителю #62 | Наверх | Cообщить модератору

89. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Аноним (??) on 09-Дек-16, 12:01 
> прямо сейчас активнейше запиливают

Да и пускай еще столько же лет этим занимаются.

Ответить | Правка | ^ к родителю #60 | Наверх | Cообщить модератору

84. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 09-Дек-16, 08:37 
HD7970 нормально работает на radeonsi, а если не хватает чего то и для amdgpu-pro эксперементальную поддержку запилили, которую Суся не поддерживает, так это вопросы к Сусе-ментейнерам. Сусе не слишьком меньше РедХата и Каконикл, и что, они не могут связаться с АМД если им что-то не нравится в нынешней упаковке дров? Даже Валв смогли запилить dkms потому что юзают старые ядра, а Сусе, не новичок в Линуксах, не смогли?
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

33. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –5 +/
Сообщение от vantoo (ok) on 08-Дек-16, 14:01 
Развели зоопарк драйверов так, что черт ногу сломит. Пусть другие в этом разбираются, следующая видяха будет от Нвидии, как и до этого. Там хоть и блоб, но ты хотя бы знаешь, что поставишь этот блоб и все заработает.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

42. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +2 +/
Сообщение от J.L. on 08-Дек-16, 15:50 
> Развели зоопарк драйверов так, что черт ногу сломит. Пусть другие в этом
> разбираются, следующая видяха будет от Нвидии, как и до этого. Там
> хоть и блоб, но ты хотя бы знаешь, что поставишь этот
> блоб и все заработает.

новое ядро с этим блобом заработает ? *тролфейс*

Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

43. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Andrey Mitrofanov on 08-Дек-16, 15:53 
>> Развели зоопарк драйверов так, что черт ногу сломит. Пусть другие в этом
>> разбираются, следующая видяха будет от Нвидии, как и до этого. Там
>> хоть и блоб, но ты хотя бы знаешь, что поставишь этот
>> блоб и все заработает.
> новое ядро с этим блобом заработает ? *тролфейс*

Ты его приглашаешь к логичному выводу "развели зоопарк ядер -- ухожу на десяточку"?

Ему слабо.

Ответить | Правка | ^ к родителю #42 | Наверх | Cообщить модератору

49. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от vantoo (ok) on 08-Дек-16, 17:13 
А что, бывало такое, что новая "бубунта" уже вышла, а под ее ядро еще нет драйвера от Нвидии? Самые свежие ядра мне могут понадобится разве что на серверах, но там мне драйвер видеокарты не нужен.
Ответить | Правка | ^ к родителю #42 | Наверх | Cообщить модератору

61. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +2 +/
Сообщение от Аноним (??) on 08-Дек-16, 17:56 
> новое ядро с этим блобом заработает ? *тролфейс*

Более того - с модулем от нвидии - баги ядра репортить можно только в спортлото. Ну или нвидии. Пусть нвидия все ядро и поддержвает со своим модулем, если пупок не развяжется.

Ответить | Правка | ^ к родителю #42 | Наверх | Cообщить модератору

63. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 08-Дек-16, 18:12 
> новое ядро с этим блобом заработает ? *тролфейс*

Тем не менее это амдшный блоб выбросили в убунте 16.04, а теперь и в сузе.

Ответить | Правка | ^ к родителю #42 | Наверх | Cообщить модератору

48. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  –1 +/
Сообщение от Игорь email(??) on 08-Дек-16, 16:30 
Господа, а какова судьба fglrx-legasy в openSUSE?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

52. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +1 +/
Сообщение от Sluggard (ok) on 08-Дек-16, 17:33 
Она в целом никакова, его судьба, не поддерживаются новые ядра и иксы (1.13 и выше) этим драйвером, в AMD забили уже давно.
Ответить | Правка | ^ к родителю #48 | Наверх | Cообщить модератору

75. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 08-Дек-16, 23:20 
Какие драйвера для ATI RS600 самые свежие?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

82. "Проект openSUSE прекращает поддержку пакетов с драйвером AMD..."  +/
Сообщение от Аноним (??) on 09-Дек-16, 00:18 
> Какие драйвера для ATI RS600 самые свежие?

Распоследний linux kernel, свежая MESA, ну и не очень древний libdrm. Это даже не затычка для слота по современным меркам - что ты от него хочешь? По идее должен просто работать с свежими пингвинами. Вывешивая OpenGL 2.1 - больше там железо не умеет. Это, блин, R400. Т.е. совсем уж винтаж в архитектурно-железячном плане.

Как максимум... нннну.... оно наверное будет не очень круто тормозить в 0ad и warzone2100, которые как-то ползают даже на древнем интеловском интеграте.

Ответить | Правка | ^ к родителю #75 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру