The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  вход/выход  слежка  RSS
"Корректирующие выпуски  Python 2.7.12, 3.4.5 и 3.5.2"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Корректирующие выпуски  Python 2.7.12, 3.4.5 и 3.5.2"  +/
Сообщение от opennews (ok) on 28-Июн-16, 22:07 
Доступны корректирующие выпуски Python 2.7.12, 3.4.5 и 3.5.2 (http://permalink.gmane.org/gmane.comp.python.announce/12406), в которых отражены внесённые за последнее время исправления ошибок, среди которых  некоторые (https://hg.python.org/cpython/raw-file/v3.4.5/Misc/NEWS) связаны с устранением уязвимостей. Поддержка ветки Python 2.7 будет осуществляться (https://www.opennet.ru/opennews/art.shtml?num=39565) до 2020 года. Ветка 3.4.x находится на финальной стадии сопровождения, подразумевающей прекращение устранения ошибок, не связанных с безопасностью.

Исправления, связанные с безопасностью: устранено потенциальное целочисленное переполнение  в
функции  zipimporter.get_data(), устранены уязвимости в поставляемых в комплекте библиотеках expat (CVE-2015-1283 (https://security-tracker.debian.org/tracker/CVE-2015-1283))  и smptlib (CVE-2016-0772 (https://security-tracker.debian.org/tracker/CVE-2016-0772)), на платформе Windows запрещена запись в хранилище сертификатов ssl.enum_certificates, устранены проблемы с обработкой в pathlib.Path.[r]glob() маски "**"  при обходе символических ссылок.


URL: http://permalink.gmane.org/gmane.comp.python.announce/12408
Новость: https://www.opennet.ru/opennews/art.shtml?num=44690

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


3. "Корректирующие выпуски  Python 2.7.12, 3.4.5 и 3.5.2"  +1 +/
Сообщение от Аноним (??) on 28-Июн-16, 22:42 
Вот бы еще для PyS60 для Symbian9 обновили, а то там до сих пор только 2.5.4
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Корректирующие выпуски  Python 2.7.12, 3.4.5 и 3.5.2"  +/
Сообщение от . on 29-Июн-16, 01:49 
Зачем? Рухляди - рухляль.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

6. "Корректирующие выпуски  Python 2.7.12, 3.4.5 и 3.5.2"  –5 +/
Сообщение от тОпор on 29-Июн-16, 16:40 
>> Зачем? Рухляди - рухляль.

Python 3.5.2 вроде пока не рухлядь, хотя и слаб.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Корректирующие выпуски  Python 2.7.12, 3.4.5 и 3.5.2"  –5 +/
Сообщение от trolleybus email on 29-Июн-16, 22:02 
Зачем продолжать поддержку 2.7? Сейчас на тройку не перешли только самые упрямые двоечники. Так они тем более не перейдут.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "Корректирующие выпуски  Python 2.7.12, 3.4.5 и 3.5.2"  +/
Сообщение от Dmitry email(??) on 01-Июл-16, 15:17 
Есть такое матерное слово - Legacy. Вот из-за него самого ещё не все перешли.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру