The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  вход/выход  слежка  RSS
"Конфликт из-за поставки устаревшей версии XScreenSaver в Debian"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Конфликт из-за поставки устаревшей версии XScreenSaver в Debian"  +/
Сообщение от opennews on 06-Апр-16, 10:25 
Мэтью Гаррет (Matthew Garrett), известный разработчик ядра Linux и один из директоров Фонда Свободного ПО, в своё время получивший от Фонда СПО премию за вклад в развитие свободного ПО, обратил внимание (https://mjg59.dreamwidth.org/41085.html) на обратную сторону методов обеспечения стабильности в Debian.


Политика поддержания релизов Debian основывается на сохранении изначально представленных в релизе версий программ с бэкпортированием в пакеты исправлений уязвимостей и серьёзных проблем. Переход на новые версии, содержащие функциональные улучшения, за редким исключением (например, Firefox), не применяется, так как сохранение изначального поведения и отсутствие появления новых ошибок рассматриваются как важные атрибуты стабильности.


При этом из виду упускается обратная сторона медали  - исправления не всех уязвимостей удаётся бэкпортировать в поставляемые в дистрибутиве версии программ. Не все исправления ошибок, которые имеют отношение к безопасности, помечаются разработчиками программ как устранение уязвимостей - в одних случаях разработчики специально отдельно не выделяют устранение уязвимостей, а в других случаях не догадываются, что определённая проблема может быть связана с уязвимостью. Определение того, является ли ошибка уязвимостью зачастую требует проведения специального аудита. Таким образом, в обычных обновлениях версий программ, наряду с явно помеченными уязвимостями, также  устраняются потенциальные уязвимости, которые могут всплыть после детального изучения сути исправленной ошибки.


Устранения подобных неявных уязвимостей не переносятся в Debian, так как формально связанные с ними ошибки не касаются безопасности, а мэйнтейнеры пакетов не могут досконально разбирать каждое исправление. Для злоумышленников же открываются двери для проведения целевых атак, выявляя новые уязвимости через изучение исправлений, не перенесённых в пакеты стабильных выпусков Debian. Ситуацию усугубляет то, что в Debian силами мэйнтейнеров продолжается сопровождение версий, которые уже не поддерживаются разработчиками основных проектов (upstream).


Внимание к проблеме привлёк разработчик хранителя экрана XScreenSaver, который попросил (https://www.jwz.org/blog/2016/04/i-would-like-debian-to-stop.../) прекратить поставку его приложения в составе Debian, так как устал от постоянных жалоб пользователей о проблемах с устаревшими версиями XScreenSaver. Кроме того, в код XScreenSaver добавлен (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=819703) вывод специального диалогового окна, во время блокировки экрана информирующего пользователя об использовании устаревшего выпуска и призывающего перейти на актуальную версию.


<center><a href="https://www.jwz.org/images/obsolete.png"><img src="https://www.opennet.ru/opennews/pics_base/0_1459925318.png&q... style="border-style: solid; border-color: #e9ead6; border-width: 15px;max-width:100%;" title="" border=0></a></center>


В Debian используется версия XScreenSaver, выпущенная в 2014 году. В настоящее время в системе отслеживания ошибок Debian размещено (https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=xscreensav...) около ста сообщений о проблемах, которые никак не решаются. Не получив возможности добиться исправления проблемы в дистрибутиве, пользователи направляют запросы на исправления в upstream, чем создают дополнительную нагрузку на разработчиков основных проектов. Кроме того, незаслуженно страдает репутация проектов, например, в случае XScreenSaver пользователи пытаются добиться устранения проблем, которые уже годы как исправлены в основном проекте.


URL: https://mjg59.dreamwidth.org/41085.html
Новость: https://www.opennet.ru/opennews/art.shtml?num=44184

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –53 +/
Сообщение от IMHO on 06-Апр-16, 10:25 
вот вам линукс и исправление моментальное ошибок
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

9. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +58 +/
Сообщение от Аноним (??) on 06-Апр-16, 10:41 
Осталось только тебе узнать разницу между дебианом и линуксом.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору
Часть нити удалена модератором

25. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –9 +/
Сообщение от Анонимизатор on 06-Апр-16, 11:30 
Угу. Щас выяснится, что линукс - это редхат и стоит больше винды. А опенсуси и прочие арчи - не линукс т к нештабильные.
Все жизнь меж двух огней: тухлое и нестабильное. Даже тут решения оптимального не достигли, а все орут о превосходстве.
Ответить | Правка | Наверх | Cообщить модератору

42. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Аноним (??) on 06-Апр-16, 12:09 
Гентушечка же
Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

106. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от Адекват (ok) on 06-Апр-16, 15:15 
> Все жизнь меж двух огней: тухлое и нестабильное. Даже тут решения оптимального
> не достигли, а все орут о превосходстве.

Причем с винды.

Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

172. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от Vasia (??) on 06-Апр-16, 17:38 
>опенсуси

Опензюзи.

Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

291. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 12-Апр-16, 21:49 
> Все жизнь меж двух огней: тухлое и нестабильное. Даже тут решения оптимального
> не достигли, а все орут о превосходстве.

Ты так говоришь, как будто на винде все по другому. Там обычно если поставил 20 программ - обновлять их муторно и никто не связывается вообще.

Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

27. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +5 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 11:33 
> Ранее собрание козломордых бандерлогов постановило, что Убунту не Линукс. Теперь выясняется,
> что и Дебиан им не является. Куда же делся Линукс, товарищи
> рогоногие приматы? давайте искать!

лучший Linux - это OpenBSD. но и он, досада такая, тоже не Linux.

а Debian - это ось, инфраструктура и социологический проект. А какое там ядро, linux, hurd или kfreebsd - это дело десятое, какое лучше на сегодняшний день работает, то и используется, будет лучше работать другое - просто подменят ядро и всё.

Ответить | Правка | Наверх | Cообщить модератору
Часть нити удалена модератором

64. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 12:55 
> дебиан не ось а гну/линух - ядро + набор утилит, а вот опёнок это ось.

дебиан это даже больше, чем ось. формально ему не нужен ни gnu, ни linux. а вообще, от того, что у кого-то есть gnu или нет gnu, есть linux или нет linux, это не перестаёт делать это осью. поэтому openbsd такая же ось, как и дистрибутив gnu/linux. а вот Debian - это намного большее.

Ответить | Правка | ^ к родителю #291 | Наверх | Cообщить модератору

94. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +2 +/
Сообщение от Аноним (??) on 06-Апр-16, 14:38 
Ленин - гриб.
Ответить | Правка | ^ к родителю #64 | Наверх | Cообщить модератору

96. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +12 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 14:41 
> Ленин - гриб.

Ленин - тоже дебиан. Только старенький уже.

Ответить | Правка | ^ к родителю #94 | Наверх | Cообщить модератору

228. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от lor_anon (ok) on 07-Апр-16, 02:22 
Не старенький, а стабильный
Ответить | Правка | ^ к родителю #96 | Наверх | Cообщить модератору

229. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 07-Апр-16, 02:38 
> Не старенький, а стабильный

Из-за окаменения?


Ответить | Правка | ^ к родителю #228 | Наверх | Cообщить модератору

256. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Какаянахренразница (ok) on 07-Апр-16, 14:09 
> Не старенький, а стабильный

Заморожен перед релизом.

Ответить | Правка | ^ к родителю #228 | Наверх | Cообщить модератору

293. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Васькович (ok) on 23-Сен-16, 17:14 
>> Не старенький, а стабильный
> Заморожен перед релизом.

про backports cлыхали?

Ответить | Правка | ^ к родителю #256 | Наверх | Cообщить модератору

195. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Ano on 06-Апр-16, 18:43 
Из OpenBSD выпилили krb5 и как теперь его вводить в домен виндузовый? Или сквид прикрутить с проверкой по тикетам? Ни как. Жаль. Хотел потестить, но теперь смотрю в сторону NetBSD
Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

220. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Вареник on 06-Апр-16, 23:52 
Если выбирать между Linux и репами Debian - я не сомневаясь выберу Debian. Ядро дело наживное, одним больше, одним меньше.
Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

283. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 12-Апр-16, 17:56 
> лучший Linux - это OpenBSD. но и он, досада такая, тоже не Linux.

В этом то вся и проблема. Teo the retard с его cvs, система не работающая до сих пор нормально на многоядерниках и плохая поддержка оборудования - это не линукс. Даже на слакварь не потянет.

> а Debian - это ось, инфраструктура и социологический проект. А какое там
> ядро, linux, hurd или kfreebsd - это дело десятое, какое лучше
> на сегодняшний день работает, то и используется, будет лучше работать другое
> - просто подменят ядро и всё.

Красиво расписал почему они на systemd перешли. Да, работать стало лучше. Админить и майнтайнить проще.

Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

22. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –3 +/
Сообщение от Аноним (??) on 06-Апр-16, 11:16 
лол, в дебиане лично мне приходится много пакетов потом пересобирать в ручную.

Я вообще не понимаю нытье этих дебианшиков. Хочется по свежее, собери сам. Пол часа времени.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

31. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +20 +/
Сообщение от Анонимизатор on 06-Апр-16, 11:36 
Дебиан выбирают как коробочное штабильное и документированное решение, а собирать руками каждую новую версию ПО - увольте. Для этого есть прекрасные гиковские дистры.


Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

40. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от IB on 06-Апр-16, 12:01 
Если версии нужные вам реально свежее testing/unstable, то это ОЧЕНЬ частный случай.
Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

45. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +3 +/
Сообщение от botman (ok) on 06-Апр-16, 12:25 
тут некоторые по привычке сравнивают нынешний oldstable с релизом Fedora, который уровня testing и делают выводы о том что лучше или хуже
Ответить | Правка | ^ к родителю #40 | Наверх | Cообщить модератору

289. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от Аноним (??) on 12-Апр-16, 18:41 
> тут некоторые по привычке сравнивают нынешний oldstable с релизом Fedora, который уровня
> testing и делают выводы о том что лучше или хуже

Это опеннет, детка. Тут могут сравнить зеленое с горячим и сделать далеко идущие выводы.

Ответить | Правка | ^ к родителю #45 | Наверх | Cообщить модератору

78. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +2 +/
Сообщение от Аноним (??) on 06-Апр-16, 13:29 

> Хочется по свежее, собери сам. Пол часа времени.
> Хочется посвежее, собери сам.  Полчаса времени.
> лол, в дебиане лично мне приходится много пакетов потом пересобирать в ручную, вместо того, чтобы делать уроки!

fix =)

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

240. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 07-Апр-16, 10:17 
Может быть, там имелось в виду "Хочется ПО свежее <...>".
Ответить | Правка | ^ к родителю #78 | Наверх | Cообщить модератору

69. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +3 +/
Сообщение от Roo2AT7d (ok) on 06-Апр-16, 13:02 
Линукс ни при чем, проблемы в юзерспейсе.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

92. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +2 +/
Сообщение от Аноним (??) on 06-Апр-16, 14:35 
скажи супервайзеру, что в ваших методичках не хватает информации о том, что дебиян таким подходом к безопасности уже лет 15 славен, а то ваш отдел продаж лужи метанирует с завидной регулярностью
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Turbid (??) on 06-Апр-16, 10:30 
xscreensaver (5.34-2) unstable; urgency=medium

  * Fix sort order in hacks/Makefile (for reproducible builds)
    (Closes: #819595)
  * Disable Easter egg about "outdated" version
    (Closes: #819703)

-- Tormod Volden <debian.tormod@gmail.com>  Tue, 05 Apr 2016 22:53:13 +0200

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Аноним (??) on 06-Апр-16, 10:34 
И это победа! Где наш ScreenSaverD?
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

139. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +3 +/
Сообщение от Michael Shigorin email(ok) on 06-Апр-16, 16:13 
>   * Disable Easter egg

Вообще-то это заметание проблемы под ковёр и жалкая попытка терминологической манипуляции.  Фу, стыдно.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

140. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +2 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 16:16 
>>   * Disable Easter egg
> Вообще-то это заметание проблемы под ковёр и жалкая попытка терминологической манипуляции. Фу, стыдно.

А чё не так-то? Какая-то фигня вылазит на ровном месте и выводит окошко "итс вери вери олд", при этом закрытия у этого окошка нет.

Ну, я бы назвал это трояном (если в цензурном варианте)

Ответить | Правка | ^ к родителю #139 | Наверх | Cообщить модератору

197. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Elhana (ok) on 06-Апр-16, 19:05 
Есть закрытие, просто нажимаешь сеттингс и закрываешь.
Ответить | Правка | ^ к родителю #140 | Наверх | Cообщить модератору

215. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 06-Апр-16, 23:15 
> выводит окошко "итс вери вери олд"

Интересно, как сабж определяет, что он "вери вери олд" и есть более новые версии? Уж не в инет ли лазит?

Ответить | Правка | ^ к родителю #140 | Наверх | Cообщить модератору

217. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от iZEN email(ok) on 06-Апр-16, 23:30 
Time bomb.
Ответить | Правка | ^ к родителю #215 | Наверх | Cообщить модератору

218. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от myhand (ok) on 06-Апр-16, 23:30 
По дате, глупый.
Ответить | Правка | ^ к родителю #215 | Наверх | Cообщить модератору

236. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Аноним (??) on 07-Апр-16, 08:14 
Чтобы по одной только дате определить наличие новых версий, нужна чётко определённая частота релизов а-ля Firefox или Ubuntu.
Ответить | Правка | ^ к родителю #218 | Наверх | Cообщить модератору

247. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от myhand (ok) on 07-Апр-16, 12:59 
> Чтобы по одной только дате определить наличие новых версий, нужна чётко определённая
> частота релизов а-ля Firefox или Ubuntu.

Ноу проблемо.  Раз в год, например.  У xscreensaver с этим как раз порядок, они на сайте и жалуются что в дистрибутивах версия может быть устаревшей на годы.

Ответить | Правка | ^ к родителю #236 | Наверх | Cообщить модератору

286. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 12-Апр-16, 18:31 
> Интересно, как сабж определяет, что он "вери вери олд"

Смотрит на часы, сравнивает с датой своего выпуска забитой в сорце.

Ответить | Правка | ^ к родителю #215 | Наверх | Cообщить модератору

151. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от myhand (ok) on 06-Апр-16, 16:48 
Вообще-то, стоит определиться _что_ здесь проблема.  Багов много, но похоже что мейнтейнер занимается пакетом, serious/critical устраняются своевременно, оснований для того, чтобы пакет осиротел по приговору QA и сменил мейнтейнера - я не вижу.  Лучше б ему помочь, вместо нытья.

А вообще, если разработчик не хочет никак поддерживать старые версии - его право.  Только вот каждый раз в морду тыкать назойливым окошком про это - уже перебор.  У проекта обычно есть страничка, где можно все культурно изложить - в частности что и куда постить, что не считается за баг и т.п.  То что найдутся интересные личности, которые проигнорируют любые инструкции - не проблема Debian.

PS: Мэтью все больше ****ой страдает.

Ответить | Правка | ^ к родителю #139 | Наверх | Cообщить модератору

182. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +2 +/
Сообщение от cmp (ok) on 06-Апр-16, 18:04 
У кого из дистров пакеты старее чем в дебиане? из нормальных дистров, а не мертвых проприетарных поделок. Сколько серваков на дьмьяне не видел, от всех несло могильной сыростью, и на всех были проблемы (иначе мне бы их не показывали), про который другие дистры забыли уже.
Ответить | Правка | ^ к родителю #151 | Наверх | Cообщить модератору

193. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от myhand (ok) on 06-Апр-16, 18:25 
> У кого из дистров пакеты старее чем в дебиане? из нормальных дистров,
> а не мертвых проприетарных поделок.

Понятия не имею.  Вы же не дали определения "нормального дистра".  Арчики какие-нибудь, поди.

> Сколько серваков на дьмьяне не видел,
> от всех несло могильной сыростью, и на всех были проблемы (иначе
> мне бы их не показывали), про который другие дистры забыли уже.

Например?

Ответить | Правка | ^ к родителю #182 | Наверх | Cообщить модератору

204. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от фцв on 06-Апр-16, 20:23 
арчик упоминается чаще, чем его используют
Ответить | Правка | ^ к родителю #193 | Наверх | Cообщить модератору

274. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от cmp (ok) on 08-Апр-16, 01:24 
> "нормального дистра"

Это общеиспользуемые-многофункциональные, то есть НЕ брендовые сборки убунты, НЕ тестовые дистры какой-то фичи, НЕ прибитые гвоздями к железу, а те которые можно установить на писюк или ноут или серв, и пользоваться как десктопом или сервером, комбинируя функционал по желанию. Их зовут дистры общего назначения, но далеко не каждый из тех, кто так себя зовет является дистром.

> Например?

Например, ошибка скрипта генерации xorg.conf

Ответить | Правка | ^ к родителю #193 | Наверх | Cообщить модератору

275. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от myhand (ok) on 08-Апр-16, 02:25 
> Их зовут дистры общего назначения, но далеко не каждый из тех, кто так себя зовет
> является дистром.

Т.е. внятного определения у вас нет, а есть love-hate список?

>> Например?
> Например, ошибка скрипта генерации xorg.conf

Можно поинтересоваться на кой хрен вам xorg.conf сдался на "серваке на дебиане"?

Ответить | Правка | ^ к родителю #274 | Наверх | Cообщить модератору

219. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от Ilya Indigo (ok) on 06-Апр-16, 23:35 
> У кого из дистров пакеты старее чем в дебиане?

Слака! Там до сих пор Лило по дефолту и нету системдэ. В других дистрах этого сложно не найти.

Ответить | Правка | ^ к родителю #182 | Наверх | Cообщить модератору

234. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от iCat (ok) on 07-Апр-16, 07:35 
>...Лило по дефолту и нету системдэ...

Отсутствие системдэ скорее достоинство, чем недостаток...

Ответить | Правка | ^ к родителю #219 | Наверх | Cообщить модератору

273. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от cmp (ok) on 08-Апр-16, 01:07 
Ооо, я активно пользуюсь слакой, там пакетная база обновляется, может и не оперативно, но без заморочек на совместимость версий друг с другом - кошерный свежак.

Лило там или что, без понятия, ни разу не ставил ее инсталятором, просто лил пакеты из другой системы и прописывал свой загрузчик.

А про системд вам уже сказали, в гробу его видал. И поэтому слака - это единственный дист, который может функционировать десятками лет с актуальной пакетной базой, с оверхедом на пакетные зависимости, но кто еще вам обеспечит такой лонгтайм? Ну конечно многим дела нет до того как и что, работает и похер, в крайнем случае переустановить, тогда пользуйтесь виндой, там все в два клика можно, че в никсы-то лезть.

Ответить | Правка | ^ к родителю #219 | Наверх | Cообщить модератору

276. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Ilya Indigo (ok) on 08-Апр-16, 10:56 
Я не говорил, что отсутствие поделия Лёни в Слаке это плохо, я намекал на его старость принципов, что ли.
Я посмотрел тут http://distrowatch.com/table.php?distribution=slackware
И даже удивлён, насколько там свежие пакеты, там в целом, свежее чем в OpenSUSE Tumbleweed
Меня это даже заинтересовало.
Просто в моей голове бытуют 2 мифа-страшилки о Слаке. :-)
1 Там на столько древние пакеты, что там даже Лило по умолчанию, что я только что сам и развеял.
2 В менеджере пакетов отсутствует проверка зависимостей пакетов по дизайну, и если ты что-то или не доставишь нужное сам или удалишь то, что тебе кажется лишним, но на самом деле нужным; и тебе менеджер пакетов это позволит сделать, даже не заикнувшись, а потом у тебя будут проблемы, и ты не всегда даже поймёшь почему.

Как насчёт второго мифа? Миф ли это, или так на самом деле?

Ответить | Правка | ^ к родителю #273 | Наверх | Cообщить модератору

279. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от й on 09-Апр-16, 12:40 
в составе есть slackpkg, который уже лучше того, что было традиционно; есть сторонний slapt-get, который даже знает, что такое зависимости. не apt и не yum, но на голову выше того, что было в той же slackware 10 лет назад.
Ответить | Правка | ^ к родителю #276 | Наверх | Cообщить модератору

226. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Admino (ok) on 07-Апр-16, 01:27 
> Вообще-то, стоит определиться _что_ здесь проблема.  

Проблема здесь в том, что между разработчиком и пользователем сидит какой-то майнтейнер и мутит воду. При этом пользователи жалуются разработчикам, а разработчики не могут решить проблемы пользователей.

Ответить | Правка | ^ к родителю #151 | Наверх | Cообщить модератору

269. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от myhand (ok) on 07-Апр-16, 19:07 
>> Вообще-то, стоит определиться _что_ здесь проблема.
> Проблема здесь в том, что между разработчиком и пользователем сидит какой-то майнтейнер
> и мутит воду.

Почему какой-то?  Определенный.  Причем не только "мутит воду", но и подготавливает
пакет к релизу, правит баги.  Помогли б лучше.

А если вы считаете, что это между - не нужно, то для школия понаделали других дистрибутивов.

> При этом пользователи жалуются разработчикам, а разработчики не
> могут решить проблемы пользователей.

Если разработчики желают решать проблемы пользователей - им нету никаких
препятствий в том, чтобы бекпортировать фикс, на который у мейнтейнера
времени не хватило.  Но дело в том, что они не хотят поддерживать старые
релизы от слова совсем.  А крайними у вас почему-то - те, кто это
худо-бедно, но пытается сделать...

Ответить | Правка | ^ к родителю #226 | Наверх | Cообщить модератору

4. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +45 +/
Сообщение от anonimous on 06-Апр-16, 10:31 
На правах КО:

Стабильность в Дебиане означает "предсказуемость", а не "отсутствие багов". Простейший способ добиться предсказуемости -- заморозить версию. Так и поступают. И это не хорошо и не плохо, это просто данность.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

43. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +7 +/
Сообщение от Аноним (??) on 06-Апр-16, 12:10 
Единственный адекватный комментарий. Отсутствия багов в любом случае добиться невозможно.
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

79. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +5 +/
Сообщение от anonymous (??) on 06-Апр-16, 13:29 
>Отсутствия багов в любом случае добиться невозможно.

Но можно значительно уменьшить, если сотрудничать с апстримом.

Ответить | Правка | ^ к родителю #43 | Наверх | Cообщить модератору

216. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 06-Апр-16, 23:20 
> сотрудничать с апстримом

С этим всё не так уж плохо, если судить по периодически появляющимся записям типа "removed path foo.path (stolen upstream)" в чейнджлогах пакетов.

Ответить | Правка | ^ к родителю #79 | Наверх | Cообщить модератору

272. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Имя on 07-Апр-16, 22:32 
> Единственный адекватный комментарий. Отсутствия багов в любом случае добиться невозможно.

Себе в резюме это впишите

Ответить | Правка | ^ к родителю #43 | Наверх | Cообщить модератору

198. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от Elhana (ok) on 06-Апр-16, 19:09 
> На правах КО:
> Стабильность в Дебиане означает "предсказуемость", а не "отсутствие багов". Простейший
> способ добиться предсказуемости -- заморозить версию. Так и поступают. И это
> не хорошо и не плохо, это просто данность.

Стабильность в дебиане - например в принципе неработающий пакет nethogs, потому что обновлять его никто не собирается в stable:
$ sudo nethogs
creating socket failed while establishing local IP - are you root?

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

201. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от myhand (ok) on 06-Апр-16, 19:25 
> Стабильность в дебиане - например в принципе неработающий пакет nethogs, потому что
> обновлять его никто не собирается в stable

С чего вы взяли, что "никто не собирается"?

Если так - этот пакет станет кандидатом на удаление из stable в следующих point-релизах.

Ответить | Правка | ^ к родителю #198 | Наверх | Cообщить модератору

277. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Elhana (ok) on 08-Апр-16, 14:15 
В следующем релизе то его обновят, но в текущем стабильном он не работает и не будет.
Из будущего релиза взять просто нельзя - он там собран с новыми библиотеками - получаем пляски с локальной пересборкой пакета. В Убунту в принципе можно просто сделать backport в своем ppa, благо оно автоматизировано, но я не пробовал - просто забил.
Ответить | Правка | ^ к родителю #201 | Наверх | Cообщить модератору

278. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от myhand (ok) on 08-Апр-16, 14:27 
> В следующем релизе то его обновят, но в текущем стабильном он не
> работает и не будет.

Не в следующем стабильном релизе, а в следующем стабильном point-релизе, дубинушка.

Ты не понимаешь разницы?  Тогда зачем ты нам тут такой умный нужен?

Ответить | Правка | ^ к родителю #277 | Наверх | Cообщить модератору

6. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +9 +/
Сообщение от Sunderland93 (ok) on 06-Апр-16, 10:39 
Удивительно что кто-то юзает XScreenSaver
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

44. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Boboms (ok) on 06-Апр-16, 12:18 
ИМХО, скорее всего, речь идёт о "старом" железе. Сложно сказать.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

66. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +3 +/
Сообщение от Старожелезник on 06-Апр-16, 13:01 
> ИМХО, скорее всего, речь идёт о "старом" железе. Сложно сказать.

xscreensaver с зависимостями требует десяток мегов,
xtrlock меньше ста килобайт

Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

196. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от www2 (??) on 06-Апр-16, 18:47 
>> ИМХО, скорее всего, речь идёт о "старом" железе. Сложно сказать.
> xscreensaver с зависимостями требует десяток мегов,
> xtrlock меньше ста килобайт

Самый полезный комент. Спасибо!

Ответить | Правка | ^ к родителю #66 | Наверх | Cообщить модератору

199. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от Elhana (ok) on 06-Апр-16, 19:15 
>> ИМХО, скорее всего, речь идёт о "старом" железе. Сложно сказать.
> xscreensaver с зависимостями требует десяток мегов,
> xtrlock меньше ста килобайт

Только что все что на экране остается видно, но это же фигня.


Ответить | Правка | ^ к родителю #66 | Наверх | Cообщить модератору

242. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Ананас on 07-Апр-16, 11:06 
slock:

RDEPEND="
    x11-libs/libX11
        x11-libs/libXext
        x11-libs/libXrandr
"
DEPEND="
        ${RDEPEND}
        x11-proto/randrproto
        x11-proto/xproto
"
И на экране ничего видно не остается и никаких кривых формочек нет. Там вообще нет формы ввода пароля - вводится вслепую.

Ответить | Правка | ^ к родителю #66 | Наверх | Cообщить модератору

212. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Сиромант on 06-Апр-16, 22:32 
>ИМХО, скорее всего, речь идёт о "старом" железе. Сложно сказать.

Говорят, что он лучше других блокировщиков экрана в плане надёжности блокировки. Собственно, заблокировать экран надёжно под X Window System нереально, но XScreenSaver труднее обойти.

Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

49. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 06-Апр-16, 12:31 
Задачи-то бывают разные, те же терминалы на Linux.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

57. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 06-Апр-16, 12:38 
> Удивительно что кто-то юзает XScreenSaver

Он по умолчанию используется в XFCE.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

141. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от АнонимХ (ok) on 06-Апр-16, 16:19 
Что несказанно раздражает, он не вписывается в среду Xfce
Ответить | Правка | ^ к родителю #57 | Наверх | Cообщить модератору

143. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 16:20 
> Что несказанно раздражает, он не вписывается в среду Xfce

что значит "не вписывается"? какая разница, кто тебе чёрный экран показывает?

Ответить | Правка | ^ к родителю #141 | Наверх | Cообщить модератору

179. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от АнонимХ (ok) on 06-Апр-16, 18:00 
Что-то связнное с локскрином. Вместо нормального локскрина вылезал этот XScreenSaver с кривым вводом пароля: фокус ввода хренпойми где, ни раскладку, ни капслок не индицирует.
Ответить | Правка | ^ к родителю #143 | Наверх | Cообщить модератору

180. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 18:02 
> Что-то связнное с локскрином. Вместо нормального локскрина вылезал этот XScreenSaver с
> кривым вводом пароля: фокус ввода хренпойми где, ни раскладку, ни капслок
> не индицирует.

хм. не встречал. мейби, дистропроблемы? или это не его окошки, а кто-то другой их отрисовывает?

Ответить | Правка | ^ к родителю #179 | Наверх | Cообщить модератору

292. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 12-Апр-16, 22:05 
Это он именно в дебиане такой. Требует 30 метров перловки, которой больше нигде не пользуется, выглядит отдельной нашлепкой, игнорирующей системную тему, показа всяких капслоков - нет.

Кривая программа. И пакетирование - под стать. Кому надоело - gnome screensaver на системах с GTK как-то сильно приятнее. Ни 30 мегов перловки, ни таймбомб, ни кислотного вида, да еще и индикация капслока сделана. При том что качать в 5 раз меньше!!!

Ответить | Правка | ^ к родителю #180 | Наверх | Cообщить модератору

243. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 07-Апр-16, 11:18 
Большая разница. Чёрный экран не должен тянуть 30 пакетов, связанных в perl-www для работы одного скринсейвера, показывающего рандомные картинки из гугла.
Ответить | Правка | ^ к родителю #143 | Наверх | Cообщить модератору

268. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от XoRe (ok) on 07-Апр-16, 18:49 
> Что несказанно раздражает, он не вписывается в среду Xfce

Почему не вписывается? Он тоже начинается с X.

Ответить | Правка | ^ к родителю #141 | Наверх | Cообщить модератору

184. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от www2 (??) on 06-Апр-16, 18:05 
Гномовским скринсейвером никогда не пользовался и только убедился в правильности своего решения, когда обнаружили, что гномовский скринсейвер разблокировался от нажатия какого-то особого сочетания клавиш.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

7. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Какаянахренразница (ok) on 06-Апр-16, 10:41 
Та же фигня с OwnCloud. И тоже выпилили из Дебиана.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

110. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от gfh (??) on 06-Апр-16, 15:17 
https://download.owncloud.org/download/repositories/stable/o.../
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

208. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Какаянахренразница (ok) on 06-Апр-16, 21:05 
> https://download.owncloud.org/download/repositories/stable/o.../

Спасибо.

Ответить | Правка | ^ к родителю #110 | Наверх | Cообщить модератору

8. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +4 +/
Сообщение от онимус on 06-Апр-16, 10:41 
Не надо было  это  сообщение выводить при  каждом старте  и жалоб бы было  минимум в половину меньше, а то и на 95%.

Вывести оди раз с чекбоксом о прочтении и ссылкой на рекомендации  и все.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

91. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +2 +/
Сообщение от Аноним (??) on 06-Апр-16, 14:32 
А для пользователей Дебиана сделать патч с припиской: но если у вас Дебиан, значит, так должно быть и не пишите мне больше.
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Анонусис on 06-Апр-16, 10:46 
В общем-то, кому надо новые версии, тот может Убунту каждые пол года ставить заново (или обновляться). Но вообще не всегда удобно, когда приходится ждать стабилизации программы. В той же генте косяки вспылвают иногда.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

52. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от paulus (ok) on 06-Апр-16, 12:34 
>кому надо новые версии, тот может Убунту

поменять на арч, там с этим проблем нет.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

65. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 12:56 
>>кому надо новые версии, тот может Убунту
> поменять на арч, там с этим проблем нет.

в арче, начиная с 2008 года, проблем столько, что никакой убунте и не снилось. была нормальная система - нет же, набежали, налетели, испортили хороооооошую вещь.

Ответить | Правка | ^ к родителю #52 | Наверх | Cообщить модератору

114. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от Адекват (ok) on 06-Апр-16, 15:26 
> испортили
> хороооооошую вещь.

Отсылка к Шерлоку Холмсу советскому ?

Ответить | Правка | ^ к родителю #65 | Наверх | Cообщить модератору

115. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 15:30 
>> испортили хороооооошую вещь.
> Отсылка к Шерлоку Холмсу советскому ?

отсылка к кочерге

Ответить | Правка | ^ к родителю #114 | Наверх | Cообщить модератору

232. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +3 +/
Сообщение от Адекват (ok) on 07-Апр-16, 06:51 
>>> испортили хороооооошую вещь.
>> Отсылка к Шерлоку Холмсу советскому ?
> отсылка к кочерге

Жила-была кочерга, никого не трогала, служила верой и правдой и выполняла то, ради чего была создана.
Простая и функциональная, ничего лишнего, воистину "гармония гибкости и простоты", просто кусок метала, который удобно ложиться в руку и которым удобно пользоваться по назначению.
Удобно, удобно, удобно. Было.
Но потом прибежала школота ментейнерская и стала вопить "как так ?? почему у нее не пластиковая ручка, которая будет приделана через переходник, который будет крепиться болтами и саморезами ???"
А почему в нее не встроили датчики давления и температуры ?
А где в ней переводчик на китайский язык ?
А почему у нее нет сменных наконечников ?
А почему только рукой ее используют ? давайте сделаем так, чтобы нужно было еще и ногу задействовать !!
Что значит это никому не нужно ???
АХ ВЫ РЕТРОГРАДЫ ПОГАНЫЕ, А НУ БЕГОМ В ДОМ ПРЕСТАРЕЛЫХ И НЕ МЕШАЙТЕ НАМ ВНЕДРЯТЬ ВСЕ НОВОЕ, МОДНОЕ, МОЛОДЕЖНОЕ !!!

Ответить | Правка | ^ к родителю #115 | Наверх | Cообщить модератору

206. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от фцв on 06-Апр-16, 20:27 
>>>кому надо новые версии, тот может Убунту
>> поменять на арч, там с этим проблем нет.
> в арче, начиная с 2008 года, проблем столько, что никакой убунте и
> не снилось. была нормальная система - нет же, набежали, налетели, испортили
> хороооооошую вещь.

я пользуюсь арчем с 2007, кто набежал, что испортили?

Ответить | Правка | ^ к родителю #65 | Наверх | Cообщить модератору

266. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +2 +/
Сообщение от Турбо Генератор on 07-Апр-16, 18:16 
> я пользуюсь арчем с 2007, кто набежал, что испортили?

Сочувствую

Ответить | Правка | ^ к родителю #206 | Наверх | Cообщить модератору

224. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от t (??) on 07-Апр-16, 00:28 
о чем речь?
я на арче не так давно, всего два года, но тут явно комфортнее чем в убунте.
Ответить | Правка | ^ к родителю #65 | Наверх | Cообщить модератору

53. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 06-Апр-16, 12:34 
Вообще-то, в Убунте то же самое окно стало вылетать - в актуальной на данный момент 15.10. Конкретно XScreenSaver берется из Debian без изменений.
Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

200. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Elhana (ok) on 06-Апр-16, 19:17 
> В общем-то, кому надо новые версии, тот может Убунту каждые пол года
> ставить заново (или обновляться). Но вообще не всегда удобно, когда приходится
> ждать стабилизации программы. В той же генте косяки вспылвают иногда.

в убунте проблема та же :)

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

11. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +2 +/
Сообщение от noname133 on 06-Апр-16, 10:47 
>>В Debian используется версия XScreenSaver, выпущенная в 2014 году. В настоящее время в системе отслеживания ошибок Debian размещено около ста сообщений о проблемах, которые никак не решаются

К сожалению, обычная ситуация в Debian.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

17. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +2 +/
Сообщение от Аноним (??) on 06-Апр-16, 11:05 
Но вообще виндовая служба скринсейверов - это одна из самых легендарных своей забагованностью служб! Открой папку "Спам" и посмотри соддержимое zip-архивов. scr-файлы!
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

251. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Клыкастый (ok) on 07-Апр-16, 13:46 
> Но вообще виндовая служба скринсейверов - это одна из самых легендарных своей
> забагованностью служб! Открой папку "Спам" и посмотри соддержимое zip-архивов. scr-файлы!

это не баги, это косожопость by design

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

20. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +6 +/
Сообщение от Ordu email(ok) on 06-Апр-16, 11:09 
Да, и я вот о том же. Давно уже пора всем хомячкам понять очевидные преимущества венды и свалить отсюда обратно в свою тёплую и ламповую венду. Но нет ведь, что-то этим уродам мешает.
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

33. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от НяшМяш on 06-Апр-16, 11:43 
У меня из-за тебя монитор лопнул.
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

51. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +2 +/
Сообщение от Аноним (??) on 06-Апр-16, 12:34 
> У меня из-за тебя монитор лопнул.

Попробуй новопасин. Говорят помогает от порванных пуканов.
И да, стандартное предупреждение: перед консультацией употреби врача.

Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

34. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Анонимизатор on 06-Апр-16, 11:43 
> Да, и я вот о том же. Давно уже пора всем хомячкам
> понять очевидные преимущества венды и свалить отсюда обратно в свою тёплую
> и ламповую венду. Но нет ведь, что-то этим уродам мешает.

Мне вчера сказали, что надо вались с винды т к там шифровальщики всякие. Сегодня говорят валить обратно. Чего мне делать? А знаю, купить мак и успокоиться!

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

37. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +6 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 11:49 
>> Да, и я вот о том же. Давно уже пора всем хомячкам
>> понять очевидные преимущества венды и свалить отсюда обратно в свою тёплую
>> и ламповую венду. Но нет ведь, что-то этим уродам мешает.
> Мне вчера сказали, что надо вались с винды т к там шифровальщики
> всякие. Сегодня говорят валить обратно. Чего мне делать? А знаю, купить
> мак и успокоиться!

Ты и там всех достанешь.

Нет, просто валить, куда подальше.

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

41. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +8 +/
Сообщение от Киллер Люги on 06-Апр-16, 12:08 
> Нет, просто валить

Желаете сделать заказ?

Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

48. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +7 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 12:30 
Один не потяну. Может, на кикстартер?
Ответить | Правка | ^ к родителю #41 | Наверх | Cообщить модератору

80. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +6 +/
Сообщение от Crazy Alex (ok) on 06-Апр-16, 13:42 
Кхм, вот в кои-то веки согласен с Буратиной...
Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

81. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +4 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 13:46 
> Кхм, вот в кои-то веки согласен с Буратиной...

Ты, кстати, тоже.

Ответить | Правка | ^ к родителю #80 | Наверх | Cообщить модератору

113. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +3 +/
Сообщение от Crazy Alex (ok) on 06-Апр-16, 15:21 
Кхм :-)
Ответить | Правка | ^ к родителю #81 | Наверх | Cообщить модератору

73. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от iPony on 06-Апр-16, 13:22 
> А знаю, купить мак и успокоиться!

Это да...

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

75. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +3 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 13:25 
Наркоманы. Идите лучше из булочек мак выколупывайте.
Ответить | Правка | ^ к родителю #73 | Наверх | Cообщить модератору

142. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Michael Shigorin email(ok) on 06-Апр-16, 16:19 
> А знаю, купить мак и упокоиться!

Гм, первый шаг разве обязателен?

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

155. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от _ (??) on 06-Апр-16, 16:54 
Конечно! Он обретёт однополую любовь и _это_ его успокоит. А компьютеры тут так, для антуражу :)
Ответить | Правка | ^ к родителю #142 | Наверх | Cообщить модератору

225. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Led (ok) on 07-Апр-16, 01:08 
Тебе же сказали, малыш: иди в венду!
Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

233. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Адекват (ok) on 07-Апр-16, 06:53 
> Мне вчера сказали, что надо вались с винды т к там шифровальщики
> всякие. Сегодня говорят валить обратно. Чего мне делать? А знаю, купить
> мак и успокоиться!

Оставайся на винде и просто делай бекапы на отдельный носитель, это может быть не совсем дешево, но данные дороже денег.

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

252. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Клыкастый (ok) on 07-Апр-16, 13:49 
> Оставайся на винде и просто делай бекапы на отдельный носитель каждые пять минут. Под бэкапами понимается образ диска акронисом, это может быть не совсем дешево и охренненно тупо, но венда дороже денег.

//fixed

Ответить | Правка | ^ к родителю #233 | Наверх | Cообщить модератору

261. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 07-Апр-16, 17:06 
> Оставайся на винде и просто делай бекапы на отдельный носитель,

Кстати, давно хотел спросить:
Там наконец обратную совместимость бэкап-утилит из коробки завезли? Или продолжают славную традицию со времен 98 винды?

*гуглит^W уткает и офигевает – хотел просто вбросить, а оказалось что особо некуда вбрасывать-то*
http://windows.microsoft.com/en-us/windows/restore-backup-cr...
> Restore a backup created on a previous version of Windows
> To restore a backup created on a computer running Windows XP
> Download and install the Windows NT Backup - Restore Utility for Windows 7

http://www.howtogeek.com/212768/how-to-restore-windows-7-bac.../
> Windows 8.1 does offer support for restoring system image backups, but that won’t help if you’ve just
> used Windows Backup on Windows 7 to create backup copies of your important files

В общем, "все для пользователя!", да?

Ответить | Правка | ^ к родителю #233 | Наверх | Cообщить модератору

13. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Аноним (??) on 06-Апр-16, 10:53 
Отстань от Дебиана, дипломированный долбодятел! В твоём любимом Red Hat-е даже KDE не могут довести до последних минорных версий мажорного релиза.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

157. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от _ (??) on 06-Апр-16, 16:55 
А у вас мажоры миноров релизят!
Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

244. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Andrey Mitrofanov on 07-Апр-16, 12:26 
> Отстань от Дебиана, дипломированный долбодятел! В твоём любимом Red Hat-е даже

Всё путём: РХ вассалит своих вассалов. После зюстемдеца во все "независимые" дистрибутивы, им всем указания из обкома будут нести наместники. По *всем* вопросам жизнедеятельности. Вот Гаррет-Известный -- наместник по ранее независимой области Дебиан-ии, он в свою область и "долбит".

Не мешайте человеку работать!  </>

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

14. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от iPony on 06-Апр-16, 10:55 
А чего, много народу им пользуется?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору
Часть нити удалена модератором

67. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от Аноним (??) on 06-Апр-16, 13:01 
> Демьяном? Да почти никто уже.

Это только в твоей школьной голове.

http://w3techs.com/technologies/details/os-linux/all/all

Ответить | Правка | ^ к родителю #244 | Наверх | Cообщить модератору

86. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Омноним on 06-Апр-16, 14:00 
>http://w3techs.com/technologies/details/os-linux/all/all

Unix is used by 68.0% of all the websites.
Linux is used by 36.3% of all the websites.

>http://w3techs.com/technologies/details/os-unix/all/all

Linux is used by 53.4% of all the websites who use Unix.

Лови наркоманов.

Ответить | Правка | ^ к родителю #67 | Наверх | Cообщить модератору

89. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 06-Апр-16, 14:21 
Linux Is Not UniX же.
Ответить | Правка | ^ к родителю #86 | Наверх | Cообщить модератору

227. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от Admino (ok) on 07-Апр-16, 01:33 
>>http://w3techs.com/technologies/details/os-linux/all/all
> Unix is used by 68.0% of all the websites.
> Linux is used by 36.3% of all the websites.
>>http://w3techs.com/technologies/details/os-unix/all/all
> Linux is used by 53.4% of all the websites who use Unix.
> Лови наркоманов.

К.О. просил передать, что

68.0*0.534 = 36.312

Ответить | Правка | ^ к родителю #86 | Наверх | Cообщить модератору

18. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Аноним (??) on 06-Апр-16, 11:06 
Да фиг его знает: Debian стабильный классно для серваков, не обновлется - плохо для юзеров, дистры типа убунты или арча для юзеров - при обновлениях что-нибудь отпадёт

Ну не работает XScreenSaver, замени другим или спроси на форумах.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

35. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +3 +/
Сообщение от Анонимизатор on 06-Апр-16, 11:45 
> Да фиг его знает: Debian стабильный классно для серваков, не обновлется -

Если дело не доходит до уязвимостей. Старые штабильные дыры опаснее новых и быстро меняющихся, имхо.


Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

190. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от myhand (ok) on 06-Апр-16, 18:21 
>> Да фиг его знает: Debian стабильный классно для серваков, не обновлется -
> Если дело не доходит до уязвимостей. Старые штабильные дыры опаснее новых и
> быстро меняющихся, имхо.

Для исправлений безопасности в Debian есть security.debian.org, школьник.

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

237. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от Влад (??) on 07-Апр-16, 08:15 
А теперь перечитай еще раз статью. Мантайнеры дебиана бэкпортируют не все исправления безопасности. А новую версию использовать не могут, т.к. "стабильность". В итоге в stable лежит старая забагованная версия, пользователи жалуются в апстрим, а им там отвечают, что проблема в апстриме уже годы как исправлена.
Ответить | Правка | ^ к родителю #190 | Наверх | Cообщить модератору

248. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от myhand (ok) on 07-Апр-16, 13:05 
> А теперь перечитай еще раз статью. Мантайнеры дебиана бэкпортируют не все исправления
> безопасности. А новую версию использовать не могут, т.к. "стабильность".

Если "не все" - то пакет просто удалят из stable.  Что вам непонятно?

> В итоге в stable лежит старая забагованная версия

Так "забагованная", или с известными уязвимостями?  В статье, дарагой читатель, утверждается только первое, но никак не второе.

Ответить | Правка | ^ к родителю #237 | Наверх | Cообщить модератору

258. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Anonplus on 07-Апр-16, 16:01 
Забагованная. При этом, часть багов - потенциальные уязвимости (неизвестные, иначе они бы они считались именно как уязвимости, а не в общем месиве просто багов). Причем, порой они неизвестны лишь мейнтейнерам, а разработчикам известны, но разработчики по некоторым причинам это не стали афишировать.
Ответить | Правка | ^ к родителю #248 | Наверх | Cообщить модератору

270. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от myhand (ok) on 07-Апр-16, 19:11 
> При этом, часть багов - потенциальные уязвимости

Потенциальная уязвимость - это немножко беременна.

Есть то что есть, а не ваши фантазии на тему.

Ответить | Правка | ^ к родителю #258 | Наверх | Cообщить модератору

21. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 11:15 
> В ответ на жалобы пользователей о появлении раздражающего предупреждения, которое в случае использования устаревшей версии выводится при каждой блокировке экрана, разработчики Debian приняли патч, отключающий показ данного уведомления.

и где это обновление? на секурити не подписан, обновляюсь только с 127.0.0.1, куда синхронизирую jessie, jessie-updates и jessie-proposed-updates

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

213. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 06-Апр-16, 22:46 
В unstable наверное. Подожди, через годик-другой и тебе прилетит.
Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

23. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +2 +/
Сообщение от Аноним (??) on 06-Апр-16, 11:18 
Debian не виноват что в мире больше не осталось хороших майнтейнеров пакетов :-(
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

26. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 11:31 
в Debian такая бюрократия, что иногда проще повеситься :( некоторые авторы, которые хотели сопровождать свои же пакеты, годами пороги оббивали... а потом просто вымирали. до Debian доходят только самые стойкие
Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

185. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от www2 (??) on 06-Апр-16, 18:09 
Кто им мешал сопровождать себе свои пакеты в своих репозиториях?
Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

188. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 18:12 
> Кто им мешал сопровождать себе свои пакеты в своих репозиториях?

год в mentors считается?

Ответить | Правка | ^ к родителю #185 | Наверх | Cообщить модератору

191. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от myhand (ok) on 06-Апр-16, 18:23 
Что ж это за пакет такой был?
Ответить | Правка | ^ к родителю #188 | Наверх | Cообщить модератору

38. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от Анонимомус on 06-Апр-16, 11:51 
В случае Debian майнтейнером должен быть человек, не просто понимающий поведение приложения и умеющий собирать пакеты, это должен быть опытный программист, разбирающийся в приложениях, которые он бекпорирует, не хуже разработчиков, ~40k пакетов, допустим, это ~20к приложений, сколько надо майнтейнерев, чтобы был хоть один разобравшийся в каждом приложении?
Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

54. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +13 +/
Сообщение от grec on 06-Апр-16, 12:35 
О даа, истории с exim, openssh останутся в нашей памяти навсегда.
Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

61. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +2 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 12:52 
> О даа, истории с exim, openssh останутся в нашей памяти навсегда.

и много же людей пострадало?

в советские времена в журнале Костёр я читал такую шутку:

Внук говорит бабушке - солнце погаснет через 70000000000 лет
Та, испуганно: через сколько?
- через 70000000000
- уфф, а мне показалось, через 70000000

вот примерно в этом стиле "уязвимость" в openssh. или хоть один пострадавший будет? ну и пострадавшие с exim до кучи.

вот когда в 2002 году все венды в мире вырубились и ребутились при запуске, и только добрая воля автора не привела к тотальному уничтожению всех данных на всех виндах - вот это, понимаю, "помним"

Ответить | Правка | ^ к родителю #54 | Наверх | Cообщить модератору

90. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от grec on 06-Апр-16, 14:24 
Дебинизированый подход.
С тем же успехом можно спросить "и много же людей пострадало от кровоточащего сердца?" И не получив ответа, ничего не делать. Ага.
Ответить | Правка | ^ к родителю #61 | Наверх | Cообщить модератору

95. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 14:40 
> Дебинизированый подход.
> С тем же успехом можно спросить "и много же людей пострадало от
> кровоточащего сердца?" И не получив ответа, ничего не делать. Ага.

Ну если вы не понимаете сути проблемы, а мнение имеете - зачем вы это помните? Что в этом особенного?

Ответить | Правка | ^ к родителю #90 | Наверх | Cообщить модератору

158. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от grec on 06-Апр-16, 17:00 
Обычно на личности переходят, когда "прижало" или сказать нечего.
Всего хорошего.
Ответить | Правка | ^ к родителю #95 | Наверх | Cообщить модератору

167. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 17:21 
> Обычно на личности переходят, когда "прижало" или сказать нечего. Всего хорошего.

Ну, в данном случае сказать нечего именно вам. Да и на личности - тоже.

Сказали очевидную ложь, даже не зная, в чём суть была у "уязвимости" с openssl (а не openssh, как там написано, вы даже этого не знаете), а теперь с видом оскорблённой невинности покидаете нас? Ну что тут сказать... СПАСИБО!

Ответить | Правка | ^ к родителю #158 | Наверх | Cообщить модератору

102. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от anonymous (??) on 06-Апр-16, 15:12 
> В случае Debian майнтейнером должен быть человек, не просто понимающий поведение приложения
> и умеющий собирать пакеты, это должен быть опытный программист, разбирающийся в
> приложениях, которые он бекпорирует, не хуже разработчиков, ~40k пакетов, допустим, это
> ~20к приложений, сколько надо майнтейнерев, чтобы был хоть один разобравшийся в
> каждом приложении?

А не надо разбираться. Достаточно сообщить апстриму, который вполне способен предоставить патчи, или версию с исправлениями. Как в случае сабжа. Автор исправил все баги, приподнёс на блюдечке, а эти умники носом водят.

Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

111. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Crazy Alex (ok) on 06-Апр-16, 15:19 
Проблема в том, что автора хрен убедишь, что кроме багфикса НИКАКИХ изменений быть не должно. И багфикс видимых снаружи изменений вносить не должен, если это вообще возможно. Но авторы обычно при таких условиях на стену лезут - особенно те, что пихают в свой софт подобные предупреждения.
Ответить | Правка | ^ к родителю #102 | Наверх | Cообщить модератору

170. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от anonymous (??) on 06-Апр-16, 17:30 
>Проблема в том, что автора хрен убедишь, что кроме багфикса НИКАКИХ изменений быть не должно.

Нормальный автор всегда пойдёт на встречу. Сделает багфикс-версию, выкатит патч, как и в случае сабжа.

Ответить | Правка | ^ к родителю #111 | Наверх | Cообщить модератору

238. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от Влад (??) on 07-Апр-16, 08:18 
> Проблема в том, что автора хрен убедишь, что кроме багфикса НИКАКИХ изменений
> быть не должно. И багфикс видимых снаружи изменений вносить не должен,
> если это вообще возможно. Но авторы обычно при таких условиях на
> стену лезут - особенно те, что пихают в свой софт подобные
> предупреждения.

Вот делать больше автору нечего, кроме как в старых версиях паругодовой давности баги исправлять.

Ответить | Правка | ^ к родителю #111 | Наверх | Cообщить модератору

259. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Anonplus on 07-Апр-16, 16:07 
Это хорошо, когда тот участок кода не менялся. И можно быстренько баг зафиксить сразу в прошлых мажорных версиях. А если баг остался, а код уже попереписан?

Я понимаю ваше желание ехать на горбу автора софтины с максимальным удобством. Сначала вы просто пользуетесь чужим трудом, затем вы начинаете срать на голову разработчику, а в итоге - вы имеете наглость даже говорить "а пущай он ещё и вон ту дополнительную работу на себя взвалит". Ненавижу наглых людей.

Ответить | Правка | ^ к родителю #111 | Наверх | Cообщить модератору

117. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от anonymous (??) on 06-Апр-16, 15:35 
>Это должен быть опытный бюрократ

Fixed

Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

245. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Andrey Mitrofanov on 07-Апр-16, 12:32 
> Debian не виноват что в мире больше не осталось хороших майнтейнеров пакетов
> :-(

"Debian не виноват, что тащит в ро^W реп всякую муть (мозила, jwz, "опен"стэк,  [*не* продолжайте :/]), и вот он начинает в ней захлёбываться."

//не благодари

Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

30. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +4 +/
Сообщение от Аноним (??) on 06-Апр-16, 11:35 
>Мэтью Гаррет

Опять ему неймётся! Вроде ж говорил, что забил на линукс-разработку потому что в ней унижают феминисток и прочие меньшинства.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

36. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +9 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 11:48 
Теперь его и скринсейверы унижают
Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

264. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Andrey Mitrofanov on 07-Апр-16, 17:41 
> Теперь его и скринсейверы унижают

Не, дебьян по-прежнему унижает р-х-меньшинства... Ну, не отдаваясь всеми своими скринсейверами в добавок к pid1.... брейв нью уорлду. Возмутительненько!

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

46. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 06-Апр-16, 12:27 
Дебиан плавно накрывается медным тазом. С момента голосований, если быть точным. Больно смотреть на это
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

58. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от botman (ok) on 06-Апр-16, 12:47 
Я так вообще последний раз ставил скринсейвер не помню когда. Обычно монитор выключаю. Но ради такой новости установил и запустил. В testing поставился 5.34, актуальный. Но если xscreensaver уберут из debian, наверное не замечу.
Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

72. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Аноним (??) on 06-Апр-16, 13:21 
> Я так вообще последний раз ставил скринсейвер не помню когда. Обычно монитор выключаю.

А у нас на работе за такое в лучшем случае поставят черного властелина в качестве фона рабочего стола. Также знаю, что кое-где за такое и штрафуют.

Ответить | Правка | ^ к родителю #58 | Наверх | Cообщить модератору

187. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от www2 (??) on 06-Апр-16, 18:12 
Гражданин судья, а ему не дают на работе линуксом пользоваться.
Ответить | Правка | ^ к родителю #72 | Наверх | Cообщить модератору

246. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Andrey Mitrofanov on 07-Апр-16, 12:39 
> Дебиан плавно накрывается медным тазом. С момента голосований, если быть точным.
>Больно смотреть на это

Снеси хy-скринсейвер, глaза промой-закaпай, обратись к [настоящему] вpачу. По глазам, для начала. Может и с "дебиан плавно" полегчает.

Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

76. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от EuPhobos (ok) on 06-Апр-16, 13:27 
Debian.. please.. Rolling release ..
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

83. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 06-Апр-16, 13:52 
Welcome to Gentoo, Neo !
*fanfares*
Ответить | Правка | ^ к родителю #76 | Наверх | Cообщить модератору

88. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от анон on 06-Апр-16, 14:13 
Генту конечно побыстрее поднимает версии, но тоже не сказать, чтоб моментально.
Ответить | Правка | ^ к родителю #83 | Наверх | Cообщить модератору

93. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Аноним (??) on 06-Апр-16, 14:35 
Как и везде, это зависит от конкретного мэйнтейнера и/или от их кол-ва.
Ответить | Правка | ^ к родителю #88 | Наверх | Cообщить модератору

146. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от анон on 06-Апр-16, 16:25 
Ну в арчике гораздо шустрее.
Ответить | Правка | ^ к родителю #93 | Наверх | Cообщить модератору

235. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от iCat (ok) on 07-Апр-16, 07:53 
>Ну в арчике...

Вопрос "на засыпку": "В Арчике вот прямо сейчас какая версия Zabbix"?

Ответить | Правка | ^ к родителю #146 | Наверх | Cообщить модератору

280. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от archlover on 09-Апр-16, 13:21 
https://aur.archlinux.org/packages/?O=0&SeB=nd&K=zabbix&outd...
zabbix-server 3.0.1-3
Ответить | Правка | ^ к родителю #235 | Наверх | Cообщить модератору

253. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Клыкастый (ok) on 07-Апр-16, 13:56 
> Как и везде, это зависит от конкретного мэйнтейнера и/или от их кол-ва.

сильно не хватает мейнтейнеров. очень много софта мимо портежей.

Ответить | Правка | ^ к родителю #93 | Наверх | Cообщить модератору

250. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от Andrey Mitrofanov on 07-Апр-16, 13:44 
> Debian.. please.. Rolling release ..

А ещё есть соурсбейзеды.  B б3дешники, мешающие пакажи с пакетами.

https://www.opennet.ru/openforum/vsluhforumID3/90289.html#32 Релизить не всё ахом...
/
https://www.opennet.ru/openforum/vsluhforumID3/90289.html#26 Каквубунте?

--- К теме,
https://www.opennet.ru/openforum/vsluhforumID3/104606.html#105 Резать к ч-м, не дожидаясь!
https://www.opennet.ru/openforum/vsluhforumID3/90289.html#44 Они всех.

Ответить | Правка | ^ к родителю #76 | Наверх | Cообщить модератору

254. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от Клыкастый (ok) on 07-Апр-16, 13:58 
> А ещё есть соурсбейзеды.  B б3дешники, мешающие пакажи с пакетами.

Митрофаныч не подкачает. Если нужно смешать пакажи с пакетами или громко пожопоболить поперёк gnu.org - он завсегда.

Ответить | Правка | ^ к родителю #250 | Наверх | Cообщить модератору

255. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Michael Shigorin email(ok) on 07-Апр-16, 14:03 
"девочки, не ссорьтесь" (ц)
Ответить | Правка | ^ к родителю #254 | Наверх | Cообщить модератору

77. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от anonymous (??) on 06-Апр-16, 13:27 
Это явный недостаток дебиана. Исправления апстрима он почему-то полностью игнорирует.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

82. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Crazy Alex (ok) on 06-Апр-16, 13:47 
Это, чёрт побери, ПОЛИТИКА Дебиана. Для многих случаев она хорошо подходит. Для остальных - бери другой дистрибутив с другой политикой.
Ответить | Правка | ^ к родителю #77 | Наверх | Cообщить модератору

99. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от anonymous (??) on 06-Апр-16, 15:04 
>Это, чёрт побери, ПОЛИТИКА Дебиана. Для многих случаев она хорошо подходит. Для остальных - бери другой дистрибутив с другой политикой.

И что, теперь молиться на эту политику? Она явно устарела. Очень много софта сейчас имеет LTS-ветки, куда добавляются исключительно багфисксы.

Ответить | Правка | ^ к родителю #82 | Наверх | Cообщить модератору

105. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 15:15 
>>Это, чёрт побери, ПОЛИТИКА Дебиана. Для многих случаев она хорошо подходит. Для остальных - бери другой дистрибутив с другой политикой.
> И что, теперь молиться на эту политику? Она явно устарела. Очень много
> софта сейчас имеет LTS-ветки, куда добавляются исключительно багфисксы.

очень много чего-где-куда? а дебиан чё? а они? а дебиан? а ты?

Ответить | Правка | ^ к родителю #99 | Наверх | Cообщить модератору

107. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от anonymous (??) on 06-Апр-16, 15:16 
>>>Это, чёрт побери, ПОЛИТИКА Дебиана. Для многих случаев она хорошо подходит. Для остальных - бери другой дистрибутив с другой политикой.
>> И что, теперь молиться на эту политику? Она явно устарела. Очень много
>> софта сейчас имеет LTS-ветки, куда добавляются исключительно багфисксы.
> очень много чего-где-куда? а дебиан чё? а они? а дебиан? а ты?

Дар речи потерял?

Ответить | Правка | ^ к родителю #105 | Наверх | Cообщить модератору

162. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от _ (??) on 06-Апр-16, 17:10 
>Дар речи потерял?

Ну я - тоже. Ибо ты такой "абырвалг!!!" написал что либо пол-литра, либо см. выше :-\

Демьян ясно сказал: политика такая - после релиза, только фиксы и бакпорты! И вот уже 14 лет как _это_ работает. Заметь - дольше чем ты живёшь на этом свете :)
Когда это "не то", люди просто берут другой дистр, в зависимости от ... и ругают уже его :)))

Ответить | Правка | ^ к родителю #107 | Наверх | Cообщить модератору

205. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от grec on 06-Апр-16, 20:25 
>  И вот уже 14 лет как _это_ работает.

Fix. И вот уже 14 лет как это _кое как_ работает.

Ответить | Правка | ^ к родителю #162 | Наверх | Cообщить модератору

108. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Crazy Alex (ok) on 06-Апр-16, 15:16 
А тебя кто-то молиться заставляет? Вот лично меня такая политика устраивает - для работы. А дома гента - там она больше подходит.
Ответить | Правка | ^ к родителю #99 | Наверх | Cообщить модератору

192. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от www2 (??) on 06-Апр-16, 18:25 
>И что, теперь молиться на эту политику?

Не нравится - не ешь.

>Она явно устарела.

Пример сможешь привести, применительно к каким случаям она устарела?

>Очень много софта сейчас имеет LTS-ветки, куда добавляются исключительно багфисксы.

Дооо. Разницу между багом и уязвимостью хорошо понимаешь? В Debian обеспечивается СТАБИЛЬНОСТЬ поведения. Исправление бага, не являющегося уязвимостью, может привести к изменению поведения, на которое расчитывает пользователь системы. Помню, что в CentOS настройка DHCLIENT_IGNORE_GATEWAY=yes делала прямо противоположное, и этот баг не исправляли ради стабильности. Представь, что у тебя инсталляция из 500 серверов и тебе прилетает обновление с фиксом этого бага. Вот в этом и смысл дебиановской политики. Только школота может думать, что эта политика "устарела".

Ответить | Правка | ^ к родителю #99 | Наверх | Cообщить модератору

130. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –4 +/
Сообщение от Anonplus on 06-Апр-16, 15:51 
>> Для многих случаев она хорошо подходит

То есть, для тех случаев, когда безопасность не важна (читаем в новости про то, что некоторые уязвимости не помечаются разработчиками, как уязвимости, а мейнтейнеры не вникают в сущность исправлений).

Получается, вы считаете, что Дебиан подходит только для машин, у которых нет коммуникаций с внешним миром?

Ответить | Правка | ^ к родителю #82 | Наверх | Cообщить модератору

133. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +2 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 15:53 
> То есть, для тех случаев, когда безопасность не важна (читаем в новости
> про то, что некоторые уязвимости не помечаются разработчиками, как уязвимости, а
> мейнтейнеры не вникают в сущность исправлений).

расскажи, как ты удалённо хакнул xscreensaver

Ответить | Правка | ^ к родителю #130 | Наверх | Cообщить модератору

84. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от Аноним (??) on 06-Апр-16, 13:53 
> Это явный недостаток дебиана. Исправления апстрима он почему-то полностью игнорирует.

"испарвления апстрима"(за вычетом части backport-ов) "игнорируют" и красношапка и убунта и новел/сюза и все остальные. в СТАБИЛЬНОЙ вересии. в Testing или Unstable/Experimental - практически Rolling.


Ответить | Правка | ^ к родителю #77 | Наверх | Cообщить модератору

87. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +3 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 14:08 
>> Это явный недостаток дебиана. Исправления апстрима он почему-то полностью игнорирует.
> "испарвления апстрима"(за вычетом части backport-ов) "игнорируют" и красношапка и убунта
> и новел/сюза и все остальные. в СТАБИЛЬНОЙ вересии. в Testing или
> Unstable/Experimental - практически Rolling.

Не рушь людям картину мира. Пусть наличие в дебиане веток testing, sid и experimental останется нашей маленькой тайной. :)

Ответить | Правка | ^ к родителю #84 | Наверх | Cообщить модератору

100. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –3 +/
Сообщение от anonymous (??) on 06-Апр-16, 15:08 
>>> Это явный недостаток дебиана. Исправления апстрима он почему-то полностью игнорирует.
>> "испарвления апстрима"(за вычетом части backport-ов) "игнорируют" и красношапка и убунта
>> и новел/сюза и все остальные. в СТАБИЛЬНОЙ вересии. в Testing или
>> Unstable/Experimental - практически Rolling.
> Не рушь людям картину мира. Пусть наличие в дебиане веток testing, sid
> и experimental останется нашей маленькой тайной. :)

Открой для себя стабилизирующие релизы, где, заметь, разработчики сами исправляют ошибки. Впрочем, не буду рушить картину мира. Точнее мирка, куда себя загнали сами дебианщики.

Ответить | Правка | ^ к родителю #87 | Наверх | Cообщить модератору

103. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 15:14 
>>>> Это явный недостаток дебиана. Исправления апстрима он почему-то полностью игнорирует.
>>> "испарвления апстрима"(за вычетом части backport-ов) "игнорируют" и красношапка и убунта
>>> и новел/сюза и все остальные. в СТАБИЛЬНОЙ вересии. в Testing или
>>> Unstable/Experimental - практически Rolling.
>> Не рушь людям картину мира. Пусть наличие в дебиане веток testing, sid
>> и experimental останется нашей маленькой тайной. :)
> Открой для себя стабилизирующие релизы, где, заметь, разработчики сами исправляют ошибки.
> Впрочем, не буду рушить картину мира. Точнее мирка, куда себя загнали
> сами дебианщики.

я с прошлого века больше дистрибутивов видел и пробовал, чем ты книжек в детстве прочитал. ещё несколько лет назад у меня было несколько компьютеров, на каждом из которых было по 4 дистрибутива, а то и больше. плюс пара самодельных.

так что расскажи мне ещё о других дистрибутивах. а у меня сейчас один вопрос по дебиану возник, и чтобы его решить, я вот фоном накатываю дебианы sarge и etch. а ты рассказывай, рассказывай потихоньку - про картину мира, про кругозор и про то, почему ты тут самый умный и самый везучий, который, оказывается, видел и ДРУГИЕ дистрибутивы linux-систем.

Ответить | Правка | ^ к родителю #100 | Наверх | Cообщить модератору

109. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от anonymous (??) on 06-Апр-16, 15:17 
>[оверквотинг удален]
> я с прошлого века больше дистрибутивов видел и пробовал, чем ты книжек
> в детстве прочитал. ещё несколько лет назад у меня было несколько
> компьютеров, на каждом из которых было по 4 дистрибутива, а то
> и больше. плюс пара самодельных.
> так что расскажи мне ещё о других дистрибутивах. а у меня сейчас
> один вопрос по дебиану возник, и чтобы его решить, я вот
> фоном накатываю дебианы sarge и etch. а ты рассказывай, рассказывай потихоньку
> - про картину мира, про кругозор и про то, почему ты
> тут самый умный и самый везучий, который, оказывается, видел и ДРУГИЕ
> дистрибутивы linux-систем.

Дай угадаю. Школьник?

Ответить | Правка | ^ к родителю #103 | Наверх | Cообщить модератору

112. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 15:20 
>[оверквотинг удален]
>> в детстве прочитал. ещё несколько лет назад у меня было несколько
>> компьютеров, на каждом из которых было по 4 дистрибутива, а то
>> и больше. плюс пара самодельных.
>> так что расскажи мне ещё о других дистрибутивах. а у меня сейчас
>> один вопрос по дебиану возник, и чтобы его решить, я вот
>> фоном накатываю дебианы sarge и etch. а ты рассказывай, рассказывай потихоньку
>> - про картину мира, про кругозор и про то, почему ты
>> тут самый умный и самый везучий, который, оказывается, видел и ДРУГИЕ
>> дистрибутивы linux-систем.
> Дай угадаю. Школьник?

Школьник, школьник, не отвлекайся. Тебе вредно думать, размышлять и анализировать. Ты на вопросы-то отвечай. Хотим увидеть истину, которая сделает нас свободными - расскажи, как там, в ДРУГИХ ДИСТРИБУТИВАХ.

Ответить | Правка | ^ к родителю #109 | Наверх | Cообщить модератору

156. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 06-Апр-16, 16:54 
>я с прошлого века больше дистрибутивов видел и пробовал, чем ты книжек в детстве прочитал.

ну давай по меряемся, 20 томов Александра Дюма, 12 томов Жюль Верн. 4 тома Джек Лондон. 4 тома Гоголь. 6 томов  Александр Грин. 8 Томов Герберт Уэллс. 3 тома Фрэнк Герберт.
Это мы еще не будет трогать авторов у которых прочитано по 1-2 книги и школьную программу.
А сколько там у тебя было дистрибутивов линукса до 6 класса?

Ответить | Правка | ^ к родителю #103 | Наверх | Cообщить модератору

163. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 17:14 
>>я с прошлого века больше дистрибутивов видел и пробовал, чем ты книжек в детстве прочитал.
> ну давай по меряемся, 20 томов Александра Дюма, 12 томов Жюль Верн.
> 4 тома Джек Лондон. 4 тома Гоголь. 6 томов  Александр
> Грин. 8 Томов Герберт Уэллс. 3 тома Фрэнк Герберт.
> Это мы еще не будет трогать авторов у которых прочитано по 1-2
> книги и школьную программу.
> А сколько там у тебя было дистрибутивов линукса до 6 класса?

Ну, до 6 класса я книжек прочёл побольше, причём заметно. :) А вот дистрибутивов я даже все не вспомню, большинство было минидистрибутивами, которые я с bbs-ок скачивал, там гигазами варезов не накачаешься (один раз думал, что выкачиваю corel linux, долго выкачивал, и оказалось, что это corel draw for linux).

поехали, начиная с мелочи: mulinux, bbc-lnx (вещь!!!), baslinux (до сих пор пользуюсь, если попадаются 486 с мелким количеством ram и мелким hdd), dsl, и ещё пару десятков названий, которые я не вспомню.

средние: slax и несколько его вариантов, включая два самодельных и заметно изменённых. austrumi + несколько собственных его переделок под узкие ниши (в том числе, основная система на нетбуке в течение долгого времени). puppy linux.

ну и крупные: слака, начиная с древних времён. дебиан с 2004. мандрейк. мандрива. магея. ред хат чили пепперс. альт. вроде бы даже asp юзал, диск точно был, на какой-то фидопойке вручили, а вот донёс ли я его до компьютера и поставил ли - не помню. арч, начиная с последнего блэк оверлорда. юбунта, начиная с 6.06 (день, когда компьютеры жены и детей сказали бай-бай винде, тогда юбунта была ещё молодой и красивой. жена так и осталась молодой и красивой, а юбунта - нет). минт. гента (первый в моей жизни x64 дистр).

честно говоря, я так зависну на полночи, уже первый час - нужен большой список, чтобы я из него выбирал, что я не видел. из популярных - не ставил только федору, что не мешает мне её ненавидеть - вообще, из всех свободных систем я ненавижу только три: федору, генту и фрибсд.

не linux: freebsd в течение нескольких месяцев. netbsd немного. openbsd в течение уже нескольких лет, начиная с 5.2 - одна из основных систем. несколько раз ставил и пробовал освоиться в haiku, syllable, icaros. ну и menuet/kolibri рулят! а ещё в детстве были популярны qnx на дискете, где был браузер и даже можно было поднять модемное соединение

Ответить | Правка | ^ к родителю #156 | Наверх | Cообщить модератору

169. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от _ (??) on 06-Апр-16, 17:27 
Мужики, давайте как в старые добрые времена - просто приложим к линейке %)

> не linux: freebsd в течение нескольких месяцев.

Любопытно почему пошло поперёк? Ели это в абзац уложится...

Ответить | Правка | ^ к родителю #163 | Наверх | Cообщить модератору

174. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 17:42 
> Мужики, давайте как в старые добрые времена - просто приложим к линейке %)
>> не linux: freebsd в течение нескольких месяцев.
> Любопытно почему пошло поперёк? Ели это в абзац уложится...

Я уже раз 60 отвечал на этот вопрос, поэтому забыл - видимо, это защитная реакция организма, чтобы больше не отвечать.

Кстати, я не совсем правильно написал, я использовал не freebsd, а frenzy (отвёл ей 1 гб на hdd, и она там в уголке жила) в конкретной "полной" вариации. Идеально подобранный набор софта, всё работает, всё пригнано тютелька к тютельке, обширная документация на русском языке в комплекте. Следующая версия frenzy утратила эту самую идеальность. А крутить freebsd, разбираться, настраивать и так далее...

собственно, для меня Debian и OpenBSD обладают главными качествами - я могу легко поднять их на новом компьютере, или на двух, или на пяти, с нуля, находясь хоть в тайге, и это потребует от меня минимальных усилий. Я могу легко собрать локальный репозиторий, опять, где бы я не находился, с нуля, с минимумом усилий и на ровном месте. На подавляющем большинстве других систем я так не могу - они или требуют повышенного внимания, или там нет некоторых мелких нюансов. А это для меня не пустой звук - когда дети были маленькими, был популярный юзкейс "сломали ноутбук, надо новый и накатить на него чего-нибудь интересное", а сейчас бывают ситуации типа "очнулся в Казахстане, что делать - не знаю, пошёл побираться и выпрашивать себе компьютер".

Во freebsd я банально не знаю, как зазеркалить весь репозиторий (чтобы можно было жить и пользоваться абсолютно автономно), там нет иксов в базовой системе (надо разбираться, чё мне ваще надо, а чё нет - netbsd и openbsd приучают меня, что в базовой системе есть всё для первого старта) и так далее и тому подобное - куча мелких мелочей, которые лишают привычного удобства. В OpenBSD я прочитал небольшой faq, ещё до того, как решил его испробовать - и после этого я уже знал кучу нюансов, понимал многие вещи, система далась мне очень легко. Фряшный хэндбук я читал несколько раз, и тут основное отличие - он даёт инормацию, а опенбсдшная вводная документация даёт ПОНИМАНИЕ. Как человек, который не технарь и очень не хочет им быть, я очень тяжело воспринимаю FreeBSD, и очень легко (и с песенками) OpenBSD.

Ответить | Правка | ^ к родителю #169 | Наверх | Cообщить модератору

207. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от _ (??) on 06-Апр-16, 20:42 
> Как человек, который не технарь и очень не хочет им быть, я очень
> тяжело воспринимаю FreeBSD, и очень легко (и с песенками) OpenBSD.

Понятно.
А у меня наоборот - фряха сама собой всё делает, а опенок надо уговаривать :)
Вот потому я за то чтобы жили все 3(?) чертовские системы и тыщщи пингвинов тоже. Меня не раздражает, "пусть цветут все цветы" ...


Ответить | Правка | ^ к родителю #174 | Наверх | Cообщить модератору

214. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +2 +/
Сообщение от Аноним (??) on 06-Апр-16, 22:55 
>а сейчас бывают ситуации типа "очнулся в Казахстане, что делать - не знаю, пошёл побираться и выпрашивать себе компьютер".

Как скучно я, оказывается, живу :(

Ответить | Правка | ^ к родителю #174 | Наверх | Cообщить модератору

176. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 17:52 
а, ещё с момента основания manjaro долго пытался приспособить эту систему. крутил, вертел, но решил понял, что с этим кораблём я на дно не пойду. также в районе года крутил frugalware, но там неработоспособность системы была просто дикая, суммарное время на синки, обновления и прочее в разы больше, чем на реальную работу с этой системой - не потому, что синки занимали много времени, а потому что я не помню, удалось ли мне её хоть раз реально запустить...
Ответить | Правка | ^ к родителю #163 | Наверх | Cообщить модератору

262. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от angra (ok) on 07-Апр-16, 17:35 
Молодец, посмотрел на книжную полку родителей или дедушки/бабушки и перечислил все на ней.

Ответить | Правка | ^ к родителю #156 | Наверх | Cообщить модератору

160. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от Вова on 06-Апр-16, 17:02 
>я вот фоном накатываю дебианы sarge и etch

Археолог? Со времён etch уже четыре стабильных релиза вышло.

Ответить | Правка | ^ к родителю #103 | Наверх | Cообщить модератору

165. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 17:17 
>>я вот фоном накатываю дебианы sarge и etch
> Археолог? Со времён etch уже четыре стабильных релиза вышло.

у меня и вуди с потато есть. я знаю, кому, куда и сколько каких релизов вышло.

а вообще, я обожаю ковыряться в 486-х машинах (правда, дохнут, заразы, всё никак не могу музей собрать). я туда стараюсь ставить самые современные версии OpenBSD или более-менее актуальные версии Debian, но если что-то не работает - могу использовать архивные версии OpenBSD, Debian или Slackware. Кто-то винт игрушками набивает, кто-то - видеом непристойного содержания, а у меня большая часть носителей - это срезы репозиториев свободных ОС, от древних до современных :) В игрушки я не играю, видео не смотрю, поэтому досуг заполняю такими вещами :)

Ответить | Правка | ^ к родителю #160 | Наверх | Cообщить модератору

209. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от Михрютка (ok) on 06-Апр-16, 21:32 
> а вообще, я обожаю ковыряться в 486-х машинах (правда, дохнут, заразы, всё
> никак не могу музей собрать). я туда стараюсь ставить самые современные
> версии OpenBSD или более-менее актуальные версии Debian, но если что-то не
> работает - могу использовать архивные версии OpenBSD, Debian или Slackware. Кто-то
> винт игрушками набивает, кто-то - видеом непристойного содержания, а у меня
> большая часть носителей - это срезы репозиториев свободных ОС, от древних
> до современных :) В игрушки я не играю, видео не смотрю,
> поэтому досуг заполняю такими вещами :)

жениться вам пора барин

Ответить | Правка | ^ к родителю #165 | Наверх | Cообщить модератору

138. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от Аноним (??) on 06-Апр-16, 16:09 

> Открой для себя стабилизирующие релизы, где, заметь, разработчики сами исправляют ошибки.

Ага, это же Великая Честь – поддерживать с полдюжины дистрибутивов.

Причем, мейнтейнеры (совсем как анонимы с опеннета), иногда мнят себя Единственными и Непогрешимыми.
Помню, как автор deadbeefа "радовался" условиям^W предложениям мейнтейнеров дебиана по использования "правильных" версий зависимостей, а потом его Вумные и  Мудрые Анонимы пытались на путь истинный наставить,  гордо надувая щеки: "Ничтожество! Твое ненужно не приняли в дебиане! Ты отказался от великой чести!".

Ответить | Правка | ^ к родителю #100 | Наверх | Cообщить модератору

177. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 06-Апр-16, 17:57 
Автор deadbeefа - известный неадекват.
Ответить | Правка | ^ к родителю #138 | Наверх | Cообщить модератору

178. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 17:58 
> Автор deadbeefа - известный неадекват.

Так уж прямо и известный...

Ответить | Правка | ^ к родителю #177 | Наверх | Cообщить модератору

194. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 06-Апр-16, 18:42 
> Автор deadbeefа - известный неадекват.

Потому что не использует истинно правильные версии либ?

Так вроде все вполне обоснованно было, патчи  там кастомные от автора и все такое.
Да и занимает тот плейер со всеми своими "неадекватностями" аж:


deadbeef-0.7.1                 7.64MiB

Но надо же раздуть из мухи слона...
Ответить | Правка | ^ к родителю #177 | Наверх | Cообщить модератору

186. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от IMHO on 06-Апр-16, 18:09 
> известный неадекват.

я также не нахожу другого метода с неадекватами общатся

Ответить | Правка | ^ к родителю #138 | Наверх | Cообщить модератору

104. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от anonymous (??) on 06-Апр-16, 15:15 
>> Это явный недостаток дебиана. Исправления апстрима он почему-то полностью игнорирует.
> "испарвления апстрима"(за вычетом части backport-ов) "игнорируют" и красношапка и убунта
> и новел/сюза и все остальные. в СТАБИЛЬНОЙ вересии. в Testing или
> Unstable/Experimental - практически Rolling.

Не знаю про что ты говоришь, но в редхат патчи спокойно принимаются. Даже новую версию ставят, если её можно собрать.

Ответить | Правка | ^ к родителю #84 | Наверх | Cообщить модератору

164. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от _ (??) on 06-Апр-16, 17:16 
> Не знаю про что ты говоришь, но в редхат патчи спокойно принимаются.

В демьяне - тоже.
> Даже новую версию ставят, если её можно собрать.

Брехня. Только для _очень_ некоторых штук. Как и в демьяне :)

Ответить | Правка | ^ к родителю #104 | Наверх | Cообщить модератору

166. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 17:19 
> Брехня. Только для _очень_ некоторых штук. Как и в демьяне :)

В Debian в последнее время политика изменилась, и всё больше пакетов "скачут по апстриму". Вон, только что в стабле прилетело обновление virtualbox 4.3.18 на 4.3.36. правда, в бэкпортах пятая ветка, на коею я и перепрыгнул :)

Ответить | Правка | ^ к родителю #164 | Наверх | Cообщить модератору

171. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от anonymous (??) on 06-Апр-16, 17:32 
>> Не знаю про что ты говоришь, но в редхат патчи спокойно принимаются.
> В демьяне - тоже.

Вижу, как приняли. Ты хоть новость читал?

> Брехня. Только для _очень_ некоторых штук. Как и в демьяне :)

А точно ты отсылал?

Ответить | Правка | ^ к родителю #164 | Наверх | Cообщить модератору

116. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Кубер100 on 06-Апр-16, 15:31 
вот сидел я девять леть на демьяне.
и что меня дернуло на генту переползти... уже третий год практически ежедневно приходится что-то допиливать, обновух лезет тонны, и не всегда правильных...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

118. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 15:36 
> вот сидел я девять леть на демьяне.
> и что меня дернуло на генту переползти... уже третий год практически ежедневно
> приходится что-то допиливать, обновух лезет тонны, и не всегда правильных...

я примерно так же на арче сидел много лет - но не основной системой, у меня тогда было несколько основных систем, арч+слака, арч+дебиан, арч+убунта, арч+мандрива... тоже чё-то крутил, пилил, мутил... потом возвращался через полгода-год на арч - всё уже ушло далеко вперёд, чё крутил не помнишь, чё мутил не знаешь... и с тех пор в жизни стало гораздо больше дебиана. сейчас на всех компьютерах только две оси - Debian и OpenBSD. ну, иногда что-нибудь покрутить в виртуалке приходится, но это так, баловство одно.

Ответить | Правка | ^ к родителю #116 | Наверх | Cообщить модератору

119. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Кубер100 on 06-Апр-16, 15:38 
так же пользую BSD. правда на шлюзе и pfsense который.
Ответить | Правка | ^ к родителю #118 | Наверх | Cообщить модератору

121. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 15:40 
> вот сидел я девять леть на демьяне.
> и что меня дернуло на генту переползти... уже третий год практически ежедневно
> приходится что-то допиливать, обновух лезет тонны, и не всегда правильных...

Хотя и к Debian у меня претензий куча. Ну как претензий, я не бегаю и не ору, что Debian неидеален, а просто знаю это. Ну, когда кто-нибудь начинает перехваливать Debian в том месте, где я точно знаю, есть недостатки, тогда я об этом говорю. За это меня дебианщики не любят. Но когда хают дебиан безо всяких причин - тут уже я за Debian. За это меня не любят все остальные. А может и не за это. В общем, никто меня не люДит. А я к Debian-у, в принципе прохладно-равнодушен, но за 12 лет пользования - это вещь, которой я могу доверить свои сейвы к angband-у.

Ответить | Правка | ^ к родителю #116 | Наверх | Cообщить модератору

222. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –3 +/
Сообщение от Алонимус on 07-Апр-16, 00:08 
>обновух лезет

Ужос, прям сами и лезут. В таком случае и Windows 98 лучше

Ответить | Правка | ^ к родителю #116 | Наверх | Cообщить модератору

239. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Кубер100 on 07-Апр-16, 08:51 
дядя, ты дурак?
если сам на генте сидишь, то в курсе как там с этим все обстоит.
если нет == то в тряпочку помолчи, пожалуйста.)
Ответить | Правка | ^ к родителю #222 | Наверх | Cообщить модератору

147. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Онаним on 06-Апр-16, 16:26 
У меня на XUbuntu 15.10 то же самое орёт. Задолбали некрорепы.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

161. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 06-Апр-16, 17:05 
Поставь себе уже арч и не ипи людям моск. Там некрореп нет, только наисвежайшее глюкалово.
Ответить | Правка | ^ к родителю #147 | Наверх | Cообщить модератору

173. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от Онаним on 06-Апр-16, 17:38 
Несколько лет на нём сидел и это радовало. Потом открыл для себя Ubuntu (в те годы ещё с GNOME2) и узрел, что оно (Ubuntu i386 с GNOME2) парадоксально работает быстрее и "отзывчивее" (чем Arch i586 с XFCE). С тех пор сижу на Ubuntu по привычке (хотя снова на XFCE т.к. прекрасная Unity прибита гвоздями к глючному насквозь Compiz, сделал себе док AWN сбоку как в Unity и в общем счастлив). От некрореп PPA и ручная установка некоторых свежих вещей в /opt более-менее спасают, но системные компоненты типа скринлокера всё же хочется чтобы ставились стандартно.
Ответить | Правка | ^ к родителю #161 | Наверх | Cообщить модератору

175. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от бедный буратино (ok) on 06-Апр-16, 17:43 
> Несколько лет на нём сидел и это радовало. Потом открыл для себя
> Ubuntu (в те годы ещё с GNOME2) и узрел, что оно
> (Ubuntu i386 с GNOME2) парадоксально работает быстрее и "отзывчивее" (чем Arch
> i586 с XFCE).

arch i586? арч всегда был 686, а на 586 был какой-то малопопулярный и маловразумительный форк, я даже не знаю, жив ли тот вообще.

Ответить | Правка | ^ к родителю #173 | Наверх | Cообщить модератору

181. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Онаним on 06-Апр-16, 18:02 
Ну может 686, я уже не помню что там, сути в данном контексте это не меняет - более новая архитектура работала хуже более старой. Может дело вообще даже не в ней, просто это показалось мне немного забавным.
Ответить | Правка | ^ к родителю #175 | Наверх | Cообщить модератору

168. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от Аноним (??) on 06-Апр-16, 17:25 
>В настоящее время в системе отслеживания ошибок Debian размещено около ста сообщений о проблемах, которые никак не решаются.

О да, больше ста. 45 - Wishlist items; Unclassified, 27 - Normal bugs; Unclassified. С меткой important там всего семь багов, да и то подозрительно мало учитывая какой глючный кусок г... этот xscreensaver.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

221. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 06-Апр-16, 23:54 
> О да, больше ста. 45 - Wishlist items; Unclassified, 27 - Normal
> bugs; Unclassified. С меткой important там всего семь багов, да и
> то подозрительно мало учитывая какой глючный кусок г... этот xscreensaver.

Вы где-то не там смотрите.

Status
95 Outstanding
1 Resolved
2 From other Branch
Severity
1 Serious (policy violations or makes package unfit for release)
10 Important bugs
28 Normal bugs
6 Minor bugs
53 Wishlist items
Classification
4 Patch Available
1 Confirmed
85 Unclassified
5 Will Not Fix

Ответить | Правка | ^ к родителю #168 | Наверх | Cообщить модератору

203. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от Ilya Indigo (ok) on 06-Апр-16, 20:15 
А если сразу перейти на testing?
Там пакеты очень даже свежие. И прошу не путать testing и unstable.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

210. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Анонимко on 06-Апр-16, 21:56 
> А если сразу перейти на testing?

Там пакеты очень даже свежие.
Рано или поздно любой Debian на моих домашних компах превращался в Sid
Пакеты в тестинге свежие, но не долго.И чем дальше, тем чаще чего-то не хватает. Что-то можно по-быстрому сбэкпортить из sid, что-то приходится ставить прямо оттуда. И вот уже "брюки превращаются..." Кроме того, стадия заморозки очень бесит. Сначала обновлений нет, а потом на твой комп прилетает Sid.
При этом в бэкпортах мало что есть. Например для Wheezy за все время так и не собрали Xfce 4.10.
Багу с php-cli в wheezy так и не поправили, не работает интерактивный режим - надо самому пересобирать или ставить хз откуда.
Так что для десктопа дистр не очень дружелюбный - вроде пару лет назад собирались запустить Debian CUT да так все и заглохло. Но для сервера вполне себе вариант- все предсказуемо работает, пакетов в репах много, в отличии от того же CentOS, да и жизненный цикл теперь продлили. Впрочем, и Убунту сервер очень даже хорош и ничем не уступает демьяну. А после однозначного перехода на системд дебиан для меня перестал быть основным дистром.
Так что мой рецепт счастья - минимальная *buntu LTS + все что надо по вкусу. А скучать на стэйбле не дают разнообразные PPA

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

223. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от ононим88 on 07-Апр-16, 00:15 
Дебиан на сервере - самое оно.
Если нужны свежие пакеты - ставьте убунту.

Делаю так последние лет 6, проблем не ведаю.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

230. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –3 +/
Сообщение от Лютый жабист on 07-Апр-16, 05:48 
Вообще, очень интересный феномен. Когда такое говорит огого-директор фонда СПО, все открывают рты. Когда анонимусы на форумах называют Дебиан засохшим мамонтовым ге - все раздражаются.

Лично я после 15 лет юзанья линуксов пришёл к выводу, что самый стабильный и клёвый дистр для десктопа - это Rolling. Т.е. Арч или Гента. Там всегда последняя СТАБИЛЬНАЯ версия ПО.

Для сервера этакий почти-роллинг alpine. Если хочется поставить в шкаф и не трогать, то CentOS.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

231. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +1 +/
Сообщение от бедный буратино (ok) on 07-Апр-16, 06:24 
> Вообще, очень интересный феномен. Когда такое говорит огого-директор фонда СПО, все открывают
> рты. Когда анонимусы на форумах называют Дебиан засохшим мамонтовым ге -
> все раздражаются.
> Лично я после 15 лет юзанья линуксов пришёл к выводу, что самый
> стабильный и клёвый дистр для десктопа - это Rolling. Т.е. Арч
> или Гента. Там всегда последняя СТАБИЛЬНАЯ версия ПО.
> Для сервера этакий почти-роллинг alpine. Если хочется поставить в шкаф и не
> трогать, то CentOS.

Ты не поверишь, но в Debian есть Sid. Который появился там, когда 99.9% арчеюзеров ещё в детский сад ходили.

Ответить | Правка | ^ к родителю #230 | Наверх | Cообщить модератору

241. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от Лютый жабист on 07-Апр-16, 10:40 
Arch:

extra/mariadb 10.1.13-1

Протухший:

mariadb-server-10.0 (10.0.24-5)

итд

Ответить | Правка | ^ к родителю #231 | Наверх | Cообщить модератору

265. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Кубер100 on 07-Апр-16, 17:53 
сам на генте 3 года сижу == ни пса она не стабильная. до этого демьян пользовал.
Ответить | Правка | ^ к родителю #230 | Наверх | Cообщить модератору

257. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –1 +/
Сообщение от Anonplus on 07-Апр-16, 15:58 
>> С другой стороны, фиксация версий программ позволяет избежать переноса новых уязвимостей, появившихся из-за ошибок в новых версиях программ, что отчасти компенсирует угрозу наличия скрытых неисправленных проблем в устаревших версиях.

Хорошее слово "отчасти".
Вот баг в новой фиче, который закрыли через два месяца, и баг в старой дебиановской версии, который висит там уже два года. Допустим, что оба бага могли быть использованы злоумышленником (так что это уже даже не баги, а дыры в безопасности, но пока никто не заметил, что это дыры). Какая из них опаснее? Какая даёт злоумышленнику больше возможностей изучить код, подготовить эксплоит? Тут не "отчасти", тут совсем невозможно говорить о том, что оно компенсирует. Нужно на время жизни конкретной дыры смотреть. В одном случае компенсирует, в другом - нет.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

260. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –3 +/
Сообщение от Аноним (??) on 07-Апр-16, 16:21 
Дебиан это такой СССР в мире Linux. Скоро совсем сдохнет, походу.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

263. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от Аноним (??) on 07-Апр-16, 17:36 
Судя по обилию помоев, что выливают на Debian в последнее время, Debian набирает всё большие обороты.
Ответить | Правка | ^ к родителю #260 | Наверх | Cообщить модератору

267. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  –2 +/
Сообщение от Кубер100 on 07-Апр-16, 18:19 
набирает у кого, кто понял "стабильность"?
а мы уже давно там.)
Ответить | Правка | ^ к родителю #263 | Наверх | Cообщить модератору

281. "Конфликт из-за поставки устаревшей версии XScreenSaver в Deb..."  +/
Сообщение от Аноним (??) on 09-Апр-16, 14:08 
Лучше бы показывали какая раскладка сейчас на скринлоке
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру