The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Выпуск браузерного движка WebKitGTK+ 2.12.0 "
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Выпуск браузерного движка WebKitGTK+ 2.12.0 "  +/
Сообщение от opennews (??) on 22-Мрт-16, 19:33 
Доступен (http://webkitgtk.org/2016/03/22/webkitgtk2.12.0-released.html) выпуск новой стабильной ветки  WebKitGTK+ 2.12.0 (http://www.webkitgtk.org/), порта браузерного движка WebKit (http://webkit.org/) для платформы  GTK+. WebKitGTK+ позволяет использовать все возможности WebKit через GNOME-ориентированный программный интерфейс на основе GObject и может применяться для интеграции средств обработки web-контента в любые приложения, от использования в специализированных HTML/CSS-парсерах, до создания полнофункциональных web-браузеров. Из известных проектов, использующих WebKitGTK+, можно отметить Midori (http://www.midori-browser.org/) и штатный браузер GNOME (Epiphany).

Ключевые изменения (http://blogs.igalia.com/carlosgc/2016/03/22/webkitgtk-2-12/) в новой стабильной ветке:


-  В JavaScriptCore на системах x86_64 по умолчанию включён JIT-компилятор FTL (https://www.opennet.ru/opennews/art.shtml?num=39784), использующий оптимизатор LLVM для генерации эффективного машинного кода;
-  В рамках многопроцессной модели обеспечено ответвление отдельного процесса для обработки сетевых соединений (раньше данный сетевой процесс был опционален, а теперь обязателен);
-  Включены скрываемые полосы прокрутки, реализованы по аналогии с полосами прокрутки виджетов и приложений GTK+;
-  Добавлена поддержка использования безоконных плагинов NPAPI, работающих без интерфейса пользователя, на системах без X11, например, в окружениях на базе Wayland;
-  В libsoup включена поддержка GSS-Negotiate;
-  Улучшена общая производительность за счёт оптимизации цикла обработки событий glib;
-  Представлен новый API для записи и восстановления сеансов WebView.

URL: http://webkitgtk.org/2016/03/22/webkitgtk2.12.0-released.html
Новость: https://www.opennet.ru/opennews/art.shtml?num=44096

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Выпуск браузерного движка WebKitGTK+ 2.12.0 "  –1 +/
Сообщение от Аноним (??) on 22-Мрт-16, 19:33 
иш чего вспомнили, Midori, сейчас и так все браузеры на вебките, теперь-то он зачем нужен?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Выпуск браузерного движка WebKitGTK+ 2.12.0 "  –1 +/
Сообщение от Аноним (??) on 22-Мрт-16, 20:45 
> все браузеры на вебките

Назови хотя бы три (не включая Midori).

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

4. "Выпуск браузерного движка WebKitGTK+ 2.12.0 "  +/
Сообщение от Нимано on 22-Мрт-16, 21:05 
> Назови хотя бы три (не включая Midori).

vimb/vimprobable, surf, xombrero, deforaos-browser, epiphany, jumanji, luakit, uzbl, lariza, dwb,
Это только более-менее известные, на webkit-gtk =)

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Выпуск браузерного движка WebKitGTK+ 2.12.0 "  +/
Сообщение от Аноним (??) on 23-Мрт-16, 00:18 
> dwb

Сам долгое время был счастливым пользователем этого браузера (думал, что вот оно, счастье, и радовался бы до сих пор, если б он не помер), поэтому отпишусь касательно него.

С WebKit2 он не собирается, требует WebKit1 (который на сайте WebKitGTK+ помечен как "Deprecated API Reference"), то есть WebKitGTK+-2.4.10 или ниже.

По слухам (вроде с форумов арча), автор dwb после прекращения апстримом поддержки WebKit1 сказал, что больше он пилить совместимое только с WebKitGTK+ не собирается и сейчас занимается браузером, в котором можно будет менять движки. С тех пор ни нового браузера, ни обновлений dwb не было, браузер заброшен.

Итого dwb со сколь-нибудь последними версиями WebKitGTK+ не собирается и не работает, так что в новости о выходе WebKitGTK+-2.12 его можно не упоминать. Отсюда вопрос: среди остальных перечисленных вами хотя бы половина работает с WebKit2?

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

7. "Выпуск браузерного движка WebKitGTK+ 2.12.0 "  +/
Сообщение от Нимано on 23-Мрт-16, 01:52 
> По слухам (вроде с форумов арча), автор dwb после прекращения апстримом поддержки
> WebKit1 сказал, что больше он пилить совместимое только с WebKitGTK+ не
> собирается и сейчас занимается браузером, в котором можно будет менять движки.
> С тех пор ни нового браузера, ни обновлений dwb не было,
> браузер заброшен.

Там (Webkitgtk) все еще хуже насчет прибивания гвоздями:
https://bugs.webkit.org/show_bug.cgi?id=113663
отписался автор uzbl, но не суть важно – список длинный, "на всех хватит".

xombrero-вцы в свое время писали, что сетевую часть поменяли так, что "вклиниться" стало намного труднее.
Из того, что тогда, в этом контексте запомнилось: [гткшники9 перемудрили с кукисами – есть прибитое гвоздями классическое "принимать все, отклонять все, отклонять сторонние", а вот свой фильтр уже не встроить. Можно конечно получать уведомления о новых кексах, но там не указыается, какой именно "новый" – так что нужно пройтись по всему списку, сравнить с предыдущей "версией" и при надобности удалить – и так каждый раз.


> Отсюда вопрос: среди остальных перечисленных вами хотя бы половина работает с
> WebKit2?

Пилится для surf, но не тыкал.
Epiphany с версии 3.6.
Uzbl – вроде бы ожил и что-то есть на вебкит2 https://github.com/uzbl/uzbl/tree/next

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

8. "Выпуск браузерного движка WebKitGTK+ 2.12.0 "  +/
Сообщение от трукамент on 23-Мрт-16, 12:17 
это заговор!кто-то портит нормальные браузеры в никсах. не сложно догадаться кто.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

6. "Выпуск браузерного движка WebKitGTK+ 2.12.0 "  +1 +/
Сообщение от Аноним (??) on 23-Мрт-16, 01:18 
>> все браузеры на вебките
> Назови хотя бы три (не включая Midori).

Otter Browser, QtWeb, QupZilla

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

11. "Выпуск браузерного движка WebKitGTK+ 2.12.0 "  +1 +/
Сообщение от Аноним (??) on 23-Мрт-16, 20:55 
А в кутях разве не протухшая версия вебкита, в которой и ошибки далеко не всегда правили? Да и с кастомизацией было как то не очень, а уж теперь, после перехода на блинк...
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

13. "Выпуск браузерного движка WebKitGTK+ 2.12.0 "  +/
Сообщение от Аноним (??) on 26-Мрт-16, 13:03 
Да, всевышеперечисленное на Webkit образца где-то 2013. Годных браузеров на Эппловском свежаке по пальцам фрезеровщика пересчитать. :(
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

12. "Выпуск браузерного движка WebKitGTK+ 2.12.0 "  –1 +/
Сообщение от Дуплик (ok) on 23-Мрт-16, 20:59 
Причём тут WebKitGTK+? Перечисленные тобой недопрограммы на Qt.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

2. "Выпуск браузерного движка WebKitGTK+ 2.12.0 "  +/
Сообщение от Аноним (??) on 22-Мрт-16, 20:44 
> раньше данный сетевой процесс был опционален, а теперь обязателен

Кто-нибудь знает, чем вызвано такое решение?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

9. "Выпуск браузерного движка WebKitGTK+ 2.12.0 "  +/
Сообщение от Pickle on 23-Мрт-16, 12:28 
Фича стала считаться достаточно стабильной для включения её по умолчанию (ранее опционально, т.к. могли быть проблемы).
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

10. "Выпуск браузерного движка WebKitGTK+ 2.12.0 "  +/
Сообщение от Аноним (??) on 23-Мрт-16, 12:30 
> для включения её по умолчанию

Насколько я понял, она не "включена по умолчанию", а "сделана неотключаемой" :(

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру