The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Снова про подключение к двум провайдерам используя PBR"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]
Курсы по Juniper Junos в Москве и Петербурге
"Снова про подключение к двум провайдерам используя PBR"  
Сообщение от kant76 email(ok) on 03-Июн-06, 13:36 
Доброго дня всем!

Знаю что эта тема уже много раз обсуждалось.. Уже все по 10 раз перечитал.. Сделал конфиг как по книжке.. А не работает в чем трабл не пойму. Вот и прошу помощи. Ногами сильно не бить я в Cisco новичок
У меня значит ситуация такая. Локалка --> PIX и DMZ --> за оутсайдом пикса соответсвенно роутер (Cisco2651 c IOS 12.3(8)T3) на котором и хотелось бы реализовать подключение к двум провайдерам с отказоустойчивостью и балансировкой. В DMZ, между PIX и роутером и между роутером и первым провайдером(ISP1) используются реальные адреса этого провайдера. Ко второму провайдеру ISP2 подключение через его адреса. Значит траффик из DMZ  и из локалки при прохождении по маршруту ISP1 натить не надо , а надо делать нат только в случае если будет выбран маршрут через ISP2.
Такое вообще возможно?
Я попытался сделать вот что получилось. Весь трафик идет через ISP1 и при обрыве связи переключения не происходит, балансировки темболее.

!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname brd_router
!
boot-start-marker
boot-end-marker
!
no network-clock-participate slot 1
no network-clock-participate wic 0
aaa new-model
!
!
aaa authentication login default local
aaa session-id common
ip subnet-zero
ip cef
!
!
!
!
ip ips po max-events 100
ip domain name cisco.com
ip ssh time-out 60
ip ssh source-interface FastEthernet0/0
no ftp-server write-enable
!
!
!
!
!
track 123 rtr 1 reachability
!
track 124 rtr 2 reachability
!
!
!
!
interface FastEthernet0/0
ip address 81.177.x.x 255.255.255.240
ip nat inside
ip policy route-map ISP1_ISP2
duplex auto
speed 100
no cdp enable
!
interface FastEthernet0/1
no ip address
speed 100
full-duplex
!
interface FastEthernet0/1.1
description <NET Inside>
encapsulation dot1Q 10
ip address 81.177.x.x 255.255.255.240
no cdp enable
!
interface FastEthernet0/1.2
description <NET_Inside>
encapsulation dot1Q 20
ip address 83.221.x.x 255.255.255.248
no cdp enable
!
ip classless
**** маршрут на DMZ ****
ip route 81.177.x.x 255.255.255.224 FastEthernet0/0 81.177.x.x

ip route 81.177.x.x 255.255.255.240 FastEthernet0/0 permanent
ip route 81.177.x.x 255.255.255.240 FastEthernet0/1 permanent
ip http server
no ip http secure-server
ip nat inside source route-map ISP2_NAT interface FastEthernet0/1.2 overload
!
!
access-list 10 permit 81.177.x.x 0.0.0.15
access-list 11 permit 81.177.x.x 0.0.0.31

route-map ISP1_ISP2 permit 20
match ip address 10 11
set ip next-hop verify-availability 81.177.x.x 20 track 123
set ip next-hop verify-availability 83.221.x.x 30 track 124
!
route-map ISP2_NAT permit 10
match ip address 10 11
match interface FastEthernet0/1.2
!
!
!
control-plane
!
!
rtr 1
type echo protocol ipIcmpEcho 81.177.x.x
rtr schedule 1 life forever start-time now
rtr 2
type echo protocol ipIcmpEcho 83.221.x.x
rtr schedule 2 life forever start-time now

end

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Снова про подключение к двум провайдерам используя PBR"  
Сообщение от ilya email(ok) on 05-Июн-06, 10:33 
>Доброго дня всем!
>
>Знаю что эта тема уже много раз обсуждалось.. Уже все по 10
>раз перечитал.. Сделал конфиг как по книжке.. А не работает в
>чем трабл не пойму. Вот и прошу помощи. Ногами сильно не
>бить я в Cisco новичок
>У меня значит ситуация такая. Локалка --> PIX и DMZ --> за оутсайдом пикса соответсвенно роутер (Cisco2651 c IOS 12.3(8)T3) на котором и хотелось бы реализовать подключение к двум провайдерам с отказоустойчивостью и балансировкой. В DMZ, между PIX и роутером и между роутером и первым провайдером(ISP1) используются реальные адреса этого провайдера. Ко второму провайдеру ISP2 подключение через его адреса. Значит траффик из DMZ  и из локалки при прохождении по маршруту ISP1 натить не надо , а надо делать нат только в случае если будет выбран маршрут через ISP2.
>Такое вообще возможно?
>Я попытался сделать вот что получилось. Весь трафик идет через ISP1 и
>при обрыве связи переключения не происходит, балансировки темболее.

т.е. переключения вообще не происходит?

а балансировка в данном случае работать не будет корректно...

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

2. "Снова про подключение к двум провайдерам используя PBR"  
Сообщение от kant76 email(??) on 05-Июн-06, 10:42 
>
>т.е. переключения вообще не происходит?
>
именно... вообще не происходит....
Мне вот еще сказали чтоя на FastEthernet0/1.2 забыл nat outside добавить. Но попробовать нет пока возможности...

>а балансировка в данном случае работать не будет корректно...

Пусть не корректно но хоть как то будет работать? Уж не до хорошего...

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

3. "Снова про подключение к двум провайдерам используя PBR"  
Сообщение от boom (??) on 05-Июн-06, 12:51 
Почитайте вот это Reliable Static Routing Backup Using Object Tracking:
http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a00804457cd.html
Довольно все хорошо разжевано, с примерами, мне помогло..
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру