The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Прекращена поддержка ветки Ruby 1.9.3"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от opennews (ok) on 24-Фев-15, 15:49 
Разработчики языка программирования Ruby предупредили (https://www.ruby-lang.org/en/news/2015/02/23/support-for-rub.../) о полном завершении жизненного цикла ветки Ruby 1.9.3. Начиная с сегодняшнего дня исправления ошибок и уязвимостей больше не будут бэкпортироваться в ветку Ruby 1.9.3. Пользователям рекомендуется как можно скорее выполнить переход на Ruby 2.0.0 или более новый выпуск. Так как при подготовке ветки 2.0 разработчики более внимательно отнеслись к обеспечению совместимости с существующими приложениями, миграции с ветки 1.9 на 2.0 должна пройти заметно легче, чем переход с 1.8 на 1.9.


URL: https://www.ruby-lang.org/en/news/2015/02/23/support-for-rub.../
Новость: https://www.opennet.ru/opennews/art.shtml?num=41716

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Прекращена поддержка ветки Ruby 1.9.3"  +3 +/
Сообщение от A.Stahl (ok) on 24-Фев-15, 15:49 
Питонопроблемы в рубомире.
Языку ведь не 2 года от роду. Неужели так сложно не ломать обратную совместимость? А потом они удивляются, что сишники крутят пальцем у виска, когда разговор идёт про всякие руби, питоны, расты и гоу.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Прекращена поддержка ветки Ruby 1.9.3"  +1 +/
Сообщение от ваноним on 24-Фев-15, 15:57 
мсье сколько языков успел разработать и развить?
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

7. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от A.Stahl (ok) on 24-Фев-15, 16:14 
Мсье счастлив, что пишет на Си и по-доброму сочувствует рубигорастонистам.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

8. "Прекращена поддержка ветки Ruby 1.9.3"  –3 +/
Сообщение от ваноним on 24-Фев-15, 16:20 
мсье уже забыл миграцию на C99?
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Прекращена поддержка ветки Ruby 1.9.3"  +3 +/
Сообщение от A.Stahl (ok) on 24-Фев-15, 16:23 
И каким образом она ломала обратную совместимость?
Старый код отлично собирается.
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

15. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от Аноним (??) on 24-Фев-15, 17:33 
Рябушки же думают что так - не возможно :))))
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

33. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от ваноним on 25-Фев-15, 21:04 
мсье стандарт не открывал
Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

30. "Прекращена поддержка ветки Ruby 1.9.3"  –1 +/
Сообщение от chinarulezzz (ok) on 25-Фев-15, 13:32 
Си не годен для быстрой разработки/прототипирования.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

5. "Прекращена поддержка ветки Ruby 1.9.3"  –1 +/
Сообщение от ананим.orig on 24-Фев-15, 16:12 
с питоном проблем на данный момент гораздо меньше:
> $ eselect python list
> Available Python interpreters:
>  [1]   python2.7
>  [2]   python3.4 *
> $ eselect ruby list
> Available Ruby profiles:
>  [1]   ruby19 (with Rubygems)
>  [2]   ruby20 (with Rubygems) *
>  [3]   ruby21 (with Rubygems)
>  [4]   ruby22 (with Rubygems)

при этом от 2.7 осталась в зависимостях (у меня) только одна программа

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

22. "Прекращена поддержка ветки Ruby 1.9.3"  –2 +/
Сообщение от Аноним (??) on 24-Фев-15, 21:21 
лол, и что вас смущает? они обратно совместимы. А вот питон не совместим.
Ну и ктож виноват что в питоне не поддерживают 3.2,3.3
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

24. "Прекращена поддержка ветки Ruby 1.9.3"  –1 +/
Сообщение от ананим.orig on 25-Фев-15, 00:44 
> лол, и что вас смущает?

4 версии руби установлены? Установлены. По зависимостям.
Вот это факт.
А лол... ну дык что ещё идиoты могут?

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

26. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от Аноним (??) on 25-Фев-15, 06:46 
ну с дуру можно и *** поломать, не то что 4 версии руби установить.
Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

32. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от ананим.orig on 25-Фев-15, 16:23 
> ну с дуру можно и *** поломать

Вот тебе (в этом вопросе) — верю.

Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

6. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от Michael Shigorin email(ok) on 24-Фев-15, 16:14 
> Языку ведь не 2 года от роду. Неужели так сложно не ломать обратную совместимость?

Жаль, что matz -- не linus хотя бы немножко: стоило жёстко и решительно дать по рукам умникам, которые потащили 1.9 в production, головой не соображая вообще. :(

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

16. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от Аноним (??) on 24-Фев-15, 17:36 
Если уж затронул ... но так:
Стоило жёстко и решительно дать по рукам умникам, которые потащили ruby в production, головой не соображая вообще. :(

Любое рябопoдeлие работает только на машине девелопера. Иногда.
Смотрите кто больше всех пЫЩь-пыЩЪ от всяких докеров и меркуйте _почему_ :)))

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

17. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от Michael Shigorin email(ok) on 24-Фев-15, 17:45 
> Стоило жёстко и решительно дать по рукам умникам, которые головой не соображая вообще.

Разве что так, и то досогласовать бы.

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

31. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от ZloySergant (ok) on 25-Фев-15, 16:18 
>Любое рябопoдeлие работает только на машине девелопера. Иногда.

Угум, ты это еще GitHub'у скажи.

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

34. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от Аноним (??) on 25-Фев-15, 22:40 
Ты развернул GitHub на своей машине? :) Так что всё правильно.
Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

37. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от rachok email(ok) on 26-Фев-15, 17:23 
>>>Стоило жёстко и решительно дать по рукам умникам, которые потащили ruby в production, головой не соображая вообще. :(

Chef на рубях, и он очень даже канхфетка

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

10. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от Аноним (??) on 24-Фев-15, 16:41 
> Неужели так сложно не ломать обратную совместимость?

Сложно и вредно.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

11. "Прекращена поддержка ветки Ruby 1.9.3"  +3 +/
Сообщение от Аноним (??) on 24-Фев-15, 16:59 
Питонопроблемы только в питоне. Ruby 1.9 принёс неплохой прирост производительности, а миграция была не слишком болезненной. Python же всё не может прибить свою ветвь, ещё на 5 лет продлил её.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

12. "Прекращена поддержка ветки Ruby 1.9.3"  –1 +/
Сообщение от ананим.orig on 24-Фев-15, 17:12 
Да пофиг на ваши внутри-рубевые трэнды.
Как и на то что там приросло, что отвалилось.
Хоть на баше пишите, лишь бы работало приемлемо.

На пользовательском уровне вон, выше дал — в 2 раза рубей больше, чем питонов. И пересобирай потом все зависимости из-за всех зависящих от руби пакетов только потому, что у каждого клоуна свой взгляд какую версию использовать.

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

14. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от Michael Shigorin email(ok) on 24-Фев-15, 17:31 
> Ruby 1.9 принёс неплохой прирост производительности

Стоило дождаться 2.0 и помочь с выпуском, а не решать сегодняшние проблемы на копейку, создавая завтрашние на рубль.

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

23. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от Аноним (??) on 24-Фев-15, 22:06 
Да в чем проблемыто? Что Ruby 2.0 обратно не совместимы с 1.9.3
Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

35. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от funny_falcon on 26-Фев-15, 06:33 
кто тебе это сказал?
Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

36. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от Аноним (??) on 26-Фев-15, 09:23 
Ченджлог рубей 2.0, ерундовые несовместимости.
Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

25. "Прекращена поддержка ветки Ruby 1.9.3"  +1 +/
Сообщение от бедный буратино (ok) on 25-Фев-15, 04:49 
> А потом они удивляются, что сишники крутят пальцем у виска, когда разговор идёт про всякие руби, питоны, расты и гоу.

Я помню, как у меня в системе были gcc 2.9x, gcc 3.4 и gcc 4.x. Потому что разные вещи требовали разных версий gcc. Это только у идеального сферического C в вакууме нет таких зависимостей, а вот в дистрах бывает и по нескольку версий gcc.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

29. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от funny_falcon on 25-Фев-15, 13:23 
> Языку ведь не 2 года от роду.

Языку Ruby? или Ruby 1.9.3 ?

Язык Ruby появился в 1995 году, если что.

Ruby 1.9.3 вышел в 2011 году - т.е. четыре года назад.

И вообще-то Ruby 2.x довольно таки обратно совместимы с 1.9.3. Можно наткнуться на несовместимость (обратную) только если глубоко зарываться в редко возникающие юзкейсы.

Переход с 1.8.7 на 1.9.x был более болезненным из-за юникода. Но в итоге все перешли как раз к выходу 1.9.3, т.к. 1.9.х был банально быстрее.

Так что, вместо того чтобы плеваться по сторонам, вначале бы разобрался в сути вопроса.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от rachok email(ok) on 24-Фев-15, 16:00 
Интересно когда уже 2 руби будут в stable debian а то как-то пичально получается
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

13. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от Andrey Mitrofanov on 24-Фев-15, 17:22 
>уже 2 руби будут в stable debian а то как-то
> пичально получается

Глаза? https://packages.debian.org/search?searchon=sourcenames&keyw...

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

19. "Прекращена поддержка ветки Ruby 1.9.3"  +1 +/
Сообщение от Аноним (??) on 24-Фев-15, 17:55 
>>уже 2 руби будут в stable debian а то как-то пичально получается
> Глаза? https://packages.debian.org/search?searchon=sourcenames&keyw...

Мозги? То что ты кинул - это Jessy. Ограничь поиск (там сверху экрана) нужной веткой ...

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

20. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от Andrey Mitrofanov on 24-Фев-15, 18:33 
>>>уже 2 руби будут в stable debian а то как-то пичально получается
>> Глаза? https://packages.debian.org/search?searchon=sourcenames&keyw...
> Мозги? То что ты кинул - это Jessy. Ограничь поиск (там сверху
> экрана) нужной веткой ...

А он ещё не стэйбл? Да, мозги-мозги. ... https://packages.debian.org/search?searchon=sourcenames&keyw....

Ждём цирка по выкидыванию ruby из wheezy а-ля iceape. (какой шикарный набор букв)

А вам счастливо затвить и ждать релиза: попадёт ли в замороженный jessie 2.2.n.

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

27. "Прекращена поддержка ветки Ruby 1.9.3"  –1 +/
Сообщение от robux (ok) on 25-Фев-15, 07:55 
При переходе 1.8 -> 1.9 были проблемы. Но фичи добавили, подсластили пилюлю.
При 1.9 -> 2.0 никаких изменений (багов и фич) замечено не было.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

28. "Прекращена поддержка ветки Ruby 1.9.3"  +/
Сообщение от Аноним (??) on 25-Фев-15, 08:25 
там есть несовместимости например теперь по молчанию кодировка utf-8 и тд. но все они незначительные.
Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру