The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Около 74% установок PHP содержат проблемы с безопасностью"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от opennews (ok) on 31-Дек-14, 15:05 
Энтони Феррара (Anthony Ferrara), работающий в Google, проанализировал (http://blog.ircmaxell.com/2014/12/php-install-statistics.html) версии PHP на публично доступных серверах и пришёл к выводу, что безопасными являются лишь 25.94% установок, в которых используются свежие и поддерживаемые пакеты с PHP, в то время как в 74.06% случаев используются устаревшие версии, которые могут содержать уязвимости.  


Отмечается, что полученные показатели являются оптимистичными, в то время как реально процент уязвимых систем может быть больше из-за того, что к безопасным отнесены не только актуальные выпуски 5.6.4,  5.5.20 и 5.4.36, но и все установки PHP, работающие в дистрибутивах Linux, не прекративших выпуск обновлений. Например, выпуск PHP 5.3.3 признан безопасным, так как он используется в пакетах CentOS 6.6 и Debian 6, для которых ещё выпускаются обновления. При этом не учитываются ситуации, когда обновления пакета могут быть не установлены или PHP собран из исходных текстов.

Интересно, что для других языков программирования, CMS и серверных приложений статистика выглядит (https://docs.google.com/spreadsheets/d/1nIknWM8no-3oyd85wbnF...) намного лучше, например, безопасными признаны 82.27% установок Perl, 77.59% - Python, 64.48% - Nginx, 61.96% - Apache, 60.45% - WordPress, 45.23% - Drupal.

URL: http://blog.ircmaxell.com/2014/12/php-install-statistics.html
Новость: https://www.opennet.ru/opennews/art.shtml?num=41374

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Около 74% установок PHP содержат проблемы с безопасностью"  +3 +/
Сообщение от Sluggard (ok) on 31-Дек-14, 15:05 
Про Java и RoR ничего нет почему-то.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Около 74% установок PHP содержат проблемы с безопасностью"  –1 +/
Сообщение от омномномнимус on 31-Дек-14, 15:24 
Где ты видел бложеки на яве?
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Около 74% установок PHP содержат проблемы с безопасностью"  +5 +/
Сообщение от Sluggard (ok) on 31-Дек-14, 15:29 
Где ты в новости видел, что речь о бложеках? А на Java ЛОР написан. )
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

7. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от омномномнимус on 31-Дек-14, 16:18 
"бложеки" -- это было иносказательно. Имелись в виду не особо сложные сайты и пр.

А на лоре периодически выпадают NullPointerException и чо? :-)

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

8. "Около 74% установок PHP содержат проблемы с безопасностью"  +1 +/
Сообщение от Sluggard (ok) on 31-Дек-14, 16:57 
В новости и не о «не особо сложных сайтах».
А на ЛОРе много чего выпадает. И он сам порой. )
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

16. "Около 74% установок PHP содержат проблемы с безопасностью"  +3 +/
Сообщение от электронщег on 31-Дек-14, 19:30 
Вот уже десятый год подряд минимум 3-5 раз в сутки захожу на ЛОР, ни единого раза не видел никаких "выпадений". У нас разные ЛОРы? :)
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

17. "Около 74% установок PHP содержат проблемы с безопасностью"  +1 +/
Сообщение от Sluggard (ok) on 31-Дек-14, 19:35 
Почитай архивы l-o-r и lor-source.
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

4. "Около 74% установок PHP содержат проблемы с безопасностью"  +2 +/
Сообщение от Rodegast (ok) on 31-Дек-14, 15:46 
> 60.45% - WordPress, 45.23% - Drupal

Разве оно не на пыхе?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

15. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от Аноним (??) on 31-Дек-14, 18:26 
Речь о версиях самих фреймворков, не учитывая версию пыха и оси.
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

5. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от Аноним email(??) on 31-Дек-14, 15:47 
Интересно, около 26% безопасных установок ПХП, а Вордпресс и Друпал, которые на нем же, аж 60% и 45% ?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от Аноним (??) on 31-Дек-14, 15:52 
тут, наверное, фишка в самом пехопе-поделии и в способе его установки, получается, что четвёртый вротпресс установленный на шестую центось из её родных репов безопасен, а перделки хомяков на пехопешесть — опасны
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

9. "Около 74% установок PHP содержат проблемы с безопасностью"  +1 +/
Сообщение от re on 31-Дек-14, 17:19 
Единственное на чем бы начал из веба кодить на данный момент это go, хотя и то пузырь рано или поздно лопнет но на данный момент хомякфренди лучше имха нет, по ощущениям ведь нет дырка при всем уважении, вообщем с наступающим #opennet даешь нормальные картинки из постов в репосты в новом году а не логотип этого прославленного рессурса при всем уважении.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

10. "Около 74% установок PHP содержат проблемы с безопасностью"  +3 +/
Сообщение от Аноним (??) on 31-Дек-14, 17:37 
Как господь молвил.
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от Аноним (??) on 31-Дек-14, 17:55 
Похоже, уже начал встречать НГ :)
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

13. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от Аноним (??) on 31-Дек-14, 18:23 
Rust красивее, как мне кажется,
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

20. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от all_glory_to_the_hypnotoad (ok) on 31-Дек-14, 19:57 
оно точно не для веба. По крайней мере типичные веб-макаки не осилят на нём херачить код.
Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

23. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от Grammar_Nazi on 01-Янв-15, 11:46 
"в общем", ёпта
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

25. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от True GN on 01-Янв-15, 19:12 
> "в общем", ёпта

«В общем», ёпта.

Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

12. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от cmp (ok) on 31-Дек-14, 18:05 
а нжинкс нынче язык программирования?

как можно противопоставлять вордпресс нжинкс и пхп, если это ингридиенты одного бутерброда, почему ссл не упомянут, получается насобирали циферок - вот они, "они не точные, и непонятно как друг на друга завязаны, но мы работаем в гугле и точно знаем, что пхп отстой!", отличная статистика, дело чурова живет

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

21. "Около 74% установок PHP содержат проблемы с безопасностью"  +2 +/
Сообщение от all_glory_to_the_hypnotoad (ok) on 31-Дек-14, 20:06 
> вот они, "они не точные, и непонятно как друг на друга завязаны, но мы работаем в гугле и точно знаем, что пхп отстой!"

Чуваку хочень хотелось написать какой-нибудь псто в своём журнале, вот он и состряпал его из чего было. Прямо таки хозяюшка рукодельница.

А другому чуваку очень захотелось что-то перепостить на опеннет и он как-то узнал что первый чувак имеет какое-то отношение к гуглу - ну а почему бы этот факт не засунуть в текст новости? Так же она громче звучит.

Ну а что пхп лютый кусок гогна и так все знают, можно было бы лишний раз не озвучивать очевидный факт.

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

27. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от Аноним (??) on 01-Янв-15, 22:34 
Ну конфиг nginx вполне себе язык программирования - правда декларативный. Туда ходи сюда не ходи. Вообще не важно что везде где есть варианты и это в виде текста PHP, HTML, JS, XAML,SQL это языки программирования только программы там специфичные. Для "различных" компиляторов.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

32. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от Другой аноним on 04-Янв-15, 23:55 
Аноним, ты идиот. HTML и иже с ним - языки разметки, а не программирования.
Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

33. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от XoRe (ok) on 05-Янв-15, 21:07 
Давно хотел перейти с php на drupal.
Заодно уйду с nginx и apache.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от YetAnotherOnanym (ok) on 31-Дек-14, 18:24 
> безопасными признаны 82.27% установок Perl

Вечно эти прокуренные старпёры со своим перлом нормальным людям статистику портят!

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

18. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от all_glory_to_the_hypnotoad (ok) on 31-Дек-14, 19:47 
> то безопасными являются лишь 25.94% установок, в которых используются свежие и поддерживаемые пакеты с PHP

Так и новые PHP пакеты когда-то становятся старыми с уязвимостями, этот замкнутый круг никак не исправить, пых обречён благодаря своим тупым апологетам.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

19. "Около 74% установок PHP содержат проблемы с безопасностью"  –1 +/
Сообщение от all_glory_to_the_hypnotoad (ok) on 31-Дек-14, 19:49 
> безопасными признаны 82.27% установок Perl,

ну да, неуловимый джо такой неуловимый. Нужно же ещё оценивать уязвимость самого кода, перл в этом плане далеко от пыха не уползёт.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

22. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от Аноним (??) on 01-Янв-15, 06:34 
100% ложь.

Куча дистров имеют "старые" "небезопасные" версии PHP, которые пропатчены на предмет уязвимостей.

"Исследователей" на помойку.

// b.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

26. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от Аноним (??) on 01-Янв-15, 20:54 
> 100% ложь.
> Куча дистров имеют "старые" "небезопасные" версии PHP, которые пропатчены на предмет уязвимостей.

Специально для таких как вы в новости пример разжеван "....в которых используются свежие и _поддерживаемые_ пакеты с PHP ...... к безопасным отнесены не только актуальные выпуски 5.6.4, 5.5.20 и 5.4.36, но и все версии PHP, поставляемые в дистрибутивах Linux, не прекративших выпуск обновлений. Например, выпуск PHP 5.3.3 признан безопасным, так как он используется в пакетах CentOS 6.6 и Debian 6, для которых ещё выпускаются обновления."

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

29. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от Аноним (??) on 02-Янв-15, 04:37 
* Protects the internal memory manager against bufferoverflows with Canary and SafeUnlink Protection
* Protects Destructors of Zend Hashtables
* Protects Destructors of Zend Linked-Lists
* Protects the PHP core and extensions against format string vulnerabilities
* Protects against errors in certain libc realpath() implementations
* Protection Simulation mode :!:
* Adds the functions sha256() and sha256_file() to the PHP core
* Adds support for CRYPT_BLOWFISH to crypt() on all platforms
* Transparent protection of open phpinfo() pages
* EXPERIMENTAL SQL database user protection
etc..

http://www.suhosin.org/stories/feature-list.html

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

30. "Около 74% установок PHP содержат проблемы с безопасностью"  +2 +/
Сообщение от sergey_klay email(ok) on 02-Янв-15, 08:00 
Это всё говорит только об одном — чаще обновляйтесь
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

31. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от CSRedRat email(ok) on 04-Янв-15, 14:52 
Drupal меньше 50% и меньше Wordpress - теперь-то всё понятно и на своих местах.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

34. "Около 74% установок PHP содержат проблемы с безопасностью"  +/
Сообщение от Аноним (??) on 08-Янв-15, 14:57 
> Интересно, что для других языков программирования, CMS и серверных приложений статистика выглядит намного лучше, например, безопасными признаны 82.27% установок Perl, 77.59% - Python, 64.48% - Nginx, 61.96% - Apache, 60.45% - WordPress, 45.23% - Drupal.

Nginx и Apache - не являются языками программирования!
WordPress и Drupal - являются CMS, и написаны на РНР!

Новость похожа на вброс информации от "Троля"
С незапамятных времен известно, что в РНР периодически находят уязвимости, которые затем исправляют. А вот что ВСЕ! хостинг-центры используют принципиально уязвимые сервисы - это КОНСТАНТА и уже несколько лет!

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру