<?xml version="1.0" encoding="koi8-r"?>
<rss version="0.91">
<channel>
    <title>OpenForum RSS: Атаки на приложения, использующие ImageMagick в конфигурации по умолчанию</title>
    <link>https://www.opennet.ru/openforum/vsluhforumID3/142366.html</link>
    <description>Координационный центр CERT (компьютерная группа реагирования на чрезвычайные ситуации), опубликовал предупреждение о выявлении уязвимостей, затрагивающих приложения и сайты, использующие библиотеку  ImageMagick в конфигурации по умолчанию для обработки или преобразования изображений. Успешная эксплуатация позволяет атакующему читать и записывать файлы, насколько позволяют права доступа под которыми выполняется  ImageMagick. Уязвимостям присвоено кодовое имя ImageTragick2, по аналогии с проблемой, выявленной в 2016 году...&lt;br&gt;&lt;br&gt;Подробнее: https://www.opennet.ru/opennews/art.shtml?num=66679&lt;br&gt;</description>

<item>
    <title>Атаки на приложения, использующие ImageMagick в конфигурации... (Аноним)</title>
    <link>https://www.opennet.ru/openforum/vsluhforumID3/142366.html#90</link>
    <pubDate>Sun, 15 Nov 2026 10:08:08 GMT</pubDate>
    <description>&amp;gt; ага, именно поэтому винда их скрывает, а каждое 2е письмо на почту это файл _моя_голая_фоточка.jpg.exe&lt;br&gt;&amp;gt; вам 5 лет чтоли?&lt;br&gt;&lt;br&gt;Пять лет, похоже, вам. Такое даже в спам уже лет пятнадцать не валится, в силу бесперспективности.&lt;br&gt;</description>
</item>

<item>
    <title>Атаки на приложения, использующие ImageMagick в конфигурации... (User)</title>
    <link>https://www.opennet.ru/openforum/vsluhforumID3/142366.html#89</link>
    <pubDate>Sat, 14 Nov 2026 19:37:23 GMT</pubDate>
    <description>&amp;gt;&amp;gt; принятый rfc на этот счёт - есть?&lt;br&gt;&amp;gt; RFC 2045, RFC 2046, RFC 2047, RFC 2048, RFC 2049...&lt;br&gt;&lt;br&gt;Ээээ... И что тут написано про использование &quot;file extension&quot; для определения типа файла и его приоритете над этим самым &quot;содержимым&quot;, М? &lt;br&gt;</description>
</item>

<item>
    <title>Атаки на приложения, использующие ImageMagick в конфигурации... (yet another anonymous)</title>
    <link>https://www.opennet.ru/openforum/vsluhforumID3/142366.html#88</link>
    <pubDate>Sat, 14 Nov 2026 17:59:42 GMT</pubDate>
    <description>Вы глаза-то разуйте. IM совршенно правильно определяет формат данных, но виноват он в том, что перед ним облажались с фильтрацией контента, с которой инфраструктура того же file&apos;а справляется.&lt;br&gt;&lt;br&gt;&amp;gt; Я уже не помню, что-то с HTML, что-то с PDF. Я убрал зависимость от file из того техпроцесса.&lt;br&gt;&lt;br&gt;Ну и молодец.&lt;br&gt;</description>
</item>

<item>
    <title>Атаки на приложения, использующие ImageMagick в конфигурации... (tkzv)</title>
    <link>https://www.opennet.ru/openforum/vsluhforumID3/142366.html#87</link>
    <pubDate>Sat, 14 Nov 2026 17:34:48 GMT</pubDate>
    <description>&amp;gt; Классно! А если у тебя файл зовут image.jpg.png.pdf.sh? Какое у него расширение? &lt;br&gt;&amp;gt; А то точки на месте, вон сколько точек, можем еще отсыпать. &lt;br&gt;&amp;gt; Ты скажешь &amp;#171;sh&amp;#187;, но это будет противоречить твоим словам, что все &lt;br&gt;&amp;gt; дело только в точках в имени. Так какое?&lt;br&gt;&lt;br&gt;Если расширений цепочка, как *.tar.gz, берётся последнее.&lt;br&gt;</description>
</item>

<item>
    <title>Атаки на приложения, использующие ImageMagick в конфигурации... (tkzv)</title>
    <link>https://www.opennet.ru/openforum/vsluhforumID3/142366.html#86</link>
    <pubDate>Sat, 14 Nov 2026 17:32:00 GMT</pubDate>
    <description>&amp;gt; принятый rfc на этот счёт - есть?&lt;br&gt;&lt;br&gt;RFC 2045, RFC 2046, RFC 2047, RFC 2048, RFC 2049...&lt;br&gt;</description>
</item>

<item>
    <title>Атаки на приложения, использующие ImageMagick в конфигурации... (tkzv)</title>
    <link>https://www.opennet.ru/openforum/vsluhforumID3/142366.html#85</link>
    <pubDate>Sat, 14 Nov 2026 17:25:49 GMT</pubDate>
    <description>За столько лет могли бы и настроить.&lt;br&gt;&lt;br&gt;MIME прописать &amp;#8212; несколько минут работы. Конвертация из/в webp полностью грузит одно ядро на секунду-две. AVIF &amp;#8212; ещё больше. Если сайт хоть кому-то интересен, постоянное конвертирование отжирает кучу времени CPU.&lt;br&gt;</description>
</item>

<item>
    <title>Атаки на приложения, использующие ImageMagick в конфигурации... (Ivan_83)</title>
    <link>https://www.opennet.ru/openforum/vsluhforumID3/142366.html#84</link>
    <pubDate>Sat, 14 Nov 2026 17:00:44 GMT</pubDate>
    <description>Вы то сами этим file пользовались?&lt;br&gt;&lt;br&gt;Удачи вам сделать так чтобы ваш файловый манагер открывал правильной прогой файлы игнорируя расширения и полагаясь только на выдачу file.&lt;br&gt;Если бы оно было так просто - это бы давно заюзали везде.&lt;br&gt;</description>
</item>

<item>
    <title>Атаки на приложения, использующие ImageMagick в конфигурации... (Ivan_83)</title>
    <link>https://www.opennet.ru/openforum/vsluhforumID3/142366.html#83</link>
    <pubDate>Sat, 14 Nov 2026 16:58:14 GMT</pubDate>
    <description>Текст для кого?&lt;br&gt;&lt;br&gt;Хочешь смотреть .html  в нотепаде а .c в браузере?&lt;br&gt;Если убрать расширение и попытатся смотреть в контент для определения реального типа при открытии то будет вот такая фигня довольно часто.&lt;br&gt;&lt;br&gt;Я не спорю с тем что расширения это не удобно, и возможно с самого начала (годах в 60-70х) нужно было архитектурно делать так чтобы файл всегда содержал заголовок с метаинформацией, тогда бы он был не отчуждаемым, и не потребовалось бы отдельно изобретать EXIF, тэги в мп3, VERSION в exe файлах и прочее что было напихано. И вот эти миме типы тоже были бы не нужны.&lt;br&gt;&lt;br&gt;Но мир пошёл по пути: &quot;потом чтонить придумаем&quot; и оно получилось как получилось.&lt;br&gt;И теперь часто есть какие то данные чьё содержимое надо угадывать по расширению, миме типу, и уже потом по внутрянке.&lt;br&gt;</description>
</item>

<item>
    <title>Атаки на приложения, использующие ImageMagick в конфигурации... (Ivan_83)</title>
    <link>https://www.opennet.ru/openforum/vsluhforumID3/142366.html#82</link>
    <pubDate>Sat, 14 Nov 2026 12:47:47 GMT</pubDate>
    <description>Да проходили мы это уже 100500 раз: у всяких кодеков, фаерволов и прочего обычно столько всяких параметров и крутилок что реализовать к ним нормальный гуй не получается, всякий раз это кастрированный функционал или там чорт ногу сломит и проще уже открыть терминал/текстовый редактор и там всё нужное написать.&lt;br&gt;&lt;br&gt;Пресеты может где то и есть, но попробуй туда упихать всё опции что есть в том же ffmpeg.&lt;br&gt;Окажется что ты и половины из своего гуя не сделаешь.&lt;br&gt;А ffmpeg и зависимые кодеки обновляются каждый месяц и там только прирастает.&lt;br&gt;В итоге любители гуём сидят со старым и кастрированным решением.&lt;br&gt;&lt;br&gt;</description>
</item>

</channel>
</rss>
