The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

PPPoE сервер на Cisco с авторизацией через Radius
сделано на Cisco 7507, коммутатор Catalyst 5000 все интерфейсы FE
Помимо предоставления фиктивных адресов через Radius, создан VLAN с реальными
адресами для тех клиентов, которым в силу определенных причин необходимы
реальные адреса.

Первым делом разрешите на cisco Radius:

aaa authentication login default local
aaa authentication ppp default group radius
aaa authorization exec default local !запрет использования Radius для exec
aaa authorization network default group radius
aaa accounting network default start-stop group radius

Разрешите VPN:

vpdn enable

Создайте группу:

vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1

Создайте сабинтерфейсы для VLAN на внутреннем Ethernet интерфейсе:

interface FastEthernet0/0.1
description PPTP clients
encapsulation dot1Q 2
ip address 192.168.0.1 255.255.255.0
no ip redirects
ip nat inside
pppoe enable

interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 81.ххх.ххх.ххх 255.255.255.240

Добавьте ip nat outside на Internet интерфейсе

Создайте Virtual-Template1

interface Virtual-Template1
ip unnumbered FastEthernet0/0.1
ip nat inside
ppp authentication chap pap callin

Добавьте использование функции NAT overload на Internet интерфейсе для адресов из access-list 1

ip nat inside source list 1 interface FastEthernet1/0 overload
access-list 1 permit 192.168.2.0 0.0.0.255 !для этих адресов разрешить NAT

На этом интерфейсе живет Radius сервер:

ip radius source-interface FastEthernet0/0.2

Это его настройки:

radius-server configure-nas
radius-server host 81.ххх.ххх.ххх auth-port 1812 acct-port 1813
radius-server retransmit 3
radius-server timeout 30
radius-server key xxxxxxxxxxxxxxxxx

P.S. Radius у меня сам выдает IP вида 192.168.2.ххх по имени пользователя. Если
вам это не подходит то сделайте:
ip local pool PPPoE 192.168.2.2 192.168.2.254
 
15.03.2005 , Автор: kukachik , Источник: http://www.opennet.ru/openforum/vsl...
Ключи: cisco, radius, pppoe / Лицензия: CC-BY
Раздел:    Корень / Маршрутизаторы Cisco, VoIP / Ограничение и учет трафика на Cisco

Обсуждение [ RSS ]
 
  • 1, sergioborcov, 17:37, 23/01/2008 [ответить] [смотреть все]
  • +/
    Добрый день!
    У меня вопрос.Что из приведенего конфига нужно для того чтобы подключать через рррое клиентов с реальными адресами.Мне нужно только таких подключить.То есть ната  мне не надо.Не могли бы показать что необходимо сконфигурить для такой задачи.
    Заранее благодарен.
    p.s.извините за глупый вопрос,но впервые делаю такое на циске.
     
     
  • 2, Илья Щепткин, 07:33, 27/06/2008 [^] [ответить] [смотреть все]
  • +/
    >Добрый день!
    >У меня вопрос.Что из приведенего конфига нужно для того чтобы подключать через
    >рррое клиентов с реальными адресами.Мне нужно только таких подключить.То есть ната
    > мне не надо.Не могли бы показать что необходимо сконфигурить для
    >такой задачи.
    >Заранее благодарен.
    >p.s.извините за глупый вопрос,но впервые делаю такое на циске.

    В статье же написано "Radius у меня сам выдает IP вида 192.168.2.ххх по имени пользователя"

    Т.е. тебе надо заменить эти приватные адреса на интерфейсе FastEthernet0/0.1 (если следовать конфигу в статье) на свои реальные

     
  • 3, kol, 07:34, 16/03/2009 [ответить] [смотреть все]
  • +/
    не подскажите как настроить vpdn на cisco 7606,какой командой можно это сделать.
    заранее благодорю!
     
  • 4, Kostya Nikonenko, 12:42, 02/10/2009 [ответить] [смотреть все]
  • +/
    Вопрос такой - как клиенту вместе с адресом отдать маску например 255.255.240.0?

    Спасибо.

     

    Ваш комментарий
    Имя:         
    E-Mail:      
    Заголовок:
    Текст:



      Закладки на сайте
      Проследить за страницей
    Created 1996-2017 by Maxim Chirkov  
    ДобавитьРекламаВебмастеруГИД  
    Hosting by Ihor