The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

Как поднять туннель между Cisco и Linux
Linux (192.168.2.1):
   /sbin/ip tunnel add tunl1 mode ipip remote 192.168.1.1
   /sbin/ifconfig tunl1 192.168.3.2 pointopoint 192.168.3.1 netmask 255.255.255.252 mtu 1500

Cisco (192.168.1.1):
  interface Tunnel0
    ip address 192.168.3.1 255.255.255.252
    ip mtu 1500
    tunnel source 192.168.1.1
    tunnel destination 192.168.2.1
    tunnel mode ipip
 
30.10.2003
Ключи: mtu, config, des, interface, tunnel, linux, ip, netmask, cpu, cisco / Лицензия: CC-BY
Раздел:    Корень / Маршрутизаторы Cisco, VoIP / Ограничение и учет трафика на Cisco

Обсуждение [ RSS ]
 
  • 1, Etvas, 12:38, 12/07/2005 [ответить] [смотреть все]
  • +/
    Хотелось добавить что не факт что всё заработает,у меня потребовались добавочные опции как на Cisco так и Linux RH-9
    В общем в начале не отрабатовался ICMP и передача файлов. Устранилось подбором mtu под провайдера и собственно опции после чего забыл про их существование.

    Cisco

    interface Tunnel2
    description Etvas
    ip address *.*.*.9 255.255.255.252
    ip access-group no_name in
    ip mtu 1400
    no ip route-cache
    ip tcp adjust-mss 1436
    tunnel source *.*.1.2
    tunnel destination *.*.25.2
    tunnel checksum

    echo "1" > /proc/sys/net/ipv4/ip_forward
    #/sbin/insmod ip_gre
    #/sbin/ip tunnel del tunnel2
    /sbin/ip tunnel add tunnel2 mode gre local *.*.25.2 remote *.*.1.2

    /sbin/ifconfig tunnel2 *.*.*.10 netmask 255.255.255.252 mtu 1400

    ip route add *.*.1.0/24 via *.*.25.1

    route del default; route add default dev tunnel2

    ─Б■≤     п≈п╟п©п╦я│я▄ 3п▒п╩п╬п╨   4п≈п╟п╪п╣пҐ╨                  п÷п╬п╦я│п╨  ╬пЁ

     

    Ваш комментарий
    Имя:         
    E-Mail:      
    Заголовок:
    Текст:



      Закладки на сайте
      Проследить за страницей
    Created 1996-2017 by Maxim Chirkov  
    ДобавитьРекламаВебмастеруГИД  
    Hosting by Ihor