The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

Установка AMD Catalyst 11.5 на Debian-подобную систему с Linux-ядром 2.6.39
Для начала должны быть установлены пакеты:

   sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf \
      libstdc++6 dkms libqtgui4 execstack libelfg0 ia32-libs

Затем, нужен драйвер Catalyst и патчи к новому ядру:

   mkdir atifix
   cd atifix
   wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-5-x86.x86_64.run
   wget http://www.mindwerks.net/wp-content/uploads/2011/03/2.6.39_bkl.patch
   wget http://www.mindwerks.net/wp-content/uploads/2011/03/no_bkl.patch

Распаковываем драйвер и применяем патчи:

   chmod +x ati-driver-installer-11-5-x86.x86_64.run
   ./ati-driver-installer-11-5-x86.x86_64.run --extract driver
   mv *.patch ./driver/
   cd ./driver/
   patch -p1 -i 2.6.39_bkl.patch && patch -p1 -i no_bkl.patch

После патчей устанавливаем драйвер:

   ./ati-installer.sh 8.85 --install

Более правильный способ установки, использованием штатного пакетного менеджера:

1. узнаём список поддерживаемых дистрибутивов:

   ./ati-installer.sh 8.85 --listpkg

2. генерируем установочный пакет для нужного дистрибутива из списка
   ./ati-installer.sh 8.85 --buildpkg YourDistrName

3. устанавливаем. к примеру, пакет для Debian

   dpkg -i fglrx*.deb


Если во время установки не всплыло никаких зависимостей, то выполняем

   aticonfig --initial -f

Перегружаем компьютер или X-Server и проводим на всякий случай диагностику:

   cat /var/log/Xorg.0.log | grep EE

После рестарта можно диагностировать с помощью

   fglrxinfo и fgl_glxgears
 
20.05.2011 , Автор: Карбофос , Источник: http://www.planet3dnow.de/vbulletin...
Ключи: ati, linux, driver, xorg, kernel / Лицензия: CC-BY
Раздел:    Корень / Пользователю / X Window

Обсуждение [ Линейный режим | Показать все | RSS ]
 
  • 1.1, Wormik, 10:12, 21/05/2011 [ответить] [смотреть все]
  • +/
    Кажется, это был не первый совет? Вот так гораздо лучше.
     
     
  • 2.7, a, 12:31, 23/05/2011 [^] [ответить] [смотреть все]
  • +/
    а судьи - кто?
     
  • 1.2, Анон, 13:30, 21/05/2011 [ответить] [смотреть все]
  • +/
    А сгенерить пакет не катит? Обязательно надо в системе насрать.
     
     
  • 2.3, Карбофос, 21:24, 21/05/2011 [^] [ответить] [смотреть все]
  • +/
    ну почему же, по пунктам
    ./ati-installer.sh 8.85 --listpkg
    и потом для волнующего массы дистрибутива из доступных из списка
    ./ati-installer.sh 8.85 --buildpkg DistrName
     
     
  • 3.4, stranger, 21:52, 21/05/2011 [^] [ответить] [смотреть все]
  • +/
    Вот и надо было это написать, а не install.
     
     
  • 4.14, Карбофос, 13:26, 24/05/2011 [^] [ответить] [смотреть все]  
  • +/
    дополнил
     
  • 1.5, Аноним, 12:28, 22/05/2011 [ответить] [смотреть все]  
  • +/
    - for i 0 i __KE_MAX_SPINLOCKS i - dev- spinlock i SPIN_L... весь текст скрыт [показать]
     
     
  • 2.8, bang, 19:07, 23/05/2011 [^] [ответить] [смотреть все]  
  • +/
    так это ж linux style! не?
     
  • 2.9, Аноним, 19:47, 23/05/2011 [^] [ответить] [смотреть все]  
  • +/
    Они кривые хотя-бы потому что вообще требуют всей этой возни ... весь текст скрыт [показать]
     
  • 2.13, Карбофос, 13:25, 24/05/2011 [^] [ответить] [смотреть все]  
  • +/
    ну сообщите о кривости патча автору  http://www.mindwerks.net
     
  • 1.6, Аноним, 12:30, 22/05/2011 [ответить] [смотреть все]  
  • +/
    вопрос просто убрать bkl тоже вызывает сомнения - мало ли чего им снхронизиров... весь текст скрыт [показать]
     
  • 1.10, Аноним, 10:56, 24/05/2011 [ответить] [смотреть все]  
  • +/
    Заплакал от радости, когда увидел этот совет - ибо эти дрова от рождения кривые ... весь текст скрыт [показать]
     
  • 1.11, Аноним, 11:51, 24/05/2011 [ответить] [смотреть все]  
  • +/
    Где бы найти такие патчи для 38-го ядра?
     
     
  • 2.12, Карбофос, 12:51, 24/05/2011 [^] [ответить] [смотреть все]  
  • +/
    а что с 38 не так?
     
  • 1.15, Аноним, 15:08, 24/05/2011 [ответить] [смотреть все]  
  • +/
    стоит 38-е ядро из бэкпортов Debian 6 0 1 - так вот, на него не встает fglrx и... весь текст скрыт [показать]
     
  • 1.17, lmerZb0t, 14:18, 27/05/2011 [ответить] [смотреть все]  
  • +/
    А для 2.6.32-5 пойдёт?
     

    Ваш комментарий
    Имя:         
    E-Mail:      
    Заголовок:
    Текст:



      Закладки на сайте
      Проследить за страницей
    Created 1996-2017 by Maxim Chirkov  
    ДобавитьРекламаВебмастеруГИД  
    Hosting by Ihor