The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

Маршрутизатор Cisco как PPTP клиент
Задача: заставить маршрутизатор Cisco с ios 12.4 работать в качестве pptp-клиента. 
В данном примере 172.28.254.21 - pptp-сервер, а myusername и mypassword -
соответственно имя пользователя и пароль.
Адреса интерфейс получает по dhcp.


    service internal
    !
    no ip gratuitous-arps
    ip cef
    !
    ip multicast-routing
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pptp
    rotary-group 1
    initiate-to ip 172.28.254.21
    !
    !
    interface FastEthernet 0/0
    ip dhcp
    !
    interface Dialer1
    mtu 1450
    ip address negotiated
    ip pim dense-mode
    encapsulation ppp
    dialer in-band
    dialer idle-timeout 0
    dialer string 123
    dialer vpdn
    dialer-group 1
    ppp pfc local request
    ppp pfc remote apply
    ppp encrypt mppe auto
    ppp chap hostname myusername
    ppp chap password 0 mypassword
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 172.28.254.21 255.255.255.255 FastEthernet0/0
    !
    !
    dialer-list 1 protocol ip permit
    !
    end
 
24.06.2009 , Автор: BETEP , Источник: http://dr-betep.blogspot.com/2009/0...
Ключи: cisco, pptp, vpn / Лицензия: CC-BY
Раздел:    Корень / Маршрутизаторы Cisco, VoIP / Ограничение и учет трафика на Cisco

Обсуждение [ RSS ]
 
  • 1, fozz, 07:56, 26/06/2009 [ответить] [смотреть все]
  • +/
    ip route 172.28.254.21 255.255.255.255 FastEthernet0/0

    лучше б заменить на
    ip route 172.28.254.21 255.255.255.255 dhcp

     
  • 2, luzers, 10:05, 29/06/2009 [ответить] [смотреть все]
  • +/
    осталось научить делать исходящий pppoe конект на влане - то можно наконец-то циску поставить на раздачу инета.
     
  • 3, angelweb, 17:52, 30/06/2009 [ответить] [смотреть все]
  • +/
    Копи  пасте однако

    http://ccnp.ru/cgi-bin/forum.cgi?action=thread&id=29528&page=1

     
     
  • 4, pavlinux, 15:31, 01/07/2009 [^] [ответить] [смотреть все]
  • +/
    Да и там не ангелочки:  

    Аж за 21 ноября 2006
    http://groups.google.com/group/comp.dcom.sys.cisco/msg/81d58c31469d558b?pli=1

     
  • 5, t3mp, 02:40, 22/11/2012 [ответить] [смотреть все]
  • +/
    Вместо IP-VPN/32 "ip route 172.28.254.21 255.255.255.255 FastEthernet0/0" можно просто не добавлять адрес p2p peer-a как direct connected: "no peer neighbor-route".
     

    Ваш комментарий
    Имя:         
    E-Mail:      
    Заголовок:
    Текст:



      Закладки на сайте
      Проследить за страницей
    Created 1996-2017 by Maxim Chirkov  
    ДобавитьРекламаВебмастеруГИД  
    Hosting by Ihor