The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Релиз Firefox 52

07.03.2017 18:36

Состоялся релиз web-браузера Firefox 52, а также мобильной версии Firefox 52 для платформы Android. Выпуск отнесён к категории веток с длительным сроком поддержки (ESR), обновления для которых выпускаются в течение года. В ближайшие часы ожидается обновление прошлой ветки с длительным сроком поддержки 45.8. Выпуск SeaMonkey 2.48 планировалось сформировать в феврале, но от так и не был выпущен. В скором времени на стадию бета-тестирования перейдёт ветка Firefox 53 и будет отделён Firefox Developer Edition 54. В соответствии с шестинедельным циклом разработки релиз Firefox 53 намечен на 18 апреля, а Firefox 54 на 13 июня.

Основные новшества:

  • В состав браузера добавлена технология WebAssembly, которая предоставляет не зависящий от браузера универсальный низкоуровневый промежуточный код для выполнения в браузере приложений, скомпилированных из различных языков программирования. Бинарный формат и JavaScript API зафиксированы и в дальнейшем будут развиваться с сохранением обратной совместимости. Для наглядной оценки оптимизаций в процессе выполнения проектов на WebAssembly разработчиками Firefox подготовлен инструмент WebAssembly Explorer;
  • Модернизирован интерфейс управления загрузками: В случае сбоя загрузки обеспечен вывод соответствующего уведомления на панель инструментов. Список быстрого доступа к недавним загрузкам расширен с трёх до пяти элементов. Увеличены кнопки отмены загрузки и перезапуска загрузки;
  • Реализована спецификация Strict Secure Cookies, запрещающая установку cookie с атрибутом "secure" при открытии сайта через http:// без создания защищённого соединения. Новая возможность также не позволяет открытому по http:// сайту установить cookie с теми же именами, что и имеющиеся безопасные ("secure") cookie, уже выставленные для текущего домена;
  • Изменён вывод предупреждения о проблемах с безопасностью в случае обращения к страницам, содержащим форму ввода пароля, без использования HTTPS. Вместо индикатора наличия проблем с безопасностью в адресной строке реализовано контекстное предупреждение, выводящееся непосредственно рядом с полем ввода пароля. Кроме того, при открытии страницы с формой входа по HTTP теперь отключается автозаполнение имени пользователя и пароля;
  • Добавлена возможность обработки контента в нескольких процессах и началась интеграция наработок из проекта Quantum, в котором производится работа по переносу в движок Gecko возможностей, изначально развиваемых для движка Servo. Если ранее при включении многопроцессного режима осуществлялось разделение на два процесса - один для обработки содержимого вкладок и один для формирования интерфейса, то теперь появилась возможность запуска нескольких процессов для обработки контента (число запускаемых процессов для обработки контента задаётся через переменную dom.ipc.processCount в about:config);
  • В Firefox Sync расширены средства синхронизации вкладок - пользователь теперь может отправить вкладки на другое устройство, а также инициировать автоматическое открытие выбранной вкладки на другом устройстве;
  • Прекращена по умолчанию поддержка плагинов с интерфейсом NPAPI, в том числе Silverlight, Java, Acrobat, Unitym, Gnome Shell Integration и плагинов с поддержкой мультимедийных кодеков (список активных плагинов можно посмотреть через URL about:plugins). Исключение сделано только для Adobe Flash, так как данная технология ещё остаётся востребована большим числом пользователей. Для пользователей пока оставлена специальная опция, которая позволяет вернуть NPAPI, но в Firefox 53 данная опция будет удалена. В более отдалённом будущем разработчики намереваются полностью удалить поддержку NPAPI, а для пользователей Flash предоставить возможность использования плагина с интерфейсом PPAPI.

  • Для всех пользователей ведена блокировка сертификатов, заверенных с использованием алгоритма хэширования SHA-1, для которого недавно была продемонстрирована возможность практической генерации коллизий. При обращении к сайтам, использующим сертификаты с SHA-1, отныне будет выводиться ошибка и соединение будет помечаться незащищённым. Как и в случае с самоподписанными сертификатами, ошибку можно обойти через специальный диалог. Поддержка SHA-1 для вручную импортированных сертификатов пока сохранена;
  • Включена поддержка CSS Grid Layout, новой техники многослойной компоновки элементов страницы, основанной на идее разбиения страницы на области по аналогии с табличной компоновкой с выравниванием по столбцам и строкам. Но в отличие от таблиц при CSS Grid Layout не определяет структуру содержимого, что позволяет выстраивать произвольные макеты, которые недостижимы с использованием обычных таблиц (например, дочерние элементы могут перекрывать друг друга). Для упрощения манипуляции с CSS-элементами Grid в средства для разработчиков добавлен инструмент grid highlighter;

  • Включена поддержка двух новых ключевых слов async и await, предложенных в черновике спецификаци ECMAScript 7 и позволяющих упростить написание кода, выполняемого в асинхронном режиме. Конструкции с async/await значительно проще для восприятия и более читаемы, по сравнению с аналогичными конструкциями на основе механизма Promise;
  • В средства для web-разработчиков добавлен режим адаптивного дизайна (включается через меню "Responsive Design Mode" в разделе "Web Developer"), позволяющий протестировать работу сайта в окружении, симулирующем работу на устройствах с различным экранным разрешением и DPI, с управлением через сенсорный экран, с разными значениями User-Agent и в условиях ограниченной пропускной способности сети и повышенных задержках доставки пакетов (например, можно симулировать доступ по GPRS со скоростью 50 KB/s и задержкой в 500 мс);
  • Представлен новый отладчик для JavaScript - debugger.html, развиваемый в рамках инициативы по замене отладчика, встроенного в Firefox. Debugger.html реализован в виде web-приложения, которое может выполняться в web-браузерах Firefox и Chrome, а также запускаться в обособленном режиме под управлением Node.js или встраиваться в другие web-приложения. Основным отличием нового отладчика является поддержка одновременной отладки нескольких web-приложений. Поддерживается удалённая отладка с использованием протоколов Firefox RDP и Chrome Debugging Protocol.

    Основной экран отладчика разделён на три области: Панель с исходными текстами, показывает древовидное представление исходных текстов всех отлаживаемых web-приложений; Область редактирования, позволяет редактировать конкретные файлы проекта и даёт возможность устанавливать точки останова в коде и приводить упакованный код в читаемый вид; Боковая панель, отображает список текущих точек останова, состояние стека вызовов и значения переменных на момент приостановки выполнения приложения. Поддерживаются операции остановки, пошаговой отладки, входа в функции и другие типовые возможности. Интерфейс разработчики попытались сделать доступным, предсказуемым, простым для изучения и понятным, но при этом предоставить максимальную функциональность. Debugger.html написан на JavaScript с использованием фреймворков React и Redux.

  • Реализованы средства для автоматического определения перенаправления на страницы аутентификации для подключения к сети (captive portal);
  • В многопроцессном режиме появилась поддержка систем озвучивания содержимого экрана (screen reader) и сенсорных экранов Windows 8;
  • На платформе Windows, если не используется Direct2D, для отрисовки содержимого теперь применяется графическая библиотека Skia, которая ранее была задействована только для Linux и Android;
  • Пользователи Windows XP и Windows Vista будут автоматически переключены на текущую ESR-ветку, так как в дальнейших релизах поддержка данных систем будет прекращена;
  • Прекращена поддержка API Battery Status. Изначально разработчики полагали, что данный API, позволяющий получить информацию об уровне заряда аккумулятора, будет использован в web-приложениях для экстренного сохранения данных или для отключения требующих интенсивных вычислений операций при исчерпании заряда аккумулятора. Но на деле, данный API получил распространение лишь для отслеживания пользователей (уровень заряда аккумулятора как дополнительный параметр для выделения пользователя в общем потоке) и жульничества (например, Uber повышал цены для пользователей с низким зарядом аккумулятора);
  • Добавлен API для проверки видимости рекламных блоков силами JavaScript, без необходимости использования для этого Flash;
  • Включён по умолчанию оператор JavaScript для возведения в степень (x**n);
  • Продолжено усовершенствование API WebExtensions для разработки дополнений, совместимых с браузером Chrome. Из новых программных интерфейсов отмечается реализация API для управления сеансами (sessions.getRecentlyClosed и sessions.restore), позволяющего получить информацию о недавно закрытых вкладках и восстановить их при необходимости. Добавлен API topSites, предоставляющий дополнениям доступ к списку наиболее часто открываемых сайтов. Также представлен API omnibox через который можно зарегистрировать ключевое слово, предоставив для него собственный набор операций в адресной строке. Готов для тестирования API storage.sync, через который дополнение может организовать обмен данными между разными устройствами. Добавлены события onRemoved, onMoved, onCreated и onChanged для перехвата действий с закладками;
  • Добавлен метод window.requestIdleCallback, позволяющий отложить вызов функции на время, когда браузер будет находится в состоянии простоя (idle). Например, при помощи данной возможности можно организовать выполнение низкоприоритетных и фоновых задач, без их негативного влияния на выполнение чувствительных к задержкам операций, таких как вывод анимации и ввод. По умолчанию метод отключен и может быть активирован через флаг dom.requestIdleCallback.enabled в about:config;
  • В массивах и объектах теперь разрешено оставлять запятые после последнего элемента (например, "var arr = [1, 2, 3,];"), в массивах также можно оставлять незаполненные элементы (например, "var arr = [1, 2, 3,,,];") вместо которых останутся пустые значения;
  • Добавлена поддержка HTTP-заголовока Large-Allocation, предназначенный для информирования браузера о том, что загружаемая страница потребует много памяти (например, "Large-Allocation: 500" информирует, что приложению на WebAssembly или asm.js потребуется непрерывный блок памяти, размером 500 Мб);
  • По умолчанию включена поддержка спецификации TLS 1.3, которая пока находится в состоянии черновика. В последующих ESR-сборках Firefox 52 с длительным сроком поддержки TLS 1.3 будет отключен.
  • Добавлен новый тип ссылок rel="noopener", который может применяться для перехода к не заслуживающим доверия страницам. При использовании данного типа для открываемой страницы не выставляется свойство Window.opener и не открывается доступ к контексту из которого была открыта ссылка;
  • В средствах совместного доступа к экрану (WebRTC Screen Sharing) обеспечен показ эскизов и отменено требование присутствия домена в белом списке;
  • В версии для платформы Android более чем на 5 Мб сокращён размер установочного APK-архива. Улучшены элементы интерфейса для управления воспроизведением звука и видео - в область уведомлений добавлены кнопки для остановки и продолжения воспроизведения;
  • Внимание! Из-за прекращения поддержка NPAPI-плагинов в Firefox 52 временно ограничена функциональность сервиса Google Hangouts, в котором перестали работать голосовые звонки и видеовызовы. Обмен текстовыми сообщениями в Google Hangouts работает как и раньше.
  • Дополнение: По умолчанию в Linux отключена поддержка звуковой подсистемы ALSA (вывод звука теперь осуществляется только через PulseAudio). Для возобновления работы через ALSA требуется пересборка с флагом "--enable-alsa";

Кроме новшеств и исправления ошибок в Firefox 52 устранена серия уязвимостей, из которых несколько помечены как критические, т.е. могут привести к выполнению кода злоумышленника при открытии специально оформленных страниц. В настоящее время информация с подробностями об исправленных проблемах безопасности недоступна, ожидается, что перечень уязвимостей будет опубликован в течение нескольких часов.

  1. Главная ссылка к новости (https://hacks.mozilla.org/2017...)
  2. OpenNews: В Firefox началось тестирование контекстных контейнеров
  3. OpenNews: План прекращения совместимости Firefox со старыми дополнениями
  4. OpenNews: Доля обращений по HTTPS среди пользователей Firefox превысила 50%
  5. OpenNews: Релиз Firefox 51
  6. OpenNews: Технология WebAssembly признана готовой для включения в браузерах по умолчанию
Лицензия: CC-BY
Тип: Интересно / Программы
Ключевые слова: firefox
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (165) Ajax | 1 уровень | Линейный | Раскрыть всё | RSS
  • 1.1, Я (??), 19:18, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +7 +/
    Что делать с банками, в которых используется джава-плагин?
     
     
  • 2.3, A.Stahl (ok), 19:19, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +50 +/
    Простерилизовать.
     
  • 2.4, аноним2 (?), 19:29, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Ставить ESR версию?
     
     
  • 3.5, Аноним (-), 19:32, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Firefox 52 и есть новая ветка ESR. Прошлая будет поддерживаться ещё месяц или два и всё.
     
     
  • 4.7, Anonplus (?), 19:33, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Firefox 52 и есть новая ветка ESR. Прошлая будет поддерживаться ещё месяц
    > или два и всё.

    Firefox 52 и Firefox 52 ESR это разные "каналы обновлений". В ESR ещё год можно будет включить плагины, а в Firefox 53 настройку, включающую плагины, удалят совсем.

     
  • 4.34, Аноним (-), 22:42, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Firefox 52 и есть новая ветка ESR. Прошлая будет поддерживаться ещё месяц
    > или два и всё.

    А предыдущий ESR, он с выходом нового перестанет работать и будет принудительно удалён со всех компьютеров специальной секретной мозилловской ESR-полицией?

     
     
  • 5.41, Anonplus (?), 23:55, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +2 +/
    А у вас когда ключи крадут, вы меняете замок или задаётесь вопросом "перестанет ли замок работать"?

    Работать будет, защищать от будущих угроз уже нет.

     
  • 2.6, Anonplus (?), 19:32, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Перейти на ESR и отключить "plugin.load_flash_only". Через год сменить банк, если банк не почешется.
     
     
  • 3.11, Аноним (-), 19:44, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • –6 +/
    >>Через год сменить банк, если банк не почешется.

    Смешной вы батенька. Зачем ему чесаться если в рекомендованном браузере (ИЕ) все по прежнему работает? Счета в другом банке открывать из-за того, что мозилла такая хромоколонозилла?

     
     
  • 4.12, анонимус_б6_выпуск_3 (?), 19:49, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    >Счета в другом банке открывать из-за того, что мозилла такая хромоколонозилла?

    почему бы и нет? Вы знаете, КАК банки радуются открытию счета от Юр.лица?! Им же бабло капает за обслуживание счета и увеличиваются показатели, а это уже важно для отчетности перед ЦБ.

     
  • 4.44, mumu (??), 00:22, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    IE УЖЕ похоронили, а в Edge всё точно так же, как в хроме и фф.
     
     
  • 5.53, anon2 (?), 01:46, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    бкс только с ие работает
     
     
  • 6.99, Аноним (-), 16:39, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > бкс только с ие работает

    А вот представляете, через год дропнут поддержку Win 7 и 8? Куда ваши банки пойдут?

     
     
  • 7.131, iPony (?), 08:59, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • –2 +/
    А давай представим, что у тебя штаны сейчас порвутся. Смысл?
    Срок поддержки заранее объявляется.
     
     
  • 8.134, vitektm (?), 10:43, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Хорош ныть То что банки тормозят до последнего Это проблема банков и ваша Т... текст свёрнут, показать
     
     
  • 9.140, Аноним (-), 13:42, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • –2 +/
    У них есть ссылки на донат Может он донатит, откуда тебе известно ... текст свёрнут, показать
     
  • 7.138, Stax (ok), 13:14, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    А причем тут вообще win 7 и win 8? Будут использовать десятку. Там такой же 11 эксплорер как и везде, активно поддерживается, патчи безопасности выходят, а Edge настроен автоматически при обнаружении элементов, от поддержки которых в нем отказались открывать данный сайт в эксплорере. Пользователи и не заметят ничего, у них все будет работать.
     
  • 3.27, Timur I. Davletshin (?), 21:04, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Настройку создать нужно, её по-умолчанию нет. Работает и на ESR и в обычной версии. Но ESR поддерживаться будет дольше.
     
  • 2.16, Аноним (-), 20:17, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Поддерживаю вопрос. Ответьте по существу, если кто знает, что делать если нужен для клиент-банка Java-плагин под Linux.
    PS Не нужно испражнятся в остроумии, смишных шуток и без вас достаточно.
     
     
  • 3.17, Аноним (-), 20:22, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Пока услышал вариант посавить ESR до лучших времен. На крайний случай так можно сделать, но мне лично не нравится такой подход из-за излишнего консерватизма.
     
     
  • 4.38, Анонимм (??), 23:30, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > Пока услышал вариант посавить ESR до лучших времен. На крайний случай так
    > можно сделать, но мне лично не нравится такой подход из-за излишнего
    > консерватизма.

    неужели "git clone git.firefox.com/..." ?


     
  • 3.57, leap42 (ok), 02:09, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    поставить в виртуалку centos 7?
     
  • 2.20, X3asd (?), 20:44, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +11 +/
    > Что делать с банками, в которых используется джава-плагин?

    Ну вы как с луны свалились!

    Всё остаётся так же как и раньше!

    Весь банковский кривой дырявый гõвносõфт -- запускать в отдельной виртуальной машине -- на Windows с Интернет Эксплорером или другим гõвнõм (можно даже не обновлять софт ни какой).

     
     
  • 3.103, лзз (?), 17:47, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    потом окажется что клиент-банк принципиально не работает с слегка устаревшей джавой 1.8.хх, надо установить 1.8.yy или даже 1.9.zz а та в свою очередь не работает с устаревшим firefox 51 или IE
     
     
  • 4.128, Линукс еще не готов (?), 06:18, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Как обычно
     
  • 2.33, Аноним (-), 22:41, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Поставить в бухгалтерию Windows. Кесарю кесарево.
     
  • 2.35, кельвин (?), 23:04, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +2 +/
    избегать.
     
  • 2.74, Нет (?), 10:46, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Банки свои клиенты хоть иногда да обновляют. Рано или поздно что-то изменится.
    В комментариях полностью отсутствуют упоминания об удаленных консолях, из которых 95% работают или через activex, или через java. Что, админов не-локалхоста на опеннете уже вообще не осталось?
     
     
  • 3.100, Аноним (-), 16:49, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > Банки свои клиенты хоть иногда да обновляют. Рано или поздно что-то изменится.
    > В комментариях полностью отсутствуют упоминания об удаленных консолях, из которых 95% работают
    > или через activex, или через java. Что, админов не-локалхоста на опеннете
    > уже вообще не осталось?

    Удалённые "консоли" через браузер? ...

     
     
  • 4.145, Lain_13 (ok), 15:10, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Я думаю имеется в виду установка VPN-подключения. Не сказал бы, что часто с этим сталкиваюсь, но попадалось несколько клиентов к сети которых можно подключиться только черех ActiveX/Java апплет загруженный в браузере с их домена. В основном требуют "Cisco AnyConnect" и подобное поставить.
     
  • 2.75, anonymous (??), 10:52, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Переходить на webstart
     
  • 2.174, алекс (??), 19:29, 14/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Перестать пользоваться их ЭЦП и перейти на ненавистные SMS-пароли.
     

     ....нить свёрнута, показать (31)

  • 1.8, Семилетов (ok), 19:39, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +7 +/
    > Включена поддержка CSS Grid Layout

    Аллилуйя!

     
  • 1.10, Anonplus (?), 19:43, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    >> Добавлен API Intersection Observer

    Отложили до 53, вроде
    "Tentatively moved this entry from the 52 to the 53 release notes.  Still listed on https://developer.mozilla.org/en-US/Firefox/Releases/52 though, that needs to be updated."
    https://bugzilla.mozilla.org/show_bug.cgi?id=1243846


    >> Добавлен метод window.requestIdleCallback

    Отключён по умолчанию: about:config -> dom.requestIdleCallback.enabled = false

     
  • 1.14, paulus (ok), 19:56, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +5 +/
    >> Добавлен API для проверки видимости рекламных блоков силами JavaScript, без необходимости использования для этого Flash;

    И без флешта таки заставят смотреть флешрекламу! ;)

     
     
  • 2.15, Аноним (-), 20:12, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Интересно, как этот API отключить.
     
     
  • 3.23, X3asd (?), 20:52, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Интересно, как этот API отключить.

    Что тут такого интересного? У вас опенсурс или где? Обычная банальщина ---

    Накатываешь свой патч, и делаешь

    makepkg -si

    ...или хочешь чтобы твою хотелку внедрили бы прямо через *готовый* (слегка скрытый) переключатель уже в бинарный браузер? Если бы этот переключатель был бы -- то ни кто бы из рекламодателей не доверился бы этому API

     
     
  • 4.136, Lain_13 (ok), 11:46, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Вы таки не поверите, но доверять в JS API, предоставляемым браузером, всё одно невозможно. Дело в том, что пользователь своими скриптами и расширениями может практически все их переназначить так, как ему вздумается. Причём до загрузки страницы и исполнения её кода.
     

  • 1.18, Аноним (-), 20:22, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > Добавлен API для проверки видимости рекламных блоков силами JavaScript, без необходимости использования для этого Flash;

    а эта ересь откуда? что-то по ссылкам упоминаний об этой каке не нашел

     
     
  • 2.26, Аноним (-), 21:01, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > а эта ересь откуда? что-то по ссылкам упоминаний об этой каке не
    > нашел

    В списке изменений "Adding a new API that will help developers move ad viewability checks from Flash to JavaScript".  См. секцию DOM в https://developer.mozilla.org/en-US/Firefox/Releases/52

     
     
  • 3.60, Аноним (-), 04:10, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    я, может, туп или слеп, но по приведенной ссылке данной фразы не вижу. ни в dom, ни в остальных секциях. а поиск по "Flash" находит только удаляемый npapi
     
     
  • 4.85, Аноним (-), 13:24, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Эта строчка ещё была ночью, потом видимо убрали. Например есть упоминание вот тут https://forum.mozilla-russia.org/viewtopic.php?id=70953
     

  • 1.19, Аноним (-), 20:38, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Проверил, дебаггер все ещё прежний.
     
  • 1.21, Аноним (-), 20:45, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Hangouts когда починят?((
    за -5мб, они наконец-то додумались обфусцировать код?))
     
  • 1.22, Аноним (-), 20:46, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Удалён код работы с ALSA.
     
     
  • 2.63, Аноним (-), 07:45, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Пока не полностью. Но уже скоро.
     
  • 2.142, Аноним (-), 14:51, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Чем им альса-то помешала? Норкоманы...
     

  • 1.25, Аноним (-), 21:01, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +5 +/
    > Uber повышал цены для пользователей с низким зарядом аккумулятора

    Хахаха.

     
     
  • 2.130, Аноним (-), 07:10, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    А вознаграждение для таксистов он одновременно не повышал?
     

  • 1.28, Аноним (-), 21:04, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    "We are currently considering EOL'ing Windows XP on ESR 52"

    Хехе.

     
  • 1.29, th3m3 (ok), 21:08, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    >>Firefox 52 устранена серия уязвимостей, из которых несколько помечены как критические

    В Ubuntu завезут опять в конце недели. В лучшем случае.

     
     
  • 2.43, VINRARUS (ok), 00:21, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Шо мешает снести убунтовского Firefox и поставить Firefox с оф. сайта?
     
     
  • 3.56, th3m3 (ok), 01:56, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    А потом руками каждый раз его обновлять?
     
     
  • 4.70, Аноним (-), 09:00, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Оно обновляется автомастически.
     
     
  • 5.108, th3m3 (ok), 19:06, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Это ок. Если что, буду пробовать так.
     
     
  • 6.135, username (??), 11:37, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Только так лису и пользую, ждать неделю пока в экосистеме убунту посчитают новый релиз firefox стабильным как-то глупо, не им решать рабочий релиз или нет, непонятно что они там тестируют)
     
     
  • 7.149, th3m3 (ok), 19:16, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Бывало, некоторые промежуточные версии совсем не доходили. А сразу основная приходила, опять же с задержкой :) Ещё раз такая фигня будет, тоже перейду на такой вариант.
     
  • 2.51, Oe (?), 01:18, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Уже завезли
     
     
  • 3.55, th3m3 (ok), 01:56, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Внезапно - да. Всегда бы так.
     
     
  • 4.119, Аноним (-), 23:30, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Последние пол года так всегда и было.
     
     
  • 5.150, th3m3 (ok), 19:17, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Не помню такого. Всегда где-то ближе к субботе прилетало.
     
  • 3.164, paulus (ok), 19:43, 12/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    --enable-alsa завезли или только пульсят?
     
     
  • 4.165, Lain_13 (ok), 11:53, 13/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Они поддержку алсы из кодовой базы вывозят. О каком enable речь?
     

  • 1.30, Аноним (-), 21:22, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    >Модернизирован интерфейс управления загрузками

    Лучше бы вернули независимые окна для загрузок и закладок. Они уже за[censored] прятать любое из них при открытии другого.

     
  • 1.31, Аноним (-), 21:23, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Кто бы ещё майнтанерам debian/ubuntu показал пальцем, что определитель кодировки текста ruprob у них не знает ничего кроме ISO-8859-5, без определителя кодировки для языка ru железно вбит cp-1251. Подозреваю, что на остальных дистрибутивах также. Проверить просто - открыть любой file.txt с текстом на русском языке.

     
     
  • 2.77, Аноним (-), 11:59, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Не понял. Зачем вы текстовые файлы браузером открываете? А для всего остального выставляется параметр прямо в страничке, по стандарту W3C.
     
     
  • 3.90, Аноним (-), 13:44, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    >для всего остального выставляется параметр прямо в страничке, по стандарту W3C.

    Да ты прямо эталонный житель идеальной вселенной.

     
     
  • 4.94, Аноним (-), 14:33, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > Да ты прямо эталонный житель идеальной вселенной.

    Вот знаешь, я открыл документ, содержащий кириллицу, в формате utf-8. Действительно получил квадратики, не спорю, это так. Но. Любой сайт с кириллицей у меня отображается нормально. Здорово, правда?!

     

  • 1.32, An (??), 22:11, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    Ну вот и настало это обновление.
    А какой браузер сегодня поддерживает java кроме esr?
     
     
  • 2.45, mumu (??), 00:24, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    java-софт запускает jvm. Зачем ему браузер?
     
     
  • 3.95, Аноним (-), 14:36, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > java-софт запускает jvm. Зачем ему браузер?

    Не могу понять, то ли тролль, то ли погуглить не может.

     

  • 1.36, Аноним (-), 23:05, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    По ходу придётся юзать это следующие несколько лет пока банки и госведомства перестанут думать, что аутентификация через Java - это круто и секьюрно...
     
     
  • 2.37, llolik (ok), 23:25, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > аутентификация через Java

    Некоторые ещё с ActiveX расстаться не могут, какая уж тут Java. Это привет ЕИС Госзакупки, например.
    А вот разрабочикам казначейской СУФД, например, походу придётся несладко: там сплошная java, и клиентское место ЧСХ сборка firefox.

     
     
  • 3.40, Gemorroj (ok), 23:53, 07/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    тут сложности с жопностью js. java апплет в браузере видится лучшим решением с точки зрения разработки.
    т.к. альтернатива - ставить клиентский софт. а это влечет за собой кучу гемора (обновление, поддержка хтрожопых zvercd и т.п. и т.д.).
     
     
  • 4.46, llolik (ok), 00:38, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > тут сложности с жопностью js. java апплет в браузере видится лучшим решением с точки зрения разработки.

    Ну может быть. Не буду спорить, в этой области я не силён.
    Однако же на ближайшую пару/тройку лет всё равно назревает живительный пинок в том плане, что MS IE вроде как официально похоронили в пользу Edge в котором тоже ни NPAPI ни ActiveX. Наверное придётся как-то из этой ситуации выкручиваться? Очень хотелось бы кроссбраузерно (WebAssembly?), а не очередной условный chrome-only.

     
  • 4.48, аноним2 (?), 00:41, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Раздавать тот же самый super_soft.jar, а ява вм и так на машине есть (т.к. запускали через браузер).
    Какая нафиг поддержка zvercd?
     
     
  • 5.50, Gemorroj (ok), 01:16, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    ну мы сейчас так и делаем. но проблем с локальными конфигурациями ОС уйма.
    сам не занимаюсь этой десктопной частью, но вижу как рядом разработчик каждый день по пол рабочего дня на телефоне сидит и решает клиентские проблемы.
    zvercd точно помню что всплывало (службы что-ли отключены какие-то были).
     

  • 1.39, Vladjmir (ok), 23:33, 07/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    То-то многие стали ставить версию ESR, чтобы не оказаться под прессом инновационной агрессии.
     
  • 1.42, Аноним (-), 00:05, 08/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    Async/await. Наконец-то и в этот отсталый браузер завезли. Последним между прочим. Во всех уже есть.
     
     
  • 2.83, Аноним (-), 12:35, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    во всех это в хроме? Изучай прелесть ты моя https://html5test.com/compare/feature/scripting.es7.async.html
     

  • 1.47, Аноним (-), 00:41, 08/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    Максим не написал про главное - они ВЫПИЛИЛИ поддержку ALSA - сейчас только PulseAudio.

    Уроды.

    Жаль, этот комментарий удалят. Мне пофигу - я не тролль. Пускай это будет на совести тех, кто занимается цензурой на opennet.

    // b.

     
     
  • 2.49, Аноним (-), 00:57, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Лучше бы и PulseAudio убрали, незачем смотрелке гипертекста корчить из себя плеер.
     
     
  • 3.78, Аноним (-), 12:01, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > Лучше бы и PulseAudio убрали, незачем смотрелке гипертекста корчить из себя плеер.

    Но как же... Видео с котиками?.. :(

     
     
  • 4.107, Котофалк (?), 18:36, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Мурмур и мямфмяф каждый сам может исполнить, чай не Чайковский.
     
     
  • 5.111, Аноним (-), 19:29, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Мурмур и мямфмяф каждый сам может исполнить, чай не Чайковский.

    Но добиться того же уровня милоты не каждый лишь может.

     
  • 2.62, Ilya Indigo (ok), 05:22, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Ё-маё ж...
    Ну нафига?
     
  • 2.64, Аноним (-), 07:46, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +1 +/
    не выпилили. просто при сборке надо явно прописывать ac_add_options --enable-alsa
     
     
  • 3.71, Аноним (-), 09:02, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > не выпилили. просто при сборке надо явно прописывать ac_add_options --enable-alsa

    Ну скоро выпилят.

     
  • 3.87, Ilya Indigo (ok), 13:32, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Благодарю, уже сам в OBS собираю и ментайнеру сообщил.
     
  • 2.69, Аноним (-), 08:56, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    В новости же есть "По умолчанию в Linux отключена поддержка звуковой подсистемы ALSA (вывод звука теперь осуществляется только чрез PulseAudio)"
     
  • 2.88, Ilya Indigo (ok), 13:33, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Я попытался.
    https://bugzilla.mozilla.org/show_bug.cgi?id=1345414
    Поддержите войтами.
     
     
  • 3.89, soarin (ok), 13:37, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Илюха, Поттеринга тебе в ухо.
    От таких как ты они комменты даже ограничили https://bugzilla.mozilla.org/show_bug.cgi?id=1345414
    Это не попытка, а посмешище.
     
  • 3.96, Аноним (-), 14:38, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Я попытался.
    > https://bugzilla.mozilla.org/show_bug.cgi?id=1345414
    > Поддержите войтами.

    Да, им конечно заняться нечем, кроме как легаси код опять поднимать.

     
     
  • 4.97, Ilya Indigo (ok), 15:11, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    >> Я попытался.
    >> https://bugzilla.mozilla.org/show_bug.cgi?id=1345414
    >> Поддержите войтами.
    > Да, им конечно заняться нечем, кроме как легаси код опять поднимать.

    1 ALSA это не легаси, а вполне актуальная звуковая система.
    2 Поднимать его не нужно, его нужно просто НЕ выпиливать, точнее не дать им сделать это!
    3 Конечно, ведь у них ещё столько идей по поводу того, как можно ещё изменить интерфейс, какой зонд ещё запихнуть, и какую функциональность ещё выпилить.

     
     
  • 5.98, Аноним (-), 16:37, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –2 +/
    1. Легаси код в кодовой базе Firefox. Они уже почти выпилили alsa.
    2. Они уже начали, и навряд ли остановятся. Если хоть раз трогали libalsa, поняли бы, почему они её дропают. Кстати, да, я тоже был не особо рад, когда они сказали, что переходят на пульсу, я её тоже недолюбливаю.
    3. Ну а что вы хотели от них? Мозилла давно скатилась. Лет эдак 5 назад.
     
     
  • 6.104, Аноним (-), 17:51, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +2 +/
    libalsa не существует в природе. от слова вообще. расскажите нам, что вы там еще трогали
     
     
  • 7.112, Аноним (-), 19:33, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –3 +/
    > libalsa не существует в природе. от слова вообще. расскажите нам, что вы
    > там еще трогали

    А вы только к словам придираться умеете? Она называется libasound, да. Что-то ещё? Пробовал запрограммировать хеллоу-ворлд при помощи этой библиотеки? Даже не пытайся, сломаешь мозг.

     
     
  • 8.126, Аноним (-), 06:04, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    да не, ничего боюсь ваш хрупкий мозг еще чем-то сломать ... текст свёрнут, показать
     
     
  • 9.141, Аноним (-), 13:44, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Очень толсто, младой человееееек ... текст свёрнут, показать
     
  • 3.101, soarin (ok), 17:04, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Тьфу, ссылку не ту дал.
    https://bugzilla.mozilla.org/show_bug.cgi?id=1247056
    > Require PulseAudio to play sound on Linux - Restrict Comments: true
     
     
  • 4.102, Ilya Indigo (ok), 17:39, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Тьфу, ссылку не ту дал.
    > https://bugzilla.mozilla.org/show_bug.cgi?id=1247056
    >> Require PulseAudio to play sound on Linux - Restrict Comments: true

    Я это видел, и что мне с этого?
    Какой-то засланный казачёк из M$/RH или просто фанатик поттеринга/идиот решил, что если ALSA не нужна ему, то она не нужна никому, и каким-то образом прогнул мейнтайнеров ff прибить гвоздями ff к pa. И что мне с этого?

     
     
  • 5.123, soarin (ok), 03:47, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Какой-то засланный казачёк из M$/RH

    Вшивый все о бане.
    Не интересен пульсаудио RH в коммерческом плане, а причем тут компания <CENSORED> вообще непонятно.
    Просто разработчики не хотят возиться с зоопарком. Да и отлично оно не работало - можно посмотреть багтрекер.
    PS: все заговоры, заговоры. Голову может включать надо?

     
     
  • 6.124, Аноним (-), 04:11, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Да и отлично оно не работало - можно посмотреть багтрекер.

    У меня, как и у всех, всё работало отлично. А вот с пульсой иногда вообще звука нет.

     
     
  • 7.127, iPony (?), 06:07, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > как и у всех

    Багтрекер говорит о другом. Причем само собой проблем достаточно в обоих. Но когда поддержка звука для 2% пользователей тяжелее поддержки для 98%, то тут уж бызнес и ничего лишнего.

    > у меня

    Тоже так себе заявления от пользователя, который использует уже готовый продукт, который прошёл всякие там найтли, альфа, бета версии. Не видя этой кухни, а потребляя уже готовое, странно такое заявлять.

     
  • 3.105, Аноним (-), 17:56, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > Поддержите войтами.

    патчами надо поддерживать. от ваших плюсадин ничего не изменится

     
     
  • 4.114, Ilya Indigo (ok), 20:57, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >> Поддержите войтами.
    > патчами надо поддерживать. от ваших плюсадин ничего не изменится

    Какие патчи, когда оно есть и так с незапамятных времён и отлично работает, но её тупо хотят удалить?

     
     
  • 5.125, Аноним (-), 05:57, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    удалить ее хотят только со слов анонима
     
     
  • 6.132, iPony (?), 09:01, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > удалить ее хотят только со слов анонима

    Со слов Mozilla: "код все еще есть, поддерживать его не будем".
    Вывод сам сделаешь, на основе постоянного изменения в софтах.

     

  • 1.52, Oe (?), 01:20, 08/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Они убрали поддержку alsa?! После обновы звук пропал, а вверху ласково выскакивает уведомление о pulseaudio.
     
     
  • 2.61, iPony (?), 04:16, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Да. Засовывают помаленьку.
     
  • 2.65, Аноним (-), 07:47, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Они убрали поддержку alsa?! После обновы звук пропал, а вверху ласково выскакивает
    > уведомление о pulseaudio.

    собери сам с --disable-pulseaudio и --enable-alsa

     
     
  • 3.73, Аноним (-), 10:32, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Вопрос профессиональным сборщикам. Сколько ни собираю софт с --enable-pulse, он потом плохо работает на системах без PulseAudio. Если либа libpulse.so.0 есть, но системная служба не запущена, то всё работает через ALSA без вопросов. Если библиотеки libpulse.so.0 нет, прога говорит что либы нет и завершает работу.

    Два антипримера: Wine, Skype и SDL. Они линукются с этой библиотекой через dlopen(). А можно ли Firefox собрать так же?

     
     
  • 4.79, Аноним (-), 12:02, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > А можно ли Firefox собрать так же?

    Наверняка в Firefox линкуется тоже. Потому что поддержка пульсы была добавлена уже много лет назад, емнип.


     
  • 4.91, Аноним (-), 14:00, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    >  А можно ли Firefox собрать так же?

    нет, скорее всего. по крайней мере libxul явно слинкован с libasound. с пульсой, скорее всего, та же фигня

     
  • 2.133, Ilya Indigo (ok), 09:29, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Если у вас openSUSE Tumbleweed могу предложить поставить из моей репы, в придачу и с gtk2.

    sudo zypper ar -cf https://download.opensuse.org/repositories/home:/13ilya:/GTK2/openSUSE_Tumbleweed GTK2;

    В противном случае придётся или вам самим собирать, или использовать apulse.

     

  • 1.54, BlackRaven86 (ok), 01:49, 08/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    > пользователь теперь может отправить вкладки на другое устройство, а также инициировать автоматическое открытие выбранной вкладки на другом устройстве

    Я джва года этого ждал!

     
     
  • 2.68, Аноним (-), 08:37, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Это сможет делать не только пользователь...
     

  • 1.58, Аноним (-), 02:22, 08/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    >добавлена технология WebAssembly

    Где можно отключить?

     
     
  • 2.59, ы (?), 02:59, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    javascript.options.wasm=false

    с некоторых пор будет проще не устанавливать. ибо отныне web по сути тот же телевизор.

     
     
  • 3.80, Аноним (-), 12:03, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > web по сути тот же телевизор.

    Какой телевизор?

     
     
  • 4.157, abi (?), 16:33, 10/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Телекран
     
  • 2.82, VEG (ok), 12:07, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    А зачем её отключать? Хорошая технология же. Призвана повысить производительность сложных веб-приложений.
     
     
  • 3.92, Аноним (-), 14:27, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > А зачем её отключать? Хорошая технология же. Призвана повысить производительность сложных
    > веб-приложений.

    Потому что сложные веб-технологии должны умереть вместе с web 2.0.

     
  • 3.109, iLex (ok), 19:11, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Я правильно понимаю, что WebAssembly - это игрушка исключительно для плюсовиков, а все прочие языки программирования в него не компилируются?
     
     
  • 4.120, VEG (ok), 23:45, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    В него можно компилировать код на любых языках программирования. Нужно только написать соответствующие компиляторы.
     

  • 1.66, Dexanewcomer (?), 08:23, 08/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Я этим 52 еще с прошлго года польщуюсь. Еще с бетта тестирования.
     
  • 1.67, Аноним (-), 08:30, 08/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    ФФ стал слишком тормозным. Никуда не годится.
    Нужен просто браузер, который будет поддерживать базу html5, без новых модных технологий, вроде пуш уведомлений или поддержки классов в js. На двух ядрах 2.5 ГГц все должно летать, не выжирая 4 гига для 20 вкладок.
    Поддержка ненужной хрени стала спецолимпиадой разработчиков браузеров. Боятся вылететь на свалку истории, проиграв в фичах андроиду. Но это все равно произойдет, когда появится возможность нормально запускать приложения андроида из-под винды.
     
     
  • 2.76, Аноним (-), 11:17, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Нужен форк Оперы 12.15 в Даркнете :-)
     
  • 2.81, VEG (ok), 12:05, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Вся проблема в том, что сайты стали слишком тяжёлыми. Мало кто из веб-разработчиков задумывается об оптимизации.
     
  • 2.86, irinat (ok), 13:26, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > Нужен просто браузер, который будет поддерживать базу html5
    > На двух ядрах 2.5 ГГц все должно летать, не выжирая 4 гига для 20 вкладок.
    > Я не понимаю технологий, о которых рассуждаю, но моё мнение правильное.

    ftfy

     
     
  • 3.129, Аноним (-), 06:52, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    >отписался типа умный, который на самом деле понимает в этих технологиях гораздо меньше

    stfu and gtfo

     
     
  • 4.144, irinat (ok), 15:04, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Докажи, что понимаешь лучше — реализуй в коде.
     
     
  • 5.153, Аноним (-), 08:43, 10/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Сам уже реализовал? Можно посмотреть?
     
     
  • 6.159, irinat (ok), 02:07, 11/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > Сам уже реализовал? Можно посмотреть?

    Нет. Не я же заявлял, что:

    > На двух ядрах 2.5 ГГц все должно летать, не выжирая 4 гига для 20 вкладок.

    Такое требование просто невозможно выполнить. Это бессмысленное заявление человека, даже не попытавшегося вникнуть в суть задачи.

    Вот пусть кто заявлял, тот и делает. А когда сделает, я сгенерирую пример, на котором он выйдет за рамки заявленного бюджета.

     
  • 2.93, Аноним (-), 14:28, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    >  не выжирая 4 гига для 20 вкладок.

    Что за сайты у вас такие? У меня максимум пик был при 30 вкладках - гиг отожрало, и то это жутко много для меня. Обычно при 10-15 вкладках не превышает 500-600Мб.

     
  • 2.110, Вы забыли заполнить поле Name (?), 19:13, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Какой тольстенький и с таким слабеньким компьютером.
     
  • 2.115, VINRARUS (ok), 21:24, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    K-Meleon - браузер твоей мечты.
     
     
  • 3.154, Аноним (-), 08:45, 10/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > K-Meleon - браузер твоей мечты.

    Надо под линукс.

     
  • 3.158, VINRARUS (ok), 20:10, 10/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > K-Meleon - браузер твоей мечты.

    Да он в вайне прекрасно работает из за своей простоты.

     
  • 3.166, Аноним (-), 13:05, 13/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    тогда уж мидори или купзилла =)
     

  • 1.72, Аноним (-), 09:50, 08/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >Добавлена возможность обработки контента в нескольких процессах и началась интеграция наработок из проекта Quantum, в котором производится работа по переносу в движок Gecko возможностей, изначально развиваемых для движка Servo. Если ранее при включении многопроцессного режима осуществлялось разделение на два процесса - один для обработки содержимого вкладок и один для формирования интерфейса, то теперь появилась возможность запуска нескольких процессов для обработки контента (число запускаемых процессов для обработки контента задаётся через переменную dom.ipc.processCount в about:config);

    Что-то не влияет ни на что параметр dom.ipc.processCount. Поставил по количеству ядер, а в about:support всё равно 1/1.

     
     
  • 2.84, Alex (??), 12:37, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Количество процессов Web надо смотреть

     
     
  • 3.113, Аноним (-), 20:03, 08/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Один
     

  • 1.116, rvs2016 (ok), 21:50, 08/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    > Добавлен API для проверки видимости рекламных блоков силами JavaScript,
    > без необходимости использования для этого Flash;

    Как с этим API работать?

     
  • 1.117, Аноним (-), 22:35, 08/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > По умолчанию в Linux отключена поддержка звуковой подсистемы ALSA

    Ну это уже совсем никуда не годится. Конпелять себе браузер с поддержкой ALSA на дебиане? Городить костыли с apulse? Неужели настал момент когда пора перекатываться на Хромиум...

     
  • 1.118, Аноним (-), 23:23, 08/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >Изменён вывод предупреждения о проблемах с безопасностью в случае обращения к страницам, содержащим форму ввода пароля, без использования HTTPS. Вместо индикатора наличия проблем с безопасностью в адресной строке реализовано контекстное предупреждение, выводящееся непосредственно рядом с полем ввода пароля. Кроме того, при открытии страницы с формой входа по HTTP теперь отключается автозаполнение имени пользователя и пароля

    Ребята а вот это как то можно отключить или хотя бы вернуть старый бехавиор?

     
     
  • 2.121, th3m3 (ok), 00:03, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Нельзя. Оно и правильно. Нужно всё шифровать. Таков современный веб.
     
     
  • 3.147, ыщьутфьу (?), 18:32, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Я всегда поражался таким людям в интернете, которые всегда знают чем мне нужно пользоваться и как. Нужно совсем все блокировать кроме https А ТОЖ НЕ СИКУРНА. Мне всеравно че там холопы хотят, я вумный, я кодо-слесарь, мне видней.
    ru.wikipedia.org/wiki/Максимализм
     
     
  • 4.148, Анонимм (??), 18:54, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > Я всегда поражался таким людям в интернете, которые всегда знают чем мне
    > нужно пользоваться и как. Нужно совсем все блокировать кроме https А
    > ТОЖ НЕ СИКУРНА. Мне всеравно че там холопы хотят, я вумный,
    > я кодо-слесарь, мне видней.

    Не нравятся ответы - можно не общаться.
    Не нравится поведение разработчиков упенсурс продукта - git clone

     
  • 4.152, th3m3 (ok), 20:16, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Конечно, тебя никто не заставляет. Я только лишь высказываю своё мнение. Оно может расходиться с твоим. С твоими устоями. Мировоззрением. Выбор делать все равно тебе.
     
  • 2.122, Anonimmm (?), 01:40, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +2 +/
    security.insecure_field_warning.contextual.enabled=false
    security.insecure_password.ui.enabled=false
    signon.autofillForms.http=true
     
     
  • 3.143, th3m3 (ok), 14:54, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Учишь плохому.
     
  • 3.146, ыщьутфьу (?), 18:24, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Спасибо, друкг!
     

  • 1.137, Аноним (137), 12:58, 09/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Знающие люди, подскажите, пожалуйста, какая-нибудь работа по нормальному отображению в браузере вот такого примерно текста (на русском) %D0%BF%D0%B0%D0%BD%D1%81%D0%B8%D0%BE%D0%BD ведется?
     
     
  • 2.139, Lain_13 (ok), 13:33, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Знающие люди, подскажите, пожалуйста, какая-нибудь работа по нормальному отображению
    > в браузере вот такого примерно текста (на русском) %D0%BF%D0%B0%D0%BD%D1%81%D0%B8%D0%BE%D0%BD
    > ведется?

    А что ты имеешь в виду под нормальным отображением? Это явно кусок из URL. Тебе хочется копировать такой текст из адресной строки как есть (русским текстом)? Тогда about:config > browser.urlbar.decodeURLsOnCopy = true

    Если попался текст с таким мусором, то:
    Ctrl+Shift+I > Console
    > decodeURIComponent('%D0%BF%D0%B0%D0%BD%D1%81%D0%B8%D0%BE%D0%BD')

    "пансион"

     
  • 2.151, Lain_13 (ok), 19:23, 09/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Ещё можно сделать скрипт, который будет выправлять такой текст на страницах на лету.
    Proof of concept: https://greasyfork.org/en/scripts/27980-unurlencode
    Правда этот скрипт может ломать текстовые ссылки если их обрабатывает и превращает в полноценные ссылки какой-то другой скрипт на странице.
     

  • 1.155, Mirraz (ok), 13:46, 10/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Не было печали, теперь придётся ставить и настраивать пульсу. inb4: пересобери: делать мне больше нечего, не для того я убунту ставил. Вот убунтовские ментейнеры - сволочи, не стали впиливать альсу в фуррифокс.
     
     
  • 2.156, Lain_13 (ok), 16:19, 10/03/2017 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > убунтовские ментейнеры
    > не стали впиливать альсу в фуррифокс

    Я был бы несказанно удивлён, если бы они стали. Им-то это счастье на кой надо, когда их пульса устраивает?

     

  • 1.167, Мимо проходил (?), 16:04, 14/03/2017 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >На платформе Windows, если не используется Direct2D, для отрисовки содержимого >теперь применяется графическая библиотека Skia, которая ранее была задействована >только для Linux и Android;

    Слава Богу это отключается. Все шрифты на XP замылились, пока не догадался удалить это.

     
     
  • 2.168, Lain_13 (ok), 16:27, 14/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > на XP

    Господин знает толк в некро…мантии?

     
     
  • 3.169, Мимо проходил (?), 17:46, 14/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > Господин знает толк в некро…мантии?

    Я знаю толк в своей ОС, которая ничем не хуже современной десяточки со встроенной телеметрией.

     
     
  • 4.170, Lain_13 (ok), 18:01, 14/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Кроме отсутствия поддержки, да. Надеюсь хоть в виртуалке, а не голой ... в Интернет?
     
     
  • 5.171, Мимо проходил (?), 18:13, 14/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > Кроме отсутствия поддержки, да. Надеюсь хоть в виртуалке, а не голой ...
    > в Интернет?

    Не голой, а настроенной по протоколу под ограниченной учётной записью и с EMET.

     
     
  • 6.172, Lain_13 (ok), 18:34, 14/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Это всё совершенно никак тебе не поможет если найдут очередную дыру в TCP/IP стеке, позволяющую выполнять любой код на твоей системе подсунув кривой пакет. Актуальные версии EMET WinXP тоже не поддерживают. Т.е. от того, что ты надел полупрозрачные дырявые трусы, сильно легче не становится.
     
     
  • 7.173, Мимо проходил (?), 19:19, 14/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    > Это всё совершенно никак тебе не поможет если найдут очередную дыру в
    > TCP/IP стеке, позволяющую выполнять любой код на твоей системе подсунув кривой
    > пакет. Актуальные версии EMET WinXP тоже не поддерживают. Т.е. от того,
    > что ты надел полупрозрачные дырявые трусы, сильно легче не становится.

    И кто этим будет заниматься ради мельчайшей доли процента XP x64, которая даже в пору своего расцвета не занимала и 0.1% пользовательских ПК?
    К тому же конкретно сетевой стек в ХР весьма надёжен и допилен, это в Висте его переписали. Так что общих дыр с новыми ОС там не будет.
    Ну и от всякой фигни в TCP/IP стеке спасёт оутпост (тоже не поддерживаемый. Так вышло).

     
     
  • 8.175, Lain_13 (ok), 19:41, 14/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Поздравляю, практически вся твоя защита строится на принципе 171 неуловимого... текст свёрнут, показать
     
     
  • 9.176, Мимо проходил (?), 20:36, 14/03/2017 [^] [^^] [^^^] [ответить]  
  • +/
    Большие х64 защищён намного лучше изначально DEP обязателен для х64 процессов,... текст свёрнут, показать
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    MIRhosting
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру