The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

В ночных сборках Firefox прекращена поддержка NPAPI-плагинов, кроме Flash

09.10.2016 09:34

В ночных сборках Firefox, которые лягут в основу выпуска Firefox 52, по умолчанию прекращена поддержка плагинов с интерфейсом NPAPI, в том числе Silverlight, Java, Unitym, Gnome Shell Integration и плагинов с поддержкой мультимедийных кодеков (список активных плагинов можно посмотреть через URL about:plugins). Исключение сделано только для Adobe Flash, так как данная технология ещё остаётся востребована большим числом пользователей. Для пользователей Firefox 52, будет оставлена специальная опция, которая позволит вернуть NPAPI, но в Firefox 53 данная опция будет удалена.

Релиз Firefox 52, который позиционируется как выпуск с длительным сроком поддержки (ESR), запланирован на 7 марта. Релиз Firefox 53 запланирован на 18 апреля. В более отдалённом будущем разработчики намереваются полностью удалить поддержку NPAPI, а для пользователей Flash предоставить возможность использования плагина с интерфейсом PPAPI.



  1. Главная ссылка к новости (https://www.soeren-hentzschel....)
  2. OpenNews: Firefox прекращает поддержку плагинов NPAPI, за исключением Adobe Flash
  3. OpenNews: В ночные сборки Firefox добавлен API для 3D-шлемов и изоляция NPAPI-плагинов
  4. OpenNews: Новый выпуск FreshPlayer, прослойки для запуска PPAPI-плагинов в Firefox
  5. OpenNews: В Firefox заблокирован по умолчанию Java-плагин
  6. OpenNews: В Firefox будут по умолчанию неактивны все плагины, кроме последней версии Flash
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/45294-firefox
Ключевые слова: firefox, npapi, plugin
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (129) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, nazarpc (?), 10:04, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +5 +/
    Ура!
     
  • 1.2, modos189 (ok), 10:15, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Как же теперь в Gnome дополнения устанавливать?
     
     
  • 2.5, Ergil (ok), 10:46, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Со страданиями. Поставьте себе глюкомун или еще какую сборочку от васянов старых и дырявых версий Firefox.
     
  • 2.7, Аноним (-), 10:55, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    В Epiphany все работает, если включить плагины в настройках.
     
     
  • 3.113, Аноним (-), 05:32, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ты перепутал ветку.
     
  • 2.35, nE0sIghT (ok), 13:39, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Поддержка Firefox в chrome-gnome-shell в планах (https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome/RoadMap).

    От Mozilla сейчас нужна только реализация onMessageExternal (https://bugzilla.mozilla.org/show_bug.cgi?id=1258360#c12);

     
  • 2.145, Аноним (-), 15:08, 11/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    ищи на гитхабе gnome-shell-extension-installer - очень удобная штука, в отличии от фаерфокса, умеет ставить "несовместимые" экстеншны старых версий (в 90% случаев они прекрасно работают).
     

  • 1.3, Илья (??), 10:27, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –5 +/
    До свидания, silverlight. Если бы не флеш, ты был бы жив
     
     
  • 2.21, soarin (ok), 13:10, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > До свидания, silverlight

    А как же теперь Президентскую библиотеку смотреть?
    http://www.prlib.ru/Lib/Pages/russian_state_and_economy_1.aspx

    PS: это единственный ресурс, который я видел с сильверлайтом за годы использования интернетами

     
     
  • 3.36, Аноним (-), 13:39, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +15 +/
    > А как же теперь Президентскую библиотеку смотреть?

    Издадут закон, в котором запретят установку браузеров, не поддерживающих Silverlight. Делов-то.

     
     
  • 4.114, Аноним (-), 05:33, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >> А как же теперь Президентскую библиотеку смотреть?
    > Издадут закон, в котором запретят установку браузеров, не поддерживающих Silverlight.
    > Делов-то.

    И заставят смотреть президентский канал? А какие браузеры поддерживают Silverlight?

     
  • 3.44, Илья (??), 14:07, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    На силверлайте разрабатывается в основном корпоративное по.
     
     
  • 4.89, Аноним (-), 21:12, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +6 +/
    > На силверлайте разрабатывается в основном корпоративное по.

    копро-пративное по //fix

     
  • 2.88, труляляй (?), 20:08, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    А был ли мальчик?
     

  • 1.4, Ergil (ok), 10:45, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    Всего на полтора года отстали от Google Chrome/Chromium в выкидывании дырявого застарелого дерьма. Какие молодцы.
     
     
  • 2.108, Аноним (-), 02:47, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    А я всегда говорил, что фф играет чисто догоняющую роль в отношении хрома. Вот ответьте мне, хейтеры, чего нет в хроме такого, что есть в фф?
     
     
  • 3.115, Аноним (-), 05:34, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > А я всегда говорил, что фф играет чисто догоняющую роль в отношении
    > хрома. Вот ответьте мне, хейтеры, чего нет в хроме такого, что
    > есть в фф?

    Кастомизация интерфейса? Меньшее потребление памяти? Gecko? Мы никогда не узнаем...

     
     
  • 4.116, Аноним (-), 05:35, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >> А я всегда говорил, что фф играет чисто догоняющую роль в отношении
    >> хрома. Вот ответьте мне, хейтеры, чего нет в хроме такого, что
    >> есть в фф?
    > Кастомизация интерфейса? Меньшее потребление памяти? Gecko? Мы никогда не узнаем...

    Забыл тег /s. Я хотел сказать, что каждому свою, мне лично Лиса (она же Панда) нравится, несмотря на некоторые её проблемы :)

     
  • 3.136, Аноним (-), 18:03, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Поддержки AdBlock и NoScript.
     

  • 1.6, Аноним (-), 10:53, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Как же без джявы-то? Офонарели совсем.
     
     
  • 2.17, Zenitur (ok), 12:22, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Плагина Java нет в Java 8. Есть только в Java 7, для которой не выпускаются обновления (но они выпускаются для линукса и OpenJDK).
     
     
  • 3.30, soarin (ok), 13:33, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Плагина Java нет в Java 8. Есть только в Java 7, для которой не выпускаются обновления (но они выпускаются для линукса и OpenJDK).

    Врешь
    1) Плагин Java есть в восьмой версии. В 9-ой не будет.
    2) обновления для Oracle Java 7 выпускаются так же для избранных, кто денежку в Oracle занёс

     
     
  • 4.45, Zenitur (ok), 14:13, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    И правда есть. Извините.
     
  • 2.38, nE0sIghT (ok), 13:42, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Java Web Start как и рекомендует Oracle (https://blogs.oracle.com/java-platform-group/entry/moving_to_a_plugin_free)
     

  • 1.8, Аноним (-), 11:05, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +5 +/
    OpenH264 - всё?
     
     
  • 2.10, sergio78 (?), 11:25, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    похоже что ага
     
  • 2.11, fi (ok), 11:26, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –9 +/
    скорей всего фф всё :)))

    последняя версия будет 51 ну или 52 с патчем.

     
     
  • 3.117, Аноним (-), 05:46, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > последняя версия будет 51 ну или 52 с патчем.

    А вот и диванные кукаретики подтянулись. Так пруфы то будут или опять только кукареку?

     
     
  • 4.134, лолушки (?), 16:26, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >> последняя версия будет 51 ну или 52 с патчем.
    > А вот и диванные кукаретики подтянулись. Так пруфы то будут или опять
    > только кукареку?

    Аноним, неужели сам не видишь, насколько идиотично выглядит твоё требование пруфов? Что пруфами подтверждать, предположение "последняя версия будет 51 ну или 52 с патчем"? ЛОЛ же.

     
     
  • 5.137, Аноним (-), 18:18, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > насколько идиотично выглядит твоё требование пруфов

    Настолько же "идиотично" как и сообщение товарища fi. Я просто увеличиваю энтропию.

     
  • 2.12, soarin (ok), 11:42, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    OpenH264 - это GMP плагин, а не NPAPI
     
  • 2.22, iZEN (ok), 13:10, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    > OpenH264 - всё?

    От  Cisco? У меня включен (пакет openh264-1.5.0,2), используется в составе FFMPEG (пакет ffmpeg-2.8.8_3,1), а тот, в свою очередь, задействуется в Firefox (пакет firefox-49.0_7,1).
    Есть альтернативы?

     

  • 1.13, Аноним (-), 12:00, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +8 +/
    То есть 2/3 корпоративных банкингов - прекратило работать из-за нерабочей жабы... Отличная идея я считаю - положила конец зоопарку браузеров на рабочих местах, теперь - только ie, только хардкор!
     
     
  • 2.14, Ordu (ok), 12:19, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Да. Пользоваться жабой на десктопе запуская её в браузере -- это извращение. Жабу можно запустить отдельным приложением, с полноценным интерфейсом, без браузерной прослойки. Между прочим от этого вся цепочка передачи данных станет проще и, как следствие, безопаснее. А если 2/3 банков этого не понимают, то их клиенты должны страдать, и биться головой об ie. Это закон жизни.
     
     
  • 3.19, Аноним (-), 12:53, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Ты видимо плохо понимаешь как устроен реальный мир, а не альтернативный мир розо... большой текст свёрнут, показать
     
     
  • 4.24, iZEN (ok), 13:13, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    > Какой решение примет архитектор системы, то бишь я? Правильно - нафиг ВСЕ браузеры, кроме ie.

    Решение правильное, но почему не Edge?


     
     
  • 5.25, soarin (ok), 13:15, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > но почему не Edge?

    Ну так он не поддерживает же ни NPPAPI, ни ActiveX плагины. Из мажорных браузеров только Safari останется с их поддержкой.

     
     
  • 6.31, Аноним (-), 13:37, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >> но почему не Edge?
    > Ну так он не поддерживает же ни NPPAPI, ни ActiveX плагины. Из
    > мажорных браузеров только Safari останется с их поддержкой.

    Сафари сто лет как под винду не выпускается раз, два - им нельзя управлять с помощью политик.

     
  • 4.70, Аноним (-), 16:06, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Переходи работать в Альт Линукс. Там всё демократично.


     
     
  • 5.78, Аноним (-), 17:09, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Переходи работать в Альт Линукс. Там всё демократично.

    Самое смешное - что уже пробовали. :) Результат - суммарные потери примерно на полтора миллиарда. Да-да - миллиарда. Рублей правда.
    Нет не я - меня пригласи все налаживать, после увольнение архитектора подобного перехода. :)

     
     
  • 6.125, Аноним (-), 10:32, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Епифанцев.jpg
     
  • 4.79, commiethebeastie (ok), 17:28, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    У вас монолитная система в одном домене? Если да, то лучше держи намыленную веревку в легкодоступном месте.
     
  • 4.91, Ordu (ok), 22:10, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Какой решение примет архитектор системы, то бишь я? Правильно - нафиг ВСЕ браузеры, кроме ie.

    Я и говорю: клиенты идиотских банков должны страдать. И если ты хочешь работать на такого клиента -- то это твоё личное желание. Если ты любишь страдать, страдай. Как будто тебя кто-то заставляет.

    Мне не нравится работать с Windows, я не работаю с Windows. Мне не нравится Java, я не работаю с Java. Ты же своими руками внедряешь IE и жалуешься, что тебе с ним работать приходится. Ты, и такие как ты, поддерживают Windows на плаву. Если бы вы отказались работать с Windows, то этого бы не было. Но вы все рассуждаете по принципу "кто-нибудь всё равно будет работать, так почему бы не мне", так? Вот и работай. И не ной. Мне насрать на твои проблемы, это self inflicted проблемы.

     
     
  • 5.103, anonymous (??), 00:35, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ну да, один зубами вцепились в вындовс, а другие выкидывают всё подряд. Ясен пень, будет ie, если под него пинками загоняют.
     
     
  • 6.105, Ordu (ok), 01:11, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Нам это важно настолько, что нам не лень говорить об этом, потому что... ?
    Почему?
     
     
  • 7.109, iCat (ok), 02:57, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >Нам это важно настолько, что нам не лень говорить об этом, потому что... ?
    >Почему?

    Вот лично мне это важно потому, что осточертело слышать истошный вой IE-рабов, изо всех сил поддерживающих IE и продолжающих истошно выть.
    И дело тут не столько в акустическом бэкграунде, а в том, что поддержка заскорузлых тупиковых технологий пожирает ресурсы человечества.

     
     
  • 8.126, Uri (??), 12:14, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    До Давайте побольше и побыстрее новых свежих технологий Каждые полгода по техн... текст свёрнут, показать
     
     
  • 9.131, iCat (ok), 14:12, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    А вот передёргивать не надо ... текст свёрнут, показать
     
  • 5.123, iPony (?), 08:02, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Мне не нравится работать с Windows, я не работаю с Windows. Мне не нравится Java, я не работаю с Java.

    Админ локалхоста хвастается :D
    Человек просто обрисовал весьма узкую сферу корпоративного клиентного банкинга. Да, они там, кто может быть использовал фурифокс, действительно пойдут на IE для этой узкой цели. Ибо это самый логичный выход. И страдать не будут - тот же IE 11 для тупого браузинга ничем не плох (когда не нужны вертикальные табы, QR генератор ссылок, крутой firebug какой-нибудь...).
    То что тебе (или кому-то лично) это нравится/не нравится не влияет на ситуацию. Всем так же плевать на твоё мнение.
    PS: подобные рассуждения разве что для школьника с юношеским максимализмом годятся

     
  • 4.97, Anonim (??), 23:20, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Эту хохму нужно швейцарским банкам рассказать, да и местным типа Приватбанка.
     
  • 4.100, EHLO (?), 23:55, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    >Ты видимо плохо понимаешь как устроен реальный мир, а не альтернативный мир розовых пони... Давай я расскажу тебе о нем...

    Давай я тебе расскажу.
    В реальном мире банк-клиент установлен на менее 1% рабочих ПК. Эти ПК обслуживаются иначе чем 99% других офисных. Набор ПО там на ~80% отличается от других офисных, что-то кроме банк-клиента и ИБ-шного софта туда лучше не ставить.
    Даже если это типовой офисный комп в маленькой шарашке, то браузер с банк-клиентом не используется для иных целей кроме банковских операций, то есть в основном пользуются другим браузером.
    Если у тебя это не так, ты сам себе сказочник (или враг).

     
     
  • 5.124, commiethebeastie (ok), 09:17, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Судя по его описанию, он работает в системе микрофинансирования.
     
     
  • 6.128, Клыкастый (ok), 13:08, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    т.е. проблема была не в софте, просто админ решил опустить контору посильнее. вышло на полмиллиарда. неплохо, неплохо. главное возврат на IE сделать не менее эффективным.
     
     
  • 7.132, commiethebeastie (ok), 15:27, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > т.е. проблема была не в софте, просто админ решил опустить контору посильнее.
    > вышло на полмиллиарда. неплохо, неплохо. главное возврат на IE сделать не
    > менее эффективным.

    Да у него синдром вахтера. Просто в техсаппорте когда нибудь появится человек, который знает как работает LDAP в AD и конторе останется только закрыться. Obscurity is not security.

     
  • 5.133, Pofigis (?), 16:00, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    А не важно на 1% или на 10% - софт ОБЯЗАН быть стандартизованным. Посему если кому-то необходим IE - у всех будет IE
     
     
  • 6.142, EHLO (?), 20:11, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    тоже верно. Поэтому не будем закупать молотки, закажем больше микроскопов. Или наоборот купим только молотки и откажемся от микроскопов. Не важно, главное стандартное решение.
     
  • 6.143, Led (ok), 21:41, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > софт ОБЯЗАН

    Не кричи, дурачок.


     
  • 4.141, Аноним (-), 18:59, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Что за пьяный гон?
    > Какой решение примет архитектор системы, то бишь я?

    А о том, какой ты рахитектор, ниже:
    > P.S. Не то что попытки - просто предложение использовать что-то кроме венды приводит к сам понимаешь каким последствиям
    > Предложения "сменить банк потому что их клиент не совместим с нашим ПО" в первый раз - выговор и лишение премии, 2й раз - увольнение.

    Таки да, таких бездарей как ты - только в шею... Бояться быть выгнаным с работы... Это вообще жесть.

     
  • 2.27, Ergil (ok), 13:20, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Корпоративных банкингов в стране третьего мира на которую всем разработчикам пофигу? Ну так и пофигу.
     
  • 2.34, Stax (ok), 13:38, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Да, без джавы-плагина грустно, но по справедливости надо сказать, что у банкиров было много лет, чтобы перевести свои веб-приложения на Java WS.

    Запускать java-приложения из браузера никто не запрещает. Просто говорят, что пора уже использовать современный механизм WS вместо устаревших (не безопасных, не поддерживаемых и т.п.) плагинов.

     
     
  • 3.41, Аноним (-), 13:55, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Ты сначала запили сертификацию клиента, использующего новый и прогрессивный меха... большой текст свёрнут, показать
     
     
  • 4.60, Аноним (-), 15:19, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    У банкиров было много лет, чтобы перевести свои веб-приложения на Java WS
     
     
  • 5.64, Аноним (-), 15:39, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > У банкиров было много лет, чтобы перевести свои веб-приложения на Java WS

    Зачем менять то что работает? Зачем тратить кучу бабла, как на переписывание продукта, так и на его сертификацию?

     
     
  • 6.71, Аноним (-), 16:24, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    ну вот сейчас перестанет работать
     
     
  • 7.76, Аноним (-), 17:05, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > ну вот сейчас перестанет работать

    В IE же работает... Так что - не перестанет, пока IE не удалят из винды, ну с точки зрения банкира разумеется.
    Кому это повредит по-вашему? Подсказка - не банкирам.

     
  • 6.72, Аноним (-), 16:27, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Зачем менять глиняные таблички? Зачем тратить кучу бабла как на совершенствование клинописи, так и на обучение писцов?
     
     
  • 7.77, Аноним (-), 17:06, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    > Зачем менять глиняные таблички? Зачем тратить кучу бабла как на совершенствование клинописи,
    > так и на обучение писцов?

    Да не проблема - плати СВОИ деньги за разработку и сертификацию и делай что хочешь. А если не хочешь... работает? НЕ ТРОГАЙ!

     
     
  • 8.80, Аноним (-), 17:57, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +5 +/
    О, тушите свет Крупный бизнесмен в треде, бюджеты из собственного кармана рас... текст свёрнут, показать
     
     
  • 9.92, Аноним (-), 22:11, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Если не имеешь базовых навыков работ с бюджетированием, то твое место - место по... текст свёрнут, показать
     
     
  • 10.101, Аноним (-), 00:02, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Ну и откуда у тебя, инженера с навыками бюджетирования, вышепомянутые СВОИ ден... текст свёрнут, показать
     
  • 6.102, anonymous (??), 00:32, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Это они с кризисом перепроизводства борются. А иначе куда девать эту армию кодеров.
     

  • 1.15, Володя (??), 12:20, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Наконец-та, еще бы Flash выпилили-бы вообще норм бы было
     
     
  • 2.104, anonymous (??), 00:44, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Наконец-та, еще бы Flash выпилили-бы вообще норм бы было

    Где же вы были лет 15 назад, когда компы играли видео без проблем?

     
     
  • 3.118, Аноним (-), 05:53, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Где же вы были лет 15 назад, когда компы играли видео без
    > проблем?

    Он ещё не родился.

     

  • 1.16, Zenitur (ok), 12:21, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Сделайте PPAPI, сволочи
     
     
  • 2.39, Stax (ok), 13:44, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Сделайте PPAPI, сволочи

    Зачем?
    Флеш работает и через NPAPI и продолжает поддерживаться (а с недавнего времени Адоб стала выпускать актуальный свежий флеш в NPAPI), а желаемого местной аудиторией джава-плагина под PPAPI все равно нет.

    Вы знаете о существовании еще каких-либо PPAPI-плагинов? Или плагинов вообще? Декодинг видео/аудио давно в браузере, webrtc в браузере, даже pdf в браузере.. doc/xls открываются через google docs. Я даже не могу вспомнить, какие еще когда-либо существовали плагины, кроме документов/мультимедии/флеша/джавы. Qt для проигрывания MIDI? Это нужно 0.01% пользователей. VRML? хм..

     
     
  • 3.46, Zenitur (ok), 14:15, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Плагин Java портировали бы, если так сильно надо. Не Oracle зачешется, так банки оплатят разработчика.
     
  • 3.83, irinat (ok), 18:40, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > pdf в браузере

    В Chrome чтение PDF состоит из двух частей. Интерфейс на HTML5, рисовалка в виде бинарного плагина. Ну как плагина, они встроили libpdf прямо в основной бинарник, чтобы не держать две копии кода V8.

     
     
  • 4.110, Stax (ok), 03:55, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Допустим, но в фоксе-то (который мы обсуждаем) PDF.js, не зависящий ни от каких плагинов. (после перевода его на asm.js им даже можно без мата пользоваться!)
     
     
  • 5.135, irinat (ok), 16:29, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Скорее всего, в Firefox через некоторое время в добавок к pdf.js будет ещё и бинарный libpdf и Chromium'а. И скорее всего, в отдельном процессе, как плагин, в песочнице.
     
  • 3.144, Аноним (-), 22:27, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > а с недавнего времени Адоб стала выпускать актуальный свежий флеш в NPAPI

    Ты опять выходишь на связь? Адоб никогда не прекращали выпуск флеша на NPAPI. Прекращали выпуск флеша на линуксы.

     
  • 2.86, irinat (ok), 19:38, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Сделайте PPAPI

    http://www.opennet.ru/opennews/art.shtml?num=45257

    Чего тебе ещё надо-то?

     

  • 1.18, Аноним (-), 12:25, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    >кроме Flash

    это называется "купил билет и пошёл пешком"

     
  • 1.20, Аноним (-), 12:59, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    прощай ФФ. покойся с миром. пересел на оперу -  неплохо, особенно встроеный впн свой.
     
     
  • 2.28, Ergil (ok), 13:21, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +5 +/
    > прощай ФФ. покойся с миром. пересел на оперу -  неплохо, особенно
    > встроеный впн свой.

    1. Так как жОпера не более, чем шкурка над Хромиумом, то само собой NPAPI в нем нет.
    2. В ней нет Virtual Private Network, в ней есть встроенная прокся отправляющая ваш трафик через китайцев.

     
     
  • 3.32, Аноним (-), 13:38, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    1. фф просто выпиливает все фичи, из за которых он имел преимущества над хромоподобными. при том. что его движок более глючный. пример - при запущенно фотошопе и интенсивной в нем работе. фф начинает дико тормозить систему. в хромоподобных такого не наблюдается.
    2. мне не важно через кого идет трафик (оперовский впн, если склероз не изменяет, идет через канаду), мне важно то, что флибуста, ннм и прочие работают по одному клику. в фф приходилось отдельный плагин ставить.
     
     
  • 4.37, Ergil (ok), 13:40, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +5 +/
    > 2. мне не важно через кого идет трафик (оперовский впн, если склероз
    > не изменяет, идет через канаду), мне важно то, что флибуста, ннм
    > и прочие работают по одному клику. в фф приходилось отдельный плагин
    > ставить.

    Там нет VPN'а. Нет, не было и не будет. Там есть прокси. То что маркетолухи написали «vpn» не делает его там. Идите учить матчасть.

     
     
  • 5.40, Аноним (-), 13:45, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –7 +/
    >> 2. мне не важно через кого идет трафик (оперовский впн, если склероз
    >> не изменяет, идет через канаду), мне важно то, что флибуста, ннм
    >> и прочие работают по одному клику. в фф приходилось отдельный плагин
    >> ставить.
    > Там нет VPN'а. Нет, не было и не будет. Там есть прокси.
    > То что маркетолухи написали «vpn» не делает его там. Идите учить
    > матчасть.

    и? как не назови, но свою функцию он выполняет. прокси.. впн.. пох. работает - и это хорошо

     
     
  • 6.42, Ergil (ok), 14:03, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > и? как не назови, но свою функцию он выполняет. прокси.. впн.. пох.
    > работает - и это хорошо

    Он не выполняет функции VPN'а, не предоставляет виртуальной частной сети.

     
  • 6.48, Аноним84701 (?), 14:24, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > и? как не назови, но свою функцию он выполняет. прокси.. впн.. пох.
    > работает - и это хорошо

    Да-да, что системный блок, что процессор - главное что гудит, воздух греет, контактики показывает!

    Кстати, ставим в браузере в качестве прокси "socks://127.0.0.1", запускаем tor и
    > что флибуста, ннм и прочие работают по одному клику

    внезапно, работает без левых китайцев.

     
     
  • 7.51, soarin (ok), 14:34, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > tor

    замучаешься капчу вводить

     
  • 7.53, Аноним (-), 14:42, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    >> и? как не назови, но свою функцию он выполняет. прокси.. впн.. пох.
    >> работает - и это хорошо
    > Да-да, что системный блок, что процессор - главное что гудит, воздух греет,
    > контактики показывает!

    странные люди, шашечки важнее чем ехать ))
    а предоления нагромоздить тор, для захода на флибусту.. это вообще за гранью )))
    старик окама плачет, а ведь он говорил - не умножай сущности без необходимости

     
     
  • 8.58, Оккам (?), 15:10, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Не окама, а обама ... текст свёрнут, показать
     
  • 8.59, anonymous (??), 15:11, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Флибуста не даст все книги, если не зайдешь через http flibustahezeous3 onion ... текст свёрнут, показать
     
     
  • 9.62, Аноним (-), 15:33, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ха, вот этого я не знал Что, вместо предупреждении о правомарателях будет скачк... текст свёрнут, показать
     
     
  • 10.63, Аноним (-), 15:39, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Тихо ты ... текст свёрнут, показать
     
     
  • 11.67, Аноним (-), 15:49, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Даже Поднятую Целину через onion дают скачать ... текст свёрнут, показать
     
     
  • 12.107, user (??), 01:46, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    За такую упущеную прибыть можно создать свою долину до пупа ... текст свёрнут, показать
     
  • 9.73, Аноним (-), 16:29, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    спасибо за информацию не знал ... текст свёрнут, показать
     
  • 8.75, Аноним84701 (?), 16:49, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Напоминает предложение сесть на транспортное средство с копытами, длинными ушами... текст свёрнут, показать
     
  • 6.129, Клыкастый (ok), 13:43, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > но свою функцию он выполняет.

    отдаёт твои тестикулы в приветливые руки посторонних контор? да на отлично выполняет, ящетаю.


     
  • 5.49, Аноним (-), 14:26, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Нет, не было и не будет.

    Ухх! Как ты их всех ненавидишь!

     
  • 5.106, user (??), 01:42, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >Там есть прокси

    Я сам не пользовался, но для 29.5 это лучше чем ничего.

     

  • 1.26, Аноним (-), 13:18, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Прощай, шаринг рабочего стола на BigBlueButton.
     
  • 1.33, vitalikp (?), 13:38, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >> по умолчанию прекращена поддержка плагинов с интерфейсом NPAPI

    Интересно, а что взамен предлагается использовать?

     
     
  • 2.43, Ergil (ok), 14:05, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >>> по умолчанию прекращена поддержка плагинов с интерфейсом NPAPI
    > Интересно, а что взамен предлагается использовать?

    Для чего? Было три плагина ради которых этот дырявый глюкодром жил: Flash, Java и Unity 3D. Ораклы официально объявили, что жаба-плагина больше нет и не будет, сказали использовать приложения, Unity 3D работает теперь через HTML5, все что нужно от флэша тоже уже года три работает через HTML5.

     

  • 1.47, djoe (ok), 14:21, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Банк-клиенты теперь будут работать только в IE?

    [сообщение отредактировано модератором]

     
     
  • 2.50, Аноним (-), 14:30, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    В Хроме будут работать. В Опере тоже наверное будут работать. В Edge обязаны будут работать.
    В вашем любимом броузере не будут работать? Ну так вы знаете куда вам с вашим броузером идти.


     
     
  • 3.54, djoe (ok), 14:43, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Вероятно, туда же, куда и тебе с твоими советми..
     
     
  • 4.56, Аноним (-), 14:48, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Таким образом, встречаемся под Часами на Трёх Вокзалах.


     
  • 3.66, Аноним (-), 15:41, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > В Хроме будут работать. В Опере тоже наверное будут работать.

    Там же нет NPAPI.

     
     
  • 4.69, Аноним (-), 15:52, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Но у меня в Хроме Сбер как-то же работает?
     
     
  • 5.74, Аноним (-), 16:32, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Но у меня в Хроме Сбер как-то же работает?

    Может быть Сбер тот от хакера Васяна?

     
  • 3.119, Аноним (-), 06:01, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > В Хроме будут работать.

    Java не будет.

    > В Опере тоже наверное будут работать.

    Опера использует хромиум.

    > В Edge обязаны будут работать.

    Возможно, это же Малокософт.

     
     
  • 4.120, Аноним (-), 06:02, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    З.Ы. Вообще не понимаю, в чём ваша проблема то? Раньше же банки работали без дырявых плагинов, почему они сейчас должны работать с ними?
     

  • 1.61, Аноним (61), 15:19, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    Как же мне нравятся все эти полумеры в духе фаерфокса: отключим все плагины, кроме флеша.
     
     
  • 2.121, Аноним (-), 06:03, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Как же мне нравятся все эти полумеры в духе фаерфокса: отключим все
    > плагины, кроме флеша.

    Ну может просто не надо держать флеш в системе? А по сути согласен.

     

  • 1.84, Омномномномном (?), 19:16, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Здолбали. Если NPAPI-флэш поддержтвается - значит нужный код остался. Внимание вопрос: как включить его и обойти это огро-ничение? Война войной, как говорится, а отчёты в пенсионный (не в России, там же, небось, до сих пор на дискетах тоскают) каждый месяц через web-интерфейс на Java отправлять надо...
     
     
  • 2.85, irinat (ok), 19:28, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    В about:config параметр plugin.load_flash_only нужно поставить в false.

    Если будешь сам код подправлять, просто глянь в багрепорт, там есть применённый патч. Если не сам, то и смысла объяснять нет.

     
     
  • 3.94, Омномномномном (?), 23:02, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Спасибо.
     

  • 1.87, анонимм (?), 19:41, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А кто-нибудь знает что будет с Intel Identity Protection (npIntelWebAPIIPT.dll)? Он тоже через NPAPI реализован. Или Intel выпустит его в качестве PAPI?
     
  • 1.90, Аноним (-), 22:07, 09/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Опять... Чем флеш такой особенный? Не трогали бы остальные расширения. Жду развития epiphany, буквально пару фич и фокс можно будет сносить.
     
     
  • 2.95, Омномномномном (?), 23:03, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > epiphany, буквально пару фич и фокс можно будет сносить.

    Каких например?

     
     
  • 3.98, Аноним (-), 23:50, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Недавно говорили про выпуск webkit для gtk + хотелось бы получение элемента по щелчку(инструменты разработки). До тех пор пока инструмент разработки не будут как в фоксе, фокс придётся держать. Возможно я бы и сам доделал часть работы, но я не разберусь в километрах кода на си.
     
     
  • 4.111, Омномномномном (?), 04:45, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Да, нужная вещь. Но вряд ли её там реализуют. Потому, что 99 процентам обычных пользователей не нужно, а web-программисты всё-равно используют актуальную версию Chrome/Firefox. Вообще мне кажется в идеале браузер в чистом виде должен быть максимально примитивен и прост, но иметь мощный (но в то же время достаточно лаконичный и не требующий изучения кучи мануалов и написания кучи кода для реализации элементарных функций) API для расширений, через которые и следует уже реализовывать подобные фичи.
     
     
  • 5.122, Аноним (-), 06:06, 10/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Вообще мне кажется в идеале браузер в чистом виде
    > должен быть максимально примитивен и прост,

    Luakit, dwb.

    > но иметь мощный (но в
    > то же время достаточно лаконичный и не требующий изучения кучи мануалов
    > и написания кучи кода для реализации элементарных функций) API для расширений,
    > через которые и следует уже реализовывать подобные фичи.

    Такого не бывает, уважаемый :) Если уж вы хотите из браузера комбайн сделать, то простым он не будет априори.

     
  • 2.96, Led (ok), 23:18, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Жду развития epiphany

    Дедушка ждал и тебе завещал ждать?


     
     
  • 3.99, Аноним (-), 23:51, 09/10/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Про юзеров федоры слышал? Они постоянно чего-то ждут. То новой версии, то багфиксов.
     

  • 1.130, anonymous (??), 13:58, 10/10/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Осталось только на blink пересесть.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру