The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Релиз Firefox 46, перешедший на GTK3+ в Linux

26.04.2016 18:43

Состоялся выпуск web-браузера Firefox 46, а также мобильной версии Firefox 46 для платформы Android. В ближайшие часы ожидается обновление прошлых веток с длительным сроком поддержки Firefox 38.8.0 и 45.1. Выпуск SeaMonkey 2.41 будет пропущен. В скором времени на стадию бета-тестирования перейдёт ветка Firefox 47 и будет отделён Firefox Developer Edition 48. В соответствии с шестинедельным циклом разработки релиз Firefox 47 намечен на 7 июня, а Firefox 48 на 2 августа.

Основные новшества:

  • Переход на GTK3+ в сборках для платформы GNU/Linux. Поддержка GTK2+ пока сохранена и поддерживается в полном объёме. Переход Firefox на GTK3+ является важным звеном в реализации работы на системах, поддерживающих протокол Wayland. В связи с переходом на GTK3+ наблюдается повышение качество работы на экранах с высоким разрешением и отдельные изменения внешнего вида, например, изменился фон контекстных меню, при запуске в Ubuntu.
    
       $ ldd libmozgtk.so |grep libgtk
       libgtk-3.so.0 => /usr/lib/i386-linux-gnu/libgtk-3.so.0 (0xb722c000)
  • Проведена работа по усилению безопасности JIT-компилятора JavaScript. Выполнение кода организовано с использованием применяемого в OpenBSD алгоритма W^X, суть которого в том, что страницы памяти не могут быть одновременно доступны на запись и исполнение. В контексте JIT, генерируемый код может быть исполнен только после запрещения записи. При необходимости сгенерировать обновлённый вариант, флаг исполнения меняется на флаг записи. Включение режима W^X приводит к замедлению работы JavaScript-движка на 1-4%;
  • Внесена большая порция изменений и исправлений в реализацию технологии WebRTC. Добавлена поддержка Simulcast, поддержка дуплексного режима при использовании PulseAudio, переписан код завершения соединения, добавлен вызов RTCRtpReceive, добавлены константы echoCancellation, mozAutoGainControl и mozNoiseSuppression, включена поддержка WebRTC в многопроцессном режиме;
  • Для декодирования незашифрованного контента H.264 и AAC в случае отсутствия соответствующего кодека, в качестве запасного варианта может применяться CDM-модуль (Content Decryption Module), предназначенный для декодирования защищённого DRM-контента.
  • Добавлен метод documents.elementsFromPoint, возвращающий массив элементов, находящихся в окне по указанным координатам;
  • Добавлена поддержка порции свойств с префиксом "-webkit-", например "-webkit-flexbox" и "-webkit-transforms";
  • Добавлена поддержка новых свойств, определённых в спецификации ECMAScript 6: флаг определения unicode-последовательностей в RegExp, функций блочного уровня, метод TypedArray.prototype.sort(), выражение arguments[@@iterator];
  • Представлен экспериментальный EcmaScript Shared Memory API с реализацией типа SharedArrayBuffer, позволяющего создавать массивы в разделяемой памяти, и объекта Atomics для организации синхронизации блокировок примитивов;
  • Реализован OffscreenCanvas API с конструктором OffscreenCanvas(), позволяющим организовать отрисовку через WebGL в отдельном потоке, не мешающем работе основного потока обработки контента;
  • Реализация расширения WEBGL_compressed_texture_es3 с поддержкой сжатых текстур в формате ETC;
  • В Web workers добавлена поддержка асинхронного чтения файлов при помощи объекта FileReader;
  • В Web Crypto API добавлена поддержка формирования ключей с использованием HKDF (HMAC-based Extract-and-Expand Key Derivation Function);
  • В about:config реализована опция network.dns.blockDotOnion, позволяющая заблокировать обращение к доменам .onion на уровне DNS, чтобы не афишировать случайное обращение к onion-узлам при подключении не через сеть Tor;
  • В инструмент отладки потребления памяти добавлен режим "Dominator view", отображающий косвенный размер объектов ("retained size"), помимо самого объекта включающий и данные о размере других объектов, связанных через ссылки;
  • В редакторе стилей в боковую панель правил "@media" добавлена возможность создания и отладки слоёв на базе отзывчивых изображений (Responsive Images, задание вариантов изображений, оптимизированных для различных экранных разрешений и уровня масштабирования);
  • В инструменты для оценки производительности добавлен отчёт Allocations View, позволяющий выявить функции, потребляющие много памяти, и отследить появление пауз из-за операций выделения памяти и сборки мусора;
  • Улучшения в версии для платформы Android:
    • В меню добавлены элементы для обращения к истории посещений и закладккам;
    • Прекращена поддержка платформы Android 3 (Honeycomb);
    • В уведомлениях для открытых в фоне вкладок обеспечен показ URL;
    • На устройствах с Android 6.0+ реализован вывод запроса полномочий при доступе к расширенным функциям в процессе выполнения приложения (ранее полномочия запрашивались только при установке);
    • Обеспечен показ прокэшированных страниц, при попытке их открытия без наличия доступа в интернет;
    • Увеличено разрешение пиктограмм ярлыков на домашнем экране;
    • В качестве предлагаемых по умолчанию эскизов популярных сайтов теперь выводятся сайты, занимающие первые пять мест в рейтинге Alexa;
    • Удалена поддержка Firefox Sync 1.1;

Как обычно следует отметить, что кроме новшеств и исправления ошибок в Firefox 46 устранена серия уязвимостей, из которых несколько помечены как критические, т.е. могут привести к выполнению кода злоумышленника при открытии специально оформленных страниц. В настоящее время информация с подробностями об исправленных проблемах безопасности недоступна, ожидается, что перечень уязвимостей будет опубликован в течение нескольких часов.

  1. Главная ссылка к новости (https://www.mozilla.org/en-US/...)
  2. OpenNews: Разработчики Firefox представили браузер Tofino, использующий технологии Chromium
  3. OpenNews: В Firefox собираются использовать Widevine CDM для воспроизведения защищённого DRM видео
  4. OpenNews: Некоторые новшества в Firefox будут вноситься не дожидаясь релиза
  5. OpenNews: В Firefox, Chromium и Edge добавлена экспериментальная поддержка WebAssembly
  6. OpenNews: Релиз Firefox 45
Лицензия: CC-BY
Тип: Интересно / Программы
Ключевые слова: firefox
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (84) Ajax | 1 уровень | Линейный | Раскрыть всё | RSS
  • 1.1, Аноним (-), 18:49, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –6 +/
    в шрифтах стабильный хаос
     
     
  • 2.38, Аноним (-), 00:44, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • –4 +/
    Не знаю даже что сказать. Судя по TOR'у, всё норамльно со шрифтами в Арчике. Огнелис же слушается ГНОМа. Вот Хромиум не слушается, он слушается глобального конфига Арчика. В результате, шрифты в обоих выглядят одинаково. У меня вообще тут ляпота. А может вы другой хаос имели в виду. Хаос в голове, например.
     
     
  • 3.77, Dmitry77 (ok), 22:50, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    а у меня выделения текста и чекбоксы слосмались :(
     
     
  • 4.81, Омомим (?), 15:14, 28/04/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Потому что тема GTK, которую вы используете, не поддеживает версию GTK3+, которая у вас установлена. Попробуйте переключиться на Adwaita или на последнюю версию Arc,Zuki-themes или Numix. Чекбоксы, кнопки и выделение придут в норму и в ФФ, и во всех программах на ЖТК3.
     
     
  • 5.82, Dmitry77 (ok), 18:07, 28/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Да, заработало, спасибо!
     

  • 1.2, Аноним (-), 18:58, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +16 +/
    >> security.insecure_password.ui.enabled в about:config, в Firefox 46 данная возможность включена по умолчанию

    Не включена. По умолчанию false.


    >> Увеличена плавность панорамирования и масштабирования web-контента

    Не увеличена.
    Async Pan Zoom (APZ) is not enabled in Firefox 46.
    http://www.ghacks.net/2016/04/26/firefox-46-0/


    >> В Web Crypto API добавлена поддержка формирования ключей с использованием HKDF (HMAC-based Extract-and-Expand Key Derivation Function)

    https://bugzilla.mozilla.org/show_bug.cgi?id=1200341
    Target Milestone: mozilla47

     
  • 1.3, Аноним (-), 19:12, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +9 +/
    >Переход на GTK3+ в сборках для платформы GNU/Linux.

    Боль и страдания ниже по теме предвижу я.

     
     
  • 2.7, Вовик_Путтин (?), 19:47, 26/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Почему?
     
  • 2.8, Дуплик (ok), 20:06, 26/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Разве что у KDE'шников, которые опять собрать тему под него не смогут. Или чем они там занимаются.
     
     
  • 3.11, Аноним (-), 20:34, 26/04/2016 [^] [^^] [^^^] [ответить]  
  • +19 +/
    Какую тему? В KDE прослойка отображающая GTK через Qt выглядит красивее чем сам этот GTK!
     
     
  • 4.18, Аноним (-), 21:26, 26/04/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Кстати, да. И это более чем странно.
     
     
  • 5.21, Отражение луны (ok), 21:30, 26/04/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Нету ничего странного. Гтк - устаревшее убожество.
     
     
  • 6.31, Led (ok), 23:21, 26/04/2016 [^] [^^] [^^^] [ответить]  
  • +10 +/
    > Гтк - устаревшее убожество.

    Не надо наговаривать - не устаревшее.

     
  • 6.42, Аноним (-), 00:54, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    GTK или GTK3, паёнир?
     
     
  • 7.60, Аноним (-), 11:46, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Оба.
     
  • 4.43, Аноним (-), 00:57, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • –8 +/
    > Какую тему? В KDE прослойка отображающая GTK через Qt выглядит красивее чем
    > сам этот GTK!

    Для начала,KDE попросту не работает. Ну, по меркам продакшена, по крайней мере. Оговорка: не каcается тех, кто сидит на KDE 3.5.


     
     
  • 5.71, Аноним (-), 18:45, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Руки у тебя не работают, ну или у твоих дистростроителей.
     
  • 4.46, Аноним (-), 01:12, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Вы просто не умеете его готовить!
     
  • 4.55, Аноним (-), 09:50, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    В KDE вообще ничего красиво не выглядит. Это позорище оупенсорсного дизайна.
     

  • 1.4, Аноним Анонимович (?), 19:13, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    --Добавлена поддержка порции свойств с префиксом "-webkit";--
    Через 2-3 года это будет webkit с префиксом  "Gecko";
     
  • 1.5, Аноним (-), 19:27, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +5 +/
    Так 45 же была ESR или я чего-то не понял...
     
     
  • 2.10, Аноним (-), 20:18, 26/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    И на сайте мозиллы доступны только 38 и 45 ESR.
     
     
  • 3.27, paulus (ok), 22:21, 26/04/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > И на сайте мозиллы доступны только 38 и 45 ESR.

    https://www.mozilla.org/en-US/firefox/all/#ru

     
     
  • 4.30, Аноним (-), 23:18, 26/04/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Но по ссылке же не ESR?
     
     
  • 5.64, DmA (??), 15:19, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Но по ссылке же не ESR?

    Вот все релизы Firefox
    https://download-installer.cdn.mozilla.net/pub/firefox/releases/
    папку 45.1.0esr надеюсь найдёте!

     
     
  • 6.65, Аноним (-), 15:28, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Вы не поняли суть. Первая версия новости гласила, что 46-ая версия отнесена к ESR. Но уже исправили.
     

  • 1.6, Аноним (-), 19:33, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    > первые пять мест в рейтинге Alexa

    Google.com
    Youtube.com
    Facebook.com
    Baidu.com
    Yahoo.com

     
     
  • 2.84, rvs2016 (ok), 22:16, 28/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >> первые пять мест в рейтинге Alexa
    > Google.com
    > Youtube.com
    > Facebook.com
    > Baidu.com
    > Yahoo.com

    Радость-то какая! И на кой юзерам этот спам? :о)

     

  • 1.9, Дуплик (ok), 20:07, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Ура! Наконец-то Firefox будет выглядеть нормально на HighDPI-экранах!
     
     
  • 2.63, DmA (??), 15:12, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Ура! Наконец-то Firefox будет выглядеть нормально на HighDPI-экранах!

    Буржуи, я всё ещё за ЭЛТ сижу 17 дюймовом на работе,правда фирмы SUN, работает  уже 13 лет, зараза.
    Мышь(тоже сановская,правда  без колёсика, зато трёхкнопочная,USB)  тоже работает 13 лет...

     
     
  • 3.76, Аноним (-), 22:44, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Буржуи, я всё ещё за ЭЛТ сижу 17 дюймовом на работе,правда фирмы
    > SUN, работает  уже 13 лет, зараза.
    > Мышь(тоже сановская,правда  без колёсика, зато трёхкнопочная,USB)  тоже работает 13 лет...

    Походу админа где-то приковали к сановской рабочей станции.


     

  • 1.12, Аноним (-), 20:40, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    CentOS 7 поддерживается? У меня Glib 2.32 и GTK 3.4
     
  • 1.13, Аноним (-), 20:55, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –9 +/
    Ну чтож, сидим на 45 LTS до упора, а там посмотрим.

    Сразу так на это GTK3 г-но нет желания переходить.

    // b.

     
     
  • 2.48, Аноним (-), 01:49, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • –4 +/
    Удваиваю этого анонима.

    Гномосеки, хоть обминусуйтесь!

     
  • 2.59, iPony (?), 11:17, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > сидим на NN LTS до упора

    В каждой новости такое кричат, только вот цифры меняются.

     

  • 1.14, th3m3 (ok), 21:06, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Дак, что там с многопроцессностью? Обещали вроде в 46 релизе!
     
     
  • 2.25, Anonplus (?), 22:04, 26/04/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Отложили. Оно все еще не готово. Понемногу впиливают различные элементы из которых потом сложится многопоточность.

    GTK3 тоже несколько раз не пускали дальше беты. Так что, я вам советую не ожидать, что сногопоточность вот прям точно стопудово будет в какой-то конкретной версии.

     
     
  • 3.28, th3m3 (ok), 22:29, 26/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    У меня в 45 версии активировано. Вроде всё работает нормально. Тормоза не пропали, но стало заметно лучше. Надеюсь, когда официально выкатят - тормоза пропадут совсем.
     

  • 1.15, Атикопираст (?), 21:09, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    Надеюсь в SeaMonkey всю эту ересь добавлять не станут!
     
  • 1.16, Аноним (-), 21:18, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Ну что ж, отпишусь, пожалуй... Потыкал я это дело: это было сурово для психики :(
    Во-первых, интерфейс... мда. Во-вторых, они добавили этот треугольничек справа внизу, чтобы растягивать окно браузера, но он... та-дам! не работает :) Выглядит все как-то покоцано и неполноценно. Печаль, в общем. Остаюсь на ESR-ветках до отказа, пока те вообще не перестанут работать с интернетом. Не дай б-г...
     
  • 1.17, Аноним (-), 21:20, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    мобильный фф уже перестал падать при открыте жирного сайта или картинки, а так загружать страницу с какой то достаточно долгой задержкой(в другом браузере можно страниц 5 за это время)?
     
  • 1.19, iZEN (ok), 21:28, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    У нас уже давно:
    % pkg info -x firefox
    firefox-46.0_1,1
    firefox-i18n-46.0_1
    % pkg info -x thunderbird
    thunderbird-45.0
    thunderbird-i18n-45.0
    % uname -rsm
    FreeBSD 10.3-STABLE amd64

    А Gtk2 или Gtk3 - указывается в опции при сборке.

     
     
  • 2.34, Аноним (-), 00:18, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > А Gtk2 или Gtk3 - указывается в опции при сборке.

    И поэтому тянет в зависимостях сразу и gtk2 и gtk3 )
    [code]
    % pkg rquery %Ok-%Ov firefox|grep -i gtk
    GTK2-off
    GTK3-on
    % pkg rquery %dn firefox|grep gtk
    gtk2
    gtk3
    % pkg -vv|grep url
        url             : "pkg+http://pkg.FreeBSD.org/FreeBSD:10:amd64/latest"
    % pkg rquery %v firefox                                  
    46.0_1,1                    
    [/code]

    для небздшников:
    первое: опции сборки
    второе: зависимости

     
     
  • 3.36, iZEN (ok), 00:38, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • –4 +/
    Где pkg info firefox-46 0_1,1 firefox-46 0_1,1 Name firefox Versi... текст свёрнут, показать
     
     
  • 4.45, Аноним (-), 01:05, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >>> А Gtk2 или Gtk3 - указывается в опции при сборке.
    >> И поэтому тянет в зависимостях сразу и gtk2 и gtk3 )
    > Где?
    > % pkg info firefox-46.0_1,1
    > Shared Libs required:
    >  libgdk-x11-2.0.so.0
    >  libgtk-x11-2.0.so.0

    Здесь.
    [code]
    % pkg which -oq /usr/local/lib/libgtk-x11-2.0.so
    x11-toolkits/gtk20
    [/code]

     
     
  • 5.68, iZEN (ok), 18:07, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >[оверквотинг удален]
    >> Где?
    >> % pkg info firefox-46.0_1,1
    >> Shared Libs required:
    >>  libgdk-x11-2.0.so.0
    >>  libgtk-x11-2.0.so.0
    > Здесь.
    > [code]
    > % pkg which -oq /usr/local/lib/libgtk-x11-2.0.so
    > x11-toolkits/gtk20
    > [/code]

    Логично. У меня он собран без зависимости от Gtk3.


     
     
  • 6.72, Аноним (-), 19:56, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Логично. У меня он собран без зависимости от Gtk3.

    http://www.freshports.org/www/firefox/

    Library dependencies
    libgtk-x11-2.0.so : x11-toolkits/gtk20
    ====> Options available for the single TOOLKIT: you have to select exactly one of them
         GTK2=off: GTK+ 2 GUI toolkit support
         GTK3=on: GTK+ 3 GUI toolkit support

     
     
  • 7.83, iZEN (ok), 18:55, 28/04/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >> Логично. У меня он собран без зависимости от Gtk3.
    > http://www.freshports.org/www/firefox/
    > Library dependencies
    > libgtk-x11-2.0.so : x11-toolkits/gtk20
    > ====> Options available for the single TOOLKIT: you have to select exactly
    > one of them
    >      GTK2=off: GTK+ 2 GUI toolkit support
    >      GTK3=on: GTK+ 3 GUI toolkit support

    Я сам его собрал из порта, осознанно переключив опции сборки с Gtk3 на Gtk2. Разве так трудно это понять?


     
  • 3.40, брат анонимус (?), 00:53, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >> А Gtk2 или Gtk3 - указывается в опции при сборке.
    > И поэтому тянет в зависимостях сразу и gtk2 и gtk3 )
    > % pkg rquery %dn firefox|grep gtk
    > gtk2
    > gtk3

    Gtk2 (и libmozgtk) вырубят вместе с NPAPI откатя
    https://bugzilla.mozilla.org/show_bug.cgi?id=624422

    Gtk3 плагинов не будет.
    https://bugzilla.mozilla.org/show_bug.cgi?id=1092126

     
  • 2.85, rvs2016 (ok), 22:19, 28/04/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > У нас уже давно:
    > % pkg info -x firefox
    > firefox-46.0_1,1

    А чё, надо гоняться за последней версией? А то у меня не сильно последняя версия:
    % pkg info -E firefox
    firefox-41.0.1,1

    А с учётом скорости увеличения номеров версий файрфокса у меня версия евоная очень сильно не последняя уже. :о)

     

  • 1.20, брат анонимус (?), 21:28, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >>SeaMonkey 2.41

    опять вброс и провакация..
    без пруфов хотя бы на релиз кандидаты не считается

     
     
  • 2.22, брат анонимус (?), 21:36, 26/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    ибо вот тут
    https://wiki.mozilla.org/SeaMonkey:Home_Page
    сказано что
    SeaMonkey 2.41, skipped in favor of 2.42.

    вопрос откуда такая инфа? (или лор зажелтел?)

     
     
  • 3.33, Ан (??), 00:13, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > SeaMonkey 2.41, skipped in favor of 2.42.

    SeaMonkey 2.42 уязвим так же как и Firefox 45.0. Разрабы предпочитают сами кушать кактус и кормить пользователей обещаниями вместо того, чтобы выпустить релиз на базе 38.8esr или 45.1esr как это делает Thunderbird команда.

     

  • 1.23, trubulizator (ok), 21:52, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    И как это дело ставить на относительно старые компы? Ещё чу-чуть и будет таким же монстром, как и Хромище. На прогресс не похоже, похоже на "запланированное устаревание".
     
     
  • 2.32, Аноным (ok), 23:39, 26/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Что за "относительно старые"?
     

  • 1.24, Нанобот (ok), 22:03, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > Переход на GTK3+ в сборках для платформы GNU/Linux
    >$ ldd libmozgtk.so |grep libgtk
    > libgtk-3.so.0 => /usr/lib/i386-linux-gnu/libgtk-3.so.0 (0xb722c000)

    Да мы бы и на слово поверили, не обязательно такие пруфы в новость пихать

     
     
  • 2.26, paulus (ok), 22:14, 26/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    :) ldd: ./libmozgtk.so: Нет такого файла или каталога ;)
     

  • 1.29, Аноним (-), 22:45, 26/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    А как там с дополнениями? Окончательно выпилили неподписанные?
     
  • 1.35, Аноним (-), 00:19, 27/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Всё, Pocket теперь можно физически удалить с диска?
     
     
  • 2.52, Anonplus (?), 03:23, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    После каждого обновления программы удалять? Но зачем? Он отключается одной настройкой в about:config и более визуально нигде не маячит.
     

  • 1.37, Ape (ok), 00:43, 27/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    После обновления видео HTML5 с ютуба не играет. Ютуб ругается на устаревший плагин. Проверил, все плагины в норме. Чё за фигня?
     
     
  • 2.39, Аноним (-), 00:47, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Думаю, это ваш модный дистрибутив ОС.
     
     
  • 3.41, Ape (ok), 00:54, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    А, дистрибутив тут при чём? На 45 версии дистрибутив был тот же. Или ты думал я ОСь меняю после каждого выпуска лисы?
     
     
  • 4.78, абвгдейка (ok), 10:45, 28/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    при том. Kubuntu - все работает:)
     
  • 2.62, DmA (??), 15:07, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    может речь о флешплеере идёт? Отключить его давно нужно этот флешплеер...Он давно уже устаревший морально.
     

  • 1.47, Ilya Indigo (ok), 01:34, 27/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    На этот раз выкинули Gstreamer окончательно?
    Я бы посмотрел сам, но вы знаете какой у меня мега-ролинговый дистр и раньше чем через неделю, даже не жду. :-(

    А вот если серьёзно, то мозиловцы вообще собираются реализовывать стандартные html5-элеметы форм, такие как:

    [code]input type=date
    input type=month
    input type=week
    input type=time
    input type=datetime-local[/code]

    А также очень интересный и полезный тег details.

    Я так обрадовался, что наконец-то в html5 можно не городить на JS календарики для выбора дат и спойлеры, которые теперь нативные, и так обломался, узнав, что Firefox, их до сих пор не поддерживает. :-(

    В Chromium и многочисленных его клонах, даже ещё в Opera 12, это всё давно уже есть.
    Так и хочется спросить, - доколе!

     
     
  • 2.51, Ilya Indigo (ok), 03:04, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    https://bugzilla.mozilla.org/show_bug.cgi?id=1267875
    https://bugzilla.mozilla.org/show_bug.cgi?id=1267878
     
     
  • 3.69, Аноним (-), 18:13, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >dlyas
    >meyasyastsa

    ха-ха-ха

     

  • 1.50, 0eviy (ok), 02:48, 27/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    без xwayland не работает
     
  • 1.53, Илья (??), 06:40, 27/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    О, этот скриншот с оранжевой окантовкой
     
  • 1.61, DmA (??), 15:05, 27/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >>Проведена работа по усилению безопасности...

    Что прям так взяли и отключили параметры:
    toolkit.telemetry.enabled
    datareporting.healthreport.service.enabled
    experiments.enabled
    experiments.supported
    dom.storage.enable
    geo.enabled
    devtools.remote.wifi.scan
    или может хотя бы супекуки запретили?

     
  • 1.66, Аноним (-), 16:33, 27/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А что с Электролизом, он работает?
     
     
  • 2.67, Аноним (-), 17:06, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Да. И с автогеном и с гландами и с прямой кишкой. Универсальный софт.
     
  • 2.70, th3m3 (ok), 18:44, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Я вручную активировал ещё в 45 версии. Работает. Но ожидаю улучшений в будущих версиях.
     

  • 1.73, Аноним (-), 20:15, 27/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Какое жуткое вырвиглазие
     
  • 1.74, th3m3 (ok), 21:57, 27/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Они сломали мне Firefox!

    Использую тему FT DeepDark, если это важно. Теперь у меня на некоторых сайтах такая красота:

    https://i.imgur.com/kARb8Lr.png
    https://i.imgur.com/axTtLBI.png
    https://i.imgur.com/lpRU4V3.png
    https://i.imgur.com/WuOEy8k.png
    https://i.imgur.com/UBUgOp9.png

    А где-то и фон сливается с текстом и ничего не видно. Как это фиксить теперь? Дело в теме или они что-то накрутили?

     
     
  • 2.75, th3m3 (ok), 22:09, 27/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Включил стандартную тему. Тоже самое. Жесть!
     
  • 2.86, rvs2016 (ok), 22:23, 28/04/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Они сломали мне Firefox!
    > Использую тему FT DeepDark, если это важно. Теперь у меня на некоторых
    > сайтах такая красота:
    > https://i.imgur.com/kARb8Lr.png
    > https://i.imgur.com/axTtLBI.png
    > https://i.imgur.com/lpRU4V3.png
    > https://i.imgur.com/WuOEy8k.png
    > https://i.imgur.com/UBUgOp9.png
    > А где-то и фон сливается с текстом и ничего не видно. Как
    > это фиксить теперь? Дело в теме или они что-то накрутили?

    ооооо! Вижу... - не надо гнаться за последней версией файрфокса! :-)

     

  • 1.79, Аноним (79), 11:20, 28/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    FF46-beta требует gtk3. GTK2 в релизе точно поддерживается?
     
     
  • 2.87, Онаним (?), 23:59, 28/04/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Обратная сторона медали репозиториев - ненужные зависимости, не в первой. А может Вы просто поставить GTK2-версию, наверняка тулкит выбирается на этапе компиляции.
     

  • 1.80, Ilya Indigo (ok), 11:22, 28/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Что произошло с контекстным меню по ПКМ?
    http://itmages.ru/image/view/4203918/dcd57129
    При этом оно ещё прокручивается дальше и не работает ни один пункт из него.
     
     
  • 2.88, th3m3 (ok), 01:25, 29/04/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Надеюсь скоро выйдет Firefox 46.0.1, где всё это пофиксят. У меня тоже много причуд в интерфейсе стало.
     

  • 1.89, Аноним (-), 18:00, 29/04/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    У разработчиков УМВР-мозга.
    А почему-то FF используюет какую-то особо стандартную тему GT3, и у меня контекстное меню без теней и границ, на белых страница выглядит особенно мерзко.
     
  • 1.90, Аноним (-), 09:13, 11/05/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Подсказка в формы ввода убежала куда-то в сторону. Причем не только у меня, но у разрабов - "УМВР".

    Откатился нафиг на ESR. Обожду с полгодика пока GTK3 причешут.

     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру