The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Canonical раскрывает планы, касающиеся нового менеджера пакетов

29.08.2009 10:11

Незадолго до объявления о прекращении добавления новшеств в будущий релиз Ubuntu 9.10 компания Canonical выпустила первую версию своего универсального менеджера пакетов. В процессе разработки проект именовался AppCenter и сейчас его официальное название Ubuntu Software Store. О серьезности намерений Canonical по продвижению этого проекта говорит, хотя бы, тот факт, что планы по его улучшению и интеграции с другими пакетными менеджерами расписаны вплоть до релиза Ubuntu 11.04.

Целью Ubuntu Software Store является объединение различных задач, которые регулярно выполняются при работе с инсталляционными пакетами, в рамках одного приложения с универсальным интерфейсом. Оно должно заменить такие разрозненные утилиты, как update-manager, Synaptic, gdebi, что существенно облегчит новым пользователям процесс установки приложений.

Canonical надеется, что уже к выходу Ubuntu 9.10, Ubuntu Software Store будет обладать приятным графическим интерфейсом, быстрым поиском, предоставлять детальную информацию о пакетах и иметь интерактивную презентацию, рассказывающую как пользоваться утилитой. Судя по информации с Software Store Wiki начиная с релиза Ubuntu 10.04 LTS управление пакетами окончательно перейдет на новую платформу. А в релизе Ubuntu 10.10 добавится интеграция Ubuntu Software Store с сервисом совместной работы над приложениями Launchpad.

Первое появление Ubuntu Software Store ожидается в Ubuntu 9.10 Alpha 5.

  1. Главная ссылка к новости (http://www.phoronix.com/scan.p...)
Автор новости: blkdog
Ключевые слова: Ubuntu, AppCenter
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (28) Ajax | 1 уровень | Линейный | Раскрыть всё | RSS
  • 1.1, Ъ (?), 10:32, 29/08/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Смахивает на Mint Install.
     
  • 1.3, Аноним (-), 11:02, 29/08/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Пока есть винда, капец ей не светит.
    А вот новая разработка фонт-энд'а весьма заинтересовала. Интересно на каком графическом тулките будет написана и насколько жёстко будет привязана к apt.
     
     
  • 2.4, Ъ (?), 11:36, 29/08/2009 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >Пока есть винда, капец ей не светит.
    >А вот новая разработка фонт-энд'а весьма заинтересовала. Интересно на каком графическом тулките
    >будет написана и насколько жёстко будет привязана к apt.

    1. gtk.
    2. жестко.

     

  • 1.5, Аноним (-), 11:37, 29/08/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Наконец то! Ато сунаптег достал, более неудобную утилиту еще поискать надо. Интересно настанет ли когданить щастье с репозитариями, чтоб не было этого идиотизма, в 9.04 идёт фокс 3.0.12, хочешь поставить 3.5.2, а в сунаптеге он зашифрован под 3.1 какой-то думми упграде (и еще найти надо), так мало того после установки он называетцо не файрфокс а какой-то ширетоко. Бред. Я хочу зайти в категорию www и выбрать там firefox-3.5.2 чтоб без подвывертов. Неужели это так сложно?


     
     
  • 2.6, Аноним (-), 12:23, 29/08/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Кому как... Лично для меня нет более удобной утилиты чем Synaptic. Именно из за него я полюбил debian-based дистрибутивы...
     
     
  • 3.7, ононим (?), 13:54, 29/08/2009 [^] [^^] [^^^] [ответить]  
  • +/
    поддерживаю. синаптик настолько хорош, что даже не хочется лезть в консоль.
     
     
  • 4.14, User294 (ok), 23:16, 29/08/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Мне synaptic тоже понравился. С одной стороны - интерфейс пользователя немного странный. С другой, он позволяет делать почти все что надо не спускаясь в трюм^W консоль и обладает развитыми возможносятми поиска. В целом - положительная тулза. Я его юзаю даже под кедами. Просто потому что он мне понравился.
     
  • 4.27, Frank (??), 15:13, 31/08/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Консольный apt-get(cache) настолько хорош, что даже не хочется лезть в синаптек :)
    П.С. текущий апдейт менеджер (тот, что графический, кажется, на пистоне) жрёт более 100 метров памяти при работе, из-за чего на машине с 0,5 ГБ рамы начинается своппинг при запущенном ФФ или ООо.
     
  • 3.30, xapienz (?), 19:19, 29/10/2009 [^] [^^] [^^^] [ответить]  
  • +/
    ещё в ALTLinux используется synaptic, хоть оно и не deb-based
     
  • 2.9, Анонимуссс (?), 14:57, 29/08/2009 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Ты зря выбрал линукс. Это не та система, где твоё "ХОЧУ" без твоего "МОГУ" - что-то значит. Уйди в винду обратно и не позорь себя.
    PS Пиши лучше на английском, русский ты видимо осилил так же как и линукс :Р
     
  • 2.21, Iv945n (ok), 04:55, 30/08/2009 [^] [^^] [^^^] [ответить]  
  • +/
    > нтересно настанет ли когданить щастье с репозитариями, чтоб не было этого идиотизма, в 9.04 идёт фокс 3.0.12, хочешь поставить 3.5.2...

    Да, меня тоже напрягает. Хочется чтобы автоматически всегда ставилась последняя стабильная версия софта, хотябы для основного наиболее популярного.

     
     
  • 3.26, анонано (?), 11:04, 31/08/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Мне казалось, что стабильность версии определяется мейнтенерами и помещаются в репозиторий. Алсо вас обоих ждет дебиан экспериментал.
     

  • 1.8, Аноним (-), 14:09, 29/08/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Все всё-равно не угодить. Я за внедрение Ubuntu Software Store, при условии если он действительно возьмёт всё лучшее из вышеперечисленных программ. Единый центр по мне удобнее чем разрозненные инструменты.
     
  • 1.10, _Vitaly_ (ok), 15:17, 29/08/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Какая утилита лучше - это лирика. Главное что есть четкий план слепить канал распространения коммерческого софта. Тогда станут и игрушки под линукс делать и все остальное.

    Мне пока очень нравится, как каноникал гнет свою линию. От жизни не отрывается :)

     
  • 1.11, dq0s4y71 (?), 17:58, 29/08/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Если в Update Manager, или том же Synaptic, чего-то не хватает, то почему бы просто не допилить его? Зачем нужен новый велосипед? Я, честно говоря, вообще не понимаю какие еще могут быть претензии к пакетному менеджеру: установить пакет, удалить пакет, найти пакет. Зависимости разрулить. Все. По большому счету от него больше ничего не требуется. Мне лично apt* хватает с лихвой.
     
     
  • 2.12, Ilya Evseev (?), 20:17, 29/08/2009 [^] [^^] [^^^] [ответить]  
  • +/
    > Зачем нужен новый велосипед?

    Обновлением системы, установкой приложений
    и установкой отдельных пакетов
    сейчас занимаются три графических утилиты:
    Update manager, Add/Remove program и Synaptic.

    Вместо них будет одна утилита.

    > Мне лично apt* хватает с лихвой.

    Тогда эта новость вообще не для Вас :)

     
     
  • 3.13, Аноним (-), 21:07, 29/08/2009 [^] [^^] [^^^] [ответить]  
  • –4 +/

    - обновлением занимается update-manager
    - установкой\удалением synaptic

    Всё. Всего две программы, все остальное - просто дуюлирает функционал одной из них.
    Только вместо того чтобы добавить функционал update-manager к synaptic зачем-то решили изобрести новый велосипед.

    Мне гораздо больше интересно будет-ли оно использовать PackageKit.
    Потому что если нет, то это пустая трата времени и бессмысленный лисапед.
    А если да, то у проекта отличное будущее ибо программа нужная.

     
     
  • 4.22, намехуяме (?), 05:09, 30/08/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >Мне гораздо больше интересно будет-ли оно использовать PackageKit.
    >Потому что если нет, то это пустая трата времени и бессмысленный лисапед.
    >А если да, то у проекта отличное будущее ибо программа нужная.

    вы как хотите, а я так не думаю

     
  • 2.28, Зилибоба (??), 13:03, 01/09/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Афтар, ты новость вообще читал? Там абсолютно новый подход и абсолютная интеграция всего и вся! А вообще я не понимаю зачем нужна приора? Есть же копейка, допилилибы ее... Или вот еще - я совсем не понимаю зачем нужен линукс, есть же винда, допилилибы ее...
     

  • 1.15, Thorton (?), 00:15, 30/08/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А для кубунты будет на QT? А то не по человечески получается...
     
     
  • 2.16, Alexey (??), 00:44, 30/08/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >А для кубунты будет на QT? А то не по человечески получается...

    Берите и пишите. Каноникал поддерживает ровно 1 официальный дистрибутив и это - Ubuntu.

     
     
  • 3.17, dq0s4y71 (?), 01:36, 30/08/2009 [^] [^^] [^^^] [ответить]  
  • +/
    > Каноникал поддерживает ровно 1 официальный дистрибутив и это - Ubuntu.

    Вообще-то Kubuntu отличается от Ubuntu, только тем, что там вместо гнома предустановлены кеды. Во всем остальном это такой же "официальный" дистрибутив. http://www.kubuntu.org/faq#fork

     
  • 3.25, Артем (??), 22:41, 30/08/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Шатлворт наоборот говорил, что теперь они кеды будут серьезнее поддерживать и все новые разработки туда внедрять. Даже систему оповещений вроде каким-то макаром внедрять собираются. Так что и этот менеджер, думаю, там появится.
     

  • 1.18, RKA KriK (ok), 02:07, 30/08/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Красивые скриншоты. Мне понравились.
     
     
  • 2.20, Andrey M. (??), 02:53, 30/08/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Прочитал у Алексея Федорчука потрясающую мысль:"С годами начинаешь очень хорошо понимать как мало тебе нужно по настоящему из того что тебе доступно,  и как дорого то, что тебе нужно по настоящему". Есть такая чудная утилита  dd - родилась еще до Unixa  и будет жить и после него - это как нож в походе. Он и бензопиле уступит и против топора слаб - только вот иногда удивляешска как столь малый предмет позволяет решить столь много задач совсем не занимая места в рюкзаке.
    На мой скромный взгляд механизм apt -  из той же серии. "Прост" как бревно и функционален до бесконечности. А любые попытки "лучшить" его есть "от Лукавого". В смысле есть попытки заменить нож бензопилой - по той причине что бревна больно медленно пилит ...  


     

  • 1.23, Аноним (23), 14:09, 30/08/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Всё равно Yast рулит, чтобы там Canonical не сотворила ради монополизации линуксоидов
     
  • 1.24, Аноним (-), 18:24, 30/08/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    YaST, zypper, SUSE Software search, Build Service
    здесь, возможно, делают что-то подобное
     
  • 1.29, 4574357 (?), 00:46, 04/09/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Alpha 5 на ливсиди не работает. Загружается и во время появления красивого эффекта зацикливается. Смотришь на этот эффект, смотришь, смотришь, смотришь, а через полчаса надоедает ))
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру