The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Сбивается компиляция VPN-клиента"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Программирование под UNIX (Компиляция)
Изначальное сообщение [ Отслеживать ]

"Сбивается компиляция VPN-клиента"  +/
Сообщение от Palemoon (ok) on 11-Фев-16, 20:53 
Пытаюсь скомпилировать клиент проекта SoftEther, но компиляция с помощью make совершает ошибки и заканчивается неудачей.
Использование configure вообще сразу останавливается с сообщением что нет такой программы.
Для справки: тем компиляция серверной части этого же проекта происходит сразу командой make без configure.
Офсайт на заданный вопрос молчит как рыба об лёд.
Просьба подсказать, возможно ли решение возникшей проблемы и как.

Debian 8.3/64.

make[1]: Entering directory '/root/Soft/vpnclient'
Preparing SoftEther VPN Client...
ranlib lib/libcharset.a
ranlib lib/libcrypto.a
ranlib lib/libedit.a
ranlib lib/libiconv.a
ranlib lib/libintelaes.a
ranlib lib/libncurses.a
ranlib lib/libssl.a
ranlib lib/libz.a
ranlib code/vpnclient.a
gcc code/vpnclient.a -O2 -fsigned-char -pthread -m64 -lm -ldl -lrt -lpthread -L./ lib/libssl.a lib/libcrypto.a lib/libiconv.a lib/libcharset.a lib/libedit.a lib/libncurses.a lib/libz.a lib/libintelaes.a -o vpnclient
/usr/bin/ld: cannot find crt1.o: No such file or directory
/usr/bin/ld: cannot find crti.o: No such file or directory
/usr/bin/ld: cannot find -lm
/usr/bin/ld: cannot find -ldl
/usr/bin/ld: cannot find -lrt
/usr/bin/ld: cannot find -lpthread
/usr/bin/ld: cannot find -lpthread
/usr/bin/ld: cannot find -lc
/usr/bin/ld: cannot find crtn.o: No such file or directory
collect2: error: ld returned 1 exit status
Makefile:18: recipe for target 'i_read_and_agree_the_license_agreement' failed
make[1]: *** [i_read_and_agree_the_license_agreement] Error 1
make[1]: Leaving directory '/root/Soft/vpnclient'
/vpnclient#

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Сбивается компиляция VPN-клиента"  +/
Сообщение от Doka (??) on 11-Фев-16, 21:27 
> Использование configure вообще сразу останавливается с сообщением что нет такой программы.

./

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Сбивается компиляция VPN-клиента"  +/
Сообщение от Palemoon (ok) on 11-Фев-16, 21:33 
> ./

А, ну так это подразумевается, просто для упрощения не стал указывать :)

Вообще создается впечатление, что и  VPN-клиент, и VPN-сервер рассчитаны на компиляцию без ./configure.
Во всяком случае так указано к документации к VPN-серверу, и оно в самом деле так и работает.

К VPN-клиенту документации нет вообще, даже Readme, в этом-то и проблема.

Кстати, вот мое сообщение на офсайте, оставшееся без ответа: http://www.vpnusers.com/viewtopic.php?f=7&t=5553

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Сбивается компиляция VPN-клиента"  +1 +/
Сообщение от asavah (ok) on 12-Фев-16, 00:40 
библиотек ему не хватает

apt-get install build-essential libc6-dev

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Сбивается компиляция VPN-клиента"  +/
Сообщение от Palemoon (ok) on 12-Фев-16, 01:07 
> библиотек ему не хватает
> apt-get install build-essential libc6-dev

Ура - ты оказался полностью прав!  Спасибо большое! :)
Но как ты догадался, какие именно нужны библиотеки? :-O
Я тоже краем уха понимал, что не хватает каких-то либ, но вот каких именно - не доходило, их тьма-тьмущая :(

make[1]: <skip>
Entering directory '/root/Soft/vpnclient'
Preparing SoftEther VPN Client...
ranlib lib/libcharset.a
ranlib lib/libcrypto.a
ranlib lib/libedit.a
ranlib lib/libiconv.a
ranlib lib/libintelaes.a
ranlib lib/libncurses.a
ranlib lib/libssl.a
ranlib lib/libz.a
ranlib code/vpnclient.a
gcc code/vpnclient.a -O2 -fsigned-char -pthread -m64 -lm -ldl -lrt -lpthread -L./ lib/libssl.a lib/libcrypto.a lib/libiconv.a lib/libcharset.a lib/libedit.a lib/libncurses.a lib/libz.a lib/libintelaes.a -o vpnclient
ranlib code/vpncmd.a
gcc code/vpncmd.a -O2 -fsigned-char -pthread -m64 -lm -ldl -lrt -lpthread -L./ lib/libssl.a lib/libcrypto.a lib/libiconv.a lib/libcharset.a lib/libedit.a lib/libncurses.a lib/libz.a lib/libintelaes.a -o vpncmd

--------------------------------------------------------------------
The preparation of SoftEther VPN Client is completed !


*** How to switch the display language of the SoftEther VPN Client Service ***
SoftEther VPN Client supports the following languages:
  - Japanese
  - English
  - Simplified Chinese

You can choose your prefered language of SoftEther VPN Client at any time.
To switch the current language, open and edit the 'lang.config' file.


*** How to start the SoftEther VPN Client Service ***

Please execute './vpnclient start' to run the SoftEther VPN Client Background Service.
And please execute './vpncmd' to run the SoftEther VPN Command-Line Utility to configure SoftEther VPN Client.
Of course, you can use the VPN Server Manager GUI Application for Windows on the other Windows PC in order to configure the SoftEther VPN Client remotely.
--------------------------------------------------------------------

make[1]: Leaving directory '/root/Soft/vpnclient'



Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Сбивается компиляция VPN-клиента"  +1 +/
Сообщение от asavah (ok) on 12-Фев-16, 02:23 
>> библиотек ему не хватает
>> apt-get install build-essential libc6-dev
> Ура - ты оказался полностью прав!  Спасибо большое! :)
> Но как ты догадался, какие именно нужны библиотеки? :-O
> Я тоже краем уха понимал, что не хватает каких-то либ, но вот
> каких именно - не доходило, их тьма-тьмущая :(

я не догадался, я знал, не одну сотню велосипедов скомпилил
оно ж белым по чёрному грит:

/usr/bin/ld: cannot find -lm
/usr/bin/ld: cannot find -ldl
/usr/bin/ld: cannot find -lrt
/usr/bin/ld: cannot find -lpthread
/usr/bin/ld: cannot find -lpthread
/usr/bin/ld: cannot find -lc

а все эти люди часть (e)glibc (в случае дебиана),
который и есть libc6 + libc6-dev

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Сбивается компиляция VPN-клиента"  –1 +/
Сообщение от Palemoon (ok) on 12-Фев-16, 02:39 
> я не догадался, я знал, не одну сотню велосипедов скомпилил
> оно ж белым по чёрному грит:
> /usr/bin/ld: cannot find -lm
> /usr/bin/ld: cannot find -ldl
> /usr/bin/ld: cannot find -lrt
> /usr/bin/ld: cannot find -lpthread
> /usr/bin/ld: cannot find -lpthread
> /usr/bin/ld: cannot find -lc

это черно-белое мне понятно, мне непонятно следующее - как ты догадался, что эти либы содержатся именно в (e)glibc и libc6 + libc6-dev ?

Поди знай, могло ведь и в других пакетах содержаться. Получается, узнать можно только на основании твоего опыта?
А разве какой-то командой заранее определить, в каких пакетах содержатся либы нельзя?

В CentOS это вычисляется моментально -

yum provides /*искомое_имя
Но Debian знаю плохо, может и в нем подобное есть?

----
И еще вопросик. Команда make после установки недостающих либ отработала замечательно.
Но хотелось все же использовать checkinstall.
Однако она бастует -

Installing with make install...

========================= Installation results ===========================
make: *** No rule to make target 'install'.  Stop.

****  Installation failed. Aborting package creation.

Cleaning up...OK

Bye.

- это преодолимо?


Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Сбивается компиляция VPN-клиента"  +/
Сообщение от fail on 12-Фев-16, 10:32 
> ----
> И еще вопросик. Команда make после установки недостающих либ отработала замечательно.
> Но хотелось все же использовать checkinstall.
> Однако она бастует -
Installing with make install...
> ========================= Installation results ===========================
> make: *** No rule to make target 'install'.  Stop.
> ****  Installation failed. Aborting package creation.
> Cleaning up...OK
> Bye.
- это преодолимо?

checkinstall - рекомендуется использовать при "уровне" несколько выше - и вообще checkinstall как 5 колесо к телеге, плюс есть несколько нюансов в его работе.

Лучше поискать в сети, может кто собирал эту апликуху под дебиан и скопипастить
под себя, если не найдется таковых - крайне рекомендуeтся потратить  денек - другой на освоение штатных средств создания deb - пакетов - в дальнейшем окупится стократно..

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Сбивается компиляция VPN-клиента"  +/
Сообщение от Palemoon (ok) on 12-Фев-16, 16:17 
> checkinstall - рекомендуется использовать при "уровне" несколько выше
> - и вообще checkinstall как 5 колесо к телеге, плюс есть несколько нюансов в его работе.

А что за "уровень" такой имеется в виду, любопытно?
Я частенько пользовался checkinstall, и в основном успешно.
Как раз позавчера применил его для серверной компоненты этого же SoftEther VPN - прошло на ура.
А на клиенте почему-то обломилось.


> Лучше поискать в сети, может кто собирал эту апликуху под дебиан и
> скопипастить под себя,

Не, не находится, видимо, мало кто его использует

> если не найдется таковых - крайне рекомендуeтся потратить  
> денек - другой на освоение штатных средств создания deb - пакетов
> - в дальнейшем окупится стократно..

Да уж больше потратил, но оказалось, что это занятие не для меня ;)
Поэтому и возюкаюсь с checkinstal

PS. А на оффоруме оказались полные тормоза - до сих пор никто на мою проблему даже не проблеял ;)
Хотя я не только на форуме ее обозначил, но и письмо одному из разработчиков написал.
Или в Японии сейчас тоже Новый год?...

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Сбивается компиляция VPN-клиента"  +/
Сообщение от fail on 12-Фев-16, 17:37 
>> checkinstall - рекомендуется использовать при "уровне" несколько выше
>> - и вообще checkinstall как 5 колесо к телеге, плюс есть несколько нюансов в его работе.
> А что за "уровень" такой имеется в виду, любопытно?
> Я частенько пользовался checkinstall, и в основном успешно.
> Как раз позавчера применил его для серверной компоненты этого же SoftEther VPN
> - прошло на ура.
> А на клиенте почему-то обломилось.

Кол-во собраных грабель и убитого времени,
с поправкой на кол-во софта и прочее кол-во серверов например..

...

> Да уж больше потратил, но оказалось, что это занятие не для меня
> ;)
> Поэтому и возюкаюсь с checkinstal
> PS. А на оффоруме оказались полные тормоза - до сих пор никто
> на мою проблему даже не проблеял ;)

Патч отослан был - для создания deb/rpm пакета ?

> Хотя я не только на форуме ее обозначил, но и письмо одному
> из разработчиков написал.

Если используется для себя(, облегчения работы и т.д.) спокойно можно deb/rpm/etc пакет сварганить,
у меня нек-рый софт живет подобным образом со времен Lenny, CentOS5.

> Или в Японии сейчас тоже Новый год?...

хз

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Сбивается компиляция VPN-клиента"  +/
Сообщение от Palemoon (ok) on 12-Фев-16, 19:51 
> Патч отослан был - для создания deb/rpm пакета ?

Где, какой патч?

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Сбивается компиляция VPN-клиента"  +/
Сообщение от fail on 12-Фев-16, 21:56 
>> Патч отослан был - для создания deb/rpm пакета ?
> Где, какой патч?

Думается, касаемо компиляции/сборки/etc:

> PS. А на оффоруме оказались полные тормоза - до сих пор никто
> на мою проблему даже не проблеял ;)

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру