The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"as5300+VoIP+DialUp + PBR"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"as5300+VoIP+DialUp + PBR"  
Сообщение от avorobyev email(ok) on 20-Июл-05, 15:36 
Неправильно работает policy based routing.
Оборудование: as5300
Проблема as5300 работает в нетипичной, в общем, для себя конфигурации VoIP шлюза и Dialup - сервера доступа.
Ситуация: маршрут по умолчанию для диалап-пользователей должен быть fastethernet0
Маршрут по умолчанию для VoIP-трафика: Serial0

Для всего этого настроен policy routing.
интернет-пользователи работают нормально,
для воип-пользователей: соединение устанавливается нормально, но слышно только голос, который идет с удаленной стороны, мой не слышно.
Если прописать для конкретного шлюза, с которым идет общение, прописать статик маршрут, голос тут же начинает идти (можно прямо в середине voip-сессии это делать).

такое ощущение, что local pbr работает для всего, кроме непосредственно пакетов голосовых данных, исходящих с as5300

as5300#s ver
Cisco Internetwork Operating System Software
IOS (tm) 5300 Software (C5300-IK8S-M), Version 12.3(5b), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Thu 15-Jan-04 22:35 by kellythw
Image text-base: 0x60008AEC, data-base: 0x6174C000

ROM: System Bootstrap, Version 11.2(9)XA, RELEASE SOFTWARE (fc2)
BOOTLDR: 5300 Software (C5300-BOOT-M), Version 12.2(13)T11,  RELEASE SOFTWARE (fc3)

as5300 uptime is 5 hours, 52 minutes
System returned to ROM by reload at 16:03:53 VLAST Wed Jul 20 2005
System restarted at 16:04:49 VLAST Wed Jul 20 2005
System image file is "flash:c5300-ik8s-mz.123-5b.bin"

конфиг (изрядно покусанный):
!
version 12.3
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname as5300
!
boot-start-marker
boot-end-marker
!
logging count
logging buffered 100000 warnings
logging console warnings
enable secret 5 ???
!
resource-pool disable
!
aaa new-model
!
ip subnet-zero
ip cef
!
isdn switch-type primary-net5
isdn alert-end-to-end
!
fax interface-type fax-mail
!
gw-accounting aaa
!
!
interface Loopback1
ip address 172.16.21.1 255.255.255.0
ip nat inside
ip route-cache same-interface
!
interface Loopback2
ip address xxx.xxx.xxx.66 255.255.255.252
h323-gateway voip interface
h323-gateway voip id locator ipaddr zzz.zzz.zzz.zzz 1719
h323-gateway voip bind srcaddr xxx.xxx.xxx.66
!
interface Ethernet0
no ip address
no cdp enable
!
interface Serial0
bandwidth 512
ip address 10.14.128.14 255.255.255.252
ip route-cache flow
ip ospf cost 10000
fair-queue 64 256 0
no cdp enable
!
interface FastEthernet0
ip address yyy.yyy.yyy.1 255.255.255.252
ip nat outside
ip route-cache flow
duplex full
speed 10
no cdp enable
!
interface Group-Async1
ip unnumbered Loopback1
ip nat inside
encapsulation ppp
no ip mroute-cache
no logging event link-status
async mode dedicated
peer default ip address pool main_pool
ppp callback initiate
ppp authentication pap
group-range 1 60
!
router ospf 100
log-adjacency-changes
network 10.14.128.12 0.0.0.3 area 0
network xxx.xxx.xxx.64 0.0.0.3 area 0
!
ip local policy route-map isp
ip local pool main_pool 172.16.21.40 172.16.21.130
ip nat inside source list 2 interface FastEthernet0 overload
ip flow-export source FastEthernet0
ip flow-export destination 217.149.16.54 9996
ip classless
ip route 0.0.0.0 0.0.0.0 yyy.yyy.yyy.2
no ip http server
no ip http secure-server
!
!
ip radius source-interface FastEthernet0
access-list 2 permit 172.16.21.0 0.0.0.255
access-list 2 remark Dialup NAT access-list
access-list 3 permit xxx.xxx.xxx.66
access-list 3 remark c2610 VoIP endpoint
access-list 10 permit yyy.yyy.yyy.0 0.0.0.3
no cdp run
!
route-map isp permit 10
match ip address 10
set interface FastEthernet0
!
route-map isp permit 30
match ip address 3
set interface Serial0
!
dial-peer cor custom
!
gateway
!
end

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "as5300+VoIP+DialUp + PBR"  
Сообщение от armemi (ok) on 20-Июл-05, 21:12 
Symptoms   One-way audio may occur and a caller who is using an IP telephone may not be able to hear the caller at the Public Switched Telephone Network (PSTN) side. No Real-Time Protocol (RTP) packets seem to be sent to the caller using the IP telephone.

The debug cch323 rtp command and the show call active voice brief EXEC command indicate that RTP packets are sent and received. However, the call statistics on the IP phone indicate that no RTP packets are received.

Conditions   These symptoms are observed in Cisco IOS Release 12.2(6B) when you enable the h323-gateway voip bind srcaddr interface configuration command on an interface.

Workaround   To restore two-way audio, disable the h323-gateway voip bind srcaddr interface configuration command.

Dumayu nado otklyuchit` h323-gateway voip bind srcaddr na Loopback2

Regards
Armen


>Неправильно работает policy based routing.
>Оборудование: as5300
>Проблема as5300 работает в нетипичной, в общем, для себя конфигурации VoIP шлюза
>и Dialup - сервера доступа.
>Ситуация: маршрут по умолчанию для диалап-пользователей должен быть fastethernet0
>Маршрут по умолчанию для VoIP-трафика: Serial0
>
>Для всего этого настроен policy routing.
>интернет-пользователи работают нормально,
>для воип-пользователей: соединение устанавливается нормально, но слышно только голос, который идет с
>удаленной стороны, мой не слышно.
>Если прописать для конкретного шлюза, с которым идет общение, прописать статик маршрут,
>голос тут же начинает идти (можно прямо в середине voip-сессии это
>делать).
>
>такое ощущение, что local pbr работает для всего, кроме непосредственно пакетов голосовых
>данных, исходящих с as5300
>
>as5300#s ver
>Cisco Internetwork Operating System Software
>IOS (tm) 5300 Software (C5300-IK8S-M), Version 12.3(5b), RELEASE SOFTWARE (fc1)
>Copyright (c) 1986-2004 by cisco Systems, Inc.
>Compiled Thu 15-Jan-04 22:35 by kellythw
>Image text-base: 0x60008AEC, data-base: 0x6174C000
>
>ROM: System Bootstrap, Version 11.2(9)XA, RELEASE SOFTWARE (fc2)
>BOOTLDR: 5300 Software (C5300-BOOT-M), Version 12.2(13)T11,  RELEASE SOFTWARE (fc3)
>
>as5300 uptime is 5 hours, 52 minutes
>System returned to ROM by reload at 16:03:53 VLAST Wed Jul 20
>2005
>System restarted at 16:04:49 VLAST Wed Jul 20 2005
>System image file is "flash:c5300-ik8s-mz.123-5b.bin"
>
>конфиг (изрядно покусанный):
>!
>version 12.3
>service tcp-keepalives-in
>service tcp-keepalives-out
>service timestamps debug datetime localtime
>service timestamps log datetime localtime
>service password-encryption
>!
>hostname as5300
>!
>boot-start-marker
>boot-end-marker
>!
>logging count
>logging buffered 100000 warnings
>logging console warnings
>enable secret 5 ???
>!
>resource-pool disable
>!
>aaa new-model
>!
>ip subnet-zero
>ip cef
>!
>isdn switch-type primary-net5
>isdn alert-end-to-end
>!
>fax interface-type fax-mail
>!
>gw-accounting aaa
>!
>!
>interface Loopback1
> ip address 172.16.21.1 255.255.255.0
> ip nat inside
> ip route-cache same-interface
>!
>interface Loopback2
> ip address xxx.xxx.xxx.66 255.255.255.252
> h323-gateway voip interface
> h323-gateway voip id locator ipaddr zzz.zzz.zzz.zzz 1719
> h323-gateway voip bind srcaddr xxx.xxx.xxx.66
>!
>interface Ethernet0
> no ip address
> no cdp enable
>!
>interface Serial0
> bandwidth 512
> ip address 10.14.128.14 255.255.255.252
> ip route-cache flow
> ip ospf cost 10000
> fair-queue 64 256 0
> no cdp enable
>!
>interface FastEthernet0
> ip address yyy.yyy.yyy.1 255.255.255.252
> ip nat outside
> ip route-cache flow
> duplex full
> speed 10
> no cdp enable
>!
>interface Group-Async1
> ip unnumbered Loopback1
> ip nat inside
> encapsulation ppp
> no ip mroute-cache
> no logging event link-status
> async mode dedicated
> peer default ip address pool main_pool
> ppp callback initiate
> ppp authentication pap
> group-range 1 60
>!
>router ospf 100
> log-adjacency-changes
> network 10.14.128.12 0.0.0.3 area 0
> network xxx.xxx.xxx.64 0.0.0.3 area 0
>!
>ip local policy route-map isp
>ip local pool main_pool 172.16.21.40 172.16.21.130
>ip nat inside source list 2 interface FastEthernet0 overload
>ip flow-export source FastEthernet0
>ip flow-export destination 217.149.16.54 9996
>ip classless
>ip route 0.0.0.0 0.0.0.0 yyy.yyy.yyy.2
>no ip http server
>no ip http secure-server
>!
>!
>ip radius source-interface FastEthernet0
>access-list 2 permit 172.16.21.0 0.0.0.255
>access-list 2 remark Dialup NAT access-list
>access-list 3 permit xxx.xxx.xxx.66
>access-list 3 remark c2610 VoIP endpoint
>access-list 10 permit yyy.yyy.yyy.0 0.0.0.3
>no cdp run
>!
>route-map isp permit 10
> match ip address 10
> set interface FastEthernet0
>!
>route-map isp permit 30
> match ip address 3
> set interface Serial0
>!
>dial-peer cor custom
>!
>gateway
>!
>end


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "as5300+VoIP+DialUp + PBR"  
Сообщение от avorobyev (ok) on 26-Июл-05, 03:51 
>Workaround   To restore two-way audio, disable the h323-gateway voip bind
>srcaddr interface configuration command.
>Dumayu nado otklyuchit` h323-gateway voip bind srcaddr na Loopback2

Не помогло.
Не помог также переход на x5300-is.123-10.bin

Решилось так: вместо того, чтобы полиси-рутить voip трафик, пришлось сделать default gateway для него, а PBR настроить для диалап-трафика.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "as5300+VoIP+DialUp + PBR"  
Сообщение от Mili on 15-Ноя-07, 18:09 
>>Workaround   To restore two-way audio, disable the h323-gateway voip bind
>>srcaddr interface configuration command.
>>Dumayu nado otklyuchit` h323-gateway voip bind srcaddr na Loopback2
>
>Не помогло.
>Не помог также переход на x5300-is.123-10.bin
>
>Решилось так: вместо того, чтобы полиси-рутить voip трафик, пришлось сделать default gateway
>для него, а PBR настроить для диалап-трафика.

You may try http://www.az-voipsolution.com for complate voip solution info.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру