The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"По поводу настройки VLAN на каталисте 2950..."
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 20-Май-04, 23:32  (MSK)
Прочитал в одной статье, что в каждый из созданных виланов необходимо включать транковый порт, через который подключен сервак. Так ли это? И еще вроде он должен быть тэгированым - это как?

Например, имеем вилан VLAN003, в который входит третий порт на каталисте.
Как только пытаюсь добавить туда первый порт, циска можно сказать, виснет, т.е. помогает только ее перезагрузка, конфигурация есессно не сохраняется.

Оригинал статьи тут - www.lanbilling.ru/vlan_solution.html

Разъясните плз ситуацию...

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 21-Май-04, 00:28  (MSK)
прочитал... не понял...
прочитал ещ
  Рекомендовать в FAQ | Cообщить модератору | Наверх

53. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от ostapus Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 31-Май-04, 10:55  (MSK)
При такой схеме нужно учесть вот что:
1) VTP не нужен
2) STP не нужен
3) VLAN терминируется на FreeBSD, там же роутится.
4) cisco-router вообще ни при чём. С него можно, например, снимать flow для статистики.
===========
Если FB подключен к fast0/1, вторая catalyst подключена своим fast0/1 к fast0/24 первой, то:
2950-1#conf t
2950-1(config)#int fas 0/2
2950-1(config)#switch acce vlan 2
2950-1(config)#int fas 0/3
2950-1(config)#switch acce vlan 3
...
2950-1(config)#int fas 0/23
2950-1(config)#switch acce vlan 23
2950-1(config)#no spann vlan 2
2950-1(config)#no spann vlan 3
...
2950-1(config)#no spann vlan 24
2950-1(config)#int fas 0/1
2950-1(config)#switch mode trunk #потом ещё вернёмся к нему
2950-1(config)#exit
2950-1#exit
2950-2#conf t
2950-2(config)#int fas 0/2
2950-2(config)#switch acce vlan 32
2950-2(config)#int fas 0/3
2950-2(config)#switch acce vlan 33
...
2950-2(config)#int fas 0/24
2950-2(config)#switch acce vlan 54
2950-2(config)#int fas 0/1
2950-2(config)#switch mode trunk
2950-2(config)#switch trunk allow vlan 1,32-54,1002-1005
2950-2(config)#exit
2950-2(config)#int vlan 1
2950-2(config)#ip addre 192.168.1.3 255.255.255.248
2950-2(config)#no ip direct
2950-2(config)#exit
2950-2(config)#no spann vlan 32
2950-2(config)#no spann vlan 33
...
2950-2(config)#no spann vlan 54
2950-2#exit
Сформировали VLAN на второй каталисте, идём обратно на первую каталисту.
2950-1#vlan database
2950-1(vlan)#vlan 32
2950-1(vlan)#vlan 33
...
2950-1(vlan)#vlan 54
2950-1(vlan)#apply
2950-1(vlan)#exit
2950-1#conf t
2950-1(config)#int fas 0/1
2950-1(config)#switch trunk allow vlan 1,2-23,32-54,1002-1005
2950-1(config)#exit
2950-1(config)#int fas 0/24
2950-1(config)#switch mode trunk
2950-1(config)#switch trunk allow vlan 1,32-54,1002-1005
2950-1(config)#exit
2950-1(config)#int vlan 1
2950-1(config)#ip addre 192.168.1.2 255.255.255.248
2950-1(config)#no ip direct
2950-1(config)#exit
2950-1(config)#exit
2950-1#
Проверяем состояние транков:
2950-1#sh interf trunk
Если на описаных транках (0/1 и 0/24) присутствуют нужные вланы - всё ок. Если нужные вланы есть в секции
Vlans allowed and active in management domain
- всё ок
Если нужные вланы есть в секции
Vlans in spanning tree forwarding state and not pruned
- всё ок.
Если нет - нужно либо отключить VTP (режим коммутатора - transparent), либо отключить STP - зависит от секции, в котороый проблемы.
Контрольная проверка портов:
2950-1#sh interf status
Выведет список всех портов с вланами и транками. Всё станет ясно.
Тоже самое надо сделать на второй каталисте.
============
Переходим к FreeBSD
Собираем ядро с поддержкой VLAN:
pseudo-device vlan NUM
NUM = количество VLAN которое нужно.Рекомендую +3
Потом (если в сторону каталисты смотрит rl0)
ifconfig vlan2 inet 192.168.2.1 netmask 255.255.255.0 vlan 2 vlandev rl0
ifconfig vlan3 inet 192.168.3.1 netmask 255.255.255.0 vlan 3 vlandev rl0
...
ifconfig vlan54 inet 192.168.54.1 netmask 255.255.255.0 vlan 54 vlandev rl0
Проверяем активность ip forwarding:
sysctl net.inet.ip.forwarding
должно быть 1.
Затем правим файрволл в соответствии со своими представлениями о безопасности.
И не забываем на сам rl0 повесить управляющую сеть:
ifconfig rl0 inet 192.168.1.1 netmask 255.255.255.248
С NAT  полагаю всё тривиально...

Вот, собственно, всё.
Мог где нибудь накосячить - извиняюсь сразу. Тяжело писать конфиг cisco в таком маленьком text-field.

Остап.
PS: при таком количестве пользователей лучше использовать NIC Intel на чипе 82557(8,9). Тогда в ядре FB (версии 4.8 и старше) можно сказать
options DEVICE_POLLING
options HZ=1000
и потом с помощью sysctl включить опрос буффера NIC Intel. Это значительно (в моём случае почти в 25 раз) ускорит работу NIC.
Есть ещё одна фича FB. Если сказать
ifconfig fxp0 link0
то при наличии спец. микрокода интел его загрузит и процесс пойдёт ещё быстрее...

  Рекомендовать в FAQ | Cообщить модератору | Наверх

54. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 31-Май-04, 12:59  (MSK)
>Вот, собственно, всё.
>Мог где нибудь накосячить - извиняюсь сразу. Тяжело писать конфиг cisco в
>таком маленьком text-field.
>
>Остап.

В том то и дело, что это у меня все настроено.
Пинг идет с клиента из вилана куда угодно, на все "серые" адреса.
Наружу ничего не видно.
С фрибсд тоже видно все виланы пингом.

Если сетевая здесь не причем, то похоже у меня что-то с роутингом :(((

  Рекомендовать в FAQ | Cообщить модератору | Наверх

55. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от ostapus Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 01-Июн-04, 08:28  (MSK)
Если с каталистой всё в порядке и VLAN делают своё чёрное дело, остаётся проверить три вещи:
1) ip.forwarding
2) firewall
3) NAT
=======
1) должно быть = 1
2) должен пропускать пакеты из серых сетей до NAT и обратно (после divert) и обеспечить доступ с/на внешний интерфейс.
3) должен быть запущен с примерно такими параметрами:
/sbin/natd -u -s -n rl0 (если rl0 торчит наружу)
Средствами файрволла ты перенаправляешь пакеты на порт natd (8668 по умолчанию).
Если эти вещи сделаны - ты должен получить доступ с клиентов до, по крайней мере, внутреннего интерфейса Cisco2600 (в твоей схеме)
Если Cisco2600 не фильтрует траффик и не транслирует его - должен быть доступ наружу. Пингами со стандартным размером пакета 32 байта.
На rl картах наблюдалась такая неприятная особенность: при конфигурировании vlan интерфейса на freebsd, некорректно выставлялся MTU (1462 что ли, или какой-то такой). Поэтому при ifconfig стоит указать mtu 1500. Иначе могут не проходить большие пакеты.

Остап.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

57. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 01-Июн-04, 08:57  (MSK)
>Если с каталистой всё в порядке и VLAN делают своё чёрное дело,
>остаётся проверить три вещи:
>1) ip.forwarding
>2) firewall
>3) NAT
>=======
>1) должно быть = 1
>2) должен пропускать пакеты из серых сетей до NAT и обратно (после
>divert) и обеспечить доступ с/на внешний интерфейс.
>3) должен быть запущен с примерно такими параметрами:
>/sbin/natd -u -s -n rl0 (если rl0 торчит наружу)
>Средствами файрволла ты перенаправляешь пакеты на порт natd (8668 по умолчанию).
>Если эти вещи сделаны - ты должен получить доступ с клиентов до,
>по крайней мере, внутреннего интерфейса Cisco2600 (в твоей схеме)
>Если Cisco2600 не фильтрует траффик и не транслирует его - должен быть
>доступ наружу. Пингами со стандартным размером пакета 32 байта.
>На rl картах наблюдалась такая неприятная особенность: при конфигурировании vlan интерфейса на
>freebsd, некорректно выставлялся MTU (1462 что ли, или какой-то такой). Поэтому
>при ifconfig стоит указать mtu 1500. Иначе могут не проходить большие
>пакеты.
>
>Остап.

1. Это есть.

2. На файрволе:

${fwcmd} add divert natd from 192.168.0.0/24 to any out via rl0
${fwcmd} add divert natd from any to ${my_real_ip} in via rl0

${fwcmd} add divert natd from 192.168.1.0/24 to any out via rl0
${fwcmd} add divert natd from any to ${my_real_ip} in via rl0

${fwcmd} add divert natd from 192.168.2.0/24 to any out via rl0
${fwcmd} add divert natd from any to ${my_real_ip} in via rl0

3. Это тоже есть:
/sbin/natd -u -s -n rl0


mtu 1500 тоже сделал...

>Если эти вещи сделаны - ты должен получить доступ с клиентов до,
>по крайней мере, внутреннего интерфейса Cisco2600 (в твоей схеме)
>Если Cisco2600 не фильтрует траффик и не транслирует его - должен быть
>доступ наружу.

Доступа к сожалению нет :(
Циска вроде не фильтрует и не транслирует ничего

  Рекомендовать в FAQ | Cообщить модератору | Наверх

58. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от ostapus Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 02-Июн-04, 16:26  (MSK)
>${fwcmd} add divert natd from 192.168.0.0/24 to any out via rl0
>${fwcmd} add divert natd from any to ${my_real_ip} in via rl0

Попробуй сделать
ipfw add divert natd all from any to any via rl0
ipfw add pass all from 192.168.0.0/18 to any
ipfw add pass all from any to 192.168.0.0/18

При таком divert обязателен ключ -u при запуске natd.

Если в этом случае заработает - конкретизируй правила файрволла.

Естественно, если твои сети 192.168.x.x попадают в /18.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

59. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 03-Июн-04, 10:07  (MSK)
>>${fwcmd} add divert natd from 192.168.0.0/24 to any out via rl0
>>${fwcmd} add divert natd from any to ${my_real_ip} in via rl0
>
>Попробуй сделать
>ipfw add divert natd all from any to any via rl0
>ipfw add pass all from 192.168.0.0/18 to any
>ipfw add pass all from any to 192.168.0.0/18
>
>При таком divert обязателен ключ -u при запуске natd.
>
>Если в этом случае заработает - конкретизируй правила файрволла.
>
>Естественно, если твои сети 192.168.x.x попадают в /18.

Незнаю, это не пробовал делать, но ВСЕ ЗАРАБОТАЛО!!!
После чего - незнаю!

Настроил коммутаторы по вышеприведенной тобой схеме и все заработало :)
Есть подозрение, что это от того что прописал no ip direct для первого VLAN'а.

Ну, вобщем, раьотает :)))

Спасибо большое!

  Рекомендовать в FAQ | Cообщить модератору | Наверх

60. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от ostapus Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 03-Июн-04, 16:26  (MSK)
>Незнаю, это не пробовал делать, но ВСЕ ЗАРАБОТАЛО!!!
>После чего - незнаю!
>
>Настроил коммутаторы по вышеприведенной тобой схеме и все заработало :)
>Есть подозрение, что это от того что прописал no ip direct для
>первого VLAN'а.
>
>Ну, вобщем, раьотает :)))
>
>Спасибо большое!

Ну и ладненько. Рад за тебя :)


  Рекомендовать в FAQ | Cообщить модератору | Наверх

56. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от ostapus Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 01-Июн-04, 08:32  (MSK)
>Если сетевая здесь не причем, то похоже у меня что-то с роутингом

Ты пойми, что роутинга у тебя в связке FreeBSD-Catalyst-Catalyst просто быть не может. На FB он не нужен, т.к. клиенты серые и их надо транслировать. Если клиент не серый - он чудесно отмаршрутизируется на default маршрут FreeBSD. Забудь про маршрутизацию. Смотри на NAT пристальнее.
Кстати, каким файрволлом пользуешься? ipfw или ipf?

Остап.


  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 21-Май-04, 00:29  (MSK)
может ещ
  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 21-Май-04, 00:29  (MSK)
может еще раз попытаетесь объяснить, что вы хотите сделать и зачем?
  Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Дима Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 21-Май-04, 10:23  (MSK)
>Прочитал в одной статье, что в каждый из созданных виланов необходимо включать
>транковый порт, через который подключен сервак. Так ли это? И еще
>вроде он должен быть тэгированым - это как?
>
>Например, имеем вилан VLAN003, в который входит третий порт на каталисте.
>Как только пытаюсь добавить туда первый порт, циска можно сказать, виснет, т.е.
>помогает только ее перезагрузка, конфигурация есессно не сохраняется.
>
>Оригинал статьи тут - www.lanbilling.ru/vlan_solution.html
>
>Разъясните плз ситуацию...

непонятно зачем вставлять первый порт во все ВЛАНы, да и не даст 2950 этого сделать. Рутинг между ВЛАНами должен делать рутер. а объявить скажем первый порт транковым и впихнуть его во все ВЛАНы не получится.
Задача то какая стоит у вас?


  Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Дима Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 21-Май-04, 10:29  (MSK)
>Прочитал в одной статье, что в каждый из созданных виланов необходимо включать
>транковый порт, через который подключен сервак. Так ли это? И еще
>вроде он должен быть тэгированым - это как?
>
>Например, имеем вилан VLAN003, в который входит третий порт на каталисте.
>Как только пытаюсь добавить туда первый порт, циска можно сказать, виснет, т.е.
>помогает только ее перезагрузка, конфигурация есессно не сохраняется.
>
>Оригинал статьи тут - www.lanbilling.ru/vlan_solution.html
>
>Разъясните плз ситуацию...

Например у вас 2950-24
и есть рутер воткнутый в 1 порт. По умолчанию в свиче native vlan 1.
вы создаете 23 ВЛАНа на на оставшиеся 23 порта, т.е один порт - один влан. Так вот они не будут видеть друг друга пока вы не обеспечите роутинг между вланами.Это будет делать рутер.
конфигурируете 1 порт - switchport trunk allowed vlan all

вот ссылка вобщем
http://www.cisco.com/en/US/tech/tk389/tk390/technologies_configuration_example09186a00800949fd.shtml

  Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 21-Май-04, 12:02  (MSK)
Ну схема у меня такая:

Два каталиста 2950-24, соединены между собой через 24-й порт.
Первая циска подключена через первый порт ко внутреннему интерфейсу rl2 на FreeBSD. Внешний интерфейс rl0 идет дальше на маршрутизатор циско 2600, дальше через ADSL-модем и во внешний мир.

На фрюхе я создал интерфейсы к созданным виланам на каталисте, но при пинге с вилана не видно шлюза...

Вот кусок из доки, что я привел ссылкой выше:

"Идея настройки заключается в том, что бы назначить каждый порт в его собственный VLAN, а также в VLAN к которому подключен сервер доступа. Таким образом, сервер доступа будет присутствовать сразу во всех VLAN."


Вот это меня и смутило, вобщем запутался я...

  Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 21-Май-04, 12:35  (MSK)
порт, который к freebsd идёт, должен быть транковым...
  Рекомендовать в FAQ | Cообщить модератору | Наверх

8. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 21-Май-04, 13:05  (MSK)
>порт, который к freebsd идёт, должен быть транковым...

какой командой это задается?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

9. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от ВОЛКА emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 21-Май-04, 13:19  (MSK)
conf t
int f0/0
sw tr enc dot1q
sw mo tr

  Рекомендовать в FAQ | Cообщить модератору | Наверх

10. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 21-Май-04, 14:16  (MSK)
>conf t
>int f0/0
> sw tr enc dot1q
> sw mo tr

это не работает... ругается на dot1q...

я сделал так

configure terminal
interface fastEthernet 0/1
switchport trunk allowed vlan all

правильно ли это?

после того как это прописал, клиент из вилана не видит даже айпи самого коммутатора...

  Рекомендовать в FAQ | Cообщить модератору | Наверх

11. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Skiv Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 21-Май-04, 14:29  (MSK)
>>conf t
>>int f0/0
>> sw tr enc dot1q
>> sw mo tr
>
>это не работает... ругается на dot1q...
>
>я сделал так
>
>configure terminal
>interface fastEthernet 0/1
>switchport trunk allowed vlan all
>
>правильно ли это?
>
>после того как это прописал, клиент из вилана не видит даже айпи
>самого коммутатора...

почти
2950 не поддерживает ничего кроме dot1q
соответсвенно надо говорит
switchport mode trunk

  Рекомендовать в FAQ | Cообщить модератору | Наверх

52. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от ostapus Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 31-Май-04, 10:17  (MSK)
>2950 не поддерживает ничего кроме dot1q
Поддерживает. ISL.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

12. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 21-Май-04, 16:23  (MSK)
>Например у вас 2950-24
>и есть рутер воткнутый в 1 порт. По умолчанию в свиче native
>vlan 1.
>вы создаете 23 ВЛАНа на на оставшиеся 23 порта, т.е один порт
>- один влан. Так вот они не будут видеть друг друга
>пока вы не обеспечите роутинг между вланами.Это будет делать рутер.
>конфигурируете 1 порт - switchport trunk allowed vlan all

не могли бы вы подсказать, как обеспечить роутинг между виланами?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

13. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Дима Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 21-Май-04, 17:15  (MSK)
>>Например у вас 2950-24
>>и есть рутер воткнутый в 1 порт. По умолчанию в свиче native
>>vlan 1.
>>вы создаете 23 ВЛАНа на на оставшиеся 23 порта, т.е один порт
>>- один влан. Так вот они не будут видеть друг друга
>>пока вы не обеспечите роутинг между вланами.Это будет делать рутер.
>>конфигурируете 1 порт - switchport trunk allowed vlan all
>
>не могли бы вы подсказать, как обеспечить роутинг между виланами?


идея такова:
скажем у нас есть рутер и свич
к 1 порту свича подключен рутер
ко 2 порту хост
к 3 порту хост

задача засунуть каждый порт в свой ВЛАН и обеспечить между ними маршрутизацию в соответсвии с политикой сети

действия:
ВЛАН1 native по умолчанию и в нем сидят все порты, делаем:

!-- устанавливаем IP address и шлюз для VLAN1 для управления.

3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int vlan 1
3512xl(config-if)#ip address 10.10.10.2 255.255.255.0
3512xl(config-if)#exit
3512xl(config)#ip default-gateway 10.10.10.1
3512xl(config)#end

создаем ВЛАН 2 и ВЛАН 3
3512xl(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002

3512xl(vlan)#vlan 3
VLAN 3 added:
Name: VLAN0003
3512xl(vlan)#exit
APPLY completed.
Exiting....

добавляем 2 порт во 2 влан и 3 в 3 соответственно
3512xl(config)#int fastEthernet 0/2
3512xl(config-if)#switchport access vlan 2
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#exit

3512xl(config)#int fastEthernet 0/3
3512xl(config-if)#switchport access vlan 3
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#exit


конфигурируем VTP
3512xl#vlan database
3512xl(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.

определяем 1 порт как транковый
!-- включаем транк на 1 порту fastEthernet 0/1.
3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int fastEthernet 0/1
3512xl(config-if)#switchport mode trunk

!-- добавляем все вланы в trunk.
3512xl(config-if)#switchport trunk allowed vlan all
3512xl(config-if)#exit


вроде со свичем все, итого имеем три влана и три порта

теперь задача создать на рутере три сабинтерфейса и каждому определить номер влана

например для циски с интерфесом 0/0 который воткнут в 1 порт

создание сабинтерфейсов и конфигурирование ВЛАНОВ

c2600(config)#int fastEthernet 0/0.1
c2600(config-subif)#encapsulation dot1Q 1 native
c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
c2600(config-subif)#exit


c2600(config)#int fastEthernet 0/0.2
c2600(config-subif)#encapsulation dot1Q 2
c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z

c2600(config)#int fastEthernet 0/0.3
c2600(config-subif)#encapsulation dot1Q 3
c2600(config-subif)#ip address 10.10.12.1 255.255.255.0
c2600(config-subif)#exit

c2600#wr mem
Building configuration...
[OK]
c2600#

теперь у нас на циске три сабинтерфейса
каждый сабинтерфейс доступен с соответствующего ВЛАНУ порта, т.е. 1 с 1, 2 со 2 и 3 с 3.
таким образом настраивая рутинг между этими сабинтерфейсами мы обеспечиваем рутинг между вланами( в ннашем случае портами)

как конфигурить рутер под NIX точно не напишу, но в нете полно доков. Идея то одна,просто реализация чуток разная

удачи

  Рекомендовать в FAQ | Cообщить модератору | Наверх

14. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 21-Май-04, 18:03  (MSK)
>идея такова:
>скажем у нас есть рутер и свич
>к 1 порту свича подключен рутер
>ко 2 порту хост
>к 3 порту хост
>
>задача засунуть каждый порт в свой ВЛАН и обеспечить между ними маршрутизацию
>в соответсвии с политикой сети
>
>действия:
>ВЛАН1 native по умолчанию и в нем сидят все порты, делаем:
>
>!-- устанавливаем IP address и шлюз для VLAN1 для управления.
>
>3512xl#configure terminal
>Enter configuration commands, one per line. End with CNTL/Z.
>3512xl(config)#int vlan 1
>3512xl(config-if)#ip address 10.10.10.2 255.255.255.0
>3512xl(config-if)#exit
>3512xl(config)#ip default-gateway 10.10.10.1
>3512xl(config)#end
>
>создаем ВЛАН 2 и ВЛАН 3
>3512xl(vlan)#vlan 2
>VLAN 2 added:
>Name: VLAN0002
>
>3512xl(vlan)#vlan 3
>VLAN 3 added:
>Name: VLAN0003
>3512xl(vlan)#exit
>APPLY completed.
>Exiting....
>
>добавляем 2 порт во 2 влан и 3 в 3 соответственно
>3512xl(config)#int fastEthernet 0/2
>3512xl(config-if)#switchport access vlan 2
>3512xl(config-if)#spanning-tree portfast
>3512xl(config-if)#exit
>
>3512xl(config)#int fastEthernet 0/3
>3512xl(config-if)#switchport access vlan 3
>3512xl(config-if)#spanning-tree portfast
>3512xl(config-if)#exit
>
>
>конфигурируем VTP
>3512xl#vlan database
>3512xl(vlan)#vtp transparent
>Setting device to VTP TRANSPARENT mode.
>
>определяем 1 порт как транковый
>!-- включаем транк на 1 порту fastEthernet 0/1.
>3512xl#configure terminal
>Enter configuration commands, one per line. End with CNTL/Z.
>3512xl(config)#int fastEthernet 0/1
>3512xl(config-if)#switchport mode trunk
>
>!-- добавляем все вланы в trunk.
>3512xl(config-if)#switchport trunk allowed vlan all
>3512xl(config-if)#exit
>
>


Да, это все у меня уже сконфигурировано.


>вроде со свичем все, итого имеем три влана и три порта
>
>теперь задача создать на рутере три сабинтерфейса и каждому определить номер влана
>
>
>например для циски с интерфесом 0/0 который воткнут в 1 порт
>
>создание сабинтерфейсов и конфигурирование ВЛАНОВ
>
>c2600(config)#int fastEthernet 0/0.1
>c2600(config-subif)#encapsulation dot1Q 1 native
>c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
>c2600(config-subif)#exit
>
>
>c2600(config)#int fastEthernet 0/0.2
>c2600(config-subif)#encapsulation dot1Q 2
>c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
>c2600(config-subif)#exit
>c2600(config)#^Z
>
>c2600(config)#int fastEthernet 0/0.3
>c2600(config-subif)#encapsulation dot1Q 3
>c2600(config-subif)#ip address 10.10.12.1 255.255.255.0
>c2600(config-subif)#exit
>
>c2600#wr mem
>Building configuration...
>[OK]
>c2600#
>
>теперь у нас на циске три сабинтерфейса
>каждый сабинтерфейс доступен с соответствующего ВЛАНУ порта, т.е. 1 с 1, 2
>со 2 и 3 с 3.
>таким образом настраивая рутинг между этими сабинтерфейсами мы обеспечиваем рутинг между вланами(
>в ннашем случае портами)
>

А вот про это не знал. Спасибо за подробное объяснение, попробую так сделать.

Но! Машину с FreeBSD тоже ведь можно считать роутером, отсюда вопрос: на каком роутере, на фрюхе или на циске поднимать сбинтерфейсы? Или разницы нет?

Если на фрюхе, то вот что я прописал в rc.conf:

...

ifconfig_vlan2="inet 192.168.1.2 netmask 255.255.255.0 vlan 2 vlandev rl2"
ifconfig_vlan3="inet 192.168.1.3 netmask 255.255.255.0 vlan 3 vlandev rl2"
...

где 3 - это ID вилана на свиче,
vlandev rl2 - сетевуха, подключенная к первому порту на свиче.

P.S. К комутатору ближе является FreeBSD, а потом уже идет циска 2600.


  Рекомендовать в FAQ | Cообщить модератору | Наверх

15. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Дима Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 21-Май-04, 18:21  (MSK)
Машину с FreeBSD тоже ведь можно считать роутером, отсюда вопрос: на
>каком роутере, на фрюхе или на циске поднимать сбинтерфейсы? Или разницы
>нет?
>
>Если на фрюхе, то вот что я прописал в rc.conf:
>
>...
>
>ifconfig_vlan2="inet 192.168.1.2 netmask 255.255.255.0 vlan 2 vlandev rl2"
>ifconfig_vlan3="inet 192.168.1.3 netmask 255.255.255.0 vlan 3 vlandev rl2"
>...
>
>где 3 - это ID вилана на свиче,
>vlandev rl2 - сетевуха, подключенная к первому порту на свиче.
>
>P.S. К комутатору ближе является FreeBSD, а потом уже идет циска 2600.
>
первое что приходит в голову это то что адреса сабинтерфейсов должны принадлежать разным сетям, т.е
ifconfig_vlan2="inet 192.168.2.1 netmask 255.255.255.0 vlan 2 vlandev rl2"
ifconfig_vlan3="inet 192.168.3.1 netmask 255.255.255.0 vlan 3 vlandev rl2"


а вот дальнейшие нюансы надо копать доки, так как у  меня все крутится на cisco

  Рекомендовать в FAQ | Cообщить модератору | Наверх

16. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 21-Май-04, 19:59  (MSK)
> Машину с FreeBSD тоже ведь можно считать роутером, отсюда вопрос: на
>
>>каком роутере, на фрюхе или на циске поднимать сбинтерфейсы? Или разницы
>>нет?
>>
>>Если на фрюхе, то вот что я прописал в rc.conf:
>>
>>...
>>
>>ifconfig_vlan2="inet 192.168.1.2 netmask 255.255.255.0 vlan 2 vlandev rl2"
>>ifconfig_vlan3="inet 192.168.1.3 netmask 255.255.255.0 vlan 3 vlandev rl2"
>>...
>>
>>где 3 - это ID вилана на свиче,
>>vlandev rl2 - сетевуха, подключенная к первому порту на свиче.
>>
>>P.S. К комутатору ближе является FreeBSD, а потом уже идет циска 2600.
>>
>первое что приходит в голову это то что адреса сабинтерфейсов должны принадлежать
>разным сетям, т.е
>ifconfig_vlan2="inet 192.168.2.1 netmask 255.255.255.0 vlan 2 vlandev rl2"
>ifconfig_vlan3="inet 192.168.3.1 netmask 255.255.255.0 vlan 3 vlandev rl2"

это понятно, осталось выяснить, на каком роутере мутить сабинтерфейсы.

Спасибо за помощь!

  Рекомендовать в FAQ | Cообщить модератору | Наверх

17. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 22-Май-04, 17:01  (MSK)
>теперь задача создать на рутере три сабинтерфейса и каждому определить номер влана
>
>
>например для циски с интерфесом 0/0 который воткнут в 1 порт
>
>создание сабинтерфейсов и конфигурирование ВЛАНОВ
>
>c2600(config)#int fastEthernet 0/0.1
>c2600(config-subif)#encapsulation dot1Q 1 native
>c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
>c2600(config-subif)#exit
>
>
>c2600(config)#int fastEthernet 0/0.2
>c2600(config-subif)#encapsulation dot1Q 2
>c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
>c2600(config-subif)#exit
>c2600(config)#^Z
>
>c2600(config)#int fastEthernet 0/0.3
>c2600(config-subif)#encapsulation dot1Q 3
>c2600(config-subif)#ip address 10.10.12.1 255.255.255.0
>c2600(config-subif)#exit
>
>c2600#wr mem
>Building configuration...
>[OK]
>c2600#
>
>теперь у нас на циске три сабинтерфейса
>каждый сабинтерфейс доступен с соответствующего ВЛАНУ порта, т.е. 1 с 1, 2
>со 2 и 3 с 3.
>таким образом настраивая рутинг между этими сабинтерфейсами мы обеспечиваем рутинг между вланами(
>в ннашем случае портами)


А вот еще такой вопрос.
Вот что показывает show running-config на роутере:

c2600#show running-config

...

!
interface ATM/0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/0.1 point-to-point
ip address 74.128.23.125 255.255.255.240
pvc 0/35
!
!
interface FastEthernet0/0
ip address 74.128.23.125 255.255.255.240
speed 100
full-duplex
!
interface FastEthernet0/0.1
!
ip classless
ip route 0.0.0.0 0.0.0.0 ATM0/0.1
no ip http server
!
!
access-list 1 permit 192.168.0.0 0.0.0.255 log
snmp-server community public RO
snmp-server enable traps tty
!

можно ли в этом случае создавать сабинтерфейсы так, как ты описал выше?
тут уже вроде что-то создано, можно ли что изменять, незнаю.
И еще: что за аксесс лист для сети 192.168.0.0?
а как же сеть 192.168.1.0?

что-то я ничего не пойму...

ЗЫ на роутер сегодня первый раз залез, раньше его не трогал.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

18. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Дима Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 22-Май-04, 19:57  (MSK)
>А вот еще такой вопрос.
>Вот что показывает show running-config на роутере:
>
>c2600#show running-config
>
>...
>
>!
>interface ATM/0
> no ip address
> no atm ilmi-keepalive
> dsl operating-mode auto
>!
>interface ATM0/0.1 point-to-point
> ip address 74.128.23.125 255.255.255.240
> pvc 0/35
>!
>!
>interface FastEthernet0/0
> ip address 74.128.23.125 255.255.255.240
> speed 100
> full-duplex
>!
>interface FastEthernet0/0.1
>!
>ip classless
>ip route 0.0.0.0 0.0.0.0 ATM0/0.1
>no ip http server
>!
>!
>access-list 1 permit 192.168.0.0 0.0.0.255 log
>snmp-server community public RO
>snmp-server enable traps tty
>!
>
>можно ли в этом случае создавать сабинтерфейсы так, как ты описал выше?
>
>тут уже вроде что-то создано, можно ли что изменять, незнаю.
>И еще: что за аксесс лист для сети 192.168.0.0?
>а как же сеть 192.168.1.0?
>
>что-то я ничего не пойму...
>
>ЗЫ на роутер сегодня первый раз залез, раньше его не трогал.


ощущение как будто конфигурил кто-то и бросил на пол пути :))
АТМ смотрит в инет, а фаст езер внутрь?
и между циской и свичом стоит Фри с НАТом?
и вы пользуетесь невалидными адресами?
на Фри ещё и Сквид какой-нить?

аксеслист тут действительно ни к чему
можно думаю создать ВЛАНЫ на фастезере
будут скажем невалидные(192,168,х,х) вланы на фастезере и один реальный FastEthernet0/0.1
ip address 74.128.23.125 255.255.255.240

interface FastEthernet0/0.2
ip address 192.168.2.1 255.255.255.0


interface FastEthernet0/0.3
ip address 192.168.3.1 255.255.255.0

мож там нат аутсайд на реальном и инсайд на остальных
сквид на фре пусть с роутмапом или WCCP пашет

вобщем чтото в этом духе

  Рекомендовать в FAQ | Cообщить модератору | Наверх

19. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 22-Май-04, 20:19  (MSK)
>ощущение как будто конфигурил кто-то и бросил на пол пути :))
> АТМ смотрит в инет, а фаст езер внутрь?
>и между циской и свичом стоит Фри с НАТом?
>и вы пользуетесь невалидными адресами?
>на Фри ещё и Сквид какой-нить?
>

Да! Да! Да! :-)

1. Сконфигурировали не до конца.
2. АТМ смотрит в инет, а фаст езер внутрь - правильно.
3. И между циской и свичом стоит Фри с НАТом, невалидными адресами и Сквид - все это так и есть...

Сейчас буду смотреть... может чего и получицца....

  Рекомендовать в FAQ | Cообщить модератору | Наверх

20. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 23-Май-04, 01:53  (MSK)
>ip address 74.128.23.125 255.255.255.240
>
>interface FastEthernet0/0.2
>ip address 192.168.2.1 255.255.255.0
>
>
>interface FastEthernet0/0.3
>ip address 192.168.3.1 255.255.255.0

Это все я сделал, по прежнему не работает.
Из клиента ничего не пингуется, кроме собственного айпи.
Имхо, это связано с тем, что фря находится между свичами и роутером... хотя здесь вопрос уже стоит наверное о маршрутизации...

>мож там нат аутсайд на реальном и инсайд на остальных
>сквид на фре пусть с роутмапом или WCCP пашет

Вот из этого я ничего не понял...

>вобщем чтото в этом духе

ага, в теории оно ой как просто все выглядит :-)
а на практике, что-то не получается...

  Рекомендовать в FAQ | Cообщить модератору | Наверх

21. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Дима Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 23-Май-04, 08:20  (MSK)
>>ip address 74.128.23.125 255.255.255.240
>>
>>interface FastEthernet0/0.2
>>ip address 192.168.2.1 255.255.255.0
>>
>>
>>interface FastEthernet0/0.3
>>ip address 192.168.3.1 255.255.255.0
>
>Это все я сделал, по прежнему не работает.
>Из клиента ничего не пингуется, кроме собственного айпи.
>Имхо, это связано с тем, что фря находится между свичами и роутером...
>хотя здесь вопрос уже стоит наверное о маршрутизации...
>
>>мож там нат аутсайд на реальном и инсайд на остальных
>>сквид на фре пусть с роутмапом или WCCP пашет
>
>Вот из этого я ничего не понял...
>
>>вобщем чтото в этом духе
>
>ага, в теории оно ой как просто все выглядит :-)
>а на практике, что-то не получается...


инет - cisco router- свич1 - свич2
                       |
                    FreeBSD
1. поднять ВЛАны на свич1
2. создать сабинтерфейсы на cisco router
3. проверить как работает маршрутизация между ВЛАНами
4. выпустить в инет невалидные ВЛАНы подняв НАТ на cisco router
5. приспособить сквид как transparent proxy при помощи route map или WCCP


смысл держать фри между рутером и свичем?
пропускает ли в этом случае Free теггированные 802.1q фреймы( с поднятым НАТом)?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

22. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Дима Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 23-Май-04, 08:24  (MSK)
поправка к предыдущему посту
за неимением свободного езера на рутере Free втыкается в свич1

  Рекомендовать в FAQ | Cообщить модератору | Наверх

23. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 23-Май-04, 08:46  (MSK)
Схема немного другая:

инет - ciscorouter
            |
         FreeBSD - свич1 - свич2

>1. поднять ВЛАны на свич1
>2. создать сабинтерфейсы на cisco router
>3. проверить как работает маршрутизация между ВЛАНами
>4. выпустить в инет невалидные ВЛАНы подняв НАТ на cisco router
>5. приспособить сквид как transparent proxy при помощи route map или WCCP
>

1. Сделано.
2. Сделано.
3. Нифига походу не работает, из вилана нифига не пингуется :( Зато с FreeBSD пингуется всею.
4. НАТ крутится на фре.
5. Зачем?

>
>смысл держать фри между рутером и свичем?
>пропускает ли в этом случае Free теггированные 802.1q фреймы( с поднятым НАТом)?
>

смысл в том, что на фре висит биллинг (за неимением возможности юзать билинг под циску) и еще куча всего.

А тогда зачем вообще прокси использовать, тем более транспарент, ведь НАТ крутится?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

24. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Дима Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 23-Май-04, 09:02  (MSK)
>Схема немного другая:
>
>инет - ciscorouter
>            
>|
>         FreeBSD - свич1
>- свич2
>
>>1. поднять ВЛАны на свич1
>>2. создать сабинтерфейсы на cisco router
>>3. проверить как работает маршрутизация между ВЛАНами
>>4. выпустить в инет невалидные ВЛАНы подняв НАТ на cisco router
>>5. приспособить сквид как transparent proxy при помощи route map или WCCP
>>
>
>1. Сделано.
>2. Сделано.
>3. Нифига походу не работает, из вилана нифига не пингуется :( Зато
>с FreeBSD пингуется всею.
>4. НАТ крутится на фре.
>5. Зачем?
>
>>
>>смысл держать фри между рутером и свичем?
>>пропускает ли в этом случае Free теггированные 802.1q фреймы( с поднятым НАТом)?
>>
>
>смысл в том, что на фре висит биллинг (за неимением возможности юзать
>билинг под циску) и еще куча всего.
>
>А тогда зачем вообще прокси использовать, тем более транспарент, ведь НАТ крутится?
>


попробуйте вотнкнуть рутер прям в свич в 1 порт и все сконфигурировать
сквид=кэш+рестрикт

что за биллинг
какие критерии?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

25. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 23-Май-04, 09:07  (MSK)
>>Схема немного другая:
>>
>>инет - ciscorouter
>>            
>>|
>>         FreeBSD - свич1
>>- свич2
>>
>>>1. поднять ВЛАны на свич1
>>>2. создать сабинтерфейсы на cisco router
>>>3. проверить как работает маршрутизация между ВЛАНами
>>>4. выпустить в инет невалидные ВЛАНы подняв НАТ на cisco router
>>>5. приспособить сквид как transparent proxy при помощи route map или WCCP
>>>
>>
>>1. Сделано.
>>2. Сделано.
>>3. Нифига походу не работает, из вилана нифига не пингуется :( Зато
>>с FreeBSD пингуется всею.
>>4. НАТ крутится на фре.
>>5. Зачем?
>>
>>>
>>>смысл держать фри между рутером и свичем?
>>>пропускает ли в этом случае Free теггированные 802.1q фреймы( с поднятым НАТом)?
>>>
>>
>>смысл в том, что на фре висит биллинг (за неимением возможности юзать
>>билинг под циску) и еще куча всего.
>>
>>А тогда зачем вообще прокси использовать, тем более транспарент, ведь НАТ крутится?
>>
>
>
>попробуйте вотнкнуть рутер прям в свич в 1 порт и все сконфигурировать
>
а как же FreeBSD?

>сквид=кэш+рестрикт
>
>что за биллинг
>какие критерии?

IP-статистика, критерии - необходимо считать трафик клиентов сети 192.168.1.0


  Рекомендовать в FAQ | Cообщить модератору | Наверх

26. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Andrey Y. Ostanovsky emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 24-Май-04, 14:09  (MSK)
>>>Схема немного другая:
>>>
>>>инет - ciscorouter
>>>           |
>>>         FreeBSD-свич1-свич2
===skip
>>попробуйте вотнкнуть рутер прям в свич в 1 порт и все сконфигурировать
>а как же FreeBSD?

Так ведь если делать транзит vlan-ов со свича на cisco-router (как было подробно показано выше) - то в промежутке машина вроде бы и не нужна.

Для Вашей схемы имеет смысл поднимать vlan-ы на FreeBSD, а не на cisco-router-е. Тогда можно будет и транспарент-прокси восю использовать и трафик обсчитывать.

>>что за биллинг какие критерии?
>IP-статистика, критерии - необходимо считать трафик клиентов сети 192.168.1.0

рекомендую ng_ipacctd - с дальнейшей укладкой в sql по вкусу.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

27. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Agp emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 24-Май-04, 18:24  (MSK)

>Для Вашей схемы имеет смысл поднимать vlan-ы на FreeBSD, а не на
>cisco-router-е. Тогда можно будет и транспарент-прокси восю использовать и трафик

А если вланы на FreeBSD то и роутить надо фрибсдой, и НАТ на ней, и роутер не надо настраивать :)

  Рекомендовать в FAQ | Cообщить модератору | Наверх

28. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 24-Май-04, 22:08  (MSK)
>
>>Для Вашей схемы имеет смысл поднимать vlan-ы на FreeBSD, а не на
>>cisco-router-е. Тогда можно будет и транспарент-прокси восю использовать и трафик
>
>А если вланы на FreeBSD то и роутить надо фрибсдой, и НАТ
>на ней, и роутер не надо настраивать :)

ну блин ребята вы меня совсем запутали :)))

то что машина с фрюхой не нужна между свичами и роутером это понятно.
Но она есть, и убирать ее нельзя.
Другое дело - поднимать виланы на фре - это я тоже делал... не понял только как между ними роутинг сделать, т.к. с сервера пингуется все, а из виланов нихрена не видно.

Короче, схема все равно та же:

инет - ciscorouter
           |
         FreeBSD - свич1 - свич2

и надо как то выкручиваться...

другое дело, настроил я сабинтерфейсы на циско роутере. вроде бы все ОК.
но из роутера пинг не проходит на внутренние адреса вообще, только наружу... незнаю правильно ли это или опять я что-то упустил и роутинг надо делать как-то на циске?

завал, вобщем....

  Рекомендовать в FAQ | Cообщить модератору | Наверх

29. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Andrey Y. Ostanovsky emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 25-Май-04, 11:11  (MSK)
>ну блин ребята вы меня совсем запутали :)))
>то что машина с фрюхой не нужна между свичами и роутером это
>понятно.
>Но она есть, и убирать ее нельзя.
>Другое дело - поднимать виланы на фре - это я тоже делал...
>не понял только как между ними роутинг сделать,

Роутинг делается с помощью построения таблицы маршрутизации - обычно происходит автоматически при поднятии интерфейсов, смотрится по "netstat - rn", плюс надо ядру разрешить роутить пакетики - что-то типа "gateway_enable=yes" в районе /etc/rc.conf

>т.к. с сервера
>пингуется все, а из виланов нихрена не видно.

Погоди, из виланов серверный интерфейс пингуется, или вообще ничего никуда не ходит?

>Короче, схема все равно та же:
>инет - ciscorouter
>           |
>         FreeBSD-свич1-свич2
>
>и надо как то выкручиваться...
>
>другое дело, настроил я сабинтерфейсы на циско роутере. вроде бы все ОК.
>но из роутера пинг не проходит на внутренние адреса вообще, только наружу...
>незнаю правильно ли это или опять я что-то упустил и роутинг
>надо делать как-то на циске?

На фре есть такая полезная команда - "tcpdump -pni rl0", на циске, вроде тоже есть что-то похожее - как звать, не подскажу.

Вот ими можно посмотреть - какие пакеты и куда идут или не идут.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

30. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 25-Май-04, 13:47  (MSK)
>Роутинг делается с помощью построения таблицы маршрутизации - обычно >происходит автоматически при поднятии интерфейсов, смотрится >по "netstat - rn", плюс надо ядру разрешить роутить пакетики - что-то >типа "gateway_enable=yes" в районе /etc/rc.conf
>

в районе /etc/rc.conf это все настроено...

вот что видно по netstat -rn касательно виланов:

192.168.2   link#5  UC  0  0  vlan0
192.168.3   link#6  UC  0  0  vlan1

здесь я нифига не пойму что происходит...

>Погоди, из виланов серверный интерфейс пингуется, или вообще ничего никуда не ходит?
>
да, из виланов ничего не видно :(


А вот что у меня на циско роутере:

Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface:   FastEthernet0/0

This is configured as native Vlan for the following interface(s) :
FastEthernet0/0

Protocols Configured:  Address:              Received:        Transmitted:
IP                     213.56.182.11         45946956         11334573
Other                                        0                29769

45946958 packets, 6225287220 bytes input
11364342 packets, 5890973746 bytes output

Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface:   FastEthernet0/0.2

Protocols Configured:   Address:             Received:        Transmitted:
IP                      192.168.2.1          0                30
Other                                        0                63

0 packets, 0 bytes input
93 packets, 18841 bytes output

vLAN Trunk Interface:   FastEthernet0/0.3

Protocols Configured:   Address:             Received:        Transmitted:
IP                      192.168.3.1          0                30
Other                                        0                63

0 packets, 0 bytes input
93 packets, 18841 bytes output

  Рекомендовать в FAQ | Cообщить модератору | Наверх

31. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Andrey Y. Ostanovsky emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 25-Май-04, 18:53  (MSK)
>>Погоди, из виланов серверный интерфейс пингуется, или вообще ничего никуда не ходит?
>да, из виланов ничего не видно :(
>А вот что у меня на циско роутере:
>
>Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)
>
>vLAN Trunk Interface:   FastEthernet0/0
>
Еще раз - виланы 192.168. должны заканчиваться на внутреннем интерфейсе сервера, иначе пропадает всякий смысл в промежуточном сервере.
  Рекомендовать в FAQ | Cообщить модератору | Наверх

32. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 25-Май-04, 19:33  (MSK)
>
>Еще раз - виланы 192.168. должны заканчиваться на внутреннем интерфейсе сервера, иначе
>пропадает всякий смысл в промежуточном сервере.

Короче так. Потихоньку начинает распутываться все...

Забудем что у меня есть роутер циска 2600. Все будет на машине с FreeBSD.
Создаем интерфейс rl1, который соединен с trunk-портом на свиче:
ifconfig rl1 inet 192.168.100.1 netmask 255.255.255.0

Создаем интерфейсы виланов:
ifconfig vlan0 inet 192.168.0.1 netmask 255.255.255.0 vlan 2 vlandev rl1
ifconfig vlan1 inet 192.168.1.1 netmask 255.255.255.0 vlan 3 vlandev rl1

где,
vlan 2 и vlan 3 - тэги виланов на свиче (номер вилана)
vlandev - устройство, через которое будем виланить.

Все!!!
Подключаемся с клиента, имеющего IP 192.168.0.2 во 2-й порт свича (vlan 2), и пингуем спокойно сервер.
Подключаемся с клиента, имеющего IP 192.168.1.2 в 3-й порт свича (vlan 3), и так же спокойно пингуем сервер.
С сервера соответственно пингуются клиенты обеих виланов.
Виланы между собой друг друга не видят. Все так, как и должно быть.

С виланами разобрались :)

Теперь вопрос: ЧТО УКАЗЫВАТЬ В КАЧЕСТВЕ ШЛЮЗА НА КЛИЕНТАХ???
Ну чтобы сквид и другие сервисы работали на клиентах.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

33. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Дима Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 26-Май-04, 08:03  (MSK)
>>
>>Еще раз - виланы 192.168. должны заканчиваться на внутреннем интерфейсе сервера, иначе
>>пропадает всякий смысл в промежуточном сервере.
>
>Короче так. Потихоньку начинает распутываться все...
>
>Забудем что у меня есть роутер циска 2600. Все будет на машине
>с FreeBSD.
>Создаем интерфейс rl1, который соединен с trunk-портом на свиче:
>ifconfig rl1 inet 192.168.100.1 netmask 255.255.255.0
>
>Создаем интерфейсы виланов:
>ifconfig vlan0 inet 192.168.0.1 netmask 255.255.255.0 vlan 2 vlandev rl1
>ifconfig vlan1 inet 192.168.1.1 netmask 255.255.255.0 vlan 3 vlandev rl1
>
>где,
>vlan 2 и vlan 3 - тэги виланов на свиче (номер вилана)
>
>vlandev - устройство, через которое будем виланить.
>
>Все!!!
>Подключаемся с клиента, имеющего IP 192.168.0.2 во 2-й порт свича (vlan 2),
>и пингуем спокойно сервер.
>Подключаемся с клиента, имеющего IP 192.168.1.2 в 3-й порт свича (vlan 3),
>и так же спокойно пингуем сервер.
>С сервера соответственно пингуются клиенты обеих виланов.
>Виланы между собой друг друга не видят. Все так, как и должно
>быть.
>
>С виланами разобрались :)
>
>Теперь вопрос: ЧТО УКАЗЫВАТЬ В КАЧЕСТВЕ ШЛЮЗА НА КЛИЕНТАХ???
>Ну чтобы сквид и другие сервисы работали на клиентах.

как погляжу прогресс на лицо)))

а шлюзом для клиентов есессно будет соответствующий саб интерфейс на фре.
а фря уж сама разберется дальше куда что кидать.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

34. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 26-Май-04, 08:52  (MSK)
>
>как погляжу прогресс на лицо)))

Спасибо :)

>
>а шлюзом для клиентов есессно будет соответствующий саб интерфейс на фре.
>а фря уж сама разберется дальше куда что кидать.

А вот это не работает...
Вернее, не совсем работает...

Пинг проходит до сабинтерфейса и до интерфейса rl0 - 192.168.1.1

А сервисы нифига не работаюь...


  Рекомендовать в FAQ | Cообщить модератору | Наверх

35. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от Agp emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 26-Май-04, 10:00  (MSK)
>>а шлюзом для клиентов есессно будет соответствующий саб интерфейс на фре.
>>а фря уж сама разберется дальше куда что кидать.
>Вернее, не совсем работает...
>Пинг проходит до сабинтерфейса и до интерфейса rl0 - 192.168.1.1
>А сервисы нифига не работаюь...

А 'default route' на фре есть?
А firewall на фре не работает?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

36. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 26-Май-04, 10:43  (MSK)
А почему клиенты на VLANах друх друга не видят?
  Рекомендовать в FAQ | Cообщить модератору | Наверх

37. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 26-Май-04, 11:37  (MSK)
>А почему клиенты на VLANах друх друга не видят?

ну ведь технология VLAN это и подразумевает по-моему... разделить одну сеть как бы на несколько локальных сетей...

  Рекомендовать в FAQ | Cообщить модератору | Наверх

38. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 26-Май-04, 11:40  (MSK)
>>>а шлюзом для клиентов есессно будет соответствующий саб интерфейс на фре.
>>>а фря уж сама разберется дальше куда что кидать.
>>Вернее, не совсем работает...
>>Пинг проходит до сабинтерфейса и до интерфейса rl0 - 192.168.1.1
>>А сервисы нифига не работаюь...
>
>А 'default route' на фре есть?
Есть, у меня прописан на адрес типа 81.х.х.х, все как и должно быть.
Не пойму, причем тут дефолтовый маршрут и сабинтерфейсы с виланами ???

>А firewall на фре не работает?
работает, думаешь с этим связано?


  Рекомендовать в FAQ | Cообщить модератору | Наверх

39. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 26-Май-04, 11:55  (MSK)
Да, если просто коммутатор с VLAN без маршрутизатора, не спорю VLAN изолированы, сети друг друга не видят. Но у тебя по транку подключен маршрутизатор на FreeBSD, так что VLAN между собой должны маршрутизироваться (мы берем когда любая фильтрация выключена).
  Рекомендовать в FAQ | Cообщить модератору | Наверх

40. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 26-Май-04, 12:42  (MSK)
>Да, если просто коммутатор с VLAN без маршрутизатора, не спорю VLAN изолированы,
>сети друг друга не видят. Но у тебя по транку подключен
>маршрутизатор на FreeBSD, так что VLAN между собой должны маршрутизироваться (мы
>берем когда любая фильтрация выключена).

И как этого избежать (чтобы не видели друг друга) ?

Я все настраивал согласно этой доке:
http://www.opennet.ru/base/net/vlan_freebsd.txt.html

  Рекомендовать в FAQ | Cообщить модератору | Наверх

41. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 26-Май-04, 15:35  (MSK)
Что бы не видели это на маршутизаторе ACL (IPFILTER, IPWF, PF по желанию)

Может я заблуждаюсь.
И у тебя тоже должны видеть однозначно.
Если включен GATEWAY_ENABLE="YES", если на клиенте прописан шлюз - FREEBSD и если с клиентов пингуется FREEBSD то клиенты должны видеть друг друга и никак иначе. (фаервол выключен на шлюзе)

  Рекомендовать в FAQ | Cообщить модератору | Наверх

42. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 26-Май-04, 19:44  (MSK)
>Что бы не видели это на маршутизаторе ACL (IPFILTER, IPWF, PF по
>желанию)
>
>Может я заблуждаюсь.
>И у тебя тоже должны видеть однозначно.
>Если включен GATEWAY_ENABLE="YES", если на клиенте прописан шлюз - FREEBSD и если
>с клиентов пингуется FREEBSD то клиенты должны видеть друг друга и
>никак иначе. (фаервол выключен на шлюзе)

Вы меня разочаровали.... :(

Ну как хотя бы сделать, чтобы клиенты до сервисов могли достучаться, скквид итп... пинг ведь идет в обе стороны, а сервисы не работают :(

  Рекомендовать в FAQ | Cообщить модератору | Наверх

43. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 27-Май-04, 07:08  (MSK)
Непонятно разочарование.

Так вроде все же настроил. Клиенты пингуют маршрутизатора на FreeBSD.
НА клиентах выставлен шлюз. На FreeBSD выставлен шлюз. Что еще надо.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

44. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 27-Май-04, 11:26  (MSK)
>Непонятно разочарование.

Ну это пока, в первом приближении :)

>
>Так вроде все же настроил. Клиенты пингуют маршрутизатора на FreeBSD.
>НА клиентах выставлен шлюз. На FreeBSD выставлен шлюз. Что еще надо.

Вот и я о том же. Раньше у клиента было выставлено в настройках броузера например работать через прокси адрес 192.168.1.1 порт 3128. Сейчас, после поднятия вилан нифига не работает, ни при каких условиях :(


  Рекомендовать в FAQ | Cообщить модератору | Наверх

45. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 27-Май-04, 17:02  (MSK)
А прокси у тебя работал на FreeBSD на которм виланы подняты?
  Рекомендовать в FAQ | Cообщить модератору | Наверх

46. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 27-Май-04, 17:28  (MSK)
>А прокси у тебя работал на FreeBSD на которм виланы подняты?

Да

  Рекомендовать в FAQ | Cообщить модератору | Наверх

47. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от vlad Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 27-Май-04, 21:30  (MSK)
>>А прокси у тебя работал на FreeBSD на которм виланы подняты?
>
>Да

Используй traceroute, ping на клиентах, tcpdump на сервере. Проверь  включена ли опция маршрутизации между  интерфейсами на BSD. Еще раз внимательно промотри свой файрволл на bsd.

  Рекомендовать в FAQ | Cообщить модератору | Наверх

48. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от A Clockwork Orange Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 28-Май-04, 07:43  (MSK)
И попробуй прокси служать адрес отличный от адреса принадлежащего вилана, может проблема и не в этом
  Рекомендовать в FAQ | Cообщить модератору | Наверх

49. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 28-Май-04, 16:55  (MSK)
>И попробуй прокси служать адрес отличный от адреса принадлежащего вилана, может проблема
>и не в этом

нет, к сожалению, я все перепробовал, не работает :(
пинг есть, но только на внутренние адреса...
пробовал даже при отключенном файрволе.

Я вот тут подумал, не может ли это быть из-за сетевой карты?
Сетевая у меня Realtek 8139.
И знаете, чему я больше всего поражаюсь?
Тому, что один говорит, что у него все нормально работает на етой карте, другой говорит, что такое невозможно впринципе
(у нее нет поддержки 802.1Q).

Начинаю смотреть в сторону покупки Intel Pro/1000 MT Server Adapter (PWLA8490MT)

Что думаете по этому поводу?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

50. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от balex Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 30-Май-04, 13:39  (MSK)
>Я вот тут подумал, не может ли это быть из-за сетевой карты?
>
>Сетевая у меня Realtek 8139.
>И знаете, чему я больше всего поражаюсь?
>Тому, что один говорит, что у него все нормально работает на етой
>карте, другой говорит, что такое невозможно впринципе
>(у нее нет поддержки 802.1Q).
>
>Начинаю смотреть в сторону покупки Intel Pro/1000 MT Server Adapter (PWLA8490MT)
>
>Что думаете по этому поводу?

Реально работает и Realtek 8139 по крайней мере на версиях FreeBSD 4 и 5

  Рекомендовать в FAQ | Cообщить модератору | Наверх

51. "По поводу настройки VLAN на каталисте 2950..." 
Сообщение от reticon emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 30-Май-04, 14:25  (MSK)
>>Я вот тут подумал, не может ли это быть из-за сетевой карты?
>>
>>Сетевая у меня Realtek 8139.
>>И знаете, чему я больше всего поражаюсь?
>>Тому, что один говорит, что у него все нормально работает на етой
>>карте, другой говорит, что такое невозможно впринципе
>>(у нее нет поддержки 802.1Q).
>>
>>Начинаю смотреть в сторону покупки Intel Pro/1000 MT Server Adapter (PWLA8490MT)
>>
>>Что думаете по этому поводу?
>
>Реально работает и Realtek 8139 по крайней мере на версиях FreeBSD 4
>и 5

Ну тогда незнаю... :(

Бред какой-то


  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor