The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]



"Перераспределение статических маршрутов в OSPF"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Перераспределение статических маршрутов в OSPF"  +/
Сообщение от WhaTISSexY (ok), 06-Сен-18, 14:42 
Добрый день.
Имеется схема организации каналов связи с удаленным объектом с использованием трех каналов с трех разных маршрутизаторов (R2, R3, R4) через серийные интерфейсы. Маршруты до подсети удаленного объекта прописаны статикой на каждом из трех роутеров с разными метриками. Маршрутизация в пределах офиса организована с использованием протокола OSPF. Конфигурация транзитных роутеров ниже:

=== R2 ===
interface Loopback0
ip address 172.25.3.2 255.255.255.255
!
interface Ethernet0/0
ip address 172.19.97.2 255.255.255.240
!
interface Serial1/0
ip address 172.24.111.1 255.255.255.252
keepalive 2
serial restart-delay 0
!
router ospf 1
router-id 172.25.3.2
redistribute static subnets
network 172.19.97.0 0.0.0.15 area 1
network 172.25.3.2 0.0.0.0 area 1
!
ip route 10.99.43.0 255.255.255.240 Serial1/0
==========

=== R3 ===
interface Loopback0
ip address 172.25.3.3 255.255.255.255
!
interface Ethernet0/0
ip address 172.19.97.3 255.255.255.240
!
interface Serial1/0
ip address 172.24.111.5 255.255.255.252
keepalive 2
serial restart-delay 0
!
router ospf 1
router-id 172.25.3.3
redistribute static subnets
network 172.19.97.0 0.0.0.15 area 1
network 172.25.3.3 0.0.0.0 area 1
!
ip route 10.99.43.0 255.255.255.240 Serial1/0 200
==========

=== R4 ===
interface Loopback0
ip address 172.25.3.4 255.255.255.255
!
interface Ethernet0/0
ip address 172.19.97.4 255.255.255.240
!
interface Serial1/0
ip address 172.24.111.9 255.255.255.252
keepalive 2
serial restart-delay 0
!
router ospf 1
router-id 172.25.3.4
redistribute static subnets
network 172.19.97.0 0.0.0.15 area 1
network 172.25.3.4 0.0.0.0 area 1
!
ip route 10.99.43.0 255.255.255.240 Serial1/0 250
==========

Проблема в том, что если в работе только два канала (с R2 и R3), то при обрыве канала по R2 передача данных переключается на канал через R3, при восстановлении канала с R2 - переключается на канал на R2. То есть метрика статических маршрутов вроде бы отрабатывает.

Если же в работе все три канала, то при обрыве канала на R2 переключение выполняется произвольно (либо на R3, либо на R4), что при переключении на R4 приводит к асинхронной передаче, т.к. на стороне объекта резервирование каналов настроено другим образом и отрабатывает согласно приоритетам R2-R3-R4.

Суть вопроса - играют ли роли метрики статических маршрутов при перераспределении в OSPF?
Пробовал в настройках OSPF на R3 и R4 задавать метрики для перераспределенных статических подсетей:

!
router ospf 1
router-id 172.25.3.3
redistribute static subnets metric 50
network 172.19.97.0 0.0.0.15 area 1
network 172.25.3.3 0.0.0.0 area 1
!

результат тот же, при обрыве канала на R2 роутеры R3 и R4 не могут между собой договориться, при этом в дебаге OSPF отображается заданные мной при редистрибуции метрики для каждого из роутеров.
Использование route-map для задания метрик приводит к аналогичному результату.
Можно ли заставить работать указанную схему с тремя каналами?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Перераспределение статических маршрутов в OSPF"  +1 +/
Сообщение от fantom (??), 07-Сен-18, 15:28 
>[оверквотинг удален]
>  router-id 172.25.3.3
>  redistribute static subnets metric 50
>  network 172.19.97.0 0.0.0.15 area 1
>  network 172.25.3.3 0.0.0.0 area 1
> !
> результат тот же, при обрыве канала на R2 роутеры R3 и R4
> не могут между собой договориться, при этом в дебаге OSPF отображается
> заданные мной при редистрибуции метрики для каждого из роутеров.
> Использование route-map для задания метрик приводит к аналогичному результату.
> Можно ли заставить работать указанную схему с тремя каналами?

Думаю можно,
metric-type 1 укажите OSPF-у, что бы он учитывал не только метрику редистрибуции, но  и цену "доставки".
Ну и правильно и расписать бэндвиз, чтоб таблицы у рутеров "сошлись"

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Перераспределение статических маршрутов в OSPF"  +/
Сообщение от WhaTISSexY (ok), 10-Сен-18, 15:50 
>[оверквотинг удален]
>> !
>> результат тот же, при обрыве канала на R2 роутеры R3 и R4
>> не могут между собой договориться, при этом в дебаге OSPF отображается
>> заданные мной при редистрибуции метрики для каждого из роутеров.
>> Использование route-map для задания метрик приводит к аналогичному результату.
>> Можно ли заставить работать указанную схему с тремя каналами?
> Думаю можно,
> metric-type 1 укажите OSPF-у, что бы он учитывал не только метрику редистрибуции,
> но  и цену "доставки".
> Ну и правильно и расписать бэндвиз, чтоб таблицы у рутеров "сошлись"

День добрый!

Попробовал по Вашему совету:

R2#sh run | s router ospf
router ospf 1
router-id 172.25.3.2
redistribute static metric-type 1 subnets
network 172.19.97.0 0.0.0.15 area 1
network 172.25.3.2 0.0.0.0 area 1

R2#sh int s1/0 | i BW
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,


R3#sh run | s router ospf
router ospf 1
router-id 172.25.3.3
redistribute static metric-type 1 subnets
network 172.19.97.0 0.0.0.15 area 1
network 172.25.3.3 0.0.0.0 area 1

R3#sh int s1/0 | i BW
  MTU 1500 bytes, BW 1000 Kbit/sec, DLY 20000 usec,


R4#sh run | s router ospf
router ospf 1
router-id 172.25.3.4
redistribute static metric-type 1 subnets
network 172.19.97.0 0.0.0.15 area 1
network 172.25.3.4 0.0.0.0 area 1

R4#sh int s1/0 | i BW
  MTU 1500 bytes, BW 512 Kbit/sec, DLY 20000 usec,

Результат аналогичный, при отключении канала на R2 в дебаг OSPF роутера, не участвующего в организации этих трех каналов, валится следующее:

R1#
*Sep 10 15:31:34: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.2 on Ethernet0/1, source 172.25.3.2
*Sep 10 15:31:34: OSPF-1 LRIB : No more paths for 10.99.43.0/28 type Ext1 - delete route from local RIB
*Sep 10 15:31:34: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext1 - change (Delete, PathChange): added 0 paths, deleted 1 paths, spf 9, route instance 8
*Sep 10 15:31:34: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext1, dist 30,  forward 10, tag 0x0, via 172.19.97.4 Ethernet0/1, route flags (PartialSPF), path flags (none), source 172.25.3.4, spf 10, list-type route_type_list
*Sep 10 15:31:34: OSPF-1 GRIB : IP route replace of 1 next hops succeeded for 10.99.43.0/28 (flags (None), type Ext1, tag 0x0), retcode 0
*Sep 10 15:31:34: OSPF-1 GRIB : Next hop via 172.19.97.4 on Ethernet0/1 (distance 30, source 172.25.3.4, label 1048578) installed
*Sep 10 15:31:34: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext1 - change (Change, PathChange, HigherCost): added 1 paths, deleted 0 paths, spf 10, route instance 10
*Sep 10 15:31:34: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext1, dist 30,  forward 10, tag 0x0, via 172.19.97.3 Ethernet0/1, route flags (PartialSPF), path flags (none), source 172.25.3.3, spf 11, list-type route_type_list
R1#
*Sep 10 15:31:34: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext1, dist 30,  forward 10, tag 0x0, via 172.19.97.4 Ethernet0/1, route flags (PartialSPF), path flags (none), source 172.25.3.4, spf 11, list-type route_type_list
*Sep 10 15:31:34: OSPF-1 GRIB : IP route add of 1 next hops succeeded for 10.99.43.0/28 (flags (None), type Ext1, tag 0x0), retcode 0
*Sep 10 15:31:34: OSPF-1 GRIB : Next hop via 172.19.97.3 on Ethernet0/1 (distance 30, source 172.25.3.3, label 1048578) installed
*Sep 10 15:31:34: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext1 - change (PathChange): added 1 paths, deleted 0 paths, spf 11, route instance 11
R1#
*Sep 10 15:31:39: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext1, dist 30,  forward 10, tag 0x0, via 172.19.97.4 Ethernet0/1, route flags (PartialSPF), path flags (none), source 172.25.3.4, spf 12, list-type route_type_list
*Sep 10 15:31:39: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.3 on Ethernet0/1, source 172.25.3.3
*Sep 10 15:31:39: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext1 - change (PathChange): added 0 paths, deleted 1 paths, spf 12, route instance 12
*Sep 10 15:31:39: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.4 on Ethernet0/1, source 172.25.3.4
R1#
*Sep 10 15:31:39: OSPF-1 LRIB : No more paths for 10.99.43.0/28 type Ext1 - delete route from local RIB
*Sep 10 15:31:39: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext1 - change (Delete, PathChange): added 0 paths, deleted 1 paths, spf 13, route instance 12
R1#
*Sep 10 15:31:44: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext1, dist 30,  forward 10, tag 0x0, via 172.19.97.3 Ethernet0/1, route flags (PartialSPF), path flags (none), source 172.25.3.3, spf 14, list-type route_type_list
*Sep 10 15:31:44: OSPF-1 GRIB : IP route replace of 1 next hops succeeded for 10.99.43.0/28 (flags (None), type Ext1, tag 0x0), retcode 0
*Sep 10 15:31:44: OSPF-1 GRIB : Next hop via 172.19.97.3 on Ethernet0/1 (distance 30, source 172.25.3.3, label 1048578) installed
*Sep 10 15:31:44: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext1 - change (Change, PathChange, HigherCost): added 1 paths, deleted 0 paths, spf 14, route instance 14
*Sep 10 15:31:44: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext1, dist 30,  forward 10, tag 0x0, via 172.19.97.3 Ethernet0/1, route flags (PartialSPF), path flags (none), source 172.25.3.3, spf 15, list-type route_type_list
*Sep 10 15:31:44: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext1, dist 30,  forward 10, tag 0x0, via 172.19.97.4 Ethernet0/1, route flags (PartialSPF), path flags (none), source 172.25.3.4, spf 15, list-type route_type_list
*Sep 10 15:31:44: OSPF-1 GRIB : IP route add of 1 next hops succeeded for 10.99.43.0/28 (flags (None), type Ext1, tag 0x0), retcode 0
R1#
*Sep 10 15:31:44: OSPF-1 GRIB : Next hop via 172.19.97.4 on Ethernet0/1 (distance 30, source 172.25.3.4, label 1048578) installed
*Sep 10 15:31:44: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext1 - change (PathChange): added 1 paths, deleted 0 paths, spf 15, route instance 15
R1#
*Sep 10 15:31:49: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext1, dist 30,  forward 10, tag 0x0, via 172.19.97.4 Ethernet0/1, route flags (PartialSPF), path flags (none), source 172.25.3.4, spf 16, list-type route_type_list
*Sep 10 15:31:49: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.3 on Ethernet0/1, source 172.25.3.3
*Sep 10 15:31:49: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext1 - change (PathChange): added 0 paths, deleted 1 paths, spf 16, route instance 16
*Sep 10 15:31:49: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.4 on Ethernet0/1, source 172.25.3.4

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Перераспределение статических маршрутов в OSPF"  +/
Сообщение от fantom (??), 10-Сен-18, 16:12 
>[оверквотинг удален]
> Ext1, dist 30,  forward 10, tag 0x0, via 172.19.97.4 Ethernet0/1,
> route flags (PartialSPF), path flags (none), source 172.25.3.4, spf 16, list-type
> route_type_list
> *Sep 10 15:31:49: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.3
> on Ethernet0/1, source 172.25.3.3
> *Sep 10 15:31:49: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext1 - change
> (PathChange): added 0 paths, deleted 1 paths, spf 16, route instance
> 16
> *Sep 10 15:31:49: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.4
> on Ethernet0/1, source 172.25.3.4

Вы там что-то про сериалы сообщали, а в логах одни Эзернеты...
Курите вашу схему, где-то чегото намутили/напутали/намудрили....

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Перераспределение статических маршрутов в OSPF"  +/
Сообщение от WhaTISSexY (ok), 11-Сен-18, 11:06 
>[оверквотинг удален]
>> route_type_list
>> *Sep 10 15:31:49: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.3
>> on Ethernet0/1, source 172.25.3.3
>> *Sep 10 15:31:49: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext1 - change
>> (PathChange): added 0 paths, deleted 1 paths, spf 16, route instance
>> 16
>> *Sep 10 15:31:49: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.4
>> on Ethernet0/1, source 172.25.3.4
> Вы там что-то про сериалы сообщали, а в логах одни Эзернеты...
> Курите вашу схему, где-то чегото намутили/напутали/намудрили....

На форуме нет возможности прикладывать к сообщениям изображения/схемы?
R1 (с которого был снят дебаг, приложенный выше) - это центральный роутер ЛВС.
R2, R3 и R4 - граничные маршрутизаторы - серийниками смотрят в сторону удаленного объекта.
Каждый из 4-х роутеров одним эзернет портом сидит в общем влане, на каждом роутере поднят OSPF с одинаковыми area-id и анонсируемыми подсетями.

Ниже привожу дебаг OSPF RIB с R3 и R4 (метрика редистрибуции статических маршрутов настроена соответственно 50 и 100) при отключенном серийнике на R2:

=== R3 ===
R3#
*Sep 11 07:24:52.388: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.2 on Ethernet0/0, source 172.25.3.2
*Sep 11 07:24:52.388: OSPF-1 LRIB : No more paths for 10.99.43.0/28 type Ext2 - delete route from local RIB
*Sep 11 07:24:52.388: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Delete, PathChange): added 0 paths, deleted 1 paths, spf 17, route instance 16
*Sep 11 07:24:52.388: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
*Sep 11 07:24:52.425: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext2, dist 100,  forward 10, tag 0x0, via 172.19.97.4 Ethernet0/0, route flags (PartialSPF), path flags (none), source 172.25.3.4, spf 18, list-type route_type_list
*Sep 11 07:24:52.425: OSPF-1 GRIB : IP route replace of 1 next hops succeeded for 10.99.43.0/28 (flags (None), type Ext2, tag 0x0), retcode 0
*Sep 11 07:24:52.425: OSPF-1 GRIB : Next hop via 172.19.97.4 on Ethernet0/0 (distance 100, source 172.25.3.4, label 1048578) installed
R3#
*Sep 11 07:24:52.425: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Change, PathChange, HigherCost): added 1 paths, deleted 0 paths, spf 18, route instance 18
*Sep 11 07:24:52.425: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
R3#
*Sep 11 07:24:57.429: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.4 on Ethernet0/0, source 172.25.3.4
*Sep 11 07:24:57.429: OSPF-1 LRIB : No more paths for 10.99.43.0/28 type Ext2 - delete route from local RIB
*Sep 11 07:24:57.429: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Delete, PathChange): added 0 paths, deleted 1 paths, spf 19, route instance 18
*Sep 11 07:24:57.429: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
R3#
*Sep 11 07:25:02.396: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext2, dist 100,  forward 10, tag 0x0, via 172.19.97.4 Ethernet0/0, route flags (PartialSPF), path flags (none), source 172.25.3.4, spf 20, list-type route_type_list
*Sep 11 07:25:02.396: OSPF-1 GRIB : IP route replace of 1 next hops succeeded for 10.99.43.0/28 (flags (None), type Ext2, tag 0x0), retcode 0
*Sep 11 07:25:02.396: OSPF-1 GRIB : Next hop via 172.19.97.4 on Ethernet0/0 (distance 100, source 172.25.3.4, label 1048578) installed
R3#
*Sep 11 07:25:02.396: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Change, PathChange, HigherCost): added 1 paths, deleted 0 paths, spf 20, route instance 20
*Sep 11 07:25:02.396: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
R3#
*Sep 11 07:25:07.401: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.4 on Ethernet0/0, source 172.25.3.4
*Sep 11 07:25:07.401: OSPF-1 LRIB : No more paths for 10.99.43.0/28 type Ext2 - delete route from local RIB
*Sep 11 07:25:07.401: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Delete, PathChange): added 0 paths, deleted 1 paths, spf 21, route instance 20
*Sep 11 07:25:07.401: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
R3#
*Sep 11 07:25:12.406: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext2, dist 100,  forward 10, tag 0x0, via 172.19.97.4 Ethernet0/0, route flags (PartialSPF), path flags (none), source 172.25.3.4, spf 22, list-type route_type_list
*Sep 11 07:25:12.406: OSPF-1 GRIB : IP route replace of 1 next hops succeeded for 10.99.43.0/28 (flags (None), type Ext2, tag 0x0), retcode 0
*Sep 11 07:25:12.406: OSPF-1 GRIB : Next hop via 172.19.97.4 on Ethernet0/0 (distance 100, source 172.25.3.4, label 1048578) installed
R3#
*Sep 11 07:25:12.406: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Change, PathChange, HigherCost): added 1 paths, deleted 0 paths, spf 22, route instance 22
*Sep 11 07:25:12.406: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
R3#
*Sep 11 07:25:17.407: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.4 on Ethernet0/0, source 172.25.3.4
*Sep 11 07:25:17.407: OSPF-1 LRIB : No more paths for 10.99.43.0/28 type Ext2 - delete route from local RIB
*Sep 11 07:25:17.407: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Delete, PathChange): added 0 paths, deleted 1 paths, spf 23, route instance 22
*Sep 11 07:25:17.407: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
R3#
*Sep 11 07:25:22.414: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext2, dist 100,  forward 10, tag 0x0, via 172.19.97.4 Ethernet0/0, route flags (PartialSPF), path flags (none), source 172.25.3.4, spf 24, list-type route_type_list
*Sep 11 07:25:22.414: OSPF-1 GRIB : IP route replace of 1 next hops succeeded for 10.99.43.0/28 (flags (None), type Ext2, tag 0x0), retcode 0
*Sep 11 07:25:22.414: OSPF-1 GRIB : Next hop via 172.19.97.4 on Ethernet0/0 (distance 100, source 172.25.3.4, label 1048578) installed
*Sep 11 07:25:22.414: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Change, PathChange, HigherCost): added 1 paths, deleted 0 paths, spf 24, route instance 24
*Sep 11 07:25:22.414: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
*Sep 11 07:25:22.451: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext2, dist 20,  forward 10, tag 0x0, via 172.19.97.2 Ethernet0/0, route flags (PartialSPF), path flags (none), source 172.25.3.2, spf 25, list-type route_type_list
*Sep 11 07:25:22.451: OSPF-1 GRIB : IP route replace of 1 next hops succeeded for 10.99.43.0/28 (flags (None), type Ext2, tag 0x0), retcode 0
R3#
*Sep 11 07:25:22.451: OSPF-1 GRIB : Next hop via 172.19.97.2 on Ethernet0/0 (distance 20, source 172.25.3.2, label 1048578) installed
*Sep 11 07:25:22.451: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Change, PathChange): added 1 paths, deleted 0 paths, spf 25, route instance 25
R3#
*Sep 11 07:25:27.421: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext2, dist 20,  forward 10, tag 0x0, via 172.19.97.2 Ethernet0/0, route flags (PartialSPF), path flags (none), source 172.25.3.2, spf 26, list-type route_type_list
*Sep 11 07:25:27.421: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (0x0): added 0 paths, deleted 0 paths, spf 26, route instance 26
R3#
==========================

=== R4 ===
R4#
*Sep 11 07:24:52.388: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.2 on Ethernet0/0, source 172.25.3.2
*Sep 11 07:24:52.388: OSPF-1 LRIB : No more paths for 10.99.43.0/28 type Ext2 - delete route from local RIB
*Sep 11 07:24:52.388: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Delete, PathChange): added 0 paths, deleted 1 paths, spf 19, route instance 18
*Sep 11 07:24:52.388: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
*Sep 11 07:24:52.424: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext2, dist 50,  forward 10, tag 0x0, via 172.19.97.3 Ethernet0/0, route flags (PartialSPF), path flags (none), source 172.25.3.3, spf 20, list-type route_type_list
*Sep 11 07:24:52.424: OSPF-1 GRIB : IP route replace of 1 next hops succeeded for 10.99.43.0/28 (flags (None), type Ext2, tag 0x0), retcode 0
*Sep 11 07:24:52.424: OSPF-1 GRIB : Next hop via 172.19.97.3 on Ethernet0/0 (distance 50, source 172.25.3.3, label 1048578) installed
R4#
*Sep 11 07:24:52.424: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Change, PathChange, HigherCost): added 1 paths, deleted 0 paths, spf 20, route instance 20
*Sep 11 07:24:52.424: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
R4#
*Sep 11 07:24:57.389: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.3 on Ethernet0/0, source 172.25.3.3
*Sep 11 07:24:57.389: OSPF-1 LRIB : No more paths for 10.99.43.0/28 type Ext2 - delete route from local RIB
*Sep 11 07:24:57.389: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Delete, PathChange): added 0 paths, deleted 1 paths, spf 21, route instance 20
*Sep 11 07:24:57.389: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
R4#
*Sep 11 07:25:02.396: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext2, dist 50,  forward 10, tag 0x0, via 172.19.97.3 Ethernet0/0, route flags (PartialSPF), path flags (none), source 172.25.3.3, spf 22, list-type route_type_list
*Sep 11 07:25:02.396: OSPF-1 GRIB : IP route replace of 1 next hops succeeded for 10.99.43.0/28 (flags (None), type Ext2, tag 0x0), retcode 0
*Sep 11 07:25:02.396: OSPF-1 GRIB : Next hop via 172.19.97.3 on Ethernet0/0 (distance 50, source 172.25.3.3, label 1048578) installed
R4#
*Sep 11 07:25:02.396: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Change, PathChange, HigherCost): added 1 paths, deleted 0 paths, spf 22, route instance 22
*Sep 11 07:25:02.396: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
R4#
*Sep 11 07:25:07.401: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.3 on Ethernet0/0, source 172.25.3.3
*Sep 11 07:25:07.401: OSPF-1 LRIB : No more paths for 10.99.43.0/28 type Ext2 - delete route from local RIB
*Sep 11 07:25:07.401: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Delete, PathChange): added 0 paths, deleted 1 paths, spf 23, route instance 22
*Sep 11 07:25:07.401: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
R4#
*Sep 11 07:25:12.406: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext2, dist 50,  forward 10, tag 0x0, via 172.19.97.3 Ethernet0/0, route flags (PartialSPF), path flags (none), source 172.25.3.3, spf 24, list-type route_type_list
*Sep 11 07:25:12.406: OSPF-1 GRIB : IP route replace of 1 next hops succeeded for 10.99.43.0/28 (flags (None), type Ext2, tag 0x0), retcode 0
*Sep 11 07:25:12.406: OSPF-1 GRIB : Next hop via 172.19.97.3 on Ethernet0/0 (distance 50, source 172.25.3.3, label 1048578) installed
R4#
*Sep 11 07:25:12.406: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Change, PathChange, HigherCost): added 1 paths, deleted 0 paths, spf 24, route instance 24
*Sep 11 07:25:12.406: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
R4#
*Sep 11 07:25:17.407: OSPF-1 GRIB : Route delete succeeded 10.99.43.0/28 via 172.19.97.3 on Ethernet0/0, source 172.25.3.3
*Sep 11 07:25:17.407: OSPF-1 LRIB : No more paths for 10.99.43.0/28 type Ext2 - delete route from local RIB
*Sep 11 07:25:17.407: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Delete, PathChange): added 0 paths, deleted 1 paths, spf 25, route instance 24
*Sep 11 07:25:17.407: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
R4#
*Sep 11 07:25:22.414: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext2, dist 50,  forward 10, tag 0x0, via 172.19.97.3 Ethernet0/0, route flags (PartialSPF), path flags (none), source 172.25.3.3, spf 26, list-type route_type_list
*Sep 11 07:25:22.414: OSPF-1 GRIB : IP route replace of 1 next hops succeeded for 10.99.43.0/28 (flags (None), type Ext2, tag 0x0), retcode 0
*Sep 11 07:25:22.414: OSPF-1 GRIB : Next hop via 172.19.97.3 on Ethernet0/0 (distance 50, source 172.25.3.3, label 1048578) installed
*Sep 11 07:25:22.414: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Change, PathChange, HigherCost): added 1 paths, deleted 0 paths, spf 26, route instance 26
*Sep 11 07:25:22.415: OSPF-1 REDIS: Notification to redistribute 10.99.43.0/28
*Sep 11 07:25:22.451: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext2, dist 20,  forward 10, tag 0x0, via 172.19.97.2 Ethernet0/0, route flags (PartialSPF), path flags (none), source 172.25.3.2, spf 27, list-type route_type_list
*Sep 11 07:25:22.451: OSPF-1 GRIB : IP route replace of 1 next hops succeeded for 10.99.43.0/28 (flags (None), type Ext2, tag 0x0), retcode 0
R4#
*Sep 11 07:25:22.451: OSPF-1 GRIB : Next hop via 172.19.97.2 on Ethernet0/0 (distance 20, source 172.25.3.2, label 1048578) installed
*Sep 11 07:25:22.451: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (Change, PathChange): added 1 paths, deleted 0 paths, spf 27, route instance 27
R4#
*Sep 11 07:25:27.421: OSPF-1 LRIB : Add 10.99.43.0/28, area dummy area, type Ext2, dist 20,  forward 10, tag 0x0, via 172.19.97.2 Ethernet0/0, route flags (PartialSPF), path flags (none), source 172.25.3.2, spf 28, list-type route_type_list
*Sep 11 07:25:27.421: OSPF-1 LRIB : Sync'ed 10.99.43.0/28 type Ext2 - change (0x0): added 0 paths, deleted 0 paths, spf 28, route instance 28
R4#
==========================

Адресация:
R1 - 172.19.97.1/28, 172.25.3.1/32;
R2 - 172.19.97.2/28, 172.25.3.2/32;
R3 - 172.19.97.3/28, 172.25.3.3/32;
R4 - 172.19.97.4/28, 172.25.3.4/32;
ЛВС офиса - 172.31.28.32/28;
Подсеть удаленного объекта - 10.99.43.0/28.

Судя по дебагу роутеры поочередно устанавливают в свои RIB маршруты через R3 и R4, при этом метрика редистрибуци на R3 - 50, на R4 - 100.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Перераспределение статических маршрутов в OSPF"  +/
Сообщение от fantom (??), 14-Сен-18, 11:43 
>[оверквотинг удален]
> Адресация:
> R1 - 172.19.97.1/28, 172.25.3.1/32;
> R2 - 172.19.97.2/28, 172.25.3.2/32;
> R3 - 172.19.97.3/28, 172.25.3.3/32;
> R4 - 172.19.97.4/28, 172.25.3.4/32;
> ЛВС офиса - 172.31.28.32/28;
> Подсеть удаленного объекта - 10.99.43.0/28.
> Судя по дебагу роутеры поочередно устанавливают в свои RIB маршруты через R3
> и R4, при этом метрика редистрибуци на R3 - 50, на
> R4 - 100.

Next hop via 172.19.97.2 on Ethernet0/0 (distance 20, source 172.25.3.2, label 1048578) installed
какой же R3 или R4 когда это сообщение явно указывает на R2 ???

Попробуйте решить проблему поэтапно, а не все и сразу.
Указывать для статики интерфейс - не всегда хорошая идея.

Решите вопрос с 2-мя маршрутизаторами, и потом переходите к 3-ему.

Вполне вероятно, что у вас там крутятся ip sla, которые переключают маршруты, эти маршруты "прилетают" в OSPF....
Почти наверняка участвуют "внешние" относительно OSPF факторы, которые вы тут не показали.


Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor