The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]



"cisco ospf backbone через dmvpn"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"cisco ospf backbone через dmvpn"  +/
Сообщение от cr1m2 email(ok) on 18-Июн-18, 07:49 
Здравствуйте, возник такой вопрос. Между 7ю офисами на cisco 29ХХ организован dmvpn (nhrs) в сети 192.168.35.0/28.
Пытаюсь поднять обмемн маршрутами по ospf area 0 в vpn.
На хабе:

interface Tunnel1
ip address 192.168.35.1 255.255.255.240
no ip redirects
ip nhrp authentication xxx
ip nhrp network-id 111
ip ospf network broadcast
ip ospf hello-interval 30
ip ospf priority 10
cdp enable
tunnel source GigabitEthernet0/1
tunnel mode gre multipoint
tunnel key 123123

router ospf 11
router-id 192.168.32.18
passive-interface default
no passive-interface GigabitEthernet0/0
no passive-interface Tunnel 1
network 192.168.32.16 0.0.0.7 area 2
network 192.168.35.0 0.0.0.15 area 0

На споке, который поднимает нормально зону 0:
interface Tunnel1
ip address 192.168.35.7 255.255.255.240
no ip redirects
ip nhrp authentication xxx
ip nhrp map multicast X.X.X.X
ip nhrp map 192.168.35.1 X.X.X.X
ip nhrp network-id 111
ip nhrp holdtime 60
ip nhrp nhs 192.168.35.1
ip nhrp registration timeout 60
ip ospf network broadcast
ip ospf hello-interval 30
ip ospf priority 0
cdp enable
tunnel source GigabitEthernet0/2
tunnel mode gre multipoint
tunnel key 123123

router ospf 11
router-id 192.168.32.2
passive-interface default
no passive-interface GigabitEthernet0/1
no passive-interface Tunnel1
network 192.168.32.0 0.0.0.7 area 1
network 192.168.35.0 0.0.0.15 area 0


А на остальных споках ospf в  area 0 не поднимается, кроме того рвется vpn, а в логах появляются сообщения о петле:
000182: Jun 14 21:03:52.845 MSK: %ADJ-5-PARENT: Midchain parent maintenance for IP midchain out of Tunnel1, addr 192.168.35.1 - looped chain attempting to stack
000183: Jun 14 21:06:58.137 MSK: %OSPF-5-ADJCHG: Process 11, Nbr 192.168.32.18 on Tunnel1 from LOADING to FULL, Loading Done

конфиг на споке, который отваливается:
interface Tunnel1
ip address 192.168.35.6 255.255.255.240
no ip redirects
ip nhrp authentication xxx
ip nhrp map multicast X.X.X.X
ip nhrp map 192.168.35.1 X.X.X.X
ip nhrp network-id 111
ip nhrp nhs 192.168.35.1
ip ospf network broadcast
ip ospf hello-interval 30
ip ospf priority 0
cdp enable
tunnel source FastEthernet0/1/0
tunnel mode gre multipoint
tunnel key 123123

router ospf 11
router-id 192.168.8.254
passive-interface default
no passive-interface Tunnel1
network 192.168.35.0 0.0.0.15 area 0

Как будто приходит маршрут к споку по ospf, что хаб 192.168.35.1 находится в туннеле, и vpn рвется. В общем непонятно, как бы это решить.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "cisco ospf backbone через dmvpn"  +/
Сообщение от ВОЛКА (ok) on 18-Июн-18, 10:37 
Вы полные конфиги покажите
Хаба, спока, и проблемного спока.
+ sh ip ospf database с хаба
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor