The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]



"Cisco 1841 + HWIC-3G-GSM и Билайн"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Диагностика и решение проблем)
Изначальное сообщение [ Отслеживать ]

"Cisco 1841 + HWIC-3G-GSM и Билайн"  +/
Сообщение от Leviafan61 on 22-Мрт-18, 01:03 
Помогите настроить модуль hwic-3g-gsm, надо ходить через него в интернет (сим Билайн)
Конфиг циски
f45-ssh#sh run
Building configuration...

Current configuration : 3732 bytes
!
! Last configuration change at 21:47:44 UTC Wed Mar 21 2018 by admin
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname f45-ssh
!
boot-start-marker
boot-end-marker
!
!
logging buffered 4096 informational
enable password 7 123115121903091C
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
!
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 172.16.10.1 172.16.10.50
!
ip dhcp pool DHCP_172.16.10.1
   network 172.16.10.0 255.255.255.0
   default-router 172.16.10.1
   dns-server 208.67.222.222
!
!
!
ip cef
ip domain name f45
ip name-server 208.67.220.220
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-4221668497
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4221668497
revocation-check none
!
!
crypto pki certificate chain TP-self-signed-4221668497
certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 34323231 36363834 3937301E 170D3138 30333137 32323537
  34365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 32323136
  36383439 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100D1FD 608C1083 F045182F 1DA5C2D1 BCBE75E0 DA085DC8 B8FD761E CC56D574
  0FCC6D32 005D9914 770904D9 562AC0D1 B7F7E46A A3F4D55E B363E4BF 82EA95B0
  3E1AC698 A31AB2D5 0E3EE392 6EF535B9 B36D31B3 4313D566 23239AF5 4A8E1FD7
  F35617A7 9E834E6F 02DD0DB9 FB2BE260 C5A1105E 63F0E84B 063CAFB0 E5622583
  7DBF0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 1443CD47 A738751C 52840858 42727A1B 38BFF73A 85301D06
  03551D0E 04160414 43CD47A7 38751C52 84085842 727A1B38 BFF73A85 300D0609
  2A864886 F70D0101 04050003 8181007C 0B72C798 E670F1DC 660DF9E2 19AA0D66
  9B2E41D5 2FD71289 6990ED11 9701D91A F9F674C7 733B8D9D 20BE3EF9 10745F75
  122D1D8C 1E35BC04 7CD8EFFE 8CBE233D 8E09B6B2 A904BFD4 E755FEF0 8BDAF300
  3A86B4EF 896B9D4F AB17AB29 015312CA 6C0D709B A184EA76 F18C3E6F 0AAA9BD1
  2EA79800 A052A439 C41B850F 5D843A
        quit
!
!
license udi pid CISCO1841 sn FCZ1412C105
username admin privilege 15 secret 5 $1$8Wnz$ih/PS.pKnYs78Bxle0GNs1
!
redundancy
!
!
controller Cellular 0/0
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly in
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Cellular0/0/0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string bee
dialer-group 23
async mode interactive
ppp chap hostname beeline
ppp chap password 7 1415170E000D242E
ppp ipcp dns request
!
interface Dialer1
no ip address
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 23 interface Cellular0/0/0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
logging esm config
access-list 23 permit any
dialer-list 23 protocol ip list 23
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 0/0/0
exec-timeout 0 0
script dialer bee
login ctrlc-disable
modem InOut
no exec
rxspeed 3600000
txspeed 384000
line vty 0 4
access-class 23 in
exec-timeout 60 0
privilege level 15
logging synchronous
transport input ssh
!
scheduler allocate 20000 1000

и профиль модема
f45-ssh#sh cellular 0/0/0 profile
Profile password Encryption level: 7

Profile 1 = INACTIVE*
--------
PDP Type = PPP
Access Point Name (APN) = internet.beeline.ru
Authentication = CHAP
Username: beeline, Password: 110B1C001B1B0509

* - Default profile

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco 1841 + HWIC-3G-GSM и Билайн"  +/
Сообщение от eek (ok) on 22-Мрт-18, 10:02 
Что ответила поддержка билайна?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Cisco 1841 + HWIC-3G-GSM и Билайн"  +/
Сообщение от _ (??) on 22-Мрт-18, 13:14 
>[оверквотинг удален]
> и профиль модема
> f45-ssh#sh cellular 0/0/0 profile
> Profile password Encryption level: 7
> Profile 1 = INACTIVE*
> --------
> PDP Type = PPP
> Access Point Name (APN) = internet.beeline.ru
> Authentication = CHAP
> Username: beeline, Password: 110B1C001B1B0509
>  * - Default profile

dialer string вижу. А chat-script?
Кто и по каким правилам будет производить "ATDT#99*" или что-нибудь подобное?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Cisco 1841 + HWIC-3G-GSM и Билайн"  +/
Сообщение от Leviafan61 on 22-Мрт-18, 22:11 
>[оверквотинг удален]
>> Profile password Encryption level: 7
>> Profile 1 = INACTIVE*
>> --------
>> PDP Type = PPP
>> Access Point Name (APN) = internet.beeline.ru
>> Authentication = CHAP
>> Username: beeline, Password: 110B1C001B1B0509
>>  * - Default profile
> dialer string вижу. А chat-script?
> Кто и по каким правилам будет производить "ATDT#99*" или что-нибудь подобное?

Странно, в конфиге он есть... видимо что то менял в этот момент(
f45-ssh#sh run
Building configuration...

Current configuration : 3783 bytes
!
! Last configuration change at 19:07:25 UTC Thu Mar 22 2018 by admin
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname f45-ssh
!
boot-start-marker
boot-end-marker
!
!
logging buffered 4096 informational
enable password 7 123115121903091C
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
!
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 172.16.10.1 172.16.10.50
!
ip dhcp pool DHCP_172.16.10.1
   network 172.16.10.0 255.255.255.0
   default-router 172.16.10.1
   dns-server 208.67.222.222
!
!
!
ip cef
ip domain name f45
ip name-server 208.67.220.220
!
multilink bundle-name authenticated
!
chat-script bee "" "ATDT*99#" TIMEOUT 30 "CONNECT"
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-4221668497
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4221668497
revocation-check none
!
!
crypto pki certificate chain TP-self-signed-4221668497
certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 34323231 36363834 3937301E 170D3138 30333137 32323537
  34365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 32323136
  36383439 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100D1FD 608C1083 F045182F 1DA5C2D1 BCBE75E0 DA085DC8 B8FD761E CC56D574
  0FCC6D32 005D9914 770904D9 562AC0D1 B7F7E46A A3F4D55E B363E4BF 82EA95B0
  3E1AC698 A31AB2D5 0E3EE392 6EF535B9 B36D31B3 4313D566 23239AF5 4A8E1FD7
  F35617A7 9E834E6F 02DD0DB9 FB2BE260 C5A1105E 63F0E84B 063CAFB0 E5622583
  7DBF0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 1443CD47 A738751C 52840858 42727A1B 38BFF73A 85301D06
  03551D0E 04160414 43CD47A7 38751C52 84085842 727A1B38 BFF73A85 300D0609
  2A864886 F70D0101 04050003 8181007C 0B72C798 E670F1DC 660DF9E2 19AA0D66
  9B2E41D5 2FD71289 6990ED11 9701D91A F9F674C7 733B8D9D 20BE3EF9 10745F75
  122D1D8C 1E35BC04 7CD8EFFE 8CBE233D 8E09B6B2 A904BFD4 E755FEF0 8BDAF300
  3A86B4EF 896B9D4F AB17AB29 015312CA 6C0D709B A184EA76 F18C3E6F 0AAA9BD1
  2EA79800 A052A439 C41B850F 5D843A
        quit
!
!
license udi pid CISCO1841 sn FCZ1412C105
username admin privilege 15 secret 5 $1$8Wnz$ih/PS.pKnYs78Bxle0GNs1
!
redundancy
!
!
controller Cellular 0/0
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly in
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Cellular0/0/0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string bee
dialer-group 23
async mode interactive
ppp chap hostname beeline
ppp chap password 7 1415170E000D242E
ppp ipcp dns request
!
interface Dialer1
no ip address
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 23 interface Cellular0/0/0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
logging esm config
access-list 23 permit any
dialer-list 23 protocol ip list 23
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 0/0/0
exec-timeout 0 0
script dialer bee
login ctrlc-disable
modem InOut
no exec
rxspeed 3600000
txspeed 384000
line vty 0 4
access-class 23 in
exec-timeout 60 0
privilege level 15
logging synchronous
transport input ssh
!
scheduler allocate 20000 1000
end

А в техподдержку не обращался пока.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Cisco 1841 + HWIC-3G-GSM и Билайн"  +/
Сообщение от _ (??) on 23-Мрт-18, 09:03 
>[оверквотинг удален]
> line vty 0 4
>  access-class 23 in
>  exec-timeout 60 0
>  privilege level 15
>  logging synchronous
>  transport input ssh
> !
> scheduler allocate 20000 1000
> end
> А в техподдержку не обращался пока.

Тогда изучать вывод:
debug ppp authentication
debug ppp authorization
debug ppp packet
debug ppp negotiation
debug dialer
debug chat

show cellular all посмотреть видит-ли HWIC вообще сеть оператора.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Cisco 1841 + HWIC-3G-GSM и Билайн"  +/
Сообщение от Leviafan61 on 23-Мрт-18, 21:51 
>[оверквотинг удален]
>> end
>> А в техподдержку не обращался пока.
> Тогда изучать вывод:
> debug ppp authentication
> debug ppp authorization
> debug ppp packet
> debug ppp negotiation
> debug dialer
> debug chat
> show cellular all посмотреть видит-ли HWIC вообще сеть оператора.

Сеть вроде видит
f45-ssh#show cellular 0/0/0 all
Hardware Information
====================
Modem Firmware Version = H1_1_9_3MCAP C:/WS/
Modem Firmware built = 12/12/07
Hardware Version = 1.1
International Mobile Subscriber Identity (IMSI) = 250994093436238
International Mobile Equipment Identity (IMEI) = 011359000430576
Integrated Circuit Card ID (ICCID) = 8970199160770360930
Mobile Subscriber International Subscriber
IDentity Number (MSISDN) =
Factory Serial Number (FSN) = D61315932131159
Modem Status = Online
Current Modem Temperature = 37 deg C, State = Normal
PRI SKU ID = 0, SKU Rev. = 20.0

Profile Information
====================
Profile password Encryption level: 7

Profile 1 = INACTIVE*
--------
PDP Type = PPP
Access Point Name (APN) = internet.beeline.ru
Authentication = CHAP
Username: beeline, Password: 110B1C001B1B0509

* - Default profile

Data Connection Information
===========================
Data Transmitted = 0 bytes, Received = 0 bytes
Profile 1, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 2, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 3, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 4, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 5, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 6, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 7, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 8, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 9, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 10, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 11, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 12, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 13, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 14, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 15, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 16, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state

Network Information
===================
Current Service Status = Normal, Service Error = None
Current Service = Combined
Packet Service = HSDPA (Attached)
Packet Session Status = Inactive
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = RUS, Network = BeeLine
Mobile Country Code (MCC) = 250
Mobile Network Code (MNC) = 99
Location Area Code (LAC) = 61221
Routing Area Code (RAC) = 3
Cell ID = 35270
Primary Scrambling Code = 87
PLMN Selection = Automatic
Registered PLMN =  , Abbreviated =
Service Provider = Beeline

Radio Information
=================
Radio power mode = ON
Current Band = WCDMA 2100, Channel Number = 10836
Current RSSI = -92 dBm
Band Selected = Auto

Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of CHV1 Retries remaining = 3

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Cisco 1841 + HWIC-3G-GSM и Билайн"  +/
Сообщение от Leviafan61 on 23-Мрт-18, 22:07 
>[оверквотинг удален]
>> end
>> А в техподдержку не обращался пока.
> Тогда изучать вывод:
> debug ppp authentication
> debug ppp authorization
> debug ppp packet
> debug ppp negotiation
> debug dialer
> debug chat
> show cellular all посмотреть видит-ли HWIC вообще сеть оператора.

Вот что говорит дебаг
*Mar 23 19:06:04.337: Ce0/0/0 DDR: re-enable timeout
*Mar 23 19:06:04.345: Ce0/0/0 DDR: place call
*Mar 23 19:06:04.345: Ce0/0/0 DDR: Dialing cause ip (s=172.16.10.51, d=208.67.222.222)
*Mar 23 19:06:04.345: Ce0/0/0 DDR: Attempting to dial bee
*Mar 23 19:06:04.345: CHAT0/0/0: Attempting async line dialer script
*Mar 23 19:06:04.345: CHAT0/0/0: Dialing using Modem script: bee & System script: none
*Mar 23 19:06:04.349: CHAT0/0/0: process started
*Mar 23 19:06:04.349: CHAT0/0/0: Asserting DTR
*Mar 23 19:06:04.349: CHAT0/0/0: Chat script bee started
*Mar 23 19:06:04.349: CHAT0/0/0: Sending string: ATDT*99#
*Mar 23 19:06:04.349: CHAT0/0/0: Expecting string: CONNECT
f45-ssh#
*Mar 23 19:06:34.349: CHAT0/0/0: Timeout expecting: CONNECT
*Mar 23 19:06:34.349: CHAT0/0/0: Chat script bee finished, status = Connection timed out; remote host not responding
*Mar 23 19:06:34.349: Ce0/0/0 DDR: disconnecting call

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

7. "Cisco 1841 + HWIC-3G-GSM и Билайн"  +/
Сообщение от Leviafan61 on 24-Мрт-18, 00:50 
Проблема решилась, в модеме нужно было прописать профиль вот так
cellular 0/0/0 gsm profile create 1 internet.beeline.ru ipv4 beeline beeline
>[оверквотинг удален]
> *Mar 23 19:06:04.349: CHAT0/0/0: process started
> *Mar 23 19:06:04.349: CHAT0/0/0: Asserting DTR
> *Mar 23 19:06:04.349: CHAT0/0/0: Chat script bee started
> *Mar 23 19:06:04.349: CHAT0/0/0: Sending string: ATDT*99#
> *Mar 23 19:06:04.349: CHAT0/0/0: Expecting string: CONNECT
> f45-ssh#
> *Mar 23 19:06:34.349: CHAT0/0/0: Timeout expecting: CONNECT
> *Mar 23 19:06:34.349: CHAT0/0/0: Chat script bee finished, status = Connection timed
> out; remote host not responding
> *Mar 23 19:06:34.349: Ce0/0/0 DDR: disconnecting call

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor