The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]



"Route-map не пенераправляет трафик"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]
Курсы Сisco по безопасности (CCNA и CCNP Security, Сisco ISE 2.1, ASA, IronPort)
"Route-map не пенераправляет трафик"  +/
Сообщение от tootsie on 27-Янв-18, 06:12 
Current configuration : 7597 bytes
!
version 12.4
service timestamps debug uptime
service timestamps log datetime localtime
service password-encryption
no service dhcp
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
logging console informational
enable secret 5 $1$qpeL$UAgvLfb60FzT.QONNeHvh.
!
no aaa new-model
!
resource policy
!
clock timezone MSK 4
no network-clock-participate slot 2
no ip source-route
ip cef
!
no ip domain lookup
ip name-server
ip name-server
!
archive
log config
  hidekeys
!
interface Null0
no ip unreachables
!
interface Loopback0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
!
interface FastEthernet0/0
description Внешний канал 1 (по-умолчанию)
ip address 1.1.1.174 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache policy
ip route-cache flow
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache policy
ip route-cache flow
duplex auto
speed auto
!
interface FastEthernet0/1.1
encapsulation dot1Q 1 native
ip address 2.2.2.3 255.255.255.248
no ip redirects
no ip unreachables
!
interface FastEthernet0/1.2
encapsulation dot1Q 302
ip address 2.2.2.61 255.255.255.252
no ip redirects
no ip unreachables
rate-limit input 51200000 3840000 7680000 conform-action transmit exceed-action
drop
rate-limit output 51200000 3840000 7680000 conform-action transmit exceed-actio
n drop
!
interface FastEthernet0/1.14
encapsulation dot1Q 314
ip address 2.2.2.81 255.255.255.252
no ip redirects
no ip unreachables
ip policy route-map 14
!
interface FastEthernet2/0
descriprion Внешний канал 2 (для route-map)
ip address 3.3.3.106 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache policy
ip route-cache flow
no ip mroute-cache
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 0.0.0.0 255.255.255.255 area 0
!
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 1.1.1.173
ip route 10.0.0.0 255.0.0.0 Null0
ip route 172.16.0.0 255.240.0.0 Null0
ip route 192.168.0.0 255.255.0.0 Null0
!
ip flow-cache timeout inactive 60
ip flow-cache timeout active 10
ip flow-export version 5
ip flow-export destination 2.2.2.162 9991
!
no ip http server
no ip http secure-server
!
logging history informational
logging facility local3
logging source-interface FastEthernet0/1.1
logging 2.2.2.165
logging 2.2.2.166
access-list 14 permit 2.2.2.80 0.0.0.3
access-list 98 permit 2.2.2.0 0.0.0.255
access-list 98 deny   any log
snmp-server community public RO 98
!
route-map 14 permit 10
match ip address 14
set ip next-hop 3.3.3.105
!
control-plane
!
line con 0
line aux 0
line vty 0 4
access-class 98 in
password 7 08375857
login
!
ntp clock-period 17180499
ntp source FastEthernet0/0
ntp master 3
ntp server 128.250.36.3
ntp server 133.100.9.2
ntp server 193.5.216.14
!
end


Внешние интерфейсы
interface FastEthernet0/0
interface FastEthernet2/0

Внутренние интерфейсы
interface FastEthernet0/1.2
interface FastEthernet0/1.14

Снаружи пингуем хост 2.2.2.82

Ответ от 2.2.2.82: число байт=32 время=4мс TTL=61
Маршрут: 4.4.4.164 ->
3.3.3.105 ->
2.2.2.81 ->
2.2.2.82 ->
2.2.2.82 ->
1.1.1.174 ->
4.4.4.161 ->
192.168.88.1

Т.е. снаружи в сторону cisco на 2.2.2.82 пакеты идут как им предписано провайдером через 3.3.3.105, от cisco от 2.2.2.82 должны ийти по роут мэп через 3.3.3.105, а идут по маршруту по- умолчанию через 1.1.1.174 (173)

Пробовали убрать маршрут по-умолчанию
ip route 0.0.0.0 0.0.0.0 1.1.1.173
и вместо него поставить роут мэп на нужный интерфейс, вообще всё перестаёт работать


deb ip pol ничего не показывает

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Route-map не пенераправляет трафик"  +/
Сообщение от shadow_alone (ok) on 28-Янв-18, 03:20 
А покажи таблицу маршрутов.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Route-map не пенераправляет трафик"  +/
Сообщение от tootsie on 28-Янв-18, 08:17 
> А покажи таблицу маршрутов.

Gateway of last resort is 194.186.234.173 to network 0.0.0.0

     3.3.3.0/30 is subnetted, 1 subnets
C       3.3.3.104 is directly connected, FastEthernet2/0
     2.2.2.0/24 is variably subnetted, 3 subnets, 2 masks
C       2.2.2.0/29 is directly connected, FastEthernet0/1.1
C       2.2.2.60/30 is directly connected, FastEthernet0/1.2
C       2.2.2.80/30 is directly connected, FastEthernet0/1.14
     1.1.1.0/30 is subnetted, 1 subnets
C       1.1.1.172 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 1.1.1.173
S    10.0.0.0/8 is directly connected, Null0
S    172.16.0.0/12 is directly connected, Null0
S    192.168.0.0/16 is directly connected, Null0

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Route-map не пенераправляет трафик"  +/
Сообщение от fantom (??) on 28-Янв-18, 10:36 
>[оверквотинг удален]
> masks
> C       2.2.2.0/29 is directly connected, FastEthernet0/1.1
> C       2.2.2.60/30 is directly connected, FastEthernet0/1.2
> C       2.2.2.80/30 is directly connected, FastEthernet0/1.14
>      1.1.1.0/30 is subnetted, 1 subnets
> C       1.1.1.172 is directly connected, FastEthernet0/0
> S*   0.0.0.0/0 [1/0] via 1.1.1.173
> S    10.0.0.0/8 is directly connected, Null0
> S    172.16.0.0/12 is directly connected, Null0
> S    192.168.0.0/16 is directly connected, Null0

Как проверяли???
И что за ИОС что за циска??
В современных присутствует в таблице маршрутов local маршруты, а в вашем выводе их нет.

Если проверяли с этой же циски:

С циско.ком

Packets that are generated by the router are not normally policy-routed.
To enable local PBR for such packets, indicate which route map the router should use by using the following command in global configuration mode:

Router(config)# ip local policy route-map map-tag

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Route-map не пенераправляет трафик"  +/
Сообщение от tootsie on 28-Янв-18, 13:02 
>[оверквотинг удален]
> И что за ИОС что за циска??
> В современных присутствует в таблице маршрутов local маршруты, а в вашем выводе
> их нет.
> Если проверяли с этой же циски:
> С циско.ком
> Packets that are generated by the router are not normally policy-routed.
> To enable local PBR for such packets, indicate which route map the
> router should use by using the following command in global configuration
> mode:
> Router(config)# ip local policy route-map map-tag

Router#sh ver
Cisco IOS Software, 3700 Software (C3725-SPSERVICESK9-M), Version 12.4(9)T7, REL
EASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Thu 10-Jan-08 17:52 by prod_rel_team

ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)

Router uptime is 45 weeks, 3 days, 3 hours, 0 minutes
System returned to ROM by power-on
System restarted at 09:40:09 MSK Thu Mar 16 2017
System image file is "flash:c3725-spservicesk9-mz.124-9.T7.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 3725 (R7000) processor (revision 0.1) with 117760K/13312K bytes of memory.
Processor board ID JMX0711L4JH
R7000 CPU at 240MHz, Implementation 39, Rev 3.3, 256KB L2 Cache
3 FastEthernet interfaces
DRAM configuration is 64 bits wide with parity disabled.
55K bytes of NVRAM.
31744K bytes of ATA System CompactFlash (Read/Write)
62720K bytes of ATA Slot0 CompactFlash (Read/Write)

Configuration register is 0x2102

Router#

Пингую с удаленной машины ping 2.2.2.82 -r 9 хост подключенный к cisco, пакеты к хосту идут по одному маршруту, а возвращаются по маршруту по-умолчанию, а должны возвращатьсяпо route-map

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Route-map не пенераправляет трафик"  +/
Сообщение от msanlimit email(ok) on 29-Янв-18, 13:18 
>[оверквотинг удален]
> 3 FastEthernet interfaces
> DRAM configuration is 64 bits wide with parity disabled.
> 55K bytes of NVRAM.
> 31744K bytes of ATA System CompactFlash (Read/Write)
> 62720K bytes of ATA Slot0 CompactFlash (Read/Write)
> Configuration register is 0x2102
> Router#
> Пингую с удаленной машины ping 2.2.2.82 -r 9 хост подключенный к cisco,
> пакеты к хосту идут по одному маршруту, а возвращаются по маршруту
> по-умолчанию, а должны возвращатьсяпо route-map

Попробуй так: set ip next-hop recursive 3.3.3.105

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Route-map не пенераправляет трафик"  +/
Сообщение от tootsie on 29-Янв-18, 15:13 
>[оверквотинг удален]
>> DRAM configuration is 64 bits wide with parity disabled.
>> 55K bytes of NVRAM.
>> 31744K bytes of ATA System CompactFlash (Read/Write)
>> 62720K bytes of ATA Slot0 CompactFlash (Read/Write)
>> Configuration register is 0x2102
>> Router#
>> Пингую с удаленной машины ping 2.2.2.82 -r 9 хост подключенный к cisco,
>> пакеты к хосту идут по одному маршруту, а возвращаются по маршруту
>> по-умолчанию, а должны возвращатьсяпо route-map
> Попробуй так: set ip next-hop recursive 3.3.3.105

запустили deb ip poli. показывает всё правильно, что для пакетов попавших под acc list следующий шлюз 3.3.3.105.

В заблуждении ввело, то, что ping -r 9 и tracert показывают разные маршруты и MRTG не показывает на внешнем интерфейсе исходящий трафик равный входящему трафику на внутреннем интерфейсе. в МRTG на внешнем интерфейсе трафик отображается неадекватно внутреннему интефрейса
и очень сильное падение исходящей скорости на внешнем интерфейсе
и очень сильное падение исходящей скорости.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Route-map не пенераправляет трафик"  +/
Сообщение от fantom (??) on 29-Янв-18, 23:31 
>[оверквотинг удален]
>>> по-умолчанию, а должны возвращатьсяпо route-map
>> Попробуй так: set ip next-hop recursive 3.3.3.105
> запустили deb ip poli. показывает всё правильно, что для пакетов попавших под
> acc list следующий шлюз 3.3.3.105.
> В заблуждении ввело, то, что ping -r 9 и tracert показывают разные
> маршруты и MRTG не показывает на внешнем интерфейсе исходящий трафик равный
> входящему трафику на внутреннем интерфейсе. в МRTG на внешнем интерфейсе трафик
> отображается неадекватно внутреннему интефрейса
> и очень сильное падение исходящей скорости на внешнем интерфейсе
> и очень сильное падение исходящей скорости.

Все... мозк вскипел и испарился...

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor