The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]



"Перенаправление с одного IP на другой"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]
Курсы Сisco по безопасности (CCNA и CCNP Security, Сisco ISE 2.1, ASA, IronPort)
"Перенаправление с одного IP на другой"  +/
Сообщение от alex6999 email(ok) on 30-Ноя-17, 22:07 
Задача: обход блокировок рутрекера
Что надо сделать на примере других ОС

Linux:
iptables -t nat -A OUTPUT -p tcp -m tcp --dport 80 -d 195.82.146.120/30 -j DNAT --to-destination 163.172.167.207:3128

Microtick:
ip firewall nat add chain=dstnat action=dst-nat \ protocol=tcp src-address=IpAdressTorrentDevice dst-address=195.82.146.120/30 dst-port=80 \ to-addresses=163.172.167.207 to-ports=3128

Keenetic:
ip static tcp 195.82.146.120 255.255.255.252 80 163.172.167.207 3128

Пытаюсь на Cisco написать
ip nat inside source static tcp 195.82.146.120 80 163.172.167.207 3128
не работает, outside тоже
в конфиге добавляет extendable в конец строки

Как правильно написать? спасибо

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Перенаправление с одного IP на другой"  +/
Сообщение от fantom (??) on 30-Ноя-17, 22:21 
>[оверквотинг удален]
> Microtick:
> ip firewall nat add chain=dstnat action=dst-nat \ protocol=tcp src-address=IpAdressTorrentDevice
> dst-address=195.82.146.120/30 dst-port=80 \ to-addresses=163.172.167.207 to-ports=3128
> Keenetic:
> ip static tcp 195.82.146.120 255.255.255.252 80 163.172.167.207 3128
> Пытаюсь на Cisco написать
> ip nat inside source static tcp 195.82.146.120 80 163.172.167.207 3128
> не работает, outside тоже
> в конфиге добавляет extendable в конец строки
> Как правильно написать? спасибо

интерфейсы определить не не забыли?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Перенаправление с одного IP на другой"  +/
Сообщение от alex6999 email(ok) on 01-Дек-17, 07:22 
> интерфейсы определить не не забыли?

не подскажете как определить?

interface GigabitEthernet0/0
description LAN
ip address 10.0.0.1 255.255.0.0
ip nat inside
ip rip send version 2
ip rip receive version 2
ip virtual-reassembly in
duplex auto
speed auto
media-type sfp
negotiation auto
hold-queue 32 in
hold-queue 100 out
!
interface GigabitEthernet0/1
description Eth-WAN
ip dhcp client client-id ascii modem
ip dhcp client class-id ISP
ip dhcp client hostname Surfboard
ip dhcp client lease 0 1 0
ip address dhcp
ip nat outside
ip rip send version 2
ip rip receive version 2
ip virtual-reassembly in
duplex auto
speed auto
media-type rj45
!
!
ip nat inside source list 100 interface GigabitEthernet0/1 overload
ip nat inside source static tcp 195.82.146.120 80 163.172.167.207 3128 extendable
ip route 0.0.0.0 0.0.0.0 192.168.0.1 254
ip route 0.0.0.0 0.0.0.0 192.168.0.1 254
!
ip access-list standard nat
permit any
!
access-list 100 permit ip 10.0.0.0 0.255.255.255 any

не совсем понимаю откуда у меня взялись в конфиге 2 повторяющиеся строчки
192.168.0.1 это gateway получаемый по DHCP на интерфейсе Eth-WAN
вроде правильно, но я их не добавлял.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Перенаправление с одного IP на другой"  +/
Сообщение от fantom (??) on 01-Дек-17, 08:14 

>> ip nat inside source static tcp 195.82.146.120 80 163.172.167.207 3128 extendable

Адреса - порты местами переставьте.
ip nat inside source static tcp  163.172.167.207 3128 195.82.146.120 80 extendable

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Перенаправление с одного IP на другой"  +/
Сообщение от alex6999 email(ok) on 01-Дек-17, 09:11 
> Адреса - порты местами переставьте.
> ip nat inside source static tcp  163.172.167.207 3128 195.82.146.120 80 extendable

не работает
а вот так заработало, спасибо.
ip nat OUTSIDE source static tcp  163.172.167.207 3128 195.82.146.120 80 extendable

можно-ли както записать все это в одну строку?
ip nat outside source static tcp  163.172.167.207 3128 195.82.146.120 80 extendable
ip nat outside source static tcp  163.172.167.207 3128 195.82.146.121 80 extendable
ip nat outside source static tcp  163.172.167.207 3128 195.82.146.122 80 extendable
ip nat outside source static tcp  163.172.167.207 3128 195.82.146.123 80 extendable

PS: вторая строка не добавляется, пишет:
% 163.172.167.207 already mapped (195.82.146.120 -> 163.172.167.207)

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Перенаправление с одного IP на другой"  +/
Сообщение от fantom (??) on 01-Дек-17, 19:09 
>[оверквотинг удален]
> не работает
> а вот так заработало, спасибо.
> ip nat OUTSIDE source static tcp  163.172.167.207 3128 195.82.146.120 80 extendable
> можно-ли както записать все это в одну строку?
> ip nat outside source static tcp  163.172.167.207 3128 195.82.146.120 80 extendable
> ip nat outside source static tcp  163.172.167.207 3128 195.82.146.121 80 extendable
> ip nat outside source static tcp  163.172.167.207 3128 195.82.146.122 80 extendable
> ip nat outside source static tcp  163.172.167.207 3128 195.82.146.123 80 extendable
> PS: вторая строка не добавляется, пишет:
> % 163.172.167.207 already mapped (195.82.146.120 -> 163.172.167.207)

Что логично. Это ж вам не балансировщик нагрузки а редирект.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Перенаправление с одного IP на другой"  +/
Сообщение от alex6999 email(ok) on 01-Дек-17, 20:23 
> Что логично. Это ж вам не балансировщик нагрузки а редирект.

Как тогда все 4 адреса 195.82.146.120/30 80
завести на 163.172.167.207 3128?
фактически это прокси

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Перенаправление с одного IP на другой"  +/
Сообщение от fantom (??) on 02-Дек-17, 00:30 
>> Что логично. Это ж вам не балансировщик нагрузки а редирект.
> Как тогда все 4 адреса 195.82.146.120/30 80
> завести на 163.172.167.207 3128?
> фактически это прокси

Вам прозрачный прокси нужен?
Или через PBR или  wccp

http://bezopasnik.org/unix/dok/Soft/squid/16.htm

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Перенаправление с одного IP на другой"  +/
Сообщение от alex6999 email(ok) on 02-Дек-17, 06:01 
> Вам прозрачный прокси нужен?
> Или через PBR или  wccp
> http://bezopasnik.org/unix/dok/Soft/squid/16.htm

вам не кажется что на вопрос "как отпилить доску под 30 градусов?"
вы предлагаете купить деревообрабатывающий завод?

неужели не существует изящной записи?


Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Перенаправление с одного IP на другой"  +/
Сообщение от fantom (??) on 02-Дек-17, 23:10 
>> Вам прозрачный прокси нужен?
>> Или через PBR или  wccp
>> http://bezopasnik.org/unix/dok/Soft/squid/16.htm
> вам не кажется что на вопрос "как отпилить доску под 30 градусов?"
> вы предлагаете купить деревообрабатывающий завод?
> неужели не существует изящной записи?

Ага, наконец сложил чего вы хотите от циски получить.
ip nat outside source ?    
  list       Specify access list describing global addresses
  route-map  Specify route-map
  static     Specify static global->local mapping

попробуйте поиграться с роутмапами и ACL - ами.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2017 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor