The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  вход/выход  слежка  RSS
"Помогите начинающему с MSTP"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Помогите начинающему с MSTP"  +/
Сообщение от Celsius (ok) on 27-Фев-17, 17:35 
Здравствуйте,
Начал изучать MSTP (на примере cisco), делаю как в статье:
http://blog.ine.com/2010/02/22/understanding-mstp/#MSTP_ONE_...

Доделал самую простую настройку с 3-мя коммутаторами и одним регионом.
http://i12.pixs.ru/storage/0/9/8/mstppng_7774597_25323098.png

соединения следующие:
SW-3 MST 0
SW-1 MST 1 (vlan 10,20,30)
SW-2 MST 2 (vlan 40,50,60)

SW-3 e0/0 -> SW-1 e0/1
SW-3 e0/1 -> SW-2 e0/1
SW-1 e0/0 -> SW-2 e0/0

(Делаю на eve-ng 2.0.2-26 (бывший unetlab), с образом Cisco IOL
i86bi_linux_l2-ipbasek9-ms.jan24-2013-team_track.bin)

************************************************************************
общие Настройки для sw-1, sw-2, sw-3:

spanning-tree mode mst
spanning-tree extend system-id
spanning-tree mst configuration
name REGION1
instance 1 vlan 10, 20, 30
instance 2 vlan 40, 50, 60

на sw-1:
spanning-tree mst 1 priority 8192

на sw-2:
spanning-tree mst 2 priority 8192

на sw-3:
spanning-tree mst 0 priority 8192

настройки интерфейсов:

interface Ethernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
duplex auto

interface Ethernet0/1
switchport trunk encapsulation dot1q
switchport mode access
duplex auto

для портов доступа:

interface Ethernet0/2
switchport access vlan 10
switchport mode access
duplex auto
spanning-tree portfast

interface Ethernet0/3
switchport access vlan 40
switchport mode access
duplex auto
spanning-tree portfast

*********************************************************************
*********************************************************************
В итоге работает неправильно и нет Altn порта.
Возможно дело в приоритетах, но думал, что mst0 и так имеет низший приоритет (пробовал ставить 4096 - ничего).
Я правильно понимаю, что даже в этой конфигурации, при обрыве любого линка от SW-3,
все vlan'ы должны передаваться по оставшемуся линку от SW-3 и линку между SW-1 и SW-2?

*********************************************************************
*********************************************************************

sw-1#show spanning-tree mst configuration
Name      [REGION1]
Revision  0     Instances configured 3

Instance  Vlans mapped
--------  ---------------------------------------------------------------------
0         1-9,11-19,21-29,31-39,41-49,51-59,61-4094
1         10,20,30
2         40,50,60
-------------------------------------------------------------------------------

sw-1#show spanning-tree mst

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-49,51-59,61-4094
Bridge        address aabb.cc00.1000  priority      32768 (32768 sysid 0)
Root          address aabb.cc00.3000  priority      8192  (8192 sysid 0)
              port    Et0/1           path cost     0
Regional Root address aabb.cc00.3000  priority      8192  (8192 sysid 0)
                                      internal cost 2000000   rem hops 19
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Et0/0            Desg FWD 2000000   128.1    Shr
Et0/1            Root FWD 2000000   128.2    Shr
Et0/2            Desg FWD 2000000   128.3    Shr Edge
Et0/3            Desg FWD 2000000   128.4    Shr Edge

##### MST1    vlans mapped:   10,20,30
Bridge        address aabb.cc00.1000  priority      8193  (8192 sysid 1)
Root          this switch for MST1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Et0/0            Desg FWD 2000000   128.1    Shr
Et0/1            Desg FWD 2000000   128.2    Shr
Et0/2            Desg FWD 2000000   128.3    Shr Edge

##### MST2    vlans mapped:   40,50,60
Bridge        address aabb.cc00.1000  priority      32770 (32768 sysid 2)
Root          address aabb.cc00.2000  priority      8194  (8192 sysid 2)
              port    Et0/0           cost          2000000   rem hops 19

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Et0/0            Root FWD 2000000   128.1    Shr
Et0/1            Desg FWD 2000000   128.2    Shr
Et0/3            Desg FWD 2000000   128.4    Shr Edge

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Помогите начинающему с MSTP"  +/
Сообщение от Celsius (ok) on 27-Фев-17, 21:42 
>interface Ethernet0/1
>switchport trunk encapsulation dot1q
>switchport mode access!!! вместо trunk
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Помогите начинающему с MSTP"  +/
Сообщение от fantom (ok) on 28-Фев-17, 08:23 
>>interface Ethernet0/1
>>switchport trunk encapsulation dot1q
>>switchport mode access!!! вместо trunk

Угу, на КАЖДОМ свиче должно быть по 2!! транка.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor