The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"PPPoE на cisco7200"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"PPPoE на cisco7200"  +/
Сообщение от drumisco email(ok) on 26-Апр-10, 10:43 
Здравствуйте! не получается настроить pppoe на cisco7200.
схема подключения проста - PC напрямую подключен к интерфейсу gigabit0/3 и через подключение конекчусь с выбранным логином и паролем. Вылазит ошибка,что такие пароль и логин не допустимы.
конфиг такой:
aaa authentication login local_authen local
aaa authentication ppp default local
aaa authorization exec default local
aaa authorization exec local_author local
aaa authorization network default local
aaa accounting delay-start

vpdn enable
!
vpdn-group 1
!
bba-group pppoe global
virtual-template 1
!
!
interface GigabitEthernet0/3
no ip address
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
media-type rj45
negotiation auto
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
!        
interface Virtual-Template1
no ip route-cache cef
peer default ip address dhcp-pool PPPoEpool
ppp authentication pap callin
ppp timeout retry 15
ppp timeout authentication 15
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname krolik
ppp chap password 7 045E110F04
ppp pap sent-username krolik password 7 030141020D
!        
ip local pool dialup 192.168.10.200 192.168.10.202
ip local pool PPPoEpool 10.10.10.1 10.10.10.254
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip nat inside source list 1 interface Dialer1 overload

Что не так, подскажите!

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

  • PPPoE на cisco7200, ShyLion, 11:44 , 26-Апр-10, (1)  
    • PPPoE на cisco7200, drumisco, 12:27 , 26-Апр-10, (3)  
      • PPPoE на cisco7200, ShyLion, 12:40 , 26-Апр-10, (6)  
  • PPPoE на cisco7200, ShyLion, 11:46 , 26-Апр-10, (2)  
    • PPPoE на cisco7200, drumisco, 12:30 , 26-Апр-10, (4)  
      • PPPoE на cisco7200, ShyLion, 12:39 , 26-Апр-10, (5)  
        • PPPoE на cisco7200, drumisco, 12:49 , 26-Апр-10, (7)  
          • PPPoE на cisco7200, ShyLion, 13:24 , 26-Апр-10, (8)  
          • PPPoE на cisco7200, ShyLion, 13:33 , 26-Апр-10, (9)  
            • PPPoE на cisco7200, drumisco, 16:00 , 27-Апр-10, (10)  
              • PPPoE на cisco7200, ShyLion, 16:08 , 27-Апр-10, (11)  
                • PPPoE на cisco7200, drumisco, 16:37 , 27-Апр-10, (12)  
                  • PPPoE на cisco7200, ShyLion, 16:46 , 27-Апр-10, (13)  
                    • PPPoE на cisco7200, drumisco, 13:58 , 28-Апр-10, (14)  
                      • PPPoE на cisco7200, ShyLion, 14:56 , 28-Апр-10, (15)  
                      • PPPoE на cisco7200, ShyLion, 15:01 , 28-Апр-10, (16)  
                        • PPPoE на cisco7200, drumisco, 17:18 , 28-Апр-10, (17)  
                        • PPPoE на cisco7200, ShyLion, 07:08 , 29-Апр-10, (18)  
                        • PPPoE на cisco7200, drumisco, 09:19 , 29-Апр-10, (19)  
                        • PPPoE на cisco7200, drumisco, 15:39 , 29-Апр-10, (20)  

Сообщения по теме [Сортировка по времени | RSS]


1. "PPPoE на cisco7200"  +/
Сообщение от ShyLion (ok) on 26-Апр-10, 11:44 
>interface Virtual-Template1
> no ip route-cache cef
> peer default ip address dhcp-pool PPPoEpool
> ppp authentication pap callin
> ppp timeout retry 15
> ppp timeout authentication 15
>!

Не указан адрес "локальной" стороны интерфейса, обычно unnumbered на лупбек или какой другой фейс
и еще не видно как заведен пользователь?
он заведен вообще?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "PPPoE на cisco7200"  +/
Сообщение от drumisco email(ok) on 26-Апр-10, 12:27 
>Не указан адрес "локальной" стороны интерфейса, обычно unnumbered на лупбек или какой
>другой фейс
>и еще не видно как заведен пользователь?
>он заведен вообще?

сейчас стоит так

interface Virtual-Template1
bandwidth 10000
ip unnumbered Loopback0
ip nat inside
ip virtual-reassembly
no ip route-cache cef
peer default ip address pool PPPoEpool
ppp authentication chap
ppp timeout retry 15
ppp timeout authentication 15

ну а пользователь указан в
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname krolik
ppp chap password 7 0824564702

или это не то?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "PPPoE на cisco7200"  +/
Сообщение от ShyLion (ok) on 26-Апр-10, 12:40 
>или это не то?

это для противоположных целей вещи, друг с другом никак не связаны, см. ниже

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "PPPoE на cisco7200"  +/
Сообщение от ShyLion (ok) on 26-Апр-10, 11:46 
>Здравствуйте! не получается настроить pppoe на cisco7200.
>схема подключения проста - PC напрямую подключен к интерфейсу gigabit0/3 и через
>подключение конекчусь с выбранным логином и паролем.

Еще, кстати, не понятно кто к чему должен коннектиться. Если киса к компу, тогда не нужен темплейт и vpdn, если наоборот, то не нужен dialer.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "PPPoE на cisco7200"  +/
Сообщение от drumisco email(ok) on 26-Апр-10, 12:30 
>>Здравствуйте! не получается настроить pppoe на cisco7200.
>>схема подключения проста - PC напрямую подключен к интерфейсу gigabit0/3 и через
>>подключение конекчусь с выбранным логином и паролем.
>
>Еще, кстати, не понятно кто к чему должен коннектиться. Если киса к
>компу, тогда не нужен темплейт и vpdn, если наоборот, то не
>нужен dialer.

нужно с компа конектиться к циске. на компе создано соединение с лг и пар

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "PPPoE на cisco7200"  +/
Сообщение от ShyLion (ok) on 26-Апр-10, 12:39 
>>>Здравствуйте! не получается настроить pppoe на cisco7200.
>>>схема подключения проста - PC напрямую подключен к интерфейсу gigabit0/3 и через
>>>подключение конекчусь с выбранным логином и паролем.
>>
>>Еще, кстати, не понятно кто к чему должен коннектиться. Если киса к
>>компу, тогда не нужен темплейт и vpdn, если наоборот, то не
>>нужен dialer.
>
>нужно с компа конектиться к циске. на компе создано соединение с лг
>и пар

interface dialer и соответственно pppoe-client это для исходящего вызова С циски, когда например к интернету надо подцепить ее посредством pppoe

для работы входящего pppoe делается так (на 28 серии, как на 72 - надо уточнять)

aaa authentication ppp default local
aaa authorization network default local
!
username vasia password vasia
!
vpdn enable
!
vpdn-group 1
accept-dialin
  protocol pppoe
  virtual-template 1
!
interface Virtual-Template1
и далее

на cisco.com примеров масса на эту тему

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "PPPoE на cisco7200"  +/
Сообщение от drumisco email(ok) on 26-Апр-10, 12:49 
>на cisco.com примеров масса на эту тему

вот потому и обратился на форум, что не нашел там того чего нужно! А тут снова гонят на другие источники...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "PPPoE на cisco7200"  +/
Сообщение от ShyLion (ok) on 26-Апр-10, 13:24 
>>на cisco.com примеров масса на эту тему
>
>вот потому и обратился на форум, что не нашел там того чего
>нужно! А тут снова гонят на другие источники...

ничего удивительного :)
это примитивная задача обычного входящего PPP, то, что он "oE" это маленький нюанс из нескольких строк с vpdn. Все остальное одинаково, что для диалапа, что для pptp и прочих PPP.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "PPPoE на cisco7200"  +/
Сообщение от ShyLion (ok) on 26-Апр-10, 13:33 
>>на cisco.com примеров масса на эту тему
>
>вот потому и обратился на форум, что не нашел там того чего
>нужно! А тут снова гонят на другие источники...

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_conf...

username <username> password <password>
!
vpdn enable
!
vpdn-group 1
accept-dialin
  protocol pppoe
  virtual-template 1
  pppoe limit per-mac 100
  pppoe limit per-vc 100
!
!
interface Virtual-Template1
ip unnumbered FastEthernet 4/0
no ip directed-broadcast
peer default ip address pool <pool name>
ppp authentication pap
!
interface FastEthernet 4/0
ip address 172.22.32.1 255.255.255.0
no ip directed-broadcast
!
ip local pool <pool name> 172.22.32.20 172.22.32.100
!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "PPPoE на cisco7200"  +/
Сообщение от drumisco email(ok) on 27-Апр-10, 16:00 
>>>на cisco.com примеров масса на эту тему
>>
>>вот потому и обратился на форум, что не нашел там того чего
>>нужно! А тут снова гонят на другие источники...
>
>http://www.cisco.com/en/US/tech/tk175/tk15/technologies_conf...

Все попробовал - не работает!
К циске напрямую подключаюсь через комп, и через него и пытаюсь подрубиться!
И ничего не выходит!
Ну помогите пожалуйста!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

11. "PPPoE на cisco7200"  +/
Сообщение от ShyLion (ok) on 27-Апр-10, 16:08 
>И ничего не выходит!
>Ну помогите пожалуйста!

давай крайний конфиг

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

12. "PPPoE на cisco7200"  +/
Сообщение от drumisco email(ok) on 27-Апр-10, 16:37 
>>И ничего не выходит!
>>Ну помогите пожалуйста!
>
>давай крайний конфиг

Вот он:

version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname C7206.MTS
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging snmp-authfail
logging queue-limit 100
logging buffered 51200 debugging
logging console critical
enable secret 5 **
enable password 7 **
!
aaa new-model
!
!
aaa authentication ppp default local
aaa authorization network default if-authenticated
!
aaa session-id common
!
resource policy
!
clock timezone PCTime 6
ip subnet-zero
no ip source-route
ip cef
!
!
!
!
ip flow-cache timeout active 1
no ip bootp server
ip domain name **
vpdn enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username alex09 password **
!
!
controller T3 1/0
!        
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface GigabitEthernet0/2
no ip address
ip nat inside
ip virtual-reassembly
shutdown
duplex auto
speed auto
media-type rj45
no negotiation auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/3
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
media-type rj45
no negotiation auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username krolik password 7 104B13100E
!
ip local pool PPPoE 10.10.10.1 10.10.10.254
ip classless
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface Dialer1 overload
!
logging alarm informational
logging trap debugging
dialer-list 1 protocol ip permit
snmp-server community public RO
!
!
!
!
control-plane
!
!        
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
login authentication local_authen
transport output telnet
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

13. "PPPoE на cisco7200"  +/
Сообщение от ShyLion (ok) on 27-Апр-10, 16:46 
>>>И ничего не выходит!
>>>Ну помогите пожалуйста!
>>
>>давай крайний конфиг
>
>Вот он:

ну и чего тут общего с последним примером, который я скидывал?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

14. "PPPoE на cisco7200"  +/
Сообщение от drumisco email(ok) on 28-Апр-10, 13:58 
>ну и чего тут общего с последним примером, который я скидывал?

service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname C7206.MTS
!
boot-start-marker
boot-end-marker
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication ppp default local
aaa authorization exec default local
aaa authorization network default local
aaa authorization network PPPoE local
aaa accounting update periodic 5
!        
aaa session-id common
!
resource policy
!
ip subnet-zero
ip cef
!
!
!
!
vpdn enable
!
!
!
!
!
!
!
!
!
!
!
!        
!
!
!
!
username alex09 password 0 atmosfera2030
!
!
controller T3 1/0
!
!
!
!
!
bba-group pppoe global
virtual-template 1
sessions max limit 10
ac name nas1
sessions per-mac limit 1
sessions per-vlan limit 5
sessions auto cleanup
!
!
interface Loopback0
no ip address
!
interface GigabitEthernet0/1
ip address 1.1.1.1 255.255.255.0
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
media-type rj45
no negotiation auto
pppoe enable group global
no cdp enable
!
interface GigabitEthernet0/3
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface Virtual-Template1
mtu 1492
ip unnumbered Loopback0
ip route-cache flow
autodetect encapsulation ppp
peer default ip address pool PPPoE
ppp max-bad-auth 3
ppp authentication chap pap callin PPPoE
ppp authorization PPPoE
ppp timeout retry 3
ppp timeout authentication 45
ppp timeout idle 3
!
ip local pool PPPoE 10.10.10.10 10.10.10.100
ip classless
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
snmp-server community public RO 1
snmp-server community private RW 1
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
access-class 1 in
exec-timeout 0 0
!
!
end

вот он новый конфиг!
оно заработало!!! оказывается, когда я с компьютора пытался подконнектиться, то вводил постоянно не те логин и пароль! но это еще не все!
Теперь через Gi0/1 я подключен к хабу который по dhcp раздает ip и выход в интернет. Выходит на циске так:
*Apr 28 01:29:53: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to up
*Apr 28 01:29:53: %ENTITY_ALARM-6-INFO: CLEAR CRITICAL Gi0/1 Physical Port Link Down
*Apr 28 01:29:54: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
*Apr 28 01:29:56: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to up
*Apr 28 01:29:57: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to up
*Apr 28 01:29:59: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down
*Apr 28 01:30:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to down

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

15. "PPPoE на cisco7200"  +/
Сообщение от ShyLion (ok) on 28-Апр-10, 14:56 
>aaa authentication ppp default local
>aaa authorization network default local
>aaa authorization network PPPoE local
>interface Virtual-Template1
> ppp authentication chap pap callin PPPoE
> ppp authorization PPPoE
>вот он новый конфиг!
>оно заработало!!! оказывается, когда я с компьютора пытался подконнектиться, то вводил

тут тоже ошибка

нету aaa authentication ppp PPPoE local
а aaa authentication ppp default local - лишнее

хотя видимо при отсутствии именованого метода использует дефолтный, но все равно надо поправить


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

16. "PPPoE на cisco7200"  +/
Сообщение от ShyLion (ok) on 28-Апр-10, 15:01 
>interface Virtual-Template1
> ppp timeout idle 3

3 секунды на idle??? не маловато-ли? оно еще линк поднять не успеет, как отрубать пора.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

17. "PPPoE на cisco7200"  +/
Сообщение от drumisco email(ok) on 28-Апр-10, 17:18 
>>interface Virtual-Template1
>> ppp timeout idle 3
>
>3 секунды на idle??? не маловато-ли? оно еще линк поднять не успеет,
>как отрубать пора.

все исправил, ситуация по сути не изменилась:
на компе берет адрес из пула:
IP-адрес  . . . . . . . . . . . . : 10.10.10.10
Маска подсети . . . . . . . . . . : 255.255.255.255
Основной шлюз . . . . . . . . . . : 10.10.10.10
порт поднимется idl 20, а потом так же падает!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

18. "PPPoE на cisco7200"  +/
Сообщение от ShyLion (ok) on 29-Апр-10, 07:08 
> interface Virtual-Template1
>   autodetect encapsulation ppp

encapsulation ppp

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

19. "PPPoE на cisco7200"  +/
Сообщение от drumisco email(ok) on 29-Апр-10, 09:19 
>> interface Virtual-Template1
>>   autodetect encapsulation ppp
>
>encapsulation ppp

Вроде все исправил, но с компа не могу выйти в инет!
Проблема кроется в настройке Loopback и Gi0/1 который подключен к хабу который по dhcp раздает адреса...

ноут---С7200---хаб---интернет

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

20. "PPPoE на cisco7200"  +/
Сообщение от drumisco email(ok) on 29-Апр-10, 15:39 
Заработала!
Вот реальный конфиг!

service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname C7206.MTS
!
boot-start-marker
boot-end-marker
!
enable password 123
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication ppp PPPoE local
aaa authorization exec default local
aaa authorization network default local
aaa authorization network PPPoE local
aaa accounting delay-start
aaa accounting update periodic 5
!
aaa session-id common
!
resource policy
!
ip subnet-zero
ip cef
!
!
vpdn enable
!
!
username 456 password 0 456
!
!
bba-group pppoe global
virtual-template 1
sessions max limit 10
ac name nas1
sessions per-mac limit 1
sessions per-vlan limit 5
sessions auto cleanup
!
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface GigabitEthernet0/1
ip address 192.168.1.50 255.255.255.0
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
media-type rj45
no negotiation auto
pppoe enable group global
no cdp enable
!
interface GigabitEthernet0/3
no ip address
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface Virtual-Template1
mtu 1492
ip unnumbered Loopback0
ip access-group 100 in
ip access-group 100 out
no ip route-cache cef
no ip route-cache
peer default ip address pool PPPoE
ppp max-bad-auth 3
ppp authentication chap pap callin PPPoE
ppp authorization PPPoE
ppp ipcp dns ххх ххх
ppp timeout retry 3
ppp timeout authentication 45
!
ip local pool PPPoE 10.10.10.2 10.10.10.100
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1 (шлюз выхода в мир)
no ip http server
no ip http secure-server
!
!
logging alarm informational
snmp-server community public RO 1
snmp-server community private RW 1
!
!
control-plane
!
!
gatekeeper
shutdown
!
!        
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
access-class 1 in
exec-timeout 0 0
!
!
end


Но теперь иная задача! Нужно организовать такую сеть:
         _____
клиент--|     |
        |     |trunk
клиент--|swich|------cisco7206---internet
        |     |
клиент--|_____|

Для каждого клиента создавать interface Virtual-Template ?
Как обезопасить доступ на рутер клиентов?
Нужны ли vlan-ы?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру