The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Помогите прописать IP чтобы создать подсети на Cisco 1841"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от KudriK_TF email(ok) on 03-Фев-10, 10:08 
Люди, помогите пожалуйста, я уже неделю обитаю на форуме и наверное всех достал, но извините, вашу помощь сложно переоценить!! Проблема вот в чем, я настроил на Cisco 1841 PPPoE, подключил ее к провайдеру через ADSL модем, работающий в режиме моста. Эта cisco будет стоять в крупной сети, и надо распределить IP следующим образом, чтобы они не повторялись внутри сети и чтобы на каждую cisco приходилось примерно по 126 ip внутренней раздачи по dhcp.
я решил использовать сеть 172.16.0.0 c маской 255.255.255.128, первые 10 ip исключить из dhcp а остальные пусть раздает, забиваю в конфиг и ничего не работает. мне еще надо просто 14 сетей с неповторяющимися и я хотел сделать так: 172.16.0.0 /25 ; 172.16.0.128 /25 ; 172.16.1.0 /25 и т.д.Помогите пожалуйста, где я ошибся?

Building configuration...

Current configuration : 1585 bytes
!
version 12.4
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$LsED$LXMPxJ35T/ylSdUK8CRWH1
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.0.1 172.16.0.10
!
ip dhcp pool k
   import all
   network 172.16.0.0 255.255.255.128
   default-router 172.16.0.1
!
!
multilink bundle-name authenticated
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pppoe
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.0.1 255.255.255.128
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
duplex auto
speed auto
no cdp enable
hold-queue 32 in
!
interface FastEthernet0/1
no ip address
ip tcp adjust-mss 1452
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip access-group 110 in
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp chap hostname omkc77009
ppp chap password 7 075C254D1E081A5312
ppp ipcp dns request
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
ip nat inside source list 102 interface Dialer0 overload
!
access-list 102 permit ip 172.16.0.0 0.0.0.128 any
access-list 110 permit tcp any any gt 1023 established
access-list 110 permit ip any any
!
!
control-plane
!
!
line con 0
password 7 121A0C041104
login
line aux 0
line vty 0 4
password 7 14141B180F0B
login
!
scheduler allocate 20000 1000
end

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от gleb.poljakov email on 03-Фев-10, 11:04 
у тебя 1841 будет обслуживать все эти сети?

схемку сети изобрази.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от KudriK_TF email(ok) on 03-Фев-10, 11:10 
>у тебя 1841 будет обслуживать все эти сети?
>
>схемку сети изобрази.

нет, схема простая, 1841 будет обслуживать только свою сеть , ну например: adsl модем - 1841 - catalist 2960 - компы, а через adsl связываться с другими сетями, и есть условие чтобы ip в различных сетях не повторялись. Например, первая cisco обслуживает сеть  172.16.0.0 /25 , вторая 172.16.0.128 /25 , третья 172.16.1.0 /25. вот так вот, как мне это прописать на одной 1841, а то тот конфиг который я привел - он не работает, комп включен напрямую в 1841 в порт fa 0/0. что делать?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от gleb.poljakov email on 03-Фев-10, 11:32 
>[оверквотинг удален]
>>схемку сети изобрази.
>
>нет, схема простая, 1841 будет обслуживать только свою сеть , ну например:
>adsl модем - 1841 - catalist 2960 - компы, а через
>adsl связываться с другими сетями, и есть условие чтобы ip в
>различных сетях не повторялись. Например, первая cisco обслуживает сеть  172.16.0.0
>/25 , вторая 172.16.0.128 /25 , третья 172.16.1.0 /25. вот так
>вот, как мне это прописать на одной 1841, а то тот
>конфиг который я привел - он не работает, комп включен напрямую
>в 1841 в порт fa 0/0. что делать?

         172.16.0.128/25
                 |
172.16.0.0/25   |   172.16.1.0/25
            \    |    /
             \   |   /
              \  |  /
               router
                 |
               adsl
                 |
               c1841
                 |
               c2960


такая схема?
если да, то какой адрес у "router" на линке со стороны adls-модема?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от KudriK_TF email(ok) on 03-Фев-10, 11:57 
>[оверквотинг удален]
>   c1841
>            
>     |
>            
>   c2960
>
>
>такая схема?
>если да, то какой адрес у "router" на линке со стороны adls-модема?
>

      c2960
>      |
>   c1841 (172.16.0.128/25)
>      |      

     adsl
>     |          

провайдер
>     |      
>   adsl
>            
>     |
>            
>   c1841 (172.16.0.0/25)
>            
>     |
>            
>   c2960

если схематически то такая

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от KudriK_TF email(ok) on 03-Фев-10, 11:31 
>у тебя 1841 будет обслуживать все эти сети?
>
>схемку сети изобрази.

т.е. схема очень проста, никаких связей пока,между сетями не будет, но как это прописать, этот конфиг рабочий, я проверял его если в ставить следующие параметры:
ip dhcp pool k
   import all
   network 172.16.0.0 255.255.255.0
   default-router 172.16.0.1

ip dhcp excluded-address 172.16.0.1 172.16.0.10

interface FastEthernet0/0
ip address 172.16.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
duplex auto
speed auto
no cdp enable
hold-queue 32 in
!

ip route 0.0.0.0 0.0.0.0 Dialer0

ip nat inside source list 102 interface Dialer0 overload
!
access-list 102 permit ip 172.16.0.0 0.0.0.255 any
access-list 110 permit tcp any any gt 1023 established
access-list 110 permit ip any any


и все работало на ура!
а теперь нет, я просто очень не сведущ в этих делах, и все изучаю методом проб и ошибок

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от gleb.poljakov email on 03-Фев-10, 11:34 
зачем access-list 110?
ты знаешь что рубишь им коннекты по портам меньше 1022 по протоколу tcp?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от KudriK_TF email(ok) on 03-Фев-10, 11:52 
>зачем access-list 110?
>ты знаешь что рубишь им коннекты по портам меньше 1022 по протоколу
>tcp?

ммм, да я дуб дерево береза в этом вопросе, я знаю что я им делаю, слушай, а что ты предлагаешь в нем прописать?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от KudriK_TF email(ok) on 03-Фев-10, 11:59 
>зачем access-list 110?
>ты знаешь что рубишь им коннекты по портам меньше 1022 по протоколу
>tcp?

а может вообще эту строку убрать, оставить только access-list ip any any&

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от kdi on 03-Фев-10, 11:47 
для начала
access-list 102 permit ip 172.16.0.0 0.0.0.127 any
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от KudriK_TF email(ok) on 03-Фев-10, 11:53 
>для начала
>access-list 102 permit ip 172.16.0.0 0.0.0.127 any

хорошо, спасибо, щас попробую

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

12. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от KudriK_TF email(ok) on 03-Фев-10, 12:30 
>для начала
>access-list 102 permit ip 172.16.0.0 0.0.0.127 any

не помогло, ping в сеть не проходит, проверял на ya.ru, и как то странно - у меня сеть отображается с маской 255.255.255.0

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

11. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от Xen (ok) on 03-Фев-10, 12:29 

>я хотел сделать так: 172.16.0.0 /25 ; 172.16.0.128 /25 ; 172.16.1.0
>/25 и т.д.Помогите пожалуйста, где я ошибся?

Сделай саб интерфейсы с этими сетями.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

13. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от KudriK_TF email(ok) on 03-Фев-10, 12:31 
>
>>я хотел сделать так: 172.16.0.0 /25 ; 172.16.0.128 /25 ; 172.16.1.0
>>/25 и т.д.Помогите пожалуйста, где я ошибся?
>
>Сделай саб интерфейсы с этими сетями.

можно маленько по конкретней, что сделать?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

14. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от KudriK_TF email(ok) on 03-Фев-10, 12:49 
Ребят, я как думаю, мне надо изменить dhcp c 172.16.0.0 255.255.255.0 на 172.16.0.0 255.255.255.128? access-list с access-list 102 permit ip 172.16.0.0 0.0.0.255 any на access-list 102 permit ip 172.16.0.0 0.0.0.127 any? int fa 0/0 - c ip addr 172.16.0.1 255.255.255.0 на 172.16.0.1 255.255.255.128 и все должно заработать по идее или я не прав?


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

15. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от gleb.poljakov email on 03-Фев-10, 12:53 
>Ребят, я как думаю, мне надо изменить dhcp c 172.16.0.0 255.255.255.0 на
>172.16.0.0 255.255.255.128? access-list с access-list 102 permit ip 172.16.0.0 0.0.0.255 any
>на access-list 102 permit ip 172.16.0.0 0.0.0.127 any? int fa 0/0
>- c ip addr 172.16.0.1 255.255.255.0 на 172.16.0.1 255.255.255.128 и все
>должно заработать по идее или я не прав?

Я же тебе сказал - СХЕМУ СЕТИ ИЗОБРАЗИ.

Тебе невозможно помочь, пока ты не объяснишь все четко.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

17. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от KudriK_TF email(ok) on 03-Фев-10, 13:11 

>Я же тебе сказал - СХЕМУ СЕТИ ИЗОБРАЗИ.
>
>Тебе невозможно помочь, пока ты не объяснишь все четко.

извини, ща сделаю:

>      adsl
>       |
>      c1841
>       |
>     c2960
>     / | \
>    /  |  \ внутренняя сеть с раздачей по dhcp 172.16.0.0\25
>   /   |   \
>  ПК  ПК   ПК
>

тут даже схемы то никакой особой нет, прост надо чтобы было 126 ip во внутренней сети и они все могли ходить в инет, это не те большущие сети которые вы разворачиваете.
а про другие устройства в сети я имел ввиду, что где то еще есть такие же сети и у них внутренние ip совпадать не должны, вот и се.. извините если кого вывожу из состояния равновесия, я не хотел, просто хочу понять почему не работает,ведь вроде больших косяков не наблюдается. Если схема не понятная, могу изобразить несколько по другому

           /провайдер интернета
>         /          |
>        /           |
>      adsl          adsl          
>       |             |
>      c1841         c1841
>       |              |
>     c2960           c2960
>     / | \           / | \
>    /  |  \         /  |  \

внутренняя          внутренняя
сеть с раздачей по   сеть с раздачей по
dhcp 172.16.0.0\25   dhcp 172.16.0.128\25
>   /   |   \
>  ПК  ПК   ПК

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

19. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от gleb.poljakov email on 03-Фев-10, 13:16 
Теперь на интерфейс смотрящий на 2960 подаешь транк.
На нем Создаешь виртуальные сабинтерфейсы.
на каждом сабинтерфейсе прописываешь ip address A.B.C.D netmask

Эти айпишники будет дефолт-гейтами для юзверей.
Создаешь dhcp-пулы.

Цепляешь юзверьские компы в 2960, смотришь как выдаются адреса.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

16. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от gleb.poljakov email on 03-Фев-10, 13:04 
>Ребят, я как думаю, мне надо изменить dhcp c 172.16.0.0 255.255.255.0 на
>172.16.0.0 255.255.255.128? access-list с access-list 102 permit ip 172.16.0.0 0.0.0.255 any
>на access-list 102 permit ip 172.16.0.0 0.0.0.127 any? int fa 0/0
>- c ip addr 172.16.0.1 255.255.255.0 на 172.16.0.1 255.255.255.128 и все
>должно заработать по идее или я не прав?

и еще сразу вывод команд покажи:
show ip int br
show ip route
sho ip protocols

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

18. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от KudriK_TF email(ok) on 03-Фев-10, 13:13 

>и еще сразу вывод команд покажи:
>show ip int br
>show ip route
>sho ip protocols

погодь часик, у нас тут завал на работе, домой доберусь все предоставлю, спасибо большое за понимание и за помощь

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

20. "Помогите прописать IP чтобы создать подсети на Cisco 1841"  +/
Сообщение от KudriK_TF email(ok) on 03-Фев-10, 17:40 
>
>>и еще сразу вывод команд покажи:
>>show ip int br
>>show ip route
>>sho ip protocols

Router#sh ip protocols

Router#sh ip rou
Router#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     172.16.0.0/25 is subnetted, 1 subnets
C       172.16.0.0 is directly connected, FastEthernet0/0
     10.0.0.0/32 is subnetted, 1 subnets
C       10.254.254.254 is directly connected, Dialer0
     94.0.0.0/32 is subnetted, 1 subnets
C       94.137.49.175 is directly connected, Dialer0
S*   0.0.0.0/0 is directly connected, Dialer0
Router#sh ip int br
Any interface listed with OK? value "NO" does not have a valid configuration

Interface                  IP-Address      OK? Method Status                Prot
ocol
FastEthernet0/0            172.16.0.1      YES manual up                    up

FastEthernet0/1            unassigned      YES NVRAM  up                    up

NVI0                       unassigned      NO  unset  up                    up

Virtual-Access1            unassigned      YES unset  up                    up

Dialer0                    94.137.49.175   YES IPCP   up                    up

Router#

народ, спасибо большущее кажется все заработало, пинги летят, все открывается, подцепил компы все открывается, спасибо, конфиги выставил, может еще что подскажете по моему конфигу, что лишнее а что необходимо добавить? да, спасибо за access-list 102 permit ip 172.16.0.0 0.0.0.127 any и лишнюю строку access-list 110 permit tcp any any gt 1023 established. Пасибо

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема



Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру
Hosting by Ihor