The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Мультикаст на WS3560-48TS"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Мультикаст на WS3560-48TS"  +/
Сообщение от DJ_Kill email(??) on 10-Ноя-09, 10:53 
Поможите решить проблемку?

Есть "плоская" сеть: несколько (около 10-ка) коммутаторов.
В одном из VLAN в этой сети ходит мультикаст.
Мультикаста примерно 250 мегабит каналами по 6-8 мегабит.
Источник мультикаста - специализированный IP Coder. Роутеров в сети
нет.
Железо - 2950, 2960 и одна WS3560-48TS. Настроены одинаково
совершенно. Querier везде выключен, snooping везде включен.

Проблема в том, что 3560 время от времени (пока никакой зависимости
установить не удалось) шлёт все 250 мегабит во все порты в этом VLAN.

Софт на нём Version 12.2(25)SEE2. Опции: ipbase

Так же обнаружено что такие же свичи стоят в одном комплексе,
который настроенный "в сборе" поставляется фирмой Harmonic. У них
аналогичные настройки (делались не мной, а их специалистами). И
проблема аналогичная - время от времени свич шлёт весь поток во все
порты.
Единственное отличие этих свичей - более свежий софт: Version
12.2(25)SEE3

Все попытки обновить софт на этих свичах успехом не увенчались: он
говорит либо что образ битый, либо просто не грузится, либо процесс
загрузки занимает более часа (дальше просто не стали ждать).

В логах при дебаге никакой информации нет. :(

Что можно посмотреть? Как это можно вылечить?

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Мультикаст на WS3560-48TS"  +/
Сообщение от Myxa (??) on 11-Ноя-09, 12:48 
Обнозначно проблема софта.
> Все попытки обновить софт на этих свичах успехом не увенчались: он
> говорит либо что образ битый, либо просто не грузится, либо процесс
> загрузки занимает более часа (дальше просто не стали ждать).

Это как такое может быть? Или вы пытались обновляться по узкому WAN-каналу??
В качестве рекомендации по обновлению:
erase flash:
arch t /x tftp://xx.xx.xx.xx/c2960-blabla-tar.52.SE.tar flash:

по ethernet займет 5-7 минут

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Мультикаст на WS3560-48TS"  +/
Сообщение от DJ_Kill email(??) on 11-Ноя-09, 12:51 
>Это как такое может быть? Или вы пытались обновляться по узкому WAN-каналу??

Обновлятся я пытаюсь залив предварительно новый софт на свич. То есть он грузится больше часа ЛОКАЛЬНО!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Мультикаст на WS3560-48TS"  +/
Сообщение от Myxa (??) on 11-Ноя-09, 13:47 
>>Это как такое может быть? Или вы пытались обновляться по узкому WAN-каналу??
>
>Обновлятся я пытаюсь залив предварительно новый софт на свич. То есть он
>грузится больше часа ЛОКАЛЬНО!

Что-то убивает ресурсы
sh proc cpu
sh proc memo

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Мультикаст на WS3560-48TS"  +/
Сообщение от DJ_Kill email(??) on 11-Ноя-09, 13:49 
>Что-то убивает ресурсы
>sh proc cpu
>sh proc memo

До загрузки софта это сделать нельзя.

После загрузки ресурсы свича мониторятся круглосуточно и загрузка не большая.

Может версия софта какая-то не та, но пробовал разный с разными опциями и разных версий (в том числе и рекомендованный Cisco Software Validator).

Да и нет уверенности что проблема мультикаста - проблема софта.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Мультикаст на WS3560-48TS"  +/
Сообщение от sh_ email(ok) on 11-Ноя-09, 18:37 
А конфиг то можно глянуть?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Мультикаст на WS3560-48TS"  +/
Сообщение от DJ_Kill email(??) on 12-Ноя-09, 11:27 
>А конфиг то можно глянуть?

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cat108
!
no aaa new-model
vtp domain A481-TDC-MNG
vtp mode transparent
ip subnet-zero
ip name-server 192.168.100.24
ip name-server 192.168.100.9
!
ip dhcp pool CU
!
no ip rcmd domain-lookup
ip rcmd rsh-enable
ip rcmd remote-host root 192.168.100.24 root enable
ip igmp snooping vlan 99 immediate-leave
!
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 15-16,20-21
!
vlan internal allocation policy ascending
!
vlan 2
name SKD-MGT
!
vlan 3
name SKD-Data
!
vlan 99
name geo-office
!
interface FastEthernet0/1
switchport access vlan 99
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/2
switchport access vlan 37
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/3
switchport access vlan 3
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/4
switchport access vlan 99
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/5
switchport access vlan 99
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/6
switchport access vlan 99
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/7
switchport access vlan 2
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/8
switchport access vlan 2
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/9
switchport access vlan 99
switchport mode access
load-interval 30
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/10
switchport access vlan 2
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/11
switchport access vlan 58
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/12
switchport access vlan 99
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/13
switchport access vlan 2
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/14
switchport access vlan 16
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/15
switchport access vlan 93
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/16
switchport access vlan 2
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/17
switchport access vlan 96
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,16,93,94,96
switchport mode trunk
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/18
switchport access vlan 2
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/19
switchport access vlan 99
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/20
switchport access vlan 60
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/21
switchport access vlan 99
switchport mode access
load-interval 30
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/22
switchport access vlan 81
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/23
switchport access vlan 2
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/24
switchport access vlan 99
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
no cdp enable
!
interface FastEthernet0/25
switchport access vlan 99
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/26
switchport access vlan 99
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/27
switchport access vlan 99
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/28
switchport access vlan 94
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/29
switchport access vlan 90
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/30
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-3,5,7,16,19,24,26,27,40,41,70-75,81,90,99
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action shutdown
storm-control action trap
!
interface FastEthernet0/31
switchport access vlan 2
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/32
switchport access vlan 2
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/33
switchport access vlan 2
switchport mode access
shutdown
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/34
switchport access vlan 99
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/35
switchport access vlan 99
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/36
switchport access vlan 99
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/37
switchport access vlan 34
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/38
switchport access vlan 99
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/39
switchport access vlan 37
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/40
switchport access vlan 37
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/41
switchport access vlan 99
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/42
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/43
shutdown
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/44
switchport access vlan 2
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/45
switchport access vlan 99
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/46
switchport access vlan 99
switchport mode access
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/47
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface FastEthernet0/48
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-4,6,7,15,16,21,23-25,27,37,42,54,70-75,81,90
switchport trunk allowed vlan add 93,99
switchport mode trunk
load-interval 30
storm-control broadcast level 30.00
storm-control multicast level 50.00
storm-control action trap
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-4,6,7,15,16,21,23-25,27,34,37,42,43,54,58,60
switchport trunk allowed vlan add 70-75,81,90,96,99
switchport mode trunk
load-interval 30
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,16,19,21,22,24,27,34,37,90,99
switchport mode trunk
!
interface GigabitEthernet0/3
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,16,21,43,99
switchport mode trunk
!
interface GigabitEthernet0/4
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 192.168.100.108 255.255.255.0
!
ip classless
ip http server
!
ip access-list standard MGT
permit 192.168.100.222
permit 192.168.100.230
permit 192.168.100.224
permit 192.168.100.225
permit 192.168.100.0 0.0.0.31
!
ip access-list extended SMENA-MON
permit tcp host 192.168.0.192 192.168.100.0 0.0.0.31 eq smtp www pop3
permit tcp host 192.168.0.192 192.168.0.0 0.0.0.31 eq smtp www pop3
permit udp host 192.168.0.192 192.168.100.0 0.0.0.31 eq domain
!
logging trap debugging
logging facility local2
logging 192.168.100.10
access-list 1 permit 192.168.100.0 0.0.0.255
!
control-plane
!
line con 0
line vty 0 4
access-class MGT in
exec-timeout 60 0
login local
line vty 5 15
access-class MGT in
exec-timeout 60 0
login local
!
ntp clock-period 36029321
ntp server 192.168.100.1
end

До кучи:

Cat108#sh ip igmp snooping vlan 99
Global IGMP Snooping configuration:
-----------------------------------
IGMP snooping              : Enabled
IGMPv3 snooping (minimal)  : Enabled
Report suppression         : Enabled
TCN solicit query          : Disabled
TCN flood query count      : 2
Last Member Query Interval : 1000

Vlan 99:
--------
IGMP snooping                       : Enabled
IGMPv2 immediate leave              : Enabled
Explicit host tracking              : Enabled
Multicast router learning mode      : pim-dvmrp
Last Member Query Interval          : 1000
CGMP interoperability mode          : IGMP_ONLY

Cat108#sh ip igmp snooping querier vlan 99
IP address               : 192.168.100.112
IGMP version             : v2
Port                     : Gi0/1
Max response time        : 10s

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру