The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"подключение к ISP с Cisco-1811 по модему через AUX"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"подключение к ISP с Cisco-1811 по модему через AUX"  +/
Сообщение от ll75 email(ok) on 03-Ноя-09, 15:17 
помогите плз рабочим конфигом - нужно дозвониться до провайдера модемом и пройти авторизацию...На данном этапе дозвон происходит,а авторизация нет ((
Вот части конфига:

chat-script optima ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45 CONNECT \c

interface Async5
no ip address
encapsulation ppp
no ip route-cache cef
dialer in-band
dialer pool-member 2
async mode dedicated
routing dynamic

interface Dialer6
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip route-cache cef
no ip route-cache
dialer pool 2
dialer string 92122077
dialer-group 2
no cdp enable
ppp authentication pap callin
ppp pap sent-username optima password 7 1041190D0C1A13

line aux 0
exec-timeout 0 0
script reset optima
modem InOut
modem autoconfigure type default
transport input telnet
autoselect ppp
stopbits 1
speed 115200
flowcontrol hardware

модем набирает номер и появляются сообщения в логе:
gateway#terminal monitor
gateway#debug chat  
gateway#clear line aux 0
[confirm]

Nov  3 11:05:04.880: CHAT5: Attempting line reset script
Nov  3 11:05:04.880: CHAT5: Matched chat script optima to string optima
Nov  3 11:05:04.880: CHAT5: Asserting DTR
Nov  3 11:05:04.880: CHAT5: Chat script optima started
Nov  3 11:05:04.880: CHAT5: Sending string: AT
Nov  3 11:05:04.880: CHAT5: Expecting string: OK
Nov  3 11:05:04.884: CHAT5: Completed match for expect: OK
Nov  3 11:05:04.884: CHAT5: Sending string: ATDT \T<92122077>
Nov  3 11:05:04.884: CHAT5: Expecting string: CONNECT [OK]
gateway#
Nov  3 11:05:24.756: CHAT5: Completed match for expect: CONNECT
Nov  3 11:05:24.756: CHAT5: Sending string: \c
Nov  3 11:05:24.756: CHAT5: Chat script optima finished, status = Success
Nov  3 11:05:26.808: TTY5: Modem command:  --AT&F&C1&D2S0=1H0--
Nov  3 11:05:27.332: TTY5: Modem configuration succeeded
Nov  3 11:05:27.332: TTY5: Detected modem speed 115200
Nov  3 11:05:27.332: TTY5: Done with modem configuration

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "подключение к ISP с Cisco-1811 по модему через AUX"  +/
Сообщение от AlexDv (??) on 03-Ноя-09, 16:03 
>[оверквотинг удален]
>interface Async5
> no ip address
> encapsulation ppp
> no ip route-cache cef
> dialer in-band
> dialer pool-member 2
> async mode dedicated
> routing dynamic
>
>interface Dialer6

[поскипано]

>
>модем набирает номер и появляются сообщения в логе:
>gateway#terminal monitor
>gateway#debug chat
>gateway#clear line aux 0
>[confirm]
>

Интерфейс Dialer необязателен, можно перенести нужное в Async.
ppp authentication pap callout
А дальше deb ppp смотреть.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "подключение к ISP с Cisco-1811 по модему через AUX"  +/
Сообщение от ll75 email(ok) on 03-Ноя-09, 16:47 

>Интерфейс Dialer необязателен, можно перенести нужное в Async.
> ppp authentication pap callout
>А дальше deb ppp смотреть.

А
chat-script optima ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45 CONNECT \c

обязательно в конфиге прописывать?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "подключение к ISP с Cisco-1811 по модему через AUX"  +/
Сообщение от AlexDv (??) on 03-Ноя-09, 17:05 
>[оверквотинг удален]
>45 CONNECT \c
>
>обязательно в конфиге прописывать?
>Nov  3 11:05:24.756: CHAT5: Completed match for expect: CONNECT
>Nov  3 11:05:24.756: CHAT5: Sending string: \c
>Nov  3 11:05:24.756: CHAT5: Chat script optima finished, status = Success
>Nov  3 11:05:26.808: TTY5: Modem command:  --AT&F&C1&D2S0=1H0--
>Nov  3 11:05:27.332: TTY5: Modem configuration succeeded
>Nov  3 11:05:27.332: TTY5: Detected modem speed 115200
>Nov  3 11:05:27.332: TTY5: Done with modem configuration

Работает, можно не трогать.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "подключение к ISP с Cisco-1811 по модему через AUX"  +/
Сообщение от ll75 email(ok) on 03-Ноя-09, 17:34 

>Работает, можно не трогать.

прописал
interface Async5
no ip address
encapsulation ppp
no ip route-cache cef
dialer in-band
dialer idle-timeout 0 either
dialer string 92122077
dialer-group 1
async mode dedicated
no fair-queue
ppp chap refuse
ppp pap sent-username optima password 7 06091F35454308

после
#cle line aux 0
не дозванивается ((....где ошибся?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "подключение к ISP с Cisco-1811 по модему через AUX"  +/
Сообщение от AlexDv (??) on 03-Ноя-09, 17:54 
>[оверквотинг удален]
> dialer string 92122077
> dialer-group 1
> async mode dedicated
> no fair-queue
> ppp chap refuse
> ppp pap sent-username optima password 7 06091F35454308
>
>после
>#cle line aux 0
>не дозванивается ((....где ошибся?

Попробуйте
int a5
dialer pool-member 1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "подключение к ISP с Cisco-1811 по модему через AUX"  +/
Сообщение от ll75 email(ok) on 04-Ноя-09, 09:23 

>Попробуйте
>int a5
>dialer pool-member 1

poll-member 1 прописан в Dialer 3 (ADSL-соединение через WAN):
dialer pool 1
dialer-group 1


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "подключение к ISP с Cisco-1811 по модему через AUX"  +/
Сообщение от AlexDv (??) on 03-Ноя-09, 18:05 
>[оверквотинг удален]
> dialer string 92122077
> dialer-group 1
> async mode dedicated
> no fair-queue
> ppp chap refuse
> ppp pap sent-username optima password 7 06091F35454308
>
>после
>#cle line aux 0
>не дозванивается ((....где ошибся?

Вдогонку
ip route 0.0.0.0 0.0.0.0 a5   есть?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "подключение к ISP с Cisco-1811 по модему через AUX"  +/
Сообщение от ll75 email(ok) on 04-Ноя-09, 09:25 

>Вдогонку
>ip route 0.0.0.0 0.0.0.0 a5   есть?

пока нет, я думал её прописать уже после самого соединения по dial-up (с проверкой имени и пароля)... это же уже маршрутизация....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "подключение к ISP с Cisco-1811 по модему через AUX"  +/
Сообщение от AlexDv (??) on 04-Ноя-09, 19:36 
>
>>Вдогонку
>>ip route 0.0.0.0 0.0.0.0 a5   есть?
>
>пока нет, я думал её прописать уже после самого соединения по dial-up
>(с проверкой имени и пароля)... это же уже маршрутизация....

Если нет трафика в этот интерфейс, дозвона и не будет.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "подключение к ISP с Cisco-1811 по модему через AUX"  +/
Сообщение от ll75 email(ok) on 05-Ноя-09, 11:34 

>
>Если нет трафика в этот интерфейс, дозвона и не будет.

На cisco.com указано:
"Cisco recommends you use the modem autoconfigure type <modemcap_name> command (introduced in Cisco IOS Software Release 11.1), to configure modems attached to async lines. If you use a version of Cisco IOS Software earlier than 11.1, you can use script startup and script reset to configure the modems via a chat script."
Т.е. имеется в виду, что если версия IOS 12.4, то в конфигурации line aux 0
указываем modem autoconfigure type default
вместо script startup и script reset . И следовательно в global configuratiom mode не указываем chat-script optima ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45 CONNECT \c.
В общем полный дебаг включил - и дозвон не происходит:
gateway#terminal monitor
gateway#debug chat  
gateway#debug modem  
gateway#debug ppp authentication
gateway#debug ppp error
gateway#debug ppp negotiation
gateway#debug dialer
gateway#show debug

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "подключение к ISP с Cisco-1811 по модему через AUX"  +/
Сообщение от AlexDv (??) on 05-Ноя-09, 12:30 
>[оверквотинг удален]
>OK "ATDT \T" TIMEOUT 45 CONNECT \c.
>В общем полный дебаг включил - и дозвон не происходит:
>gateway#terminal monitor
>gateway#debug chat
>gateway#debug modem
>gateway#debug ppp authentication
>gateway#debug ppp error
>gateway#debug ppp negotiation
>gateway#debug dialer
>gateway#show debug

Если нет "interesting traffic", то дозвона и не должно быть.
Проверяем по шагам:
1. sh line aux 0 - видит ли роутер модем.
2. sh dialer int a1 - состояние.
3. Генерируем interesting traffic (пинг, ip route 0.0.0. итд) и смотрим дальше.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "подключение к ISP с Cisco-1811 по модему через AUX"  +/
Сообщение от ll75 email(ok) on 05-Ноя-09, 12:41 

>Если нет "interesting traffic", то дозвона и не должно быть.
>Проверяем по шагам:
>1. sh line aux 0 - видит ли роутер модем.
>2. sh dialer int a1 - состояние.
>3. Генерируем interesting traffic (пинг, ip route 0.0.0. итд) и смотрим дальше.
>

gateway#sh line aux 0
   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
     5 AUX 115200/115200- inout     -    -    -     23       1   351/0       -
........................................................................
Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
Status: No Exit Banner, Modem Detected, CTS Raised
........................................................................
Modem type is default.

gateway#sh dialer int a5
As5 - dialer type = IN-BAND ASYNC NO-PARITY
Dialer pool 2, priority 0
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle


>3. Генерируем interesting traffic (пинг, ip route 0.0.0. итд) и смотрим дальше.

указан параметр
ip route 0.0.0.0 0.0.0.0 Async5

а как interesting ping начать, если поднято ещё 2 WAN интерфейса?
что-то типа
#ping ya.ru source Dialer 7
#ping ya.ru source Async 5

?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "подключение к ISP с Cisco-1811 по модему через AUX"  +/
Сообщение от AlexDv (??) on 05-Ноя-09, 12:46 
>[оверквотинг удален]
>
>>3. Генерируем interesting traffic (пинг, ip route 0.0.0. итд) и смотрим дальше.
>
>указан параметр
>ip route 0.0.0.0 0.0.0.0 Async5
>
>а как interesting ping начать, если поднято ещё 2 WAN интерфейса?
>что-то типа
>#ping ya.ru source Dialer 7
>#ping ya.ru source Async 5

Да.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру