The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Проблема в l2tp подключении corbina на cisco"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Проблема в l2tp подключении corbina на cisco"  +/
Сообщение от incomf (ok) on 13-Окт-09, 15:45 
Знаю что уже сто раз все обсуждалось на разных форумах, я проверил все варианты. У меня очень странная ситуация, l2tp соединение устанавливается, держится почти РОВНО 60 секунд, и падает. Далее конфиг и дебаги:

Current configuration : 7237 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CentrOffice_cisco
!
boot-start-marker
boot system flash:c2800nm-adventerprisek9-mz.124-19.bin
boot-end-marker
!
logging buffered 4096 debugging
enable secret 5 ****
!
aaa new-model
!
!
aaa authentication ppp default local
aaa authorization network default none
!
aaa session-id common
clock timezone Moscow 3
clock summer-time Moscow date Mar 30 2003 2:00 Oct 26 2003 3:00
!
!
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3

ip sla monitor 1
type echo protocol ipIcmpEcho 10.199.56.1
timeout 1000
threshold 40
tag tag -=Monitoring Corbina ISP GW=-
frequency 3
ip sla monitor schedule 1 life forever start-time now
ip sla monitor 2
type echo protocol ipIcmpEcho 10.0.0.1
timeout 1000
threshold 40
tag -=Monitoring UltraNet ISP GW=-
frequency 3
ip sla monitor schedule 2 life forever start-time now
vpdn enable
!
l2tp-class corbina
!
!
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!        
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-**
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-**
revocation-check none
rsakeypair TP-self-signed-**
!
!
crypto pki certificate chain TP-self-signed-**
certificate self-signed 01
...

  quit
username ***
username ***

!
!
ip ssh version 2
!
track 1 rtr 1 reachability
delay down 15 up 10
!
track 2 rtr 2 reachability
delay down 15 up 10

pseudowire-class class1
encapsulation l2tpv2
protocol l2tpv2 corbina
ip local interface FastEthernet0/0

!
!
!
!
!
bba-group pppoe global
!
!
interface Loopback0
no ip address
!
interface Loopback1
no ip address
!
interface FastEthernet0/0
description Corbina_WAN_Ethernet
ip address dhcp
no ip redirects
no ip unreachables
no ip proxy-arp
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/1
description UltraNet_WAN_Ethernet
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip virtual-reassembly
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface FastEthernet0/0/0
description CiscoLan_4ESW_VLAN172
switchport access vlan 172
!
interface FastEthernet0/0/1
description CiscoLan_4ESW_VLAN172
switchport access vlan 172
!
interface FastEthernet0/0/2
description CiscoLan_4ESW_VLAN172
switchport access vlan 172
!
interface FastEthernet0/0/3
description CiscoLan_4ESW_VLAN172
switchport access vlan 172
!
interface Virtual-PPP1
description L2TP-to-Corbina
ip address negotiated
ip mtu 1460
ip nat outside
ip virtual-reassembly
no keepalive
no cdp enable
ppp authentication chap callin
ppp chap hostname USERNAME
ppp chap password 7 *****
pseudowire 85.21.0.253 10 pw-class class1

!
interface Vlan1
no ip address
!
interface Vlan172
description -= CiscoLan_4ESW_VLAN172 =-
ip address 172.25.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 500
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname *******
ppp chap password 7 *******
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1 80 track 2
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 4.2.2.2 255.255.255.255 Virtual-PPP1
ip route 85.21.0.253 255.255.255.255 10.199.56.1
ip route 85.21.0.255 255.255.255.255 10.199.56.1

!
!
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source route-map ISP_Corbina interface Virtual-PPP1 overload
ip nat inside source route-map ISP_ULTRANet interface Dialer1 overload
!
ip access-list extended NAT_ISP_Corbina
permit ip 172.25.20.0 0.0.0.255 any
ip access-list extended NAT_ISP_ULTRANet
permit ip 172.25.20.0 0.0.0.255 any
!
dialer-list 1 protocol ip permit
!
route-map ISP_ULTRANet permit 10
match ip address NAT_ISP_ULTRANet
match interface Dialer1
!
route-map ISP_Corbina permit 10
match ip address NAT_ISP_Corbina
match interface Virtual-PPP1
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 65 0
privilege level 15
transport input telnet ssh
line vty 5 15
exec-timeout 65 0
privilege level 15
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end


CentrOffice_cisco#sh dhcp lease
Temp IP addr: 10.199.56.238  for peer on Interface: FastEthernet0/0
Temp  sub net mask: 255.255.248.0
   DHCP Lease server: 83.102.233.202, state: 3 Bound
   DHCP transaction id: 802
   Lease: 604800 secs,  Renewal: 302400 secs,  Rebind: 529200 secs
Temp default-gateway addr: 10.199.56.1
Temp ip static route0: dest 89.179.135.67 router 10.199.56.1
Temp ip static route0: dest 195.14.50.26 router 10.199.56.1
   Next timer fires after: 3d11h
   Retry count: 0   Client-ID: cisco-001e.be50.f430-Fa0/0
   Client-ID hex dump: 636973636F2D303031652E626535302E
                       663433302D4661302F30
   Hostname: CentrOffice_cisco

CentrOffice_cisco#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     85.0.0.0/32 is subnetted, 2 subnets
C       85.21.0.253 is directly connected, Virtual-PPP1
S       85.21.0.255 [1/0] via 10.199.56.1
     81.0.0.0/32 is subnetted, 1 subnets
C       81.25.***.*** is directly connected, Dialer1 получил внешний ip от Dialer1
     4.0.0.0/32 is subnetted, 1 subnets
S       4.2.2.2 is directly connected, Virtual-PPP1
     83.0.0.0/32 is subnetted, 1 subnets
S       83.102.233.202 [254/0] via 10.199.56.1, FastEthernet0/0
     172.25.0.0/24 is subnetted, 1 subnets
C       172.25.20.0 is directly connected, Vlan172
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.0.0.1/32 is directly connected, Dialer1
C       10.199.56.0/21 is directly connected, FastEthernet0/0
     194.187.206.0/32 is subnetted, 1 subnets
S       194.187.206.*** is directly connected, Virtual-PPP1
     89.0.0.0/32 is subnetted, 2 subnets
C       89.179.243.*** is directly connected, Virtual-PPP1 получил внешний ip от Virtual-PPP1
S       89.179.135.67 [254/0] via 10.199.56.1
     195.14.50.0/32 is subnetted, 1 subnets
S       195.14.50.26 [254/0] via 10.199.56.1
S*   0.0.0.0/0 is directly connected, Dialer1


CentrOffice_cisco#sh vpdn    

%No active L2F tunnels

L2TP Tunnel and Session Information Total tunnels 1 sessions 1

LocID RemID Remote Name   State  Remote Address  Port  Sessions L2TP Class/
                                                                VPDN Group
3558  6720  bras253       est    85.21.0.253     1701  1        corbina        

LocID      RemID      TunID      Username, Intf/      State  Last Chg Uniq ID  
                                 Vcid, Circuit                                  
72         59340      3558       10, Vp1              est    00:00:54 3      

%No active PPTP tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Session Information
Uniq ID  PPPoE  RemMAC          Port                  Source   VA         State
           SID  LocMAC                                         VA-st
    N/A      9  001b.2140.ec30  Fa0/1                 Di1      Vi2        UP      
                ****.****.****                                 UP        


CentrOffice_cisco#debug ppp authentication
PPP authentication debugging is on
*Oct 13 12:35:22.239: %LINK-3-UPDOWN: Interface Virtual-PPP1, changed state to up
*Oct 13 12:35:22.239: Vp1 PPP: Using vpn set call direction
*Oct 13 12:35:22.239: Vp1 PPP: Treating connection as a callout
*Oct 13 12:35:22.239: Vp1 PPP: Session handle[40000062] Session id[57]
*Oct 13 12:35:22.239: Vp1 PPP: Authorization NOT required
*Oct 13 12:35:22.239: Vp1 PPP: No remote authentication for call-out
*Oct 13 12:35:22.275: Vp1 CHAP: I CHALLENGE id 1 len 28 from "bras253"
*Oct 13 12:35:22.275: Vp1 CHAP: Using hostname from interface CHAP
*Oct 13 12:35:22.279: Vp1 CHAP: Using password from interface CHAP
*Oct 13 12:35:22.279: Vp1 CHAP: O RESPONSE id 1 len 28 from "USERNAME"
*Oct 13 12:35:22.311: Vp1 CHAP: I SUCCESS id 1 len 4
*Oct 13 12:35:23.315: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-PPP1, changed state to up

*Oct 13 12:36:22.391: %LINK-3-UPDOWN: Interface Virtual-PPP1, changed state to down
*Oct 13 12:36:23.375: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-PPP1, changed state to down
*Oct 13 12:36:32.399: %LINK-3-UPDOWN: Interface Virtual-PPP1, changed state to up
*Oct 13 12:36:32.399: Vp1 PPP: Using vpn set call direction
*Oct 13 12:36:32.399: Vp1 PPP: Treating connection as a callout
*Oct 13 12:36:32.399: Vp1 PPP: Session handle[8000064] Session id[58]
*Oct 13 12:36:32.399: Vp1 PPP: Authorization NOT required
*Oct 13 12:36:32.399: Vp1 PPP: No remote authentication for call-out
*Oct 13 12:36:32.419: Vp1 CHAP: I CHALLENGE id 1 len 28 from "bras253"
*Oct 13 12:36:32.423: Vp1 CHAP: Using hostname from interface CHAP
*Oct 13 12:36:32.423: Vp1 CHAP: Using password from interface CHAP
*Oct 13 12:36:32.423: Vp1 CHAP: O RESPONSE id 1 len 28 from "USERNAME"
*Oct 13 12:36:32.463: Vp1 CHAP: I SUCCESS id 1 len 4
*Oct 13 12:36:33.463: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-PPP1, changed state to up


Обратите внимание что сессия держится ровно минуту, потом падает и подключается снова.
1. статику на 4.2.2.2 я забил для тестов. Пинги вовремя подключенной корбины НЕ ПРОХОДЯТ.
2. Пробовал варианты с

l2tp-class corbina
receive-window 128

так же пробовал разные mtu на interface virtual-ppp1:
ip mtu 1072
ip tcp adjust-mss 1000
no keepalive

В тупике, подскажите пожалуйста! может debug какие еще посмотреть???
Заранее благодарен!!!

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проблема в l2tp подключении corbina на cisco"  +/
Сообщение от incomf (ok) on 13-Окт-09, 18:45 
Дебажу:
CentrOffice_cisco#sh deb
VPN:
  L2X protocol events debugging is on
  L2X data packets debugging is on
  L2X control packets debugging is on
  VPDN call event debugging is on
  VPDN message debugging is on
  VPDN events debugging is on
  VPDN errors debugging is on
General-purpose tunnel:
  Tunnel keepalive debugging is on

*Oct 13 15:30:54.218: L2X: Attempted multiple encap passes, dropping
*Oct 13 15:31:01.078: L2X: Punting to L2TP control message queue
*Oct 13 15:31:01.078:  Tnl 50035 L2TP: Parse  AVP 0, len 8, flag 0x8000 (M)
*Oct 13 15:31:01.078:  Tnl 50035 L2TP: Parse Hello
*Oct 13 15:31:01.078:  Tnl 50035 L2TP: No missing AVPs in Hello
*Oct 13 15:31:01.078:  Tnl 50035 L2TP: I Hello, flg TLS, ver 2, len 20, tnl 50035, ns 2, nr 4
contiguous pak, size 20
         C8 02 00 14 C3 73 00 00 00 02 00 04 80 08 00 00
         00 00 00 06
*Oct 13 15:31:01.078:  Tnl 50035 L2TP: O ZLB ctrl ack, flg TLS, ver 2, len 12, tnl 38104, ns 4, nr 3
         C8 02 00 0C 94 D8 00 00 00 04 00 03
*Oct 13 15:31:01.078:  Tnl 50035 L2TP: I Hello from bras253 tnl 38104
*Oct 13 15:31:01.082: L2X: Attempted multiple encap passes, dropping
CentrOffice_cisco#
*Oct 13 15:31:04.234: L2X: Punting to L2TP control message queue
*Oct 13 15:31:04.238: uid:197 Tnl/Sn 50035/243 L2TP: Parse  AVP 0, len 8, flag 0x8000 (M)
*Oct 13 15:31:04.238: uid:197 Tnl/Sn 50035/243 L2TP: Parse CDN
*Oct 13 15:31:04.238: uid:197 Tnl/Sn 50035/243 L2TP: Parse  AVP 1, len 38, flag 0x8000 (M)
*Oct 13 15:31:04.238: uid:197 Tnl/Sn 50035/243 L2TP: Result code(2): 2: Call disconnected, refer to error msg
*Oct 13 15:31:04.238:      Error code(6): Vendor specific
*Oct 13 15:31:04.238:      Optional msg: Locally generated disconnect

*Oct 13 15:31:04.238: uid:197 Tnl/Sn 50035/243 L2TP: Parse  AVP 14, len 8, flag 0x8000 (M)
*Oct 13 15:31:04.238: uid:197 Tnl/Sn 50035/243 L2TP: Assigned Call ID 31548
*Oct 13 15:31:04.238: uid:197 Tnl/Sn 50035/243 L2TP: Parse  AVP 46, len 11, flag 0x0
*Oct 13 15:31:04.238: uid:197 Tnl/Sn 50035/243 L2TP: disconnected, code 8, direction peer for CP 0xC021
*Oct 13 15:31:04.238: uid:197 Tnl/Sn 50035/243 L2TP: Parse Cisco AVP 104, len 11, flag 0x0
*Oct 13 15:31:04.238: uid:197 Tnl/Sn 50035/243 L2TP: PPP Disconnect Cause Code (Cisco) Already rcvd IETF version, ignoring
*Oct 13 15:31:04.238: uid:197 Tnl/Sn 50035/243 L2TP: No missing AVPs in CDN
*Oct 13 15:31:04.238: uid:197 Tnl/Sn 50035/243 L2TP: I CDN, flg TLS, ver 2, len 88, tnl 50035, lsid 243, rsid 31548, ns 3, nr 4
contiguous pak, size 88
         C8 02 00 58 C3 73 00 F3 00 03 00 04 80 08 00 00
         00 00 00 0E 80 26 00 00 00 01 00 02 00 06 4C 6F
         63 61 6C 6C 79 20 67 65 6E 65 72 61 74 65 64 20
         64 69 73 63 6F 6E 6E 65 63 74 80 08 00 00 00 0E
         7B 3C 00 0B 00 00 00 2E ...
*Oct 13 15:31:04.238: uid:197 Tnl/Sn 50035/243 L2TP: O ZLB ctrl ack, flg TLS, ver 2, len 12, tnl 38104, lsid 243, rsid 31548, ns 4, nr 4
         C8 02 00 0C 94 D8 00 00 00 04 00 04
*Oct 13 15:31:04.242: uid:197 Tnl/Sn 50035/243 L2TP: I CDN from bras253 tnl 38104, cl 31548
*Oct 13 15:31:04.242: uid:197 Tnl/Sn 50035/243 L2TP: disconnect (L2X) IETF: 9/nas-error Ascend: 41/TCP Foreign Host Close
*Oct 13 15:31:04.242: uid:197 Tnl/Sn 50035/243 L2TP: Destroying session
*Oct 13 15:31:04.242: L2X: Sending L2TUN message <Disconnect>
*Oct 13 15:31:04.242: uid:197 Tnl/Sn 50035/243 L2TP: Session state change from established to idle
*Oct 13 15:31:04.242:  Tnl 50035 L2TP: Tunnel state change from established to no-sessions-left
*Oct 13 15:31:04.242:  Tnl 50035 L2TP: No more sessions in tunnel, shutdown (likely) in 15 seconds
*Oct 13 15:31:04.250: L2X: l2tun session [1168585924], event [server terminate], old state [open], new state [wait-free]
*Oct 13 15:31:04.250: L2X: l2tun session [1168585924], event [client free], old state [wait-free], new state [terminal]
CentrOffice_cisco#
*Oct 13 15:31:04.254: %LINK-3-UPDOWN: Interface Virtual-PPP1, changed state to down
*Oct 13 15:31:05.078: L2X: Punting to L2TP control message queue
CentrOffice_cisco#
CentrOffice_cisco#
CentrOffice_cisco#
*Oct 13 15:31:05.238: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-PPP1, changed state to down
CentrOffice_cisco#
CentrOffice_cisco#
CentrOffice_cisco#
CentrOffice_cisco#
CentrOffice_cisco#
CentrOffice_cisco#
CentrOffice_cisco#
CentrOffice_cisco#
CentrOffice_cisco#
CentrOffice_cisco#
*Oct 13 15:31:13.078: L2X: Punting to L2TP control message queue
*Oct 13 15:31:13.078: L2X: Punting to L2TP control message queue
*Oct 13 15:31:13.078:  Tnl 50035 L2TP: O ZLB ctrl ack, flg TLS, ver 2, len 12, tnl 38104, ns 4, nr 4
         C8 02 00 0C 94 D8 00 00 00 04 00 04
*Oct 13 15:31:14.234: L2X: Punting to L2TP control message queue
*Oct 13 15:31:14.234:  Tnl 50035 L2TP: Parse  AVP 0, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.234:  Tnl 50035 L2TP: Parse StopCCN
*Oct 13 15:31:14.234:  Tnl 50035 L2TP: Parse  AVP 1, len 10, flag 0x8000 (M)
*Oct 13 15:31:14.234: L2X: Result code(1): 1: Request to clear control connection
*Oct 13 15:31:14.234:      Error code(0): No error
*Oct 13 15:31:14.234:  Tnl 50035 L2TP: Parse  AVP 9, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.234:  Tnl 50035 L2TP: Assigned Tunnel ID 38104
*Oct 13 15:31:14.234:  Tnl 50035 L2TP: No missing AVPs in StopCCN
*Oct 13 15:31:14.234:  Tnl 50035 L2TP: I StopCCN, flg TLS, ver 2, len 38, tnl 50035, ns 4, nr 4
contiguous pak, size 38
         C8 02 00 26 C3 73 00 00 00 04 00 04 80 08 00 00
         00 00 00 04 80 0A 00 00 00 01 00 01 00 00 80 08
         00 00 00 09 94 D8
*Oct 13 15:31:14.234:  Tnl 50035 L2TP: O ZLB ctrl ack, flg TLS, ver 2, len 12, tnl 38104, ns 4, nr 5
         C8 02 00 0C 94 D8 00 00 00 04 00 05
*Oct 13 15:31:14.234:  Tnl 50035 L2TP: I StopCCN from bras253 tnl 38104
*Oct 13 15:31:14.234:  Tnl 50035 L2TP: Tunnel state change from no-sessions-left to shutting-down
*Oct 13 15:31:14.234:  Tnl 50035 L2TP: Shutdown tunnel
*Oct 13 15:31:14.234:  Tnl 50035 L2TP: Tunnel state change from shutting-down to idle
*Oct 13 15:31:14.250: L2X: l2tun session [1168585924], event [client request], old state [open], new state [open]
*Oct 13 15:31:14.250: L2X: L2TP: Received L2TUN message <Connect>
*Oct 13 15:31:14.250:  Tnl/Sn 21640/244 L2TP: Session state change from idle to wait-for-tunnel
*Oct 13 15:31:14.250: uid:197 Tnl/Sn 21640/244 L2TP: Create session
*Oct 13 15:31:14.250:  Tnl 21640 L2TP: SM State idle
*Oct 13 15:31:14.250:  Tnl 21640 L2TP: O SCCRQ
*Oct 13 15:31:14.250:  Tnl 21640 L2TP: Parse  AVP 0, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.250:  Tnl 21640 L2TP: Parse SCCRQ
*Oct 13 15:31:14.250:  Tnl 21640 L2TP: Parse  AVP 2, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.250:  Tnl 21640 L2TP: Protocol Version 1
*Oct 13 15:31:14.254:  Tnl 21640 L2TP: Parse  AVP 6, len 8, flag 0x0
*Oct 13 15:31:14.254:  Tnl 21640 L2TP: Firmware Ver 0x1130
*Oct 13 15:31:14.254:  Tnl 21640 L2TP: Parse  AVP 7, len 23, flag 0x8000 (M)
*Oct 13 15:31:14.254:  Tnl 21640 L2TP: Hostname CentrOffice_cisco
*Oct 13 15:31:14.254:  Tnl 21640 L2TP: Parse  AVP 8, len 25, flag 0x0
*Oct 13 15:31:14.254:  Tnl 21640 L2TP: Vendor Name Cisco Systems, Inc.
*Oct 13 15:31:14.258:  Tnl 21640 L2TP: Parse  AVP 10, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.258:  Tnl 21640 L2TP: Rx Window Size 1400
*Oct 13 15:31:14.258:  Tnl 21640 L2TP: Parse  AVP 9, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.258:  Tnl 21640 L2TP: Assigned Tunnel ID 21640
*Oct 13 15:31:14.258:  Tnl 21640 L2TP: Parse  AVP 3, len 10, flag 0x8000 (M)
*Oct 13 15:31:14.258:  Tnl 21640 L2TP: Framing Cap 0x3
*Oct 13 15:31:14.258:  Tnl 21640 L2TP: Parse  AVP 4, len 10, flag 0x8000 (M)
*Oct 13 15:31:14.258:  Tnl 21640 L2TP: Bearer Cap 0x3
*Oct 13 15:31:14.258:  Tnl 21640 L2TP: Parse Cisco AVP 110, len 6, flag 0x0
*Oct 13 15:31:14.258:  Tnl 21640 L2TP: PPPoE Relay Forward Capable
*Oct 13 15:31:14.258:  Tnl 21640 L2TP: O SCCRQ, flg TLS, ver 2, len 126, tnl 0, ns 0, nr 0
         C8 02 00 7E 00 00 00 00 00 00 00 00 80 08 00 00
         00 00 00 01 80 08 00 00 00 02 01 00 00 08 00 00
         00 06 11 30 80 17 00 00 00 07 43 65 6E 74 72 4F
         66 66 69 63 65 5F 63 69 73 63 6F 00 19 00 00 00
         08 43 69 73 63 6F 20 ...
*Oct 13 15:31:14.258:  Tnl 21640 L2TP: Control channel retransmit delay set to 1 seconds
*Oct 13 15:31:14.258:  Tnl 21640 L2TP: Tunnel state change from idle to wait-ctl-reply
*Oct 13 15:31:14.258:  Tnl 21640 L2TP: SM State wait-ctl-reply
*Oct 13 15:31:14.262: L2X: Punting to L2TP control message queue
*Oct 13 15:31:14.262:  Tnl 21640 L2TP: Parse  AVP 0, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.262:  Tnl 21640 L2TP: Parse SCCRP
*Oct 13 15:31:14.262:  Tnl 21640 L2TP: Parse  AVP 2, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.262:  Tnl 21640 L2TP: Protocol Version 1
*Oct 13 15:31:14.262:  Tnl 21640 L2TP: Parse  AVP 6, len 8, flag 0x0
*Oct 13 15:31:14.262:  Tnl 21640 L2TP: Firmware Ver 0x1120
*Oct 13 15:31:14.262:  Tnl 21640 L2TP: Parse  AVP 7, len 13, flag 0x8000 (M)
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Hostname bras253
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Parse  AVP 8, len 25, flag 0x0
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Vendor Name Cisco Systems, Inc.
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Parse  AVP 10, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Rx Window Size 65530
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Parse  AVP 9, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Assigned Tunnel ID 33718
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Parse  AVP 3, len 10, flag 0x8000 (M)
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Framing Cap 0x0
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Parse  AVP 4, len 10, flag 0x8000 (M)
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Bearer Cap 0x0
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Parse Cisco AVP 110, len 6, flag 0x0
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: PPPoE Relay Forward Capable
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: No missing AVPs in SCCRP
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: I SCCRP, flg TLS, ver 2, len 116, tnl 21640, ns 0, nr 1
contiguous pak, size 116
         C8 02 00 74 54 88 00 00 00 00 00 01 80 08 00 00
         00 00 00 02 80 08 00 00 00 02 01 00 00 08 00 00
         00 06 11 20 80 0D 00 00 00 07 62 72 61 73 32 35
         33 00 19 00 00 00 08 43 69 73 63 6F 20 53 79 73
         74 65 6D 73 2C 20 49 6E ...
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: I SCCRP from bras253
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Tunnel state change from wait-ctl-reply to established
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: O SCCCN  to bras253 tnlid 33718
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Parse  AVP 0, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Parse SCCCN
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: O SCCCN, flg TLS, ver 2, len 20, tnl 33718, ns 1, nr 1
         C8 02 00 14 83 B6 00 00 00 01 00 01 80 08 00 00
         00 00 00 03
*Oct 13 15:31:14.266:  Tnl 21640 L2TP: Control channel retransmit delay set to 1 seconds
*Oct 13 15:31:14.270:  Tnl 21640 L2TP: SM State established
*Oct 13 15:31:14.270: uid:197 Tnl/Sn 21640/244 L2TP: O ICRQ to bras253 33718/0
*Oct 13 15:31:14.270: uid:197 Tnl/Sn 21640/244 L2TP: Parse  AVP 0, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.270: uid:197 Tnl/Sn 21640/244 L2TP: Parse ICRQ
*Oct 13 15:31:14.270: uid:197 Tnl/Sn 21640/244 L2TP: Parse  AVP 15, len 10, flag 0x8000 (M)
*Oct 13 15:31:14.270: uid:197 Tnl/Sn 21640/244 L2TP: Serial Number -1643067098
*Oct 13 15:31:14.270: uid:197 Tnl/Sn 21640/244 L2TP: Parse  AVP 14, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.270: uid:197 Tnl/Sn 21640/244 L2TP: Assigned Call ID 244
*Oct 13 15:31:14.270: uid:197 Tnl/Sn 21640/244 L2TP: Parse  AVP 18, len 10, flag 0x8000 (M)
*Oct 13 15:31:14.270: uid:197 Tnl/Sn 21640/244 L2TP: Bearer Type 0
*Oct 13 15:31:14.270: uid:197 Tnl/Sn 21640/244 L2TP: O ICRQ, flg TLS, ver 2, len 48, tnl 33718, lsid 244, rsid 0, ns 2, nr 1
         C8 02 00 30 83 B6 00 00 00 02 00 01 80 08 00 00
         00 00 00 0A 80 0A 00 00 00 0F 9E 10 C9 26 80 08
         00 00 00 0E 00 F4 80 0A 00 00 00 12 00 00 00 00
*Oct 13 15:31:14.270: uid:197 Tnl/Sn 21640/244 L2TP: Session state change from wait-for-tunnel to wait-reply
*Oct 13 15:31:14.270: L2X: Punting to L2TP control message queue
*Oct 13 15:31:14.274: L2X: Punting to L2TP control message queue
*Oct 13 15:31:14.274: uid:197 Tnl/Sn 21640/244 L2TP: Parse  AVP 0, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.274: uid:197 Tnl/Sn 21640/244 L2TP: Parse ICRP
*Oct 13 15:31:14.274: uid:197 Tnl/Sn 21640/244 L2TP: Parse  AVP 14, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.274: uid:197 Tnl/Sn 21640/244 L2TP: Assigned Call ID 31773
*Oct 13 15:31:14.274: uid:197 Tnl/Sn 21640/244 L2TP: No missing AVPs in ICRP
*Oct 13 15:31:14.274: uid:197 Tnl/Sn 21640/244 L2TP: I ICRP, flg TLS, ver 2, len 28, tnl 21640, lsid 244, rsid 0, ns 1, nr 3
contiguous pak, size 28
         C8 02 00 1C 54 88 00 F4 00 01 00 03 80 08 00 00
         00 00 00 0B 80 08 00 00 00 0E 7C 1D
*Oct 13 15:31:14.278: uid:197 Tnl/Sn 21640/244 L2TP: Session state change from wait-reply to established
*Oct 13 15:31:14.278: L2X: Sending L2TUN message <Connect OK>
*Oct 13 15:31:14.278: uid:197 Tnl/Sn 21640/244 L2TP: O ICCN to bras253 33718/31773
*Oct 13 15:31:14.278: uid:197 Tnl/Sn 21640/244 L2TP: Parse  AVP 0, len 8, flag 0x8000 (M)
*Oct 13 15:31:14.278: uid:197 Tnl/Sn 21640/244 L2TP: Parse ICCN
*Oct 13 15:31:14.278: uid:197 Tnl/Sn 21640/244 L2TP: Parse  AVP 24, len 10, flag 0x8000 (M)
*Oct 13 15:31:14.278: uid:197 Tnl/Sn 21640/244 L2TP: Connect Speed 0
*Oct 13 15:31:14.278: uid:197 Tnl/Sn 21640/244 L2TP: Parse  AVP 19, len 10, flag 0x8000 (M)
*Oct 13 15:31:14.278: uid:197 Tnl/Sn 21640/244 L2TP: Framing Type 1
*Oct 13 15:31:14.278: uid:197 Tnl/Sn 21640/244 L2TP: O ICCN, flg TLS, ver 2, len 40, tnl 33718, lsid 244, rsid 31773, ns 3, nr 2
         C8 02 00 28 83 B6 7C 1D 00 03 00 02 80 08 00 00
         00 00 00 0C 80 0A 00 00 00 18 00 00 00 00 80 0A
         00 00 00 13 00 00 00 01
*Oct 13 15:31:14.278:  Tnl 21640 L2TP: Control channel retransmit delay set to 1 seconds
*Oct 13 15:31:14.278: L2X: l2tun session [1168585924], event [server response], old state [open], new state [open]
*Oct 13 15:31:14.282: %LINK-3-UPDOWN: Interface Virtual-PPP1, changed state to up
CentrOffice_cisco#
*Oct 13 15:31:14.282: L2X: Punting to L2TP control message queue
*Oct 13 15:31:15.278:  Tnl 21640 L2TP: Control channel retransmit delay set to 1 seconds
CentrOffice_cisco#
*Oct 13 15:31:15.366: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-PPP1, changed state to up
CentrOffice_cisco#
CentrOffice_cisco#
CentrOffice_cisco#
CentrOffice_cisco#
CentrOffice_cisco#
*Oct 13 15:31:24.362: L2X: Attempted multiple encap passes, dropping
CentrOffice_cisco#
CentrOffice_cisco#
*Oct 13 15:31:34.378: L2X: Attempted multiple encap passes, dropping

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема



Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру
Hosting by Ihor