The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco 881 проблемы с DHCP (не раздает)"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Диагностика и решение проблем)
Изначальное сообщение [ Отслеживать ]
Курсы Сisco по безопасности (CCNA и CCNP Security, Сisco ISE 2.1, ASA, IronPort)
"Cisco 881 проблемы с DHCP (не раздает)"  +/
Сообщение от tsarush email(ok) on 08-Дек-15, 13:14 
System image file is "flash:c800-universalk9-mz.SPA.155-2.T.bin"

C881W-E-K9


Добрый день!

Столкнулся с проблемой которая не дает мне покоя.

Конфиг крайне простой 3 строчки, вопрос почему не раздает DHCP, хотя ip dhcp binding показывает что ip адрес выдан, после чего он выдает следующий одному и тому же устройству.

wireshark показывает что ничего не приходило.

RUN CONF
Building configuration...

Current configuration : 2291 bytes
!
! Last configuration change at 13:08:05 MSK Tue Dec 8 2015
! NVRAM config last updated at 13:08:07 MSK Tue Dec 8 2015
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname C881W-E-K9
!
boot-start-marker
boot-end-marker
!
aaa new-model
!
!
aaa authentication login default local
!
aaa session-id common
ethernet lmi ce
bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
clock timezone MSK 3 0
service-module wlan-ap 0 bootimage autonomous
!

ip dhcp excluded-address 192.168.16.1 192.168.16.30
!
ip dhcp pool LAN
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1
dns-server 192.168.16.1
!
ip domain name freestyleteam.ru
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
license udi pid C881W-E-K9 sn FCZ171390Z4
license accept end user agreement
license boot module c800 level advipservices
!
archive
log config
  logging enable
  hidekeys
username sysadmin privilege 15 secret 5 $1$9K1.$M1chRMHpDED286j5s0rJs1
!

ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
!

interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
description MortonTelecom
ip address dhcp
ip nat outside
ip virtual-reassembly in
shutdown
duplex auto
speed auto
!
interface Wlan-GigabitEthernet0
no ip address
!
interface wlan-ap0
no ip address
shutdown
!
interface Vlan1
description LAN
ip address 192.168.16.1 255.255.255.0
ip accounting output-packets
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!

control-plane
!

mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!

line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line vty 0 4
privilege level 15
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
192.168.16.31       01f0.def1.c89f.6c       Dec 09 2015 01:09 PM    Automatic

Мак адрес правильный но машина не получает ip (компьютеры пробовал разные, вопрос не в компьютере)

В общем прошу помочь или предложить идеи по диагностированию проблемы.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco 881 проблемы с DHCP (не раздает)"  +/
Сообщение от Aneye (ok) on 08-Дек-15, 13:28 
А Cisco - единственный DHCP в сети?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Cisco 881 проблемы с DHCP (не раздает)"  +/
Сообщение от tsarush email(ok) on 08-Дек-15, 13:33 
> А Cisco - единственный DHCP в сети?

Это сеть из cisco и проводком подключенного компьютера в fa1.

C881W-E-K9#show interfaces status

Port    Name               Status       Vlan       Duplex Speed Type
Fa0                        connected    1          a-full   a-100 10/100BaseTX
Fa1                        notconnect   1            auto    auto 10/100BaseTX
Fa2                        notconnect   1            auto    auto 10/100BaseTX
Fa3                        notconnect   1            auto    auto 10/100BaseTX
Wl0     Internal switch in connected    1          a-full  a-1000 10/100BaseTX

C881W-E-K9#show vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0, Fa1, Fa2, Fa3, Wl0
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0
C881W-E-K9#

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Cisco 881 проблемы с DHCP (не раздает)"  +/
Сообщение от cant email on 08-Дек-15, 14:20 

> wireshark показывает что ничего не приходило.

Односторонняя связь?

Назначьте статический ip на компьютер и попингайте циску.

debup ip dhcp server events
term mon

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Cisco 881 проблемы с DHCP (не раздает)"  +/
Сообщение от tsarush email(ok) on 08-Дек-15, 14:26 
>> wireshark показывает что ничего не приходило.
> Односторонняя связь?
> Назначьте статический ip на компьютер и попингайте циску.
> debup ip dhcp server events
> term mon

Если на компьютере назначить статический ip адрес то cisco пингуется.

debuG ip dhcp server events

Dec  8 11:23:23.309: %DTP-5-NONTRUNKPORTON: Port Fa3 has become non-trunk
Dec  8 11:23:23.801: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet3, changed state to down
Dec  8 11:23:23.801: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to down
Dec  8 11:23:24.301: DHCPD: checking for expired leases.
Dec  8 11:23:24.809: %LINK-3-UPDOWN: Interface FastEthernet3, changed state to down
Dec  8 11:23:26.445: %DTP-5-TRUNKPORTON: Port Fa3 has become dot1q trunk
Dec  8 11:23:27.933: %LINK-3-UPDOWN: Interface FastEthernet3, changed state to up
Dec  8 11:23:28.933: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet3, changed state to up


выглядет как будто все по фентшую =)

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Cisco 881 проблемы с DHCP (не раздает)"  +/
Сообщение от ShyLion (ok) on 08-Дек-15, 15:45 
>[оверквотинг удален]
> state to down
> Dec  8 11:23:23.801: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state
> to down
> Dec  8 11:23:24.301: DHCPD: checking for expired leases.
> Dec  8 11:23:24.809: %LINK-3-UPDOWN: Interface FastEthernet3, changed state to down
> Dec  8 11:23:26.445: %DTP-5-TRUNKPORTON: Port Fa3 has become dot1q trunk
> Dec  8 11:23:27.933: %LINK-3-UPDOWN: Interface FastEthernet3, changed state to up
> Dec  8 11:23:28.933: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet3, changed
> state to up
> выглядет как будто все по фентшую =)

выглядит странно. откуда взялся Vlan 2 ?

int f3
switchport mode access
switchport nonegotiate

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Cisco 881 проблемы с DHCP (не раздает)"  +/
Сообщение от tsarush email(ok) on 09-Дек-15, 08:56 
>[оверквотинг удален]
>> Dec  8 11:23:24.809: %LINK-3-UPDOWN: Interface FastEthernet3, changed state to down
>> Dec  8 11:23:26.445: %DTP-5-TRUNKPORTON: Port Fa3 has become dot1q trunk
>> Dec  8 11:23:27.933: %LINK-3-UPDOWN: Interface FastEthernet3, changed state to up
>> Dec  8 11:23:28.933: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet3, changed
>> state to up
>> выглядет как будто все по фентшую =)
> выглядит странно. откуда взялся Vlan 2 ?
> int f3
>  switchport mode access
>  switchport nonegotiate

vlan 2 я добавил чуть позже...
Добавил еще один hdcp pool 192.168.17.0
И попробовал привязал порт на vlan 2


В общем итог такой...


Циска начинает работать тогда когда нагреется и тогда dhcp раздает
Если она постоит ночь то перестает раздавать, похоже на какую то микротрещину на плате с нагревом она работает... Постоит и не работает...

Стремная тема...

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Cisco 881 проблемы с DHCP (не раздает)"  +/
Сообщение от ShyLion (ok) on 09-Дек-15, 09:12 
>[оверквотинг удален]
>>  switchport mode access
>>  switchport nonegotiate
> vlan 2 я добавил чуть позже...
> Добавил еще один hdcp pool 192.168.17.0
> И попробовал привязал порт на vlan 2
> В общем итог такой...
> Циска начинает работать тогда когда нагреется и тогда dhcp раздает
> Если она постоит ночь то перестает раздавать, похоже на какую то микротрещину
> на плате с нагревом она работает... Постоит и не работает...
> Стремная тема...

чудеса в решете

wireshar на компе запусти и понюхай траффик. возможно "трещина" в писюке.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Cisco 881 проблемы с DHCP (не раздает)"  +/
Сообщение от tsarush email(ok) on 09-Дек-15, 09:14 
>[оверквотинг удален]
>> vlan 2 я добавил чуть позже...
>> Добавил еще один hdcp pool 192.168.17.0
>> И попробовал привязал порт на vlan 2
>> В общем итог такой...
>> Циска начинает работать тогда когда нагреется и тогда dhcp раздает
>> Если она постоит ночь то перестает раздавать, похоже на какую то микротрещину
>> на плате с нагревом она работает... Постоит и не работает...
>> Стремная тема...
> чудеса в решете
> wireshar на компе запусти и понюхай траффик. возможно "трещина" в писюке.

Да не написал...

wireshark молчит, но туда приходит информация о том что подключена киско...

https://yadi.sk/d/ByJl-aD6m6MXr

ссылка на файл wireshark лог

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Cisco 881 проблемы с DHCP (не раздает)"  +/
Сообщение от ShyLion (ok) on 09-Дек-15, 09:17 
>[оверквотинг удален]
>>> В общем итог такой...
>>> Циска начинает работать тогда когда нагреется и тогда dhcp раздает
>>> Если она постоит ночь то перестает раздавать, похоже на какую то микротрещину
>>> на плате с нагревом она работает... Постоит и не работает...
>>> Стремная тема...
>> чудеса в решете
>> wireshar на компе запусти и понюхай траффик. возможно "трещина" в писюке.
> Да не написал...
> wireshark молчит, но туда приходит информация о том что подключена киско...
> Но от dhcp ничего не приходит...

debug dhcp detail

свича нет между ними? с DHCP snooping, например.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Cisco 881 проблемы с DHCP (не раздает)"  +/
Сообщение от tsarush email(ok) on 09-Дек-15, 09:31 
>[оверквотинг удален]
>>>> Если она постоит ночь то перестает раздавать, похоже на какую то микротрещину
>>>> на плате с нагревом она работает... Постоит и не работает...
>>>> Стремная тема...
>>> чудеса в решете
>>> wireshar на компе запусти и понюхай траффик. возможно "трещина" в писюке.
>> Да не написал...
>> wireshark молчит, но туда приходит информация о том что подключена киско...
>> Но от dhcp ничего не приходит...
> debug dhcp detail
> свича нет между ними? с DHCP snooping, например.

Свича нет. Но в самой cisco стоит модуль свич на 4 порта (L2)

Обновленный конфиг

Building configuration...

Current configuration : 2631 bytes
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname C881W-E-K9
!
boot-start-marker
boot-end-marker
!
aaa new-model
!
!
aaa authentication login default local
!
aaa session-id common
ethernet lmi ce
bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
clock timezone MSK 3 0
service-module wlan-ap 0 bootimage autonomous
!
ip dhcp excluded-address 192.168.16.1 192.168.16.30
ip dhcp excluded-address 192.168.16.200 192.168.16.254
ip dhcp excluded-address 192.168.17.1 192.168.17.30
ip dhcp excluded-address 192.168.17.200 192.168.17.254
!
ip dhcp pool LAN
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1
dns-server 192.168.16.1
!
ip dhcp pool GUEST
network 192.168.17.0 255.255.255.0
default-router 192.168.17.1
dns-server 192.168.17.1
!
ip domain name freestyleteam.ru
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
license udi pid C881W-E-K9 sn FCZ171390Z4
license accept end user agreement
license boot module c800 level advipservices
!
archive
log config
  logging enable
  hidekeys
username sysadmin privilege 15 secret 5 $1$9K1.$M1chRMHpDED286j5s0rJs1
!
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
!
interface FastEthernet0
no ip address
spanning-tree portfast
!
interface FastEthernet1
no ip address
spanning-tree portfast
!
interface FastEthernet2
no ip address
spanning-tree portfast
!
interface FastEthernet3
switchport mode trunk
no ip address
spanning-tree portfast
!
interface FastEthernet4
description MortonTelecom
ip address dhcp
ip nat outside
ip virtual-reassembly in
shutdown
duplex auto
speed auto
!
interface Wlan-GigabitEthernet0
no ip address
!
interface wlan-ap0
no ip address
!
interface Vlan1
description LAN
ip address 192.168.16.1 255.255.255.0
ip accounting output-packets
ip nat inside
ip virtual-reassembly in
!
interface Vlan2
description GUEST
ip address 192.168.17.1 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
control-plane
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line vty 0 4
privilege level 15
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Cisco 881 проблемы с DHCP (не раздает)"  +/
Сообщение от Andrey (??) on 09-Дек-15, 13:50 
>>[оверквотинг удален]

Попробуйте использовать команду service dhcp в режиме конигурации.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Cisco 881 проблемы с DHCP (не раздает)"  +/
Сообщение от Hammer (ok) on 07-Янв-16, 06:04 
>[оверквотинг удален]
> !
> interface FastEthernet4
>  description MortonTelecom
>  ip address dhcp
>  ip nat outside
>  ip virtual-reassembly in
>  shutdown
>  duplex auto
>  speed auto
> !

по updown шнурок, как я погял, ткнул в fa3

Зачем там транк?
переведи его в access vlan 2

у меня

no ip dhcp use vrf connected
!
ip dhcp pool LAN
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   lease 0 1
!

interface FastEthernet0/1
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!

3725-1-1#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
10.10.10.2          0100.5079.6668.00       Mar 01 2002 01:15 AM    Automatic

Вы понимаете к чему я клоню?

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor