The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Настройка NAT для локальной сети (тестовый стенд)"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco маршрутизаторы)
Изначальное сообщение [ Отслеживать ]

"Настройка NAT для локальной сети (тестовый стенд)"  +/
Сообщение от Almi email(ok) on 08-Окт-15, 09:26 
       --Исходные данные--

Маршрутизатор:      Cisco C2691
Внешняя сеть:       10.0.10.0/24
Шлюз внешней сети:  10.0.10.1

Внутренняя сеть:      10.168.50.0/24
Шлюз внутренней сети: 10.168.50.2
DNS:                  8.8.8.8
WAN:                внешний порт (interface Fa 0/0)
LAN:                локальный порт (interface Fa 0/1)
Клиент в локалке:     Windows XP

Топология сети: http://s020.radikal.ru/i709/1510/a9/d9f52fa2c048.png

Все действия провожу в GNS3.

Конфиг роутера:
Gw0# show config
Using 1787 out of 57336 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Gw0
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$9Sn8$mbUANn6XWlBdztomdHHDe/
!
aaa new-model
!
!
!
aaa session-id common
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool LAN_users
   network 10.168.50.0 255.255.255.0
   default-router 10.168.50.2
   dns-server 8.8.8.8
   lease 0 2
!
!
no ip domain lookup
ip domain name company.local
ip name-server 8.8.8.8
!
!
!
!
username user privilege 15 secret 5 $1$uEvD$a8VL8oIYNqPlCZ9EyLmkH.
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
description WAN
ip address 10.0.10.10 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description LAN
ip address 10.168.50.2 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
!
ip route 0.0.0.0 0.0.0.0 10.0.10.1 name .default.
!
!
no ip http server
no ip http secure-server
ip nat inside source list 4 interface FastEthernet0/0 overload
ip nat inside source list NAT interface FastEthernet0/1 overload
!
ip access-list extended NAT
permit ip 0.0.0.0 255.255.255.0 any
!
access-list 4 remark .NAT.
no cdp log mismatch duplex
no cdp run
!
!
!
!
control-plane
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
password 7 047E0616192C5E1C51
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
exec-timeout 30 0
password 7 052E0B1F37415C5B41
logging synchronous
transport input ssh
line vty 5 935
exec-timeout 30 0
password 7 052E0B1F37415C5B41
logging synchronous
transport input ssh
!
!
end


С клиента пинги идут до внутреннего и внешнего IP адреса маршрутизатора.
Выхода в глобальную сеть - нет. Как с клиента, так и с роутера.

Может быть в GNS3 есть настройка портов, которая влияет на выход в интернет.
Со вчерашнего дня парюсь, перепробовал кучу всего - не выходит результата.

Помогите дельным советом, пожалуйста!

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Настройка NAT для локальной сети (тестовый стенд)"  +/
Сообщение от Del on 08-Окт-15, 13:44 
Вот это: ip nat inside source list NAT interface FastEthernet0/1 overload зачем?

И тут пусто: access-list 4 remark .NAT.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Настройка NAT для локальной сети (тестовый стенд)"  +/
Сообщение от Almi email(ok) on 08-Окт-15, 14:53 
> Вот это: ip nat inside source list NAT interface FastEthernet0/1 overload зачем?
> И тут пусто: access-list 4 remark .NAT.

Это я удалил, но все равно не выходит Интернета (
--------------------------------------
!
hostname Gw0
!
ip cef
!
no ip dhcp use vrf connected
!
ip dhcp pool LAN_users
   network 10.168.50.0 255.255.255.0
   default-router 10.168.50.2
   dns-server 8.8.8.8
   lease 0 2
!
!
no ip domain lookup
ip domain name company.local
ip name-server 8.8.8.8
!
!
interface FastEthernet0/0
description WAN
ip address 10.0.10.10 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description LAN
ip address 10.168.50.2 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
!
ip route 0.0.0.0 0.0.0.0 10.0.10.3 name .default.
!
!
no ip http server
no ip http secure-server
!
access-list 4 remark .NAT.
access-list 4 permit 10.168.50.0 0.0.0.255
no cdp log mismatch duplex
no cdp run

end
--------------------------------------
Видимо проблема с интерфейсом VBOX, возможно он как-то по другому работает...

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Настройка NAT для локальной сети (тестовый стенд)"  +/
Сообщение от Almi email(ok) on 08-Окт-15, 15:39 
Пытался добавить облако с реальным и виртуальным адаптером VBOX - не получается выхода в инет. Видимо, я где-то сильно накосячил.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Настройка NAT для локальной сети (тестовый стенд)"  +/
Сообщение от Almi (ok) on 08-Окт-15, 18:24 
> Пытался добавить облако с реальным и виртуальным адаптером VBOX - не получается
> выхода в инет. Видимо, я где-то сильно накосячил.

Вопрос снят, настроил виртуальный адаптер VBOX в режиме моста к реальному Wi FI адаптеру физ. компа.
И далее использовал виртуальный адаптер VBOX в облаке, через которое вышел маршрутизатор Cisco.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Настройка NAT для локальной сети (тестовый стенд)"  +/
Сообщение от ShyLion (ok) on 09-Окт-15, 07:14 
>[оверквотинг удален]
>  ip nat inside
>  ip virtual-reassembly
>  duplex auto
>  speed auto
> !
> !
> ip route 0.0.0.0 0.0.0.0 10.0.10.1 name .default.
> !
> !
> ip nat inside source list 4 interface FastEthernet0/0 overload

для ната лучше extended аксеслист

> ip nat inside source list NAT interface FastEthernet0/1 overload

это неверная строка, нужно указывать внешний интерфейс


> !
> ip access-list extended NAT
>  permit ip 0.0.0.0 255.255.255.0 any
> !

почитай основы по аксес-листам циски, там не МАСКА сети используется, а ее ОБРАТНОЕ побитовое отображение , т.е. нужно указать 10.168.50.0 0.0.0.255

> access-list 4 remark .NAT.

этот аксес-лист пустой

правильно сделать так:


ip access-list extended NAT
! строки с deny добавить в реальной ситуации когда на WAN реальный IP
! deny ip any 10.0.0.0 0.255.255.255
! deny ip any 192.168.0.0 0.0.255.255
! deny ip any 172.16.0.0 0.15.255.255
! deny ip any 169.254.0.0 0.0.255.255

permit ip 10.168.50.0 0.0.0.255 any
!
ip nat inside source list NAT interface Fas0/0 overload


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Настройка NAT для локальной сети (тестовый стенд)"  +/
Сообщение от Almi email(ok) on 11-Окт-15, 20:57 
>[оверквотинг удален]
> ! строки с deny добавить в реальной ситуации когда на WAN реальный
> IP
> ! deny ip any 10.0.0.0 0.255.255.255
> ! deny ip any 192.168.0.0 0.0.255.255
> ! deny ip any 172.16.0.0 0.15.255.255
> ! deny ip any 169.254.0.0 0.0.255.255
>  permit ip 10.168.50.0 0.0.0.255 any
> !
> ip nat inside source list NAT interface Fas0/0 overload
>

Спасибо, будем знать :)

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема



Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру
Hosting by Ihor