The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Нет маршрутизации VLAN на CISCO WS-C3750X-48"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]
Cisco CCNA Routing & Switching версия 3.0 - новые курсы и экзамены
"Нет маршрутизации VLAN на CISCO WS-C3750X-48"  +/
Сообщение от Stamper1986 email(ok) on 28-Май-15, 16:14 
Добрый день.

Необходима помощь в решении вопроса маршрутизации VLAN.

Схема сети:
cisco WS-C3750X-48 - (ip 192.168.9.2 для связки с Kerio) будет в качестве центрального коммутатора сети (на нём будет настроено порядка 12 VLAN разного предназначения)
Kerio - шлюз сети. (ip 192.168.9.1)

На данный момент проведена начальная настройка Cisco, но маршрутизации нет между VLAN, интерфейсы даже не пингуются с самого свича. Где допустил ошибку не могу найти. Прошу помочь.

причём VLAN на которых прописаны  ip helper-address 192.168.0.79 (DHCP сервер) - маршрутизируются. а если со свича попробовать пропинговать 128,89,255,1 - (ip адрес свича для управления) - хост не отвечает, даже если пробовать пинговать из любого работающего VLAN такая же история. Если начать пинговать этот IP со стороны kerio, то циска возвращает пакет обратно kerio для поиска сети.

конфиг:
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW01
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone MSK 4 0
switch 1 provision ws-c3750x-48
system mtu routing 1500
ip routing
!
!
no ip domain-lookup
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
vlan internal allocation policy ascending
!
!
interface FastEthernet0
no ip address
no ip route-cache cef
no ip route-cache
shutdown
!
!
interface GigabitEthernet1/0/48
description to Kerio 02
switchport access vlan 377
switchport mode access
switchport port-security maximum 20
switchport port-security aging time 5
switchport port-security violation restrict
switchport port-security aging type inactivity
storm-control broadcast level 10.00
storm-control action shutdown
storm-control action trap
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
!
interface Vlan1
no ip address
shutdown
!
interface Vlan307
description Video_CCTV network
ip address 192.168.3.1 255.255.255.0
ip helper-address 192.168.0.79
!
interface Vlan377
description Network with KERIO
ip address 192.168.9.2 255.255.255.0
!
interface Vlan400
description CISCO MANAGEMENT
ip address 128.89.255.1 255.255.255.0
!
interface Vlan405
description Warehouse
ip address 128.89.140.1 255.255.255.0
ip helper-address 192.168.0.79
!
ip default-gateway 192.168.9.1
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.9.1
logging esm config


Так выглядит таблица маршрутизации на свиче

SW01# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.9.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 192.168.9.1
      128.89.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        128.89.140.0/24 is directly connected, Vlan405
L        128.89.140.1/32 is directly connected, Vlan405
      192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.3.0/24 is directly connected, Vlan307
L        192.168.3.1/32 is directly connected, Vlan307
      192.168.9.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.9.0/24 is directly connected, Vlan377
L        192.168.9.2/32 is directly connected, Vlan377

Таблица VLAN
SW01#

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/0/17, Gi1/0/18, Gi1/0/19
                                                Gi1/0/20, Gi1/0/21, Gi1/0/22
                                                Gi1/0/23, Gi1/0/24, Gi1/0/25
                                                Gi1/0/26, Gi1/0/27, Gi1/0/28
                                                Gi1/0/29, Gi1/0/30, Gi1/0/31
                                                Gi1/0/32, Gi1/0/33, Gi1/0/34
                                                Gi1/0/35, Gi1/0/36, Gi1/0/37
                                                Gi1/0/38, Gi1/0/39, Gi1/0/40
                                                Gi1/0/41, Gi1/0/42, Gi1/0/43
                                                Gi1/0/44, Gi1/0/45, Gi1/0/47
                                                Gi1/1/1, Gi1/1/2, Gi1/1/3
                                                Gi1/1/4
125  Native                           active
307  VIDEO_CCTV                       active    Gi1/0/1, Gi1/0/2, Gi1/0/3
                                                Gi1/0/4, Gi1/0/5, Gi1/0/6
                                                Gi1/0/7, Gi1/0/8, Gi1/0/9
                                                Gi1/0/10, Gi1/0/11, Gi1/0/12
                                                Gi1/0/46
377  Routing_with_Kerio01             active    Gi1/0/48
400  CISCO_MANAGEMENT                 active
405  Warehouse               active    Gi1/0/13, Gi1/0/14, Gi1/0/15
                                                Gi1/0/16

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Нет маршрутизации VLAN на CISCO WS-C3750X-48"  +/
Сообщение от cant email on 28-Май-15, 16:28 

Оттого что все активные порты, где прописан этот vlan находятся в дауне, нет линка.

interface Vlan400
description CISCO MANAGEMENT
ip address 128.89.255.1 255.255.255.0

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Нет маршрутизации VLAN на CISCO WS-C3750X-48"  +/
Сообщение от _alecx_ (ok) on 28-Май-15, 16:33 
ip адреса с Vlan400 нет в таблице маршрутизации.
Скорее всего он в down, так как нет физ. портов или транков к нему относящихся.

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
400  CISCO_MANAGEMENT                 active

смотрите sh ip int vlan 400

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Нет маршрутизации VLAN на CISCO WS-C3750X-48"  +/
Сообщение от Stamper1986 email(ok) on 28-Май-15, 18:02 
>[оверквотинг удален]
> Скорее всего он в down, так как нет физ. портов или транков
> к нему относящихся.
> VLAN Name          
>            
>        Status    
> Ports
> ---- -------------------------------- --------- -------------------------------
> 400  CISCO_MANAGEMENT          
>        active
> смотрите sh ip int vlan 400

Значит, если я подключаю клиентский свитч  Cisco 2960 к центральному транком , где прописан такой же VLAN только с ip 128.89.255.2 (не привязанный к портам) - Vlan должен подняться и маршрутизация должна заработать?

Спасибо за ответы.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Нет маршрутизации VLAN на CISCO WS-C3750X-48"  +/
Сообщение от ShyLion (ok) on 29-Май-15, 07:29 
> interface Vlan400
>  description CISCO MANAGEMENT
>  ip address 128.89.255.1 255.255.255.0

Это конечно к делу не относиться, НО:


# whois 128.89.255.1

NetRange:       128.89.0.0 - 128.89.255.255
CIDR:           128.89.0.0/16
NetName:        BBN-CORPENET
NetHandle:      NET-128-89-0-0-1
Parent:         NET128 (NET-128-0-0-0-0)
NetType:        Direct Assignment
OriginAS:
Organization:   Bolt Beranek and Newman Inc. (BBN)
RegDate:        1985-08-09
Updated:        2005-07-14
Ref:            http://whois.arin.net/rest/net/NET-128-89-0-0-1


OrgName:        Bolt Beranek and Newman Inc.
OrgId:          BBN
Address:        10 Moulton Street
City:           Cambridge
StateProv:      MA
PostalCode:     02138
Country:        US
RegDate:
Updated:        2011-09-24
Ref:            http://whois.arin.net/rest/org/BBN

Метод конфигурации "с потолка" ?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Нет маршрутизации VLAN на CISCO WS-C3750X-48"  +/
Сообщение от ogiss on 29-Май-15, 07:42 
conf t

interface GigabitEthernet1/0/48
no switchport mode access
no switchport access vlan 377
switchport mode trunk
Ctr z

ну и все интерфейсы VLAN кроме 377, поднимать уже на Kerio


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Нет маршрутизации VLAN на CISCO WS-C3750X-48"  +/
Сообщение от ShyLion (ok) on 29-Май-15, 07:44 
> conf t
> interface GigabitEthernet1/0/48
>  no switchport mode access
>  no switchport access vlan 377
>  switchport mode trunk
> Ctr z
> ну и все интерфейсы VLAN кроме 377, поднимать уже на Kerio

Роутить между виланами софтовым роутером на винде? Браво!
Зачем тогда в сети 3750Х ?

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Нет маршрутизации VLAN на CISCO WS-C3750X-48"  +/
Сообщение от Stamper1986 email(ok) on 29-Май-15, 10:09 
> conf t
> interface GigabitEthernet1/0/48
>  no switchport mode access
>  no switchport access vlan 377
>  switchport mode trunk
> Ctr z
> ну и все интерфейсы VLAN кроме 377, поднимать уже на Kerio

Kerio c VLAN дружит плохо, очень плохо. поэтому маршрутизацию надо поднимать именно на свиче. Kerio вообще работает как прокси, биллинг и гейт для VPN клиентов. сердито и не так дорого. резервным роутером работает cisco 1800 при "зависании" kerio (что бывает раз в 2 месяца точно)

Спасибо за советы.

по поводу ИП для цисок - я особо не парюсь, так как эта подсеть будет доступна только с 3-х ип адресов в сети.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

8. "Нет маршрутизации VLAN на CISCO WS-C3750X-48"  +/
Сообщение от ShyLion (??) on 31-Май-15, 10:36 
> по поводу ИП для цисок - я особо не парюсь, так как
> эта подсеть будет доступна только с 3-х ип адресов в сети.

это вопрос культуры производства, просто в глаза бросилось

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Нет маршрутизации VLAN на CISCO WS-C3750X-48"  +/
Сообщение от ogiss on 01-Июн-15, 08:43 
Тогда на коммутаторе надо настраивать динамический роутинг ( RIP, OSPF, EIGRP, BGP) - мануал - Catalyst 3750 Switch Software Configuration Guide на сайте Cisco

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

10. "Нет маршрутизации VLAN на CISCO WS-C3750X-48"  +/
Сообщение от ShyLion (ok) on 01-Июн-15, 14:43 
> Тогда на коммутаторе надо настраивать динамический роутинг ( RIP, OSPF, EIGRP, BGP)
> - мануал - Catalyst 3750 Switch Software Configuration Guide на сайте
> Cisco

Зачем пугаешь человека? Для двух роутеров паровозом нет необходимости в динамике.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor