The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Падение скорости на маршруте (100МБит/с ->1МБит/с)"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от vitrum82 email(ok) on 22-Апр-15, 07:52 
Здравствуйте уважаемые господа.
Прошу помочь с решением данной проблемы.
Используемое оборудование:
Маршрутизатор Cisco7206;
Коммутатор Cisco Catalist 3750 (в роли маршрутизатора);
Ноутбук.
Описание архитектуры сети:
Сеть1->...->3750->7206->Ноутбук(вместо сети2)
Описание проблемы:
При копировании из сети1 в ноутбук скорость передачи данных мала(~135кБайт/сек)
реальная ширина канала 40МБит/с (WiFi)
Что сделано (не нашел как прикретить картинку):
1) Копируем сквозь 7206
{Комп (10.64.1.49 255.255.255.252)} -> {(10.64.1.50 255.255.255.252)7206(10.64.127.1 255.255.254.0)} -> {ноутбук (10.64.127.103 255.255.254.0)}
В итоге скорость с компа 10МБайт/с;
2) Копируем без 7206
Сеть1->...->{3750 (10.64.1.49 255.255.255.252)}-> {ноутбук (10.64.1.50 255.255.255.252)}
В итоге скорость закачки из сети1 6МБайт/с;
3) Копирем через 7206 из сети1
Сеть1->...->{3750 (10.64.1.49 255.255.255.252)}-> {(10.64.1.50 255.255.255.252)7206(10.64.127.1 255.255.254.0)} -> {ноутбук (10.64.127.103 255.255.254.0)}
В итоге скорость закачки из сети1 135кБайт/с.

Конфиг 7206:

Router#sh run

version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
ip subnet-zero
!
ip cef
!
controller E1 1/0
!
controller E1 1/1
!
controller E1 1/2
!
controller E1 1/3
!
controller E1 1/4
!
controller E1 1/5
!
controller E1 1/6
!
controller E1 1/7
!
interface FastEthernet0/0
ip address 10.64.1.50 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.1
description Obshaya
encapsulation dot1Q 1 native
ip address 10.64.127.1 255.255.254.0
!
interface FastEthernet0/1.8
description Vibro
encapsulation dot1Q 8
ip address 10.64.30.225 255.255.255.224
!
ip classless
ip route 10.0.0.0 255.0.0.0 10.64.1.49
no ip http server
ip pim bidir-enable
!
call rsvp-sync
!
mgcp profile default
!
dial-peer cor custom
!
gatekeeper
shutdown
!
end

Конфиг 3750:

hostname mirny-inter-dsw1

ip routing

interface Loopback0
ip address 10.64.0.128 255.255.255.255

interface GigabitEthernet1/0/1
description "Link to network rudnik Inter"
no switchport
ip address 10.64.1.49 255.255.255.252
no cdp enable

interface GigabitEthernet1/0/24
description "Link to mirny-usw-cgw1"
no switchport
ip address 10.64.254.162 255.255.255.252

router ospf 100
redistribute connected subnets
redistribute static subnets
passive-interface default
no passive-interface GigabitEthernet1/0/24
network 10.64.0.0 0.0.255.255 area 0

ip route 10.64.30.224 255.255.255.224 10.64.1.50
ip route 10.64.126.0 255.255.254.0 10.64.1.50

ntp source Loopback0
ntp server 10.64.0.24


Из-за чего происходит такое падение скорости, ведь она должна быть как минимум 6МБайт/с?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от cant email on 22-Апр-15, 09:35 
> Сеть1->...->3750->7206->Ноутбук(вместо сети2)
> Описание проблемы:
> При копировании из сети1 в ноутбук скорость передачи данных мала(~135кБайт/сек)
> реальная ширина канала 40МБит/с (WiFi)

Первично надо посмотреть следующее:
Как слинковался eth между 3750->7206 (какие там ошибки на интерфейсах)?
Только tcp не разгоняется или реально видны дропы на ip ?(простейшим флуд-пингом проверьте)

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от vitrum82 email(ok) on 22-Апр-15, 10:29 
> Первично надо посмотреть следующее:
> Как слинковался eth между 3750->7206 (какие там ошибки на интерфейсах)?

Какой командой посмотреть ошибки, к 7206 доступ есть, 3750 не в моем владении, но могу попросить.

> Только tcp не разгоняется или реально видны дропы на ip ?(простейшим флуд-пингом
> проверьте)

Чем можно организовать флуд-пинг, какой программой. С сетями не часто сталкивался.


Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

4. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от cant email on 22-Апр-15, 10:50 
>> Первично надо посмотреть следующее:
>> Как слинковался eth между 3750->7206 (какие там ошибки на интерфейсах)?
> Какой командой посмотреть ошибки, к 7206 доступ есть, 3750 не в моем
> владении, но могу попросить.

Как и на всех цисках, типа
show interface FastEthernet0/0
обнулите счетчики сначала clear count FastEthernet0/0
и смотрите как растут ошибки, ну и как он слинковался, может на 10 Mbps half duplex

>> Только tcp не разгоняется или реально видны дропы на ip ?(простейшим флуд-пингом
>> проверьте)
> Чем можно организовать флуд-пинг, какой программой. С сетями не часто сталкивался.

Ой забудьте про это.
тогда типа такой командой из виндовса:
ping -t -l 1400 8.8.8.8

В целом лучше избавится от этой cisco7206, отроутите эти 60Mbps на чем угодно легко,
зачем вам с незнакомым и старым оборудованием связываться?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

8. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от vitrum82 email(ok) on 22-Апр-15, 12:33 
> В целом лучше избавится от этой cisco7206, отроутите эти 60Mbps на чем
> угодно легко,
> зачем вам с незнакомым и старым оборудованием связываться?

Эта циска прослужила верой и правдой 11 лет по 6ти потокам E1 на скорости в 12МБит/с. После замены радиорелейки (E1) на упомянутую 3750 ее, 7206, выключили и маршрутизацию настроили через наш свитч Catalist 3550, тогда то я и заметил что если раньше скорость была хотя бы 1 МБайт/с, а стала в 8 раз меньше - 135-150кБайт/с и это притом что канал с 12 расширился до 40 МБит/с. Я очистил конфиг 7206, т.к. не знал на него пароль и настроил его как описано в конфиге. Выводы: на двух устройствах имеем одинаково заниженную скорость:/
Завтра попробую посмотреть счетчики и заслать пинг, единственное для этого требуется отключать всю сеть от маршрутизатора, или попробовать не отключая?

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

2. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от anonymous (??) on 22-Апр-15, 10:23 
Классический случай проверки скорости записи на диск, по-моему.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

9. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от vitrum82 email(ok) on 22-Апр-15, 12:34 
> Классический случай проверки скорости записи на диск, по-моему.

Не совсем понял о чем Вы? Если о том что падает скорость при записи на диск, то при исключении 7206 такого не наблюдается.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от cant email on 22-Апр-15, 11:00 
> Описание архитектуры сети:
> Сеть1->...->3750->7206->Ноутбук(вместо сети2)
> Описание проблемы:
> При копировании из сети1 в ноутбук скорость передачи данных мала(~135кБайт/сек)
> реальная ширина канала 40МБит/с (WiFi)
> 3) Копирем через 7206 из сети1
> Сеть1->...->{3750 (10.64.1.49 255.255.255.252)}-> {(10.64.1.50 255.255.255.252)7206(10.64.127.1
> 255.255.254.0)} -> {ноутбук (10.64.127.103 255.255.254.0)}
> В итоге скорость закачки из сети1 135кБайт/с.

А каким образом у вас vlan засовывается в ноутбук с этого интерфейса cisco7206 ?

interface FastEthernet0/1.1
description Obshaya
encapsulation dot1Q 1 native
ip address 10.64.127.1 255.255.254.0

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от vitrum82 email(ok) on 22-Апр-15, 12:11 
> А каким образом у вас vlan засовывается в ноутбук с этого интерфейса
> cisco7206 ?
> interface FastEthernet0/1.1
>  description Obshaya
>  encapsulation dot1Q 1 native
>  ip address 10.64.127.1 255.255.254.0

На самом деле за этой циской находиться сеть предприятия приблизительно на 150-200 хостов. Ноутбук подключался на время тестирования чтобы исключить влияние других компов и коммутаторов. Vlan 8 используется для отдельной промышленной подсети которую надо видеть с другого подразделения (система виброконтроля)

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от cant email on 22-Апр-15, 12:29 
>> А каким образом у вас vlan засовывается в ноутбук с этого интерфейса
>> cisco7206 ?
>> interface FastEthernet0/1.1
>>  description Obshaya
>>  encapsulation dot1Q 1 native
>>  ip address 10.64.127.1 255.255.254.0
> На самом деле за этой циской находиться сеть предприятия приблизительно на 150-200
> хостов. Ноутбук подключался на время тестирования чтобы исключить влияние других компов
> и коммутаторов. Vlan 8 используется для отдельной промышленной подсети которую надо
> видеть с другого подразделения (система виброконтроля)

Ясно. Сама железка cisco7206 для этого подходящая, чтоб справиться.
Приведенная часть её конфига - тоже нареканий не вызывает.

Да тут стандартный трабшутинг, начиная с:
- пингайте по хопам
- статистика не только интерфейсов, но и cpu

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

10. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от vitrum82 email(ok) on 22-Апр-15, 12:43 
> Ясно. Сама железка cisco7206 для этого подходящая, чтоб справиться.
> Приведенная часть её конфига - тоже нареканий не вызывает.
> Да тут стандартный трабшутинг, начиная с:
>  - пингайте по хопам

Я так понимаю приложить сюда результат tracert из моей сети на хост из сети1 (в цепочке порядка 8-10 маршрутизаторов)?
>  - статистика не только интерфейсов, но и cpu

Тоже думаю что нагрузка для нее не велика, завтра сниму статистику CPU и интерфейсов.
Прошу также обратить внимание что когда вместо 7206 был 3550 картина была аналогичная, вплоть до десятка кБайт/с.
Также предлагали выставить вручную скорость и дуплекс на 3750 и 7206 на портах, которые друг на друга смотрят соответственно. Имеет смысл?

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

11. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от cant email on 22-Апр-15, 13:36 
>>  - пингайте по хопам
>
> Я так понимаю приложить сюда результат tracert из моей сети на хост
> из сети1 (в цепочке порядка 8-10 маршрутизаторов)?

Прежде общий вопрос. Важна скорость скачки с какого-то конкретного внешнего хоста?
Или с любого внешнего хоста всё плохо?

Общий совет. Состояние внешнего канала желательно мониторить. Ну типа snmp-программы строят график загрузки в течении суток. Может трафик на канале в полку.

Попсовый совет. pingplotter для виндовса визуализирует во времени и пространстве все дропы и задержки по хопам круглосуточно. На рутрекере должен валятся.


> .. когда вместо 7206 был 3550 картина была
> аналогичная, вплоть до десятка кБайт/с.
> Также предлагали выставить вручную скорость и дуплекс на 3750 и 7206 на
> портах, которые друг на друга смотрят соответственно. Имеет смысл?

Да да, если замена 7206 на 3550 не влияет, то действительно в первую очередь
убедитесь в линковке 100M full duplex с обеих сторон и бегут ли при этом ошибки на интерфейсах. Неважно как, в auto или вручную вы добьетесь 100fd.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от cant email on 22-Апр-15, 14:51 
Такое ещё предположение.
Вы располагаете тремя разными подсетями:
10.64.127.1 255.255.254.0
10.64.1.50 255.255.255.252
10.64.30.225 255.255.255.224

Администраторы управляющие ресурсами и транзитом "Сеть1" могли просто зашейпить одну подсеть(которая 10.64.127.1 255.255.254.0),
а на остальные отдают трафик без ограничений.

Проверить это можно, временно оттранслировав (NAT) одну сеть в другую.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

13. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от vitrum82 email(ok) on 22-Апр-15, 14:56 
> Такое ещё предположение.
> Вы располагаете тремя разными подсетями:
> 10.64.127.1 255.255.254.0
> 10.64.1.50 255.255.255.252
> 10.64.30.225 255.255.255.224
> Администраторы управляющие ресурсами и транзитом "Сеть1" могли просто зашейпить одну подсеть(которая
> 10.64.127.1 255.255.254.0),
> а на остальные отдают трафик без ограничений.
> Проверить это можно, временно оттранслировав (NAT) одну сеть в другую.

Как вариант еще завтра попробую с 10.64.30.225 качнуть что-нибудь.

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от cant email on 22-Апр-15, 15:45 
>> а на остальные отдают трафик без ограничений.
>> Проверить это можно, временно оттранслировав (NAT) одну сеть в другую.
>
> Как вариант еще завтра попробую с 10.64.30.225 качнуть что-нибудь.

Да можно. Или может проще, на минутку включите NAT на cisco7206

conf t
interface FastEthernet0/0
ip nat outside
!
interface FastEthernet0/1.1
ip nat inside
!
access-list 100 permit ip 10.64.126.0 0.0.1.255 any
ip nat inside source list 100 interface fa0/0 overload

Проверьте, улучшилась ли скачка у пользователей в сети 10.64.127.103,
и сразу отключите NAT:

conf t
interface FastEthernet0/0
no ip nat outside
!
interface FastEthernet0/1.1
no ip nat inside
!

Больше надежды, что не шейпят именно "операторско-интерфейсную" сеть.
Вот в неё на минутку и оттранслируйтесь таким образом.

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

15. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от vitrum82 email(ok) on 24-Апр-15, 03:39 
> Да можно. Или может проще, на минутку включите NAT на cisco7206
> Проверьте, улучшилась ли скачка у пользователей в сети 10.64.127.103,
> и сразу отключите NAT:

Включил NAT, заново перезапустил скачку файла, ситуация не изменилась.

> Как вариант еще завтра попробую с 10.64.30.225 качнуть что-нибудь.

И так мои наблюдения:
10.64.127.1 255.255.254.0     - 512 хостов - скорость 135 кБайт/с;
10.64.30.225 255.255.255.224  - 32 хоста   - скорость 1415 кБайт/с;
10.64.1.50 255.255.255.252    - 4 хоста    - скорость 6127 кБайт/с.

Как будто идет пропорциональное деление ширины канала на количество хостов в сети.

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

16. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от vitrum82 email(ok) on 24-Апр-15, 09:35 
> Как будто идет пропорциональное деление ширины канала на количество хостов в сети.

Связался с админом который рулит маршрутизаторами на пути следования трасера, сказал что шейперов нет.
Осталась надежда что шейпят админы которым принадлежит радиорелейная часть (объект у нас удаленный от города).


Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

17. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от cant email on 24-Апр-15, 10:31 
> Включил NAT, заново перезапустил скачку файла, ситуация не изменилась.
>
> И так мои наблюдения:
> 10.64.127.1 255.255.254.0     - 512 хостов - скорость 135
> кБайт/с;
> 10.64.30.225 255.255.255.224  - 32 хоста   - скорость 1415 кБайт/с;
>
> 10.64.1.50 255.255.255.252    - 4 хоста    -
> скорость 6127 кБайт/с.
>

Т.е. выходит, что включив NAT обращались к ресурсу с src ip 10.64.1.50 и получали 135kpbs,
а вставали ноутбуком прямо на него 10.64.1.50 то 6Mbps.

Я бы вернулся к началу, проверяя линковку интерфейсов eth, пропингивать по хопам, и выясняя это дефект только разгона одной сессии tcp или всего ip (типа запустите десяток одновременных tcp-сессий с ресурса).

Если администраторы ресурса "Сеть1" у себя на соседнем сервере запустят iperf и подскажут вам, как и что надо проверить, чтобы очистить свою совесть, то дело гораздо быстрее пойдет.

> Как будто идет пропорциональное деление ширины канала на количество хостов в сети.
>

Маловероятно. такое не практикуется из-за бессмысленности, или как побочный эффект чего-то вряд ли.

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

18. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от cant email on 24-Апр-15, 11:24 
> Включил NAT, заново перезапустил скачку файла, ситуация не изменилась.

Это ещё может быть похоже на поведение протокала типа (samba,ntbios,виндовс-шара).
Он нормально работает в пределах транспорта без сужений (т.е. если бы WAN не 60Mbps был, а 100Mbps, то можно было бы выйти из ситуации зажав 100fd на сервере и клиенте).

На транспорте с сужениями вдруг иногда тоже нормально работает, но чаще непредсказуемо хуже. (зависит это от кучи мелких факторов в разных местах, которые если и удается с большим трудом затюнить, то потом от любого чиха все опять валится).

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

19. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от vitrum82 email(ok) on 30-Апр-15, 15:36 
К сожалению ситуация не изменилась, релейщики нашли что-то и устранили, но результата это не дало. С 1 мая я ухожу в отпуск, по выходу буду мучить канал связи дальше.


Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

20. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от cant email on 05-Май-15, 17:20 
> К сожалению ситуация не изменилась, релейщики нашли что-то и устранили, но результата
> это не дало. С 1 мая я ухожу в отпуск, по
> выходу буду мучить канал связи дальше.

По вышеполученным данным не похоже на проблему канала.

И это явно не указывают на какой-то конкретный типичный, хорошо известный дефект.

Одного универсального инструмента по диагностике подобных проблем нет.

Порой достаточно одному юзеру в локальной сети понаблюдать наметанным взглядом на несколько одновременно запущенных окошек виндовс-cmd
с разными пингами и трейсами, чтобы сразу сказать где и что именно барахлит у одного из "провайдеров" по пути.

Иначе, если не сложно, то с циски7206 покажите вывод всех этих команд полностью:
show interfaces
show proc cpu history
ping 10.64.127.103 size 1400 repeat 500
ping 10.64.1.49 size 1400 repeat 500
ping <ip внеш.ресурса> size 1400 repeat 500

и ещё раз их же в процессе скачивания данных с внеш.ресурса.

Ещё до кучи
traceroute <ip внеш.ресурса> source 10.64.127.1
traceroute <ip внеш.ресурса> source 10.64.1.50

Это сразу отметет очень большую часть проблем.

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

21. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от vitrum82 (ok) on 07-Май-15, 12:41 
> барахлит у одного из "провайдеров"

Я возможно не упоминал, но у нас по сути дела это просто разбитая на сегменты локалка, услугами сторонних провайдеров не пользуемся (у нас свое управление связи, они же и админят маршрутизаторы) , ростелеком только для выхода в интернет и на подразделение в Москве.

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

22. "Падение скорости на маршруте (100МБит/с ->1МБит/с)"  +/
Сообщение от cant email on 07-Май-15, 13:01 
> Я возможно не упоминал, но у нас по сути дела это просто
> разбитая на сегменты локалка, услугами сторонних провайдеров не пользуемся (у нас
> свое управление связи, они же и админят маршрутизаторы) , ростелеком только
> для выхода в интернет и на подразделение в Москве.

Вы скорость меряете точно не протоколом netbios/cifs/шары-виндовс ?
Если локалка разбита на сегменты, то тогда никаких претензии к скорости этого протокола. Как ему вздумается - так и будет работать, и бороться с ним бессмысленно.

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor