The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"interVLAN routing - непонятность"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"interVLAN routing - непонятность"  +/
Сообщение от ilia kuliev (??) on 02-Июл-08, 11:22 
Есть роутер 1841 и свитч 2960G. В свитче два vlan: нативный (все порты) и vlan2 (порт 24). К vlan2 подключен сегмент сети 192.168.1.0, к остальным портам - хосты сети 192.168.15.0.
Нужна маршрутизация между ними.
Сделана самая простая вещь на свете, router on a stick.
Это fa0/1 с сабинтерфейсами, подключен к 23-му порту свитча:
Код:

interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.1
encapsulation dot1Q 1 native
ip address 192.168.15.1 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/1.2
encapsulation dot1Q 2
ip address 192.168.1.254 255.255.255.0
no snmp trap link-status

Это порты 22 (в сеть 192.168.15.0), 23 (транк к роутеру), 24 (в сеть 192.168.1.0):
Код:

interface GigabitEthernet0/22
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/23
description To the router
switchport trunk allowed vlan 1,2
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet0/24
description Link to CINEGY/AVID stub network segment
switchport access vlan 2
switchport mode access
spanning-tree portfast

И это не работает, пакеты между VLAN не ходят.
Пинг с роутера в сеть 192.168.1.0 тоже не проходит.
Что я сделал не так?

sh vlan на всякий случай:

dut2960g#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/1, Gi0/2, Gi0/3, Gi0/4, Gi0/5, Gi0/6, Gi0/7, Gi0/8, Gi0/9, Gi0/10, Gi0/11
                                                Gi0/12, Gi0/13, Gi0/14, Gi0/15, Gi0/16, Gi0/17, Gi0/18, Gi0/19, Gi0/20
                                                Gi0/21, Gi0/22
2    cinegy-avid                      active    Gi0/24
3    uplink                           active  
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0  
2    enet  100002     1500  -      -      -        -    -        0      0  
3    enet  100003     1500  -      -      -        -    -        0      0  
1002 fddi  101002     1500  -      -      -        -    -        0      0  
1003 tr    101003     1500  -      -      -        -    -        0      0  
1004 fdnet 101004     1500  -      -      -        ieee -        0      0  
1005 trnet 101005     1500  -      -      -        ibm  -        0      0  

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "interVLAN routing - непонятность"  +/
Сообщение от SergTel email(ok) on 02-Июл-08, 11:25 
скорее всего неправильно определены скорость(дуплекс) на физических интерфейсах
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "interVLAN routing - непонятность"  +/
Сообщение от ilia kuliev (??) on 02-Июл-08, 12:02 
>скорее всего неправильно определены скорость(дуплекс) на физических интерфейсах

Если бы все было так просто :)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "interVLAN routing - непонятность"  +/
Сообщение от fantom email(ok) on 02-Июл-08, 12:07 
>[оверквотинг удален]
>     0      
>0
>
>Remote SPAN VLANs
>------------------------------------------------------------------------------
>
>
>Primary Secondary Type          
>    Ports
>------- --------- ----------------- ------------------------------------------

1. незнаю поддерживает ли 2960G инкапсуляцию isl, но если поддерживает, то скорее всего именно ее поумолчанию и использует.
2. MAC адреса на портах каталиста присутствуют?
если да - то в нужных VLAN-ах ?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "interVLAN routing - непонятность"  +/
Сообщение от ilia kuliev (??) on 02-Июл-08, 22:14 

>1. незнаю поддерживает ли 2960G инкапсуляцию isl, но если поддерживает, то скорее
>всего именно ее поумолчанию и использует.

Не поддерживает. И не использует, соответственно :)

>2. MAC адреса на портах каталиста присутствуют?
>если да - то в нужных VLAN-ах ?

Угу. На gi0/24 я вижу MAC-адреса хостов из 192.168.1.0


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "interVLAN routing - непонятность"  +/
Сообщение от CrAzOiD (ok) on 02-Июл-08, 17:29 
>[оверквотинг удален]
>     0      
>0
>
>Remote SPAN VLANs
>------------------------------------------------------------------------------
>
>
>Primary Secondary Type          
>    Ports
>------- --------- ----------------- ------------------------------------------

покажите как вы проверяенте что не работает конструкция
подробно

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "interVLAN routing - непонятность"  +/
Сообщение от ilia kuliev (??) on 02-Июл-08, 22:16 

>покажите как вы проверяенте что не работает конструкция
>подробно

Пингом из 192.168.15.0 в 192.168.1.0.
Ответы не приходят.


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "interVLAN routing - непонятность"  +/
Сообщение от CrAzOiD (ok) on 02-Июл-08, 22:29 
>
>>покажите как вы проверяенте что не работает конструкция
>>подробно
>
>Пингом из 192.168.15.0 в 192.168.1.0.
>Ответы не приходят.

ну а подробности где?
где настройки IP на клиентах?
где таблицы маршрутизации с клиентов?
где трейс?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

11. "interVLAN routing - непонятность"  +/
Сообщение от Максим (??) on 04-Июл-08, 09:39 
>Пингом из 192.168.15.0 в 192.168.1.0.
>Ответы не приходят.

1. mac 1841-ой на 23-ем порту в обоих vlan'ах виден
2. sh spanning-tree vlan 2 на каталисте чего говорит? (в плане портов Gi0/23, Gi0/24)
3. Тупое предположение, но все же... на 1841 "ip routing" включен?


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

12. "interVLAN routing - непонятность"  +/
Сообщение от fantom email(ok) on 04-Июл-08, 10:01 
>>Пингом из 192.168.15.0 в 192.168.1.0.
>>Ответы не приходят.
>
>1. mac 1841-ой на 23-ем порту в обоих vlan'ах виден
>2. sh spanning-tree vlan 2 на каталисте чего говорит? (в плане портов
>Gi0/23, Gi0/24)
>3. Тупое предположение, но все же... на 1841 "ip routing" включен?

Есть еще тупое предположение - а на клиентских машинах дефолт правильный прописан?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

13. "interVLAN routing - непонятность"  +/
Сообщение от Merridius on 30-Июл-10, 12:25 
native на роутере убери с 1 влана


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру