The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"резервный канал на cisco2811"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"резервный канал на cisco2811"  
Сообщение от hop email(ok) on 23-Май-08, 12:42 
Привет всем!
Настраиваю Dial Backup на cisco 2811, к которой на serial 0/0/0 прицеплен модем Zyxel U336. Вынимаю кабель из FastEthernet 0/0 (основной канал), на терминал сыпется:

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
%LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
Se0/0/0 DDR: re-enable timeout

и на этом все, модем никуда не звонит.
Вот конфиг:
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname cisco2811
!
boot-start-marker
boot system flash c2800nm-ipbase-mz.124-3h.bin
boot-end-marker
!
enable secret 5 $1$ca6m$01Qf7rB9/26zdmn9v2Bvk1
enable password 7 050F0016354F4D0F
!
no aaa new-model
!
resource policy
!
ip subnet-zero
no ip routing
!
!
no ip cef
!
!
no ip domain lookup
!
chat-script dial ABORT ERROR ABORT BUSY "" AT OK "ATDT\T" TIMEOUT 30 CONNECT
modemcap entry zyxel336:MSC=Z4S0=1
username hop password 7 03510F58545E
!
!
!
interface FastEthernet0/0
backup delay 10 30
backup interface Serial0/0/0
ip address 192.168.9.1 255.255.255.0
no ip route-cache
duplex full
speed auto
no mop enabled
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
physical-layer async
no ip address
encapsulation ppp
dialer in-band
dialer string 07141074
dialer-group 1
async mode interactive
no peer default ip address
ppp authentication pap
ppp pap sent-username test password 7 055A545C7519
!
interface Dialer0
no ip address
!
ip local pool test 192.168.9.50 192.168.9.55
ip classless
no ip forward-protocol nd
!
no ip http server
!
dialer-list 1 protocol ip permit
!
control-plane
!
!
line con 0
line aux 0
line 0/0/0
script dialer dial
modem InOut
modem autoconfigure type zyxel336
transport input all
autoselect ppp
stopbits 1
speed 115200
flowcontrol hardware
line vty 0 4
password 7 050F0016354F4D0F
login
!
scheduler allocate 20000 1000
!
end

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "резервный канал на cisco2811"  
Сообщение от Алексей (??) on 23-Май-08, 14:19 
>[оверквотинг удален]
> stopbits 1
> speed 115200
> flowcontrol hardware
>line vty 0 4
> password 7 050F0016354F4D0F
> login
>!
>scheduler allocate 20000 1000
>!
>end

Честно, особо в конфиг не всматривался, но самое первое, что бросилось в глаза - это отсутствие шлюза по умолчанию, хоть основного, хоть резервного....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "резервный канал на cisco2811"  
Сообщение от IronRUS (ok) on 23-Май-08, 15:11 
Мне кажется, что неплохо было бы прописать clock rate на Serial. Если ошибаюсь, поясните плиз. + шлюзов нету
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "резервный канал на cisco2811"  
Сообщение от hop email(??) on 23-Май-08, 15:31 
Конфиг переписывался уже много раз, забыл про шлюзы. Сейчас добавил:

cisco2811(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 0/0
cisco2811(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0 200

и для Serial 0/0/0:
clock rate 19200

Все также.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "резервный канал на cisco2811"  
Сообщение от Алексей (??) on 23-Май-08, 17:00 
>Конфиг переписывался уже много раз, забыл про шлюзы. Сейчас добавил:
>
>cisco2811(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 0/0
>cisco2811(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0 200
>
>и для Serial 0/0/0:
>clock rate 19200
>
>Все также.

Ну в качесвте шлюза лучше прописывать все-таки удаленный конец, тем более ip-адрес я так понимаю у вас имеется хотя бы на фаст эзернете.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "резервный канал на cisco2811"  
Сообщение от Алексей (??) on 23-Май-08, 17:03 
>[оверквотинг удален]
>>cisco2811(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0 200
>>
>>и для Serial 0/0/0:
>>clock rate 19200
>>
>>Все также.
>
>Ну в качесвте шлюза лучше прописывать все-таки удаленный конец, тем более ip-адрес
>я так понимаю у вас имеется хотя бы на фаст эзернете.
>

Во-вторых, Вы уверены в правильности chat-script'а?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "резервный канал на cisco2811"  
Сообщение от Алексей (??) on 23-Май-08, 17:09 
>[оверквотинг удален]
>>>и для Serial 0/0/0:
>>>clock rate 19200
>>>
>>>Все также.
>>
>>Ну в качесвте шлюза лучше прописывать все-таки удаленный конец, тем более ip-адрес
>>я так понимаю у вас имеется хотя бы на фаст эзернете.
>>
>
>Во-вторых, Вы уверены в правильности chat-script'а?

Также разве диалер сам не должен быть сконфигурирован? Там по моему поливина того, что ты прицепил на серийный интерфейс должна висеть на диалере.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "резервный канал на cisco2811"  
Сообщение от Алексей (??) on 23-Май-08, 17:10 
>[оверквотинг удален]
>>>
>>>Ну в качесвте шлюза лучше прописывать все-таки удаленный конец, тем более ip-адрес
>>>я так понимаю у вас имеется хотя бы на фаст эзернете.
>>>
>>
>>Во-вторых, Вы уверены в правильности chat-script'а?
>
>Также разве диалер сам не должен быть сконфигурирован? Там по моему поливина
>того, что ты прицепил на серийный интерфейс должна висеть на диалере.
>

опять же НАТа разве не должно быть? Потом НАТ тоже должен смотреть на диалер...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "резервный канал на cisco2811"  
Сообщение от Алексей (??) on 23-Май-08, 17:19 
>[оверквотинг удален]
>>>>
>>>
>>>Во-вторых, Вы уверены в правильности chat-script'а?
>>
>>Также разве диалер сам не должен быть сконфигурирован? Там по моему поливина
>>того, что ты прицепил на серийный интерфейс должна висеть на диалере.
>>
>
>опять же НАТа разве не должно быть? Потом НАТ тоже должен смотреть
>на диалер...

короче, пишу по памяти, так что не обессудь... будет приблизительно...


короче в начале должен быть правильный chat-script

дальше на серийном интерфейсе либо на диалере, а может и там и там, не помню. давно не замался этой ерундой... должна быть прописана инкапсуляция ppp, диалер ин-банд, диалер пул-мембер 1, диалер-груп 1
ппп пап сент-юзернайм и т.п.

потом идет интерфейс диалер1
ай-пи адресс неготиайтед
нат на выход
инкапсуляция ппп
диалер пул 1
диалер идл-таймаут...
диалер стринг....
диалер груп 1
ппп пап сент-юзернайм...

потом идет нат на диалер 1 с оверлордом,
и шлюз на диалер 1

потом диалер-лист 1 протокол ай-пи пермит...

ну и правильные настройки line'а должны быть...

фсе собственно....

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "резервный канал на cisco2811"  
Сообщение от hop (ok) on 23-Май-08, 18:12 
Да пробовал я уже и так. Не работает.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "резервный канал на cisco2811"  
Сообщение от Алексей (??) on 23-Май-08, 19:38 
>Да пробовал я уже и так. Не работает.

ну значит где-то ошибка в конфиге....
потому что я в свое время подобную тему делал на 2600, фсе работало замечательно...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "резервный канал на cisco2811"  
Сообщение от nikl (ok) on 25-Май-08, 10:15 
http://msgibnev.livejournal.com/4947.html
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "резервный канал на cisco2811"  
Сообщение от hop (??) on 26-Май-08, 18:57 
я перепробовал все вот это

http://msgibnev.livejournal.com/4947.html
http://www.opennet.ru/openforum/vsluhforumID6/16348.html
http://www.cisco.com/en/US/docs/ios/dial/command/reference/d...
http://www.opennet.ru/base/cisco/skylink_init.txt.html
http://www.opennet.ru/base/cisco/cisco_dial_backup.txt.html
http://www.opennet.ru/docs/RUS/cisco_dialup/index.html
http://www.opennet.ru/base/cisco/serial_link.txt.html

в различных вариантах. но модем даже не пытается звонить. как просто заставит модем звонить на определенный номер? что может быть не так?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "резервный канал на cisco2811"  
Сообщение от nikl (ok) on 27-Май-08, 08:15 
>в различных вариантах. но модем даже не пытается звонить. как просто заставит
>модем звонить на определенный номер? что может быть не так?

Может он у вас сломан просто?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "резервный канал на cisco2811"  
Сообщение от hop email(??) on 27-Май-08, 11:46 
Заходил телнетом на модем, через цыску, набирал
atdtномер
звонит. Тут наверно modemcap надо править.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "резервный канал на cisco2811"  
Сообщение от CrAzOiD (ok) on 27-Май-08, 15:50 
>Заходил телнетом на модем, через цыску, набирал
>atdtномер
>звонит. Тут наверно modemcap надо править.

не надо modemcap вообще настраивать
настраивайте просто серийный интерфейс на кошке
можем же ваш умеет сам дозваниваться по номеру который в него запигите.
кошка дергает DTR - модем дозванивается
схема проще не придумаешь

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "резервный канал на cisco2811"  
Сообщение от hop (??) on 27-Май-08, 15:52 
конфиг, дайте конфиг... :)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "резервный канал на cisco2811"  
Сообщение от CrAzOiD (ok) on 27-Май-08, 16:15 
>конфиг, дайте конфиг... :)

да какой конфиг то? ничего делать то не надо
interface Serial0/0/0
physical-layer async
ip address negotiated
encapsulation ppp
ppp authentication pap
ppp pap sent-username test password 7 055A545C7519


остальное все на модеме

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру