The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"cisco 871 + acorp sprinter@adsl не выпускает наружу"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от c0nfED (ok) on 26-Мрт-08, 11:28 
пров предоставляет конторе инет по pppoe, модем также прововский.
если воткнуть модем прямо в хаб и на компах пробить как осн.шлюз адрес модема - все работает.
приспичил vpn, купили циску.
wan (eth4) смотрит в модем, а vlan в хаб.
внутренний ip модема 192.168.1.1, и соответственно внешний ip циски 192.168.1.2
пинги с циски идут и на модем, и в локалку, но наружу не идут и nslookup не прохродит.

подскажите плз, где ошибка или чего нехватает!

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
ip name-server 81.26.129.5
ip name-server 81.26.132.6
!
!
!
!
!
!
!
!
!
interface Loopback22
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description "wan"
ip address 192.168.1.2 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
description "LAN"
ip address 192.168.100.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list nat interface FastEthernet4 overload
ip nat inside source static tcp 192.168.100.0 53 interface FastEthernet4 53
!
ip radius source-interface Loopback22
dialer-list 1 protocol ip permit
!
control-plane
!
!
!
scheduler max-task-time 5000
end

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от GolDi (??) on 26-Мрт-08, 11:59 
>[оверквотинг удален]
>!
>ip radius source-interface Loopback22
>dialer-list 1 protocol ip permit
>!
>control-plane
>!
>!
>!
>scheduler max-task-time 5000
>end

А где собственно source list nat ?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от c0nfED (ok) on 26-Мрт-08, 12:03 
>А где собственно source list nat ?

каким он должен быть в самом общем виде?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от KiM on 26-Мрт-08, 13:07 
>>А где собственно source list nat ?
>
>каким он должен быть в самом общем виде?

имелся ввиду access-list который прописан в ip nat inside source list

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от c0nfED (ok) on 26-Мрт-08, 13:18 
>>>А где собственно source list nat ?
>>
>>каким он должен быть в самом общем виде?
>
>имелся ввиду access-list который прописан в ip nat inside source list

забыл убрать...
это остатки от предыдущих советов.
правда я знаю, нужно ли натовать пакеты явно, и как лучше, листом или пулом, и т.д.
еще читать и читать, но время сильно жмет.
как должна выглядеть ПРОСТЕЙШАЯ конфа для выпуска локалки в инет через циску и модем?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от KiM on 26-Мрт-08, 13:29 
>[оверквотинг удален]
>>
>>имелся ввиду access-list который прописан в ip nat inside source list
>
>забыл убрать...
>это остатки от предыдущих советов.
>правда я знаю, нужно ли натовать пакеты явно, и как лучше, листом
>или пулом, и т.д.
>еще читать и читать, но время сильно жмет.
>как должна выглядеть ПРОСТЕЙШАЯ конфа для выпуска локалки в инет через циску
>и модем?

FastEthernet 0
ip address x.x.x.x
ip nat outside

FastEthernet 1
ip address y.y.y.y 255.255.255.0
ip nat inside

ip nat inside source list 11 interface FastEthernet0 overload

access-list 11 permit y.y.y.y 255.255.255.0

писал на вскидку но енто самое простое
и маршрут по умолчанию не забудь

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от KiM on 26-Мрт-08, 13:30 
>[оверквотинг удален]
>FastEthernet 1
> ip address y.y.y.y 255.255.255.0
> ip nat inside
>
>ip nat inside source list 11 interface FastEthernet0 overload
>
>access-list 11 permit y.y.y.y 255.255.255.0
>
>писал на вскидку но енто самое простое
>и маршрут по умолчанию не забудь

забыл добавить что x.x.x.x внешний адрес

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от c0nfED (ok) on 26-Мрт-08, 13:42 
>>access-list 11 permit y.y.y.y 255.255.255.0

маска точно 255.255.255.0?
везде в таких местах конфы было 0.0.0.255
и в чем разница?
и что за лист 11? что в нем?

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от c0nfED (ok) on 26-Мрт-08, 13:51 
не завелось...
получилась вот такая конфа
поправьте меня, если где ошибся

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret ххх
enable password ххх
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
ip name-server 81.26.129.5
ip name-server 81.26.132.6
!
!
crypto pki ххх
ххх
ххх
ххх
ххх
!
!
crypto pki ххх
certificate self-signed 01
  ххх
  ...
  ххх
  quit
username ххх
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description "wan"
ip address 192.168.1.2 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
description "LAN"
ip address 192.168.100.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 11 interface FastEthernet4 overload
!
access-list 11 permit 0.0.0.0 255.255.255.0
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
privilege level 15
password ххх
login local
transport input telnet ssh
!
scheduler max-task-time 5000
end

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от KiM on 26-Мрт-08, 14:02 
>[оверквотинг удален]
>!
>ip classless
>ip route 0.0.0.0 0.0.0.0 192.168.1.1
>!
>ip http server
>ip http authentication local
>ip http secure-server
>ip nat inside source list 11 interface FastEthernet4 overload
>!
>access-list 11 permit 0.0.0.0 255.255.255.0

0.0.0.0 это нахрена было???? должно быть 192.168.100.0
>[оверквотинг удален]
> no modem enable
>line aux 0
>line vty 0 4
> privilege level 15
> password ххх
> login local
> transport input telnet ssh
>!
>scheduler max-task-time 5000
>end

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от c0nfED (ok) on 26-Мрт-08, 14:08 
>>access-list 11 permit 0.0.0.0 255.255.255.0
>
>0.0.0.0 это нахрена было???? должно быть 192.168.100.0

его автоматом меняет при добавлении
пробовал несколько раз
access-list 11 permit 192.168.100.0 255.255.255.0
в итоге добавляется как
access-list 11 permit 0.0.0.0 255.255.255.0

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от KiM on 26-Мрт-08, 14:11 
>>>access-list 11 permit 0.0.0.0 255.255.255.0
>>
>>0.0.0.0 это нахрена было???? должно быть 192.168.100.0
>
>его автоматом меняет при добавлении
>пробовал несколько раз
>access-list 11 permit 192.168.100.0 255.255.255.0
>в итоге добавляется как
>access-list 11 permit 0.0.0.0 255.255.255.0

чудес не бывает чтото у вас пошло не так

сорри мой касяк маска 0.0.0.255:)
wildcard

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от KiM on 26-Мрт-08, 14:13 
>[оверквотинг удален]
>>его автоматом меняет при добавлении
>>пробовал несколько раз
>>access-list 11 permit 192.168.100.0 255.255.255.0
>>в итоге добавляется как
>>access-list 11 permit 0.0.0.0 255.255.255.0
>
>чудес не бывает чтото у вас пошло не так
>
>сорри мой касяк маска 0.0.0.255:)
>wildcard

в смысле
access-list 11 permit 192.168.100.0 0.0.0.255

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от c0nfED (ok) on 26-Мрт-08, 14:21 
при правильной маске адрес добавился без перекосов!
остальная конфа рабочая, все завелось!
огромное спасибо!!!
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "cisco 871 + acorp sprinter@adsl не выпускает наружу"  +/
Сообщение от Ярослав (??) on 08-Июн-13, 19:30 
у меня ситуация точно такая же как и в создателя этой темы, все сделал как здесь описано, с Циски все пингуеться (в том числе и интернет ресурсы), а с компьютера  войти только в гугл и его ресурсы (переводчик ютуб и тп).   в чем может заключаться проблема?
Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
MIRhosting
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру