The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"redistribute static на cisco nexus 5596"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"redistribute static на cisco nexus 5596"  +/
Сообщение от a4ism on 07-Июл-14, 10:20 
Есть коммутатор 6500, к нему подключен nexus5500, поднята динамическая маршрутизация OSPF. Есть vrf red.

Все хорошо, 6500 от 5500 маршруты получает, но возникла необходимость поиметь статику в vrf red на nx5500 и естественно видеть маршрут на эту сеть на коммутаторе 6500.

на 5500:
пишу статику в vrf red:
vrf context red
  ip route 1.1.1.0/24 2.2.2.1

создаю префикс-лист:
ip prefix-list STATIC_INTO_OSPF seq 5 permit 1.1.1.0/24

пишу роут-мап:
route-map RM-STATIC-to-OSPF-VRF-red permit 10
  match ip address prefix-list STATIC_INTO_OSPF
  set metric 20
  set metric-type type-1

пишу в процессе ospf редистрибьюцию статического маршрута:
router ospf 1
  vrf red
  redistribute static route-map RM-STATIC-to-OSPF-VRF-red

Но не вижу сеть 1.1.1.0/24 на 6500 в vrf red.

Можно конечно сделать статику со стороны 6500 в сторону 5500, и это проверено и работает, но хотелось бы все таки сделать правильно.

Есть мысли?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "redistribute static на cisco nexus 5596"  +/
Сообщение от a4ism on 07-Июл-14, 10:29 
Нашел команду посмотреть статистику, вроде попадает куда надо.

show ip ospf policy statistics redistribute static vrf red
C: No. of comparisions, M: No. of matches

route-map RM-STATIC-to-OSPF-VRF-red permit 10
  match ip address prefix-list STATIC_INTO_OSPF              C: 1      M: 1    

Total accept count for policy: 1    
Total reject count for policy: 0    

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "redistribute static на cisco nexus 5596"  +/
Сообщение от alecx_ on 07-Июл-14, 15:43 
> Есть коммутатор 6500, к нему подключен nexus5500, поднята динамическая маршрутизация OSPF.
> Есть vrf red.
> Все хорошо, 6500 от 5500 маршруты получает, но возникла необходимость поиметь статику
> в vrf red на nx5500 и естественно видеть маршрут на эту
> сеть на коммутаторе 6500.

А можно посмотреть настройки ospf со стороны 6500?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "redistribute static на cisco nexus 5596"  +/
Сообщение от a4ism on 08-Июл-14, 13:09 
>> Есть коммутатор 6500, к нему подключен nexus5500, поднята динамическая маршрутизация OSPF.
>> Есть vrf red.
>> Все хорошо, 6500 от 5500 маршруты получает, но возникла необходимость поиметь статику
>> в vrf red на nx5500 и естественно видеть маршрут на эту
>> сеть на коммутаторе 6500.
> А можно посмотреть настройки ospf со стороны 6500?

На 99% уверен в том, что проблема в тупиковой зоне, поэтому статический маршрут не отдается, ибо внешний. Как будет время переделаю зону на nssa и проверю.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "redistribute static на cisco nexus 5596"  +/
Сообщение от Bbi4 email(ok) on 03-Авг-15, 15:01 
>>> Есть коммутатор 6500, к нему подключен nexus5500, поднята динамическая маршрутизация OSPF.
>>> Есть vrf red.
>>> Все хорошо, 6500 от 5500 маршруты получает, но возникла необходимость поиметь статику
>>> в vrf red на nx5500 и естественно видеть маршрут на эту
>>> сеть на коммутаторе 6500.
>> А можно посмотреть настройки ospf со стороны 6500?
> На 99% уверен в том, что проблема в тупиковой зоне, поэтому статический
> маршрут не отдается, ибо внешний. Как будет время переделаю зону на
> nssa и проверю.

Народ, хочу снова поднять эту тему. Аналогичная проблема, но с EIGRP.

Nexus:

vrf context n5k1
  ip route 172.16.41.21/32 192.168.100.2 tag 151
  ip route 172.30.32.0/22 192.168.100.2 tag 151
  ip route 192.168.93.0/24 192.168.100.2 tag 151

ip prefix-list Static4Redistribute seq 5 permit 192.168.93.0/24

route-map RedistributeStaticRoute permit 10
  match tag 151
route-map RedistributeStaticRoute permit 20
  match ip address prefix-list Static4Redistribute

interface Vlan3967
  desc Eigrp 2 6506
  no shutdown
  vrf member n5k1
  ip address 172.31.255.18/29
  ip router eigrp 110

router eigrp 110
  autonomous-system 110
  router-id 172.31.255.18
  redistribute static route-map RedistributeStaticRoute
  default-information originate always
  address-family ipv4 unicast
  vrf n5k1

Ничего не редистрибутируется.

Core-Nexus-1# sh ip eigrp route-map statistics redistribute static vrf default
C: No. of comparisions, M: No. of matches

route-map RedistributeStaticRoute permit 10
  match tag 151                                              C: 2      M: 0    
route-map RedistributeStaticRoute permit 20
  match ip address prefix-list Static4Redistribute           C: 2      M: 0    

Total accept count for policy: 0    
Total reject count for policy: 2    
Core-Nexus-1# sh ip eigrp route-map statistics redistribute static vrf n5k1
Core-Nexus-1#

Есть мысли?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

6. "redistribute static на cisco nexus 5596"  +/
Сообщение от ism (ok) on 05-Авг-15, 04:04 

> Есть мысли?

а в секции
>router eigrp 110
> vrf n5k1

какие настройки?

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

7. "redistribute static на cisco nexus 5596"  +/
Сообщение от Bbi4 email(ok) on 05-Авг-15, 11:22 

>> Есть мысли?
> а в секции
>>router eigrp 110
>> vrf n5k1
> какие настройки?

router eigrp 110
  autonomous-system 110
  router-id 172.31.255.18
  redistribute static route-map RedistributeStaticRoute
  default-information originate always
  address-family ipv4 unicast
  vrf n5k1

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

5. "redistribute static на cisco nexus 5596"  +/
Сообщение от ism (ok) on 05-Авг-15, 04:00 

> На 99% уверен в том, что проблема в тупиковой зоне, поэтому статический
> маршрут не отдается, ибо внешний. Как будет время переделаю зону на
> nssa и проверю.

Лучше поздно, чем никогда =)
Вчера перенастроили зону из тупиковой в nssa, все заработало, маршруты "редистрибутируются" автоматически.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

8. "redistribute static на cisco nexus 5596"  +/
Сообщение от Bbi4 email(ok) on 05-Авг-15, 11:25 

>> На 99% уверен в том, что проблема в тупиковой зоне, поэтому статический
>> маршрут не отдается, ибо внешний. Как будет время переделаю зону на
>> nssa и проверю.
> Лучше поздно, чем никогда =)
> Вчера перенастроили зону из тупиковой в nssa, все заработало, маршруты "редистрибутируются"
> автоматически.

А что за зона nssa? Это только в OSPF?

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

9. "redistribute static на cisco nexus 5596"  +/
Сообщение от ism (ok) on 08-Авг-15, 17:52 

> А что за зона nssa? Это только в OSPF?

http://www.cisco.com/c/en/us/support/docs/ip/open-shortest-p...

если вкратце, то тупиковая, но в ней может быть еще и внутренний маршрут, в моем случае это статика.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру