The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"ASP+Asterisk"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"ASP+Asterisk"  
Сообщение от podtibok (ok) on 26-Фев-07, 12:36 
Кто нибудь сталкивался с установкой Asterisk на ASP?
скачал Asterisk последней версии
пишу make
а он пишет [root@localhost asterisk-1.4.0]# make
****
**** The configure script must be executed before running 'make'.
****
make: *** [makeopts] Error 1
в чем может быть дело??? как с этим бороться???
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

  • ASP+Asterisk, weris, 14:08 , 26-Фев-07, (1)  
    • ASP+Asterisk, ruff, 14:33 , 26-Фев-07, (2)  
      • ASP+Asterisk, podtibok, 15:07 , 26-Фев-07, (3)  
        • ASP+Asterisk, ruff, 15:11 , 26-Фев-07, (4)  
          • ASP+Asterisk, podtibok, 15:25 , 26-Фев-07, (5)  
            • ASP+Asterisk, ruff, 15:28 , 26-Фев-07, (6)  
              • ASP+Asterisk, podtibok, 17:29 , 26-Фев-07, (7)  
                • ASP+Asterisk, ruff, 17:33 , 26-Фев-07, (8)  

Сообщения по теме [Сортировка по времени, UBB]


1. "ASP+Asterisk"  
Сообщение от weris (??) on 26-Фев-07, 14:08 
>Кто нибудь сталкивался с установкой Asterisk на ASP?
>скачал Asterisk последней версии
>пишу make
>а он пишет [root@localhost asterisk-1.4.0]# make
>****
>**** The configure script must be executed before running 'make'.
>****
>make: *** [makeopts] Error 1
>в чем может быть дело??? как с этим бороться???


configure
make
make install

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "ASP+Asterisk"  
Сообщение от ruff email(ok) on 26-Фев-07, 14:33 
>>Кто нибудь сталкивался с установкой Asterisk на ASP?
>>скачал Asterisk последней версии
>>пишу make
>>а он пишет [root@localhost asterisk-1.4.0]# make
>>****
>>**** The configure script must be executed before running 'make'.
>>****
>>make: *** [makeopts] Error 1
>>в чем может быть дело??? как с этим бороться???
>
>
>configure
>make
>make install


и в дальнейшем лучше такие вопросы задавать на форуме астериска. есть еще IRC канал #asteriskru на  freenode

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "ASP+Asterisk"  
Сообщение от podtibok (ok) on 26-Фев-07, 15:07 
я правильно понимаю....только не пинай меня! Я недавно начал втыкать в линукс.
папку распоковал
захожу в папку
пишу configure так или нет?
а там command not found
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "ASP+Asterisk"  
Сообщение от ruff email(ok) on 26-Фев-07, 15:11 
>я правильно понимаю....только не пинай меня! Я недавно начал втыкать в линукс.
>
>папку распоковал
>захожу в папку
>пишу configure так или нет?
>а там command not found


./configure --help
выбираешь нужные параметры и
./configure [с нужными параметрами]
потом
make menuselect
выбираешь нужные фичи потом
make
make install

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "ASP+Asterisk"  
Сообщение от podtibok (ok) on 26-Фев-07, 15:25 
короче вот пишет
[root@localhost asterisk-1.4.0]# ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for uname... /bin/uname
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

что то не хватает по ходу

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "ASP+Asterisk"  
Сообщение от ruff email(ok) on 26-Фев-07, 15:28 
>короче вот пишет
>[root@localhost asterisk-1.4.0]# ./configure
>checking build system type... i686-pc-linux-gnu
>checking host system type... i686-pc-linux-gnu
>checking for uname... /bin/uname
>checking for gcc... no
>checking for cc... no
>checking for cl.exe... no
>configure: error: no acceptable C compiler found in $PATH
>See `config.log' for more details.
>
>что то не хватает по ходу

ууу. эдак ты по каждому пакету месагу будеш штамповать. ставь необходимое барахло, типа компилера, автомейков/автохедеров и прочую лабуду. девовские либы нужны будут также. Вобщем дальше гугул в помощь.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "ASP+Asterisk"  
Сообщение от podtibok (ok) on 26-Фев-07, 17:29 
можно я задам последний воросик???
пробовал и девел другой ставить и gcc разные ставил все равно пишет вот такое

[root@localhost 111]# rpm -ihv gcc-3.3.3-7asp.i386.rpm
error: Failed dependencies:
        glibc-devel >= 2.2.90-12 is needed by gcc-3.3.3-7asp


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "ASP+Asterisk"  
Сообщение от ruff email(ok) on 26-Фев-07, 17:33 
>можно я задам последний воросик???
>пробовал и девел другой ставить и gcc разные ставил все равно пишет
>вот такое
>
>[root@localhost 111]# rpm -ihv gcc-3.3.3-7asp.i386.rpm
>error: Failed dependencies:
>        glibc-devel >= 2.2.90-12 is needed by gcc-3.3.3-7asp

вот когда такое пишет, необходимо предварительно установить все пакеты которые needed by
(в данном случае glibc-devel) а потом еще раз попробовать установить гцц.
Сразу предупреждаю, glibc-devel тоже захочет кучу депендов, которые надо будет предварительно установить. А по поводу какие девел либы нужны астериску - поищи статьи об установке асты на редхете.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
MIRhosting
Fornex
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру