The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"vpdn pptp in vrf"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VPN, VLAN, туннель)
Изначальное сообщение [ Отслеживать ]

"vpdn pptp in vrf"  +/
Сообщение от ruff email(??) on 05-Фев-07, 18:58 
входящие подключения pptp должны приниматься на интерфейсе лежащем в отдельном vrf. В процессе подключения видно что негоциация ppp идеть нормально, трафик по tcp 1723 идет нормально по маршрутам vrf. а вот когда начинается gre lcp обмен, гре пакеты выплывают из глобального врф. соотв-но сеанс не устанавливается.

vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1
vpn vrf inet
source-ip хх.хх.хх.хх
local name CISCO_VPN
!
interface Virtual-Template1
no ip address
ip virtual-reassembly
ip route-cache flow
ip mroute-cache
peer default ip address pool pptp_pool
ppp encrypt mppe auto required
ppp authentication ms-chap-v2 eap ms-chap
!

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "vpdn pptp in vrf"  +/
Сообщение от Lacunacoil email(ok) on 05-Фев-07, 21:08 
>входящие подключения pptp должны приниматься на интерфейсе лежащем в отдельном vrf. В
>процессе подключения видно что негоциация ppp идеть нормально, трафик по tcp
>1723 идет нормально по маршрутам vrf. а вот когда начинается gre
>lcp обмен, гре пакеты выплывают из глобального врф. соотв-но сеанс не
>устанавливается.
>
>vpdn-group 1
>! Default PPTP VPDN group
> accept-dialin
>  protocol pptp
>  virtual-template 1
> vpn vrf inet
> source-ip хх.хх.хх.хх
> local name CISCO_VPN
>!
>interface Virtual-Template1
> no ip address
> ip virtual-reassembly
> ip route-cache flow
> ip mroute-cache
> peer default ip address pool pptp_pool
> ppp encrypt mppe auto required
> ppp authentication ms-chap-v2 eap ms-chap
>!

interface Virtual-Template1 может этот интерфейс тоже включить в этот врф ?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "vpdn pptp in vrf"  +/
Сообщение от ruff email(??) on 06-Фев-07, 10:52 
>
>interface Virtual-Template1 может этот интерфейс тоже включить в этот врф ?


да включал, не помогало. щас еще попробую.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "vpdn pptp in vrf"  +/
Сообщение от ruff email(??) on 06-Фев-07, 10:59 
да, не помогает. LCP, Conf-Request приходят с наружи, а LCP, Conf-Reject уходит из глобального во внутрь.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "vpdn pptp in vrf"  +/
Сообщение от alchie (ok) on 06-Фев-07, 11:10 
>да, не помогает. LCP, Conf-Request приходят с наружи, а LCP, Conf-Reject уходит
>из глобального во внутрь.

vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1
session-limit 30
vpn vrf NOC

interface Virtual-Template1
description ---PPTP management---
ip vrf forwarding NOC
ip address 192.168.2.1 255.255.255.0
ip nat inside
peer default ip address pool default
no keepalive
ppp authentication pap chap ms-chap

вот в таком виде все работает

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "vpdn pptp in vrf"  +/
Сообщение от ruff email(??) on 06-Фев-07, 11:44 
>>да, не помогает. LCP, Conf-Request приходят с наружи, а LCP, Conf-Reject уходит
>>из глобального во внутрь.
>
>vpdn-group 1
>! Default PPTP VPDN group
> accept-dialin
>  protocol pptp
>  virtual-template 1
> session-limit 30
> vpn vrf NOC
>
>interface Virtual-Template1
> description ---PPTP management---
> ip vrf forwarding NOC
> ip address 192.168.2.1 255.255.255.0
> ip nat inside
> peer default ip address pool default
> no keepalive
> ppp authentication pap chap ms-chap
>
>вот в таком виде все работает

если б у меня из глобала был выход в инет я так понимаю тоже работало бы. т.к. пакет уходит через глобал но с пральными адресами, сорс интерфейса на апстрим, дест мой. но он не выходит, соотв-но конект не проходит по таймаутам. вот мой тепершний конфиг:

vpdn enable
vpdn multihop
vpdn authen-before-forward
vpdn tunnel authorization network default
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1
vpn vrf inet
source-ip xx.xx.xx.xx
local name CISCO_VPN
!
!
interface Tunnel213
ip vrf forwarding inet
ip address xx.xx.xx.xx 255.255.255.252
ip access-group fw in
ip nat outside
ip inspect gen-ips out
ip virtual-reassembly
tunnel mode ipip
tunnel path-mtu-discovery
!
interface Virtual-Template1
ip vrf forwarding inet
ip unnumbered Vlan10
ip virtual-reassembly
ip route-cache flow
ip mroute-cache
peer default ip address pool pptp_pool
ppp encrypt mppe auto required
ppp authentication ms-chap-v2 eap ms-chap
!

натыкал уже все што видел %)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "vpdn pptp in vrf"  +/
Сообщение от umax (ok) on 06-Ноя-10, 23:22 
Решил  всетаки ответить на эту старую тему.
Сам недавно пытался проделать subj - а именно у меня доступ к pptp серверу из интерфейса в VRF.
Если маршрут к pptp серверу из глобала, то все работает. pptp устанавливается, поднимается интерфейс virtual-access, все как обычно.
Если маршрут к pptp серверу из VRF, то pptp не устанавливается.

ВНИМАНИЕ это не баг, а фича :)

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t15/feature/gu...


Пришлось применить MPLS route leaking и тем самым сделать роут из VRF в глобал и обратно. Иначе не получается.


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру