The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"cisco linux vpn"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"cisco linux vpn"  
Сообщение от shizoid on 26-Дек-06, 12:14 
делаю все как написано тут:

Как поднять туннель между Cisco и Linux
    Linux (192.168.2.1):
   /sbin/ip tunnel add tunl1 mode ipip remote 192.168.1.1
   /sbin/ifconfig tunl1 192.168.3.2 pointopoint 192.168.3.1 netmask 255.255.255.252 mtu 1500

Cisco (192.168.1.1):
  interface Tunnel0
    ip address 192.168.3.1 255.255.255.252
    ip mtu 1500
    tunnel source 192.168.1.1
    tunnel destination 192.168.2.1
    tunnel mode ipip

но, у мну почему-то на циске
Tunnel0 is up, line protocol is down

и пипец, и че я тока не делал :(
как побороть, не подскажете?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

  • cisco linux vpn, ks, 15:33 , 27-Дек-06, (1)  
    • cisco linux vpn, shizoid, 11:04 , 29-Дек-06, (2)  
      • cisco linux vpn, asavenkov, 12:59 , 29-Дек-06, (3)  
      • cisco linux vpn, asavenkov, 13:00 , 29-Дек-06, (4)  
        • cisco linux vpn, shizoid, 13:13 , 29-Дек-06, (5)  
          • cisco linux vpn, asavenkov, 13:50 , 29-Дек-06, (6)  
            • cisco linux vpn, shizoid, 15:09 , 29-Дек-06, (7)  
              • cisco linux vpn, asavenkov, 15:12 , 29-Дек-06, (8)  

Сообщения по теме [Сортировка по времени, UBB]


1. "cisco linux vpn"  
Сообщение от ks (??) on 27-Дек-06, 15:33 
>делаю все как написано тут:
>
>Как поднять туннель между Cisco и Linux
>  Linux (192.168.2.1):
>   /sbin/ip tunnel add tunl1 mode ipip remote 192.168.1.1
>   /sbin/ifconfig tunl1 192.168.3.2 pointopoint 192.168.3.1 netmask 255.255.255.252 mtu 1500
>
>
>Cisco (192.168.1.1):
>  interface Tunnel0
>    ip address 192.168.3.1 255.255.255.252
>    ip mtu 1500
>    tunnel source 192.168.1.1
>    tunnel destination 192.168.2.1
>    tunnel mode ipip


На linux:

ip tunnel add ipip1 mode ipip local 91.144.150.13 remote 91.144.149.70
ifconfig ipip1 172.20.1.1 netmask 255.255.255.0 mtu 1400

На cisco:

interface Tunnel0
ip address 172.20.1.2 255.255.255.0
ip mtu 1400
tunnel source Loopback0
tunnel destination 91.144.150.13
tunnel mode ipip


Смотрим:

Tunnel0 is up, line protocol is up
Hardware is Tunnel
Internet address is 172.20.1.2/24
MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel source 91.144.148.70 (Loopback0), destination 91.144.150.13
Tunnel protocol/transport IP/IP
Tunnel TTL 255
Fast tunneling enabled

Пингуем:

ping 172.20.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.20.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Радуемся жизни.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "cisco linux vpn"  
Сообщение от shizoid on 29-Дек-06, 11:04 
>На linux:
>
>ip tunnel add ipip1 mode ipip local 91.144.150.13 remote 91.144.149.70
>ifconfig ipip1 172.20.1.1 netmask 255.255.255.0 mtu 1400
>
>На cisco:
>
>interface Tunnel0
>ip address 172.20.1.2 255.255.255.0
>ip mtu 1400
>tunnel source Loopback0
>tunnel destination 91.144.150.13
>tunnel mode ipip
>
>
>Смотрим:
>
>Tunnel0 is up, line protocol is up
>Hardware is Tunnel
>Internet address is 172.20.1.2/24
>MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
>reliability 255/255, txload 1/255, rxload 1/255
>Encapsulation TUNNEL, loopback not set
>Keepalive not set
>Tunnel source 91.144.148.70 (Loopback0), destination 91.144.150.13
>Tunnel protocol/transport IP/IP
>Tunnel TTL 255
>Fast tunneling enabled
>
>Пингуем:
>
>ping 172.20.1.1
>Type escape sequence to abort.
>Sending 5, 100-byte ICMP Echos to 172.20.1.1, timeout is 2 seconds:
>!!!!!
>Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
>
>Радуемся жизни.

На линуксе:
ip tunnel add ipip1 mode ipip local 192.168.2.1 remote 192.168.1.1
ifconfig ipip1 192.168.3.2 netmask 255.255.255.0 mtu 1514

eth0      Link encap:Ethernet  HWaddr 00:0C:F1:6B:61:CE
          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:f1ff:fe6b:61ce/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2051 errors:0 dropped:0 overruns:0 frame:0
          TX packets:86 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:199589 (194.9 Kb)  TX bytes:11870 (11.5 Kb)
          Interrupt:20

ipip1     Link encap:IPIP Tunnel  HWaddr
          inet addr:192.168.3.2  P-t-P:192.168.3.2  Mask:255.255.255.0
          UP POINTOPOINT RUNNING NOARP  MTU:1514  Metric:1
          RX packets:262 errors:0 dropped:0 overruns:0 frame:0
          TX packets:262 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:22008 (21.4 Kb)  TX bytes:27248 (26.6 Kb)

На циске:
interface Tunnel0
ip address 192.168.3.1 255.255.255.0
ip mtu 1514
tunnel source 192.168.1.1
tunnel destination 192.168.2.1
tunnel mode ipip

#show interfaces tunnel0
Tunnel0 is up, line protocol is down
  Hardware is Tunnel
  Internet address is 192.168.3.1/24
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 192.168.1.1, destination 192.168.2.1
  Tunnel protocol/transport IP/IP
  Tunnel TTL 255

и совсем не радуемся жизни :(
тоже самое если маска /30

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "cisco linux vpn"  
Сообщение от asavenkov on 29-Дек-06, 12:59 
>>На linux:
>>
>>ip tunnel add ipip1 mode ipip local 91.144.150.13 remote 91.144.149.70
>>ifconfig ipip1 172.20.1.1 netmask 255.255.255.0 mtu 1400
>>
>>На cisco:
>>
>>interface Tunnel0
>>ip address 172.20.1.2 255.255.255.0
>>ip mtu 1400
>>tunnel source Loopback0
>>tunnel destination 91.144.150.13
>>tunnel mode ipip
>>
>>
>>Смотрим:
>>
>>Tunnel0 is up, line protocol is up
>>Hardware is Tunnel
>>Internet address is 172.20.1.2/24
>>MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
>>reliability 255/255, txload 1/255, rxload 1/255
>>Encapsulation TUNNEL, loopback not set
>>Keepalive not set
>>Tunnel source 91.144.148.70 (Loopback0), destination 91.144.150.13
>>Tunnel protocol/transport IP/IP
>>Tunnel TTL 255
>>Fast tunneling enabled
>>
>>Пингуем:
>>
>>ping 172.20.1.1
>>Type escape sequence to abort.
>>Sending 5, 100-byte ICMP Echos to 172.20.1.1, timeout is 2 seconds:
>>!!!!!
>>Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
>>
>>Радуемся жизни.
>
>На линуксе:
>ip tunnel add ipip1 mode ipip local 192.168.2.1 remote 192.168.1.1
>ifconfig ipip1 192.168.3.2 netmask 255.255.255.0 mtu 1514
>
>eth0      Link encap:Ethernet  HWaddr 00:0C:F1:6B:61:CE
>          inet addr:192.168.2.1
> Bcast:192.168.2.255  Mask:255.255.255.0
>          inet6 addr:
>fe80::20c:f1ff:fe6b:61ce/64 Scope:Link
>          UP BROADCAST
>RUNNING MULTICAST  MTU:1500  Metric:1
>          RX packets:2051
>errors:0 dropped:0 overruns:0 frame:0
>          TX packets:86
>errors:0 dropped:0 overruns:0 carrier:0
>          collisions:0 txqueuelen:1000
>
>          RX bytes:199589
>(194.9 Kb)  TX bytes:11870 (11.5 Kb)
>          Interrupt:20
>
>ipip1     Link encap:IPIP Tunnel  HWaddr
>          inet addr:192.168.3.2
> P-t-P:192.168.3.2  Mask:255.255.255.0
>          UP POINTOPOINT
>RUNNING NOARP  MTU:1514  Metric:1
>          RX packets:262
>errors:0 dropped:0 overruns:0 frame:0
>          TX packets:262
>errors:0 dropped:0 overruns:0 carrier:0
>          collisions:0 txqueuelen:0
>
>          RX bytes:22008
>(21.4 Kb)  TX bytes:27248 (26.6 Kb)
>
>На циске:
>interface Tunnel0
> ip address 192.168.3.1 255.255.255.0
> ip mtu 1514
> tunnel source 192.168.1.1
> tunnel destination 192.168.2.1
> tunnel mode ipip
>
>#show interfaces tunnel0
>Tunnel0 is up, line protocol is down
>  Hardware is Tunnel
>  Internet address is 192.168.3.1/24
>  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
>     reliability 255/255, txload 1/255, rxload 1/255
>  Encapsulation TUNNEL, loopback not set
>  Keepalive not set
>  Tunnel source 192.168.1.1, destination 192.168.2.1
>  Tunnel protocol/transport IP/IP
>  Tunnel TTL 255
>
>
>
>и совсем не радуемся жизни :(
>тоже самое если маска /30


Глупы

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "cisco linux vpn"  
Сообщение от asavenkov on 29-Дек-06, 13:00 
>>На linux:
>>
>>ip tunnel add ipip1 mode ipip local 91.144.150.13 remote 91.144.149.70
>>ifconfig ipip1 172.20.1.1 netmask 255.255.255.0 mtu 1400
>>
>>На cisco:
>>
>>interface Tunnel0
>>ip address 172.20.1.2 255.255.255.0
>>ip mtu 1400
>>tunnel source Loopback0
>>tunnel destination 91.144.150.13
>>tunnel mode ipip
>>
>>
>>Смотрим:
>>
>>Tunnel0 is up, line protocol is up
>>Hardware is Tunnel
>>Internet address is 172.20.1.2/24
>>MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
>>reliability 255/255, txload 1/255, rxload 1/255
>>Encapsulation TUNNEL, loopback not set
>>Keepalive not set
>>Tunnel source 91.144.148.70 (Loopback0), destination 91.144.150.13
>>Tunnel protocol/transport IP/IP
>>Tunnel TTL 255
>>Fast tunneling enabled
>>
>>Пингуем:
>>
>>ping 172.20.1.1
>>Type escape sequence to abort.
>>Sending 5, 100-byte ICMP Echos to 172.20.1.1, timeout is 2 seconds:
>>!!!!!
>>Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
>>
>>Радуемся жизни.
>
>На линуксе:
>ip tunnel add ipip1 mode ipip local 192.168.2.1 remote 192.168.1.1
>ifconfig ipip1 192.168.3.2 netmask 255.255.255.0 mtu 1514
>
>eth0      Link encap:Ethernet  HWaddr 00:0C:F1:6B:61:CE
>          inet addr:192.168.2.1
> Bcast:192.168.2.255  Mask:255.255.255.0
>          inet6 addr:
>fe80::20c:f1ff:fe6b:61ce/64 Scope:Link
>          UP BROADCAST
>RUNNING MULTICAST  MTU:1500  Metric:1
>          RX packets:2051
>errors:0 dropped:0 overruns:0 frame:0
>          TX packets:86
>errors:0 dropped:0 overruns:0 carrier:0
>          collisions:0 txqueuelen:1000
>
>          RX bytes:199589
>(194.9 Kb)  TX bytes:11870 (11.5 Kb)
>          Interrupt:20
>
>ipip1     Link encap:IPIP Tunnel  HWaddr
>          inet addr:192.168.3.2
> P-t-P:192.168.3.2  Mask:255.255.255.0
>          UP POINTOPOINT
>RUNNING NOARP  MTU:1514  Metric:1
>          RX packets:262
>errors:0 dropped:0 overruns:0 frame:0
>          TX packets:262
>errors:0 dropped:0 overruns:0 carrier:0
>          collisions:0 txqueuelen:0
>
>          RX bytes:22008
>(21.4 Kb)  TX bytes:27248 (26.6 Kb)
>
>На циске:
>interface Tunnel0
> ip address 192.168.3.1 255.255.255.0
> ip mtu 1514
> tunnel source 192.168.1.1
> tunnel destination 192.168.2.1
> tunnel mode ipip
>
>#show interfaces tunnel0
>Tunnel0 is up, line protocol is down
>  Hardware is Tunnel
>  Internet address is 192.168.3.1/24
>  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
>     reliability 255/255, txload 1/255, rxload 1/255
>  Encapsulation TUNNEL, loopback not set
>  Keepalive not set
>  Tunnel source 192.168.1.1, destination 192.168.2.1
>  Tunnel protocol/transport IP/IP
>  Tunnel TTL 255
>
>
>
>и совсем не радуемся жизни :(
>тоже самое если маска /30


Глупый вопрос, а 192.168.1.1 видит 192.168.2.1 ???

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "cisco linux vpn"  
Сообщение от shizoid on 29-Дек-06, 13:13 

>Глупый вопрос, а 192.168.1.1 видит 192.168.2.1 ???


ни...если б они виделись, проблема отпала бы :)

даже роуты всякие попрописывал...
# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.1     192.168.3.2     255.255.255.255 UGH   0      0        0 ipip1
192.168.3.1     192.168.3.2     255.255.255.255 UGH   0      0        0 ipip1
192.168.3.0     0.0.0.0         255.255.255.0   U     0      0        0 ipip1
192.168.2.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0

нифига не пойму, чего на циске протокол в дауне?
мож как-то нуно апнуть туннель?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "cisco linux vpn"  
Сообщение от asavenkov on 29-Дек-06, 13:50 
>
>>Глупый вопрос, а 192.168.1.1 видит 192.168.2.1 ???
>
>
>ни...если б они виделись, проблема отпала бы :)
>
>даже роуты всякие попрописывал...
># route -n
>Kernel IP routing table
>Destination     Gateway      
>  Genmask        
>Flags Metric Ref    Use Iface
>192.168.1.1     192.168.3.2     255.255.255.255 UGH
>  0      0  
>     0 ipip1
>192.168.3.1     192.168.3.2     255.255.255.255 UGH
>  0      0  
>     0 ipip1
>192.168.3.0     0.0.0.0      
>  255.255.255.0   U     0
>     0      
>  0 ipip1
>192.168.2.0     0.0.0.0      
>  255.255.255.0   U     1
>     0      
>  0 eth0
>
>нифига не пойму, чего на циске протокол в дауне?
>мож как-то нуно апнуть туннель?

Думаю, что нужен конфиг всех портов и роутинг циски для работы задуманной схемы.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "cisco linux vpn"  
Сообщение от shizoid on 29-Дек-06, 15:09 
>Думаю, что нужен конфиг всех портов и роутинг циски для работы задуманной
>схемы.

такс. с цисками я никогда не работал, а вот тут нуно настроить сие действо.
вижу что роутов тут вообще не прописано никаких...
не подскажете на своем примере какие нуно прописать?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "cisco linux vpn"  
Сообщение от asavenkov on 29-Дек-06, 15:12 
>>Думаю, что нужен конфиг всех портов и роутинг циски для работы задуманной
>>схемы.
>
>такс. с цисками я никогда не работал, а вот тут нуно настроить
>сие действо.
>вижу что роутов тут вообще не прописано никаких...
>не подскажете на своем примере какие нуно прописать?

У вот оно как... Тогда рисуйте схему... Можно в Аську: 285847034

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
MIRhosting
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру