The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Критическая уязвимость в bash, которая может привести к удал..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от opennews (??) on 24-Сен-14, 20:49 
В командном интерпретаторе Bash выявлена (https://securityblog.redhat.com/2014/09/24/bash-specially-cr.../) опасная уязвимость (CVE-2014-6271), позволяющая организовать выполнение кода в контексте другого сеанса bash. Проблема вызвана недоработкой в организации экспорта переменных окружения и shell-функций  в другие экземпляры bash, что приводит к выполнению блоков кода из специально оформленных переменных окружения, полученных от других процессов. Во многих типовых конфигурация уязвимость может быть эксплуатирована по сети, если bash указан в качестве системного shell-интерпретатора. В том числе могут быть атакованы CGI-скрипты и конфигурации OpenSSH.

Текущие версии bash используют переменные окружения в том числе для экспорта функций, при этом если в переменной содержит "() {", то её содержимое воспринимается как функция. Из-за ошибки, после завершения тела функции, обработка продолжается и после символа "}". Если после функции указана команда, то bash выполнит и её (например, "VAR=() { ignored; }; /bin/id").


В случае с OpenSSH атака может быть проведена (http://www.openwall.com/lists/oss-security/2014/09/24/12) через подстановку  переменной окружения SSH_ORIGINAL_COMMAND:


<font color="#461b7e">
   ssh -o 'rsaauthentication yes' 0 '() { ignored; }; /usr/bin/id'
</font>

Выполнив указанную команду в переменную окружения будет скопирована в том числе строка '() { ignored; }; /usr/bin/id', которая инициирует выполнение пустой функции и запуск команды /usr/bin/id на стороне удалённой системы. Аналогичные атаки могут быть проведены через переменную окружения TERM или при запуске CGI-скриптов через переменную REMOTE_USER.


Для устранения проблемы подготовлена (http://www.openwall.com/lists/oss-security/2014/09/24/11) серия патчей. Обновления пакетов с bash уже выпущены для Debian (https://lists.debian.org/debian-security-announce/2014/msg00...), Ubuntu (http://www.ubuntu.com/usn/usn-2362-1/), RHEL (https://access.redhat.com/articles/1200223), CentOS (http://lists.centos.org/pipermail/centos-announce/2014-Septe...). Оценить появление обновлений для других систем можно на следующих страницах:  Fedora (https://admin.fedoraproject.org/updates/F20), openSUSE (http://lists.opensuse.org/opensuse-security-announce/), SLES (https://www.suse.com/support/update/),  Slackware (http://www.slackware.com/security/list.php?l=slackware-secur...), Gentoo (http://www.gentoo.org/security/en/index.xml), OpenBSD (http://www.openbsd.org/security.html), NetBSD (http://www.netbsd.org/support/security/), FreeBSD (http://www.vuxml.org/freebsd/).

URL: http://www.openwall.com/lists/oss-security/2014/09/24/10
Новость: http://www.opennet.ru/opennews/art.shtml?num=40667

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 24-Сен-14, 20:49 
и в zsh!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Критическая уязвимость в bash, которая может привести к удал..."  +4 +/
Сообщение от Аноним (??) on 24-Сен-14, 21:07 
нет в zsh такой беды
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

7. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Crazy Alex (ok) on 24-Сен-14, 21:15 
Таки нет
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

24. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от анонимус (??) on 24-Сен-14, 22:14 
> Хм, проверил в дебиане на 5.0.6-1 - пишет vulnerable

Wheezy, 4.3.17 - нет.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

32. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Evergreen on 24-Сен-14, 22:43 
Slackware 14.1 -- пишет, что уязвима
Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

43. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 24-Сен-14, 23:34 
> Slackware 14.1 -- пишет, что уязвима

В убунтах приехал апдейт. Оперативно.

Ответить | Правка | ^ к родителю #32 | Наверх | Cообщить модератору

113. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 25-Сен-14, 19:18 
> В убунтах приехал апдейт. Оперативно.

Рано радовался, фикс заглючен.

Ответить | Правка | ^ к родителю #43 | Наверх | Cообщить модератору

122. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 25-Сен-14, 23:51 
openSUSE 13.1, нету.
Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

31. "Критическая уязвимость в bash, которая может привести к удал..."  –5 +/
Сообщение от qqq (??) on 24-Сен-14, 22:40 
...теперь в новой упаковке и с обновленным вкусом! Дырявый баш буквально преображает сервера...
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

2. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Аноним (??) on 24-Сен-14, 21:03 
ОПА!!! а в щлюзах на лине наверное тоже такое прокатит )
на сколько я понял это у него всегда такая уязвимость была, или же это касается только в каких то определенных вариациях ?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Критическая уязвимость в bash, которая может привести к удал..."  +9 +/
Сообщение от ruata on 24-Сен-14, 21:08 
В шлюзах shell в составе busybox. bash слишком "толстый"
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

25. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Аноним (??) on 24-Сен-14, 22:14 
> В шлюзах shell в составе busybox. bash слишком "толстый"

ну это смотря какие брать .... а если возьмём IDECO или Kerio ?

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

10. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от byu on 24-Сен-14, 21:19 
> ОПА!!! а в щлюзах на лине наверное тоже такое прокатит )
> на сколько я понял это у него всегда такая уязвимость была, или
> же это касается только в каких то определенных вариациях ?

там ash обычно

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

14. "Критическая уязвимость в bash, которая может привести к удал..."  –2 +/
Сообщение от Аноним (??) on 24-Сен-14, 21:29 
>> ОПА!!! а в щлюзах на лине наверное тоже такое прокатит )
>> на сколько я понял это у него всегда такая уязвимость была, или
>> же это касается только в каких то определенных вариациях ?
> там ash обычно

у нас bash и OpenSSH полноценный )


Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

71. "Критическая уязвимость в bash, которая может привести к удал..."  +3 +/
Сообщение от Аноним (??) on 25-Сен-14, 09:22 
> )

Нашли чему радоваться.

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

115. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 25-Сен-14, 19:20 
> у нас bash и OpenSSH полноценный )

Тогда выдавайте вазелин в комплекте :)

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

131. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от XoRe (ok) on 26-Сен-14, 13:48 
>>> ОПА!!! а в щлюзах на лине наверное тоже такое прокатит )
>>> на сколько я понял это у него всегда такая уязвимость была, или
>>> же это касается только в каких то определенных вариациях ?
>> там ash обычно
> у нас bash и OpenSSH полноценный )

Напишите ваш ip :)

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

98. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Grammar_Nazi on 25-Сен-14, 13:36 
насколько
каких-то
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Xasd (ok) on 24-Сен-14, 21:09 
классная уязвимость!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Критическая уязвимость в bash, которая может привести к удал..."  +3 +/
Сообщение от Аноним (??) on 24-Сен-14, 21:12 
Вот жесть
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "Критическая уязвимость в bash, которая может привести к удал..."  +6 +/
Сообщение от онаним on 24-Сен-14, 21:15 
Да уж. Понятия "безопасность" и "защищенность" в мире ИТ довольно условны. А сколько еще таких уязвимостей? И я почему-то не уверен, что кто-то не знал об их существовании задолго до уведомления общественности.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

11. "Критическая уязвимость в bash, которая может привести к удал..."  –10 +/
Сообщение от Xasd (ok) on 24-Сен-14, 21:20 
> И я почему-то не уверен, что кто-то
> не знал об их существовании задолго до уведомления общественности.

типичное заблуждение людей:

люди склонны (это врождённая черта людей) думать будто бы ВСЁ уже придумано ГДЕ-ТО и КЕМ-ТО .

это заблюждение происходит из врождённого свойства психики -- "неупорядоченная телеология".

---------------------------------------------

а по факту же (если включить мозг): более логично предположить, что об этой уязвимости ни кто не знал раньше.

кто-то уже использовал эту уязвимость? нет? тогда как можно предположить что кто-то о ней знал?

---------------------------------------------

или вот ещё пример:

когда кто-то меня поправляет о том что я якобы не правильно пишу\говорю на русском языке -- то это точно такая же черта людей.

они думают будто "русский язык" якобы сущетвует где-то в сферическом вакууме. а на самом деле я и есть типичный носитель русского языка (если не останется ни одного носителя русского языка -- то значит и не будет самого русского языка).

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

16. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от онаним on 24-Сен-14, 21:34 
>кто-то уже использовал эту уязвимость? нет?

а он вам сказал?

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

17. "Критическая уязвимость в bash, которая может привести к удал..."  –3 +/
Сообщение от Xasd (ok) on 24-Сен-14, 21:37 
>>кто-то уже использовал эту уязвимость? нет?
> а он вам сказал?

знал но не использовал и ни кому не говорил? хахаха :)

ну вы как дети маленькие...

задним числом то ведь -- любой дурак может всё что угодно знать :-D

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

18. "Критическая уязвимость в bash, которая может привести к удал..."  +5 +/
Сообщение от онаним on 24-Сен-14, 21:44 
Если вы взломали что-либо и поимели доход с данного мероприятия, зачем вам объявлять всему миру зачем и как вы это сделали?
Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

19. "Критическая уязвимость в bash, которая может привести к удал..."  –6 +/
Сообщение от Xasd (ok) on 24-Сен-14, 21:54 
> Если вы взломали что-либо и поимели доход с данного мероприятия, зачем вам
> объявлять всему миру зачем и как вы это сделали?

зачем объяснять:

если ты крутишься в научно-инженерном сообществе -- то там принято делиться своими открытиями (сейчас это происходит по средствам интернета: почта, форумы, списки рассылок, баг-трекеры, ...)..

если ты НЕ крутишься в научно-инженерном сообществе -- то крайне-низка вероятность того что ты будешь обладать уровнем знаний, который позволит тебе выявить ту-или-иную громкую уязвимость (подобно этой). но даже если это произошло -- то крайне трудно удержать это в секрете от всех (а есть пословица: "что знают двое то знает и свинья").

кроме этого -- тот кого взломали -- если он очень важен -- то наверное он захочет сделать расследование на тему того как его взломали.

другими словами: слишком много "если" должно произойти, для того чтобы это могло сохраниться в тайне. логичнее предположить что эта методика -- ни как не могла существовать в тайне (об этом баге -- просто ни кто не знал).

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

26. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от онаним on 24-Сен-14, 22:25 
Меньше знаешь - лучше спишь.
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

99. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Trlteam on 25-Сен-14, 13:44 
fix: Меньше знают - лучше спишь.
Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

28. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 24-Сен-14, 22:31 
>[оверквотинг удален]
> громкую уязвимость (подобно этой). но даже если это произошло -- то
> крайне трудно удержать это в секрете от всех (а есть пословица:
> "что знают двое то знает и свинья").
> кроме этого -- тот кого взломали -- если он очень важен --
> то наверное он захочет сделать расследование на тему того как его
> взломали.
> другими словами: слишком много "если" должно произойти, для того чтобы это могло
> сохраниться в тайне. логичнее предположить что эта методика -- ни как
> не могла существовать в тайне (об этом баге -- просто ни
> кто не знал).

Справедливо, но немного сомнительно... по той причине что, "реверс инженеринг" атаки сделать почти невозможно, и вряд ли жертва узнала кто это сделал "(учитывая "гипотетических" "реалити" познания ... или ... , ... об этой уязвимости, и не воспользовавшемся тем же "интеллектом" что-бы - "замести следы", или ...  O_o ???)" , и пришла к нему с термо-ректальным-крипто-анализатором )) ? что-бы выведать секреты ... ))

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

34. "Критическая уязвимость в bash, которая может привести к удал..."  +5 +/
Сообщение от metallica (ok) on 24-Сен-14, 22:49 
> если ты НЕ крутишься в научно-инженерном сообществе -- то крайне-низка вероятность того
> что ты будешь обладать уровнем знаний, который позволит тебе выявить ту-или-иную
> громкую уязвимость (подобно этой).

Какой же бред то несёте. Сможешь, не сможешь, определяется врождёными умственными
спобностями, и, тоже врождёнными, маниакальным интересом к технологиям и азарту,
а не "крутишься вертишишься на х.. в инженерном обществе".
Желание поделиться, не поделиться, определяется характером человека, и/или его текущим
социальным положением.
Известнейшие, "спалившиеся", вломщики, находившие уязвимости, через них работавшие,
не имели отношения к Вашему, "научно-инженерном сообществу" никакого.

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

51. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 25-Сен-14, 00:27 
> Известнейшие, "спалившиеся", вломщики, находившие уязвимости, через них работавшие,
>  не имели отношения к Вашему, "научно-инженерном сообществу" никакого.

Например?

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

86. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от metallica (ok) on 25-Сен-14, 11:21 
> Например?

В гугеле забанили? Первый для примера https://ru.wikipedia.org/wiki/%D0%9B%D0%...

Ответить | Правка | ^ к родителю #51 | Наверх | Cообщить модератору

110. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 25-Сен-14, 15:57 
Ну и? Вот же он сам говорит: "В какой-то момент он заметил, что я интересуюсь компьютером, и он стал учить меня. Можно сказать — он создал меня как специалиста."
Ответить | Правка | ^ к родителю #86 | Наверх | Cообщить модератору

140. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Аноним (??) on 26-Сен-14, 23:10 
> В гугеле забанили? Первый для примера

Да... если вас взломал Ламо - это наверное обидно! :). Ну ладно бы у него еще фамилия Профи была...

Ответить | Правка | ^ к родителю #86 | Наверх | Cообщить модератору

56. "Критическая уязвимость в bash, которая может привести к удал..."  –2 +/
Сообщение от Michael Shigorin email(ok) on 25-Сен-14, 02:06 
> зачем объяснять:

Дяденька, эти преставления устарели, ещё когда Вы в младших классах были -- лет десять-двенадцать тому.  Когда криминальный бузинес допетрил, что и тут тоже бабки.

rtfm://"black hat" и не порите больше чушь с уверенным видом, когда ничего ВООБЩЕ не понимаете в обсуждаемом вопросе.  Если очень неймётся -- облепливайте "имхо" со всех сторон, чтоб кто-нить ещё более юный не купился с разбегу.

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

61. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Xasd (ok) on 25-Сен-14, 03:57 
ну что же я твоего imho не вижу? :) в этом твоём сообщении
Ответить | Правка | ^ к родителю #56 | Наверх | Cообщить модератору

62. "Критическая уязвимость в bash, которая может привести к удал..."  –2 +/
Сообщение от Michael Shigorin email(ok) on 25-Сен-14, 04:00 
> ну что же я твоего imho не вижу? :) в этом твоём сообщении

Потому что я _знаю_, о чём говорю, а не делаю допущения.  Первые ключевые слова указаны.

Ответить | Правка | ^ к родителю #61 | Наверх | Cообщить модератору

64. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Xasd (ok) on 25-Сен-14, 04:06 
ды, блин.. чы чё такой буйный-то?

расслабся же! хоть чуть чуть :)

на меня вот щаз орёшь.. на мать свою орал (прочитал тут https://2ch.hk/s/res/1046617.html , но не знаю правда ли это )

какое именно выступление black hat мне надо глянуть чтобы понять о том что ты пытаешься мне сказать?

Ответить | Правка | ^ к родителю #62 | Наверх | Cообщить модератору

66. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Michael Shigorin email(ok) on 25-Сен-14, 05:58 
> на меня вот щаз орёшь.. на мать свою орал

Вы готовы подписаться под этим утверждением и отвечать за него?

> какое именно выступление black hat мне надо глянуть

Не выступление.  А хотя бы немножко о том, чем такой контингент отличается от "серых" коллег.

В #34 изложено грубовато, но верно.

Ответить | Правка | ^ к родителю #64 | Наверх | Cообщить модератору

141. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 26-Сен-14, 23:12 
> Потому что я _знаю_, о чём говорю,

Оптимизм - это хорошо. Но почему-то на практике вы в 50% случаев подаете какие-то жареные факты или мнения сомнительных типов как истину в последней инстанции.

Ответить | Правка | ^ к родителю #62 | Наверх | Cообщить модератору

159. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Michael Shigorin email(ok) on 02-Окт-14, 03:24 
>> Потому что я _знаю_, о чём говорю,
> Оптимизм - это хорошо.

В надеждах, но не в оценках.

> Но почему-то на практике вы в 50% случаев подаете какие-то жареные факты
> или мнения сомнительных типов как истину в последней инстанции.

Можно пример?  Когда ссылаюсь на сомнительное, так и помечаю; когда знаю достоверно -- тоже подчёркиваю.  Без пометок воспринимать как (PS: "заведомо") жареное/последнеинстанционное не советую.

То, что по коррелированным косвенным данным нередко удаётся понять больше, чем по вроде бы ясным прямым -- может иметь отношение к тому, что манипулировать "ясными прямыми" проще, чем всей совокупностью "вторичных волн", часть которой может долететь до отдельно взятого человека.  Порой же выводы сходятся у нескольких знающих друг друга людей, при этом доводы пересекаются лишь частично, а результат заставляет вспомнить Уфимцева с его похоронами "стелсу".

А то, что такое бывает непонятно, пока уже совсем в лоб не двинет -- это нормально... ну и плюс ошибки, куда ж они денутся у людей.

Ответить | Правка | ^ к родителю #141 | Наверх | Cообщить модератору

106. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Кирилл (??) on 25-Сен-14, 14:38 
Ваши бы слова да богу... куда то там. К сожалению, ситуация диаметрально противоположная.
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

107. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Andrey Mitrofanov on 25-Сен-14, 14:46 
>ситуация диаметрально противоположная.

Чтоб не сказать ортогонально-перпендикулярная. Но нет, мы не такие, мы "не крутимся"ТМ.

Ответить | Правка | ^ к родителю #106 | Наверх | Cообщить модератору

111. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Майк on 25-Сен-14, 18:09 
Бред. Бага старая, и ей пользовались лет 5 как. Другое дело, что знало малое количество людей, кто не занимается дешевой рекламой типа "я крутой", а предпочитали сохранять свой контроль над системами и быть невидимками. Коммерция дело сложное.
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

112. "Критическая уязвимость в bash, которая может привести к удал..."  +6 +/
Сообщение от snake7 (ok) on 25-Сен-14, 18:14 
"думать [здесь нужна запятая] будто".
"ни кто"-пишется слитно.
"как можно предположить[здесь тоже нужна запятая]что кто-то о ней знал".
"поправляет о [гораздо лучше вместо 'о' написать буковку 'в'] том [снова необходима запятая] что я якобы не".
Не, дружище, ты не якобы, ты действительно хреново знаешь русский язык. Два тебе, неуд.
И твоё рассуждение о "типичном носителе" как раз и есть очередная "неупорядоченная телегогония" ) Объясняю: язык — знаковая система, соотносящая понятийное содержание и типовое звучание (написание) [Википедия]. Это означает, что существует систематика, о которой мы говорим сейчас, позволяющая, опираясь на определённые [и определены они в учебнике языка] правила, передать смысл. Если человек их не знает, то он либо не поймёт смысл, либо не сможет его передать посредством в данном случае русского языка. Всем известный пример "казнить нельзя помиловать" помнишь? Вот тебе и приговор, поставь запятую, не ошибись)
А если серьёзно, то как это хреново, что подавляющее большинство моих современников (разных возрастов) не могут выучить один (!) родной (!) язык.  Какими надо быть лодырями, чтобы не осилить, не прочесть хотя бы часть школьной программы, позволяющей хоть на интуитивном уровне, но писать, не совершая пять ошибок на абзац. Больше того, какими надо быть балбесами, чтоб не стесняться своей неграмотности, больше того, искать [и "находить"!] себе оправдания, вместо того, чтобы читать что-нибудь стоящее(на свой собственный вкус), улучшая и повышая свою грамотность.
Я конечно понимаю, что не могут все знать досконально русский язык, включая все его правила и особенности, всегда должны быть и троечники, и лодыри, и оболтусы, но почему эти не самые замечательные представители общества перестали понимать, что они в чём-то хреново соображают и что этим не кичиться нужно, а стыдиться и стараться это в себе исправить? Откуда протекла в их умы мысль, что "это не самое нужное (стараться стать лучше), смотрите лучше, какой я замечательный в том-то и том-то (каждый найдёт в себе массу умилительных черт)"? Ведь как человек ведёт себя в малом, так он и в большом будет делать. А если он, человек, даже мысли свои выразить толком не может (как он это сделает, если у него в голове сплошные "извени", "некто не знаит", "почиму", "ехай", "ихний", "прасти" и прочие режущие глаза словища), то что он может нарассуждать такими извилинами?!?
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

129. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от fx (ok) on 26-Сен-14, 11:57 
вмемориз!©
Ответить | Правка | ^ к родителю #112 | Наверх | Cообщить модератору

130. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от dddshka on 26-Сен-14, 13:28 
1. Новое предложение, юноша, надобно начинать с заглавной буквы, а не со строчной.

2. Если вы чего-то где-то носите, это не означает того, что вы оно и есть. Так же, как и не означает того, что вы это носите правильно (см. Крылов "Мартышка и очки")

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

30. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 24-Сен-14, 22:37 
> Да уж. Понятия "безопасность" и "защищенность" в мире ИТ довольно условны. А
> сколько еще таких уязвимостей? И я почему-то не уверен, что кто-то
> не знал об их существовании задолго до уведомления общественности.

Согласен, даже если брать - супер сборку для "безопасности", то всегда когда нибудь вылезут вилы...

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

12. "Критическая уязвимость в bash, которая может привести к удал..."  +3 +/
Сообщение от Нанобот (ok) on 24-Сен-14, 21:27 
проверил на bash 2.05 (десятилетней давности) - работает
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

15. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Аноним (??) on 24-Сен-14, 21:31 
> проверил на bash 2.05 (десятилетней давности) - работает

спс, а OpenSSH какой ?

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

20. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Нанобот (ok) on 24-Сен-14, 21:58 
3.6.1
Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

22. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Sylvia (ok) on 24-Сен-14, 22:10 
BASH_VERSION=1.14.7(1)
тоже с дырками :)
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

21. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 24-Сен-14, 22:07 
---> Package bash.i386 0:3.2-33.el5.1 set to be updated
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

33. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 24-Сен-14, 22:48 
> el5
> i386

Здравствуй, брат!

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

35. "Критическая уязвимость в bash, которая может привести к удал..."  +2 +/
Сообщение от metallica (ok) on 24-Сен-14, 22:52 
Интересно сколько уверенных в суперсекурности своего openbsd, жили
все эти годы с этой дырой на своём суперсекурном сервере на опенке?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

37. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от aurved on 24-Сен-14, 23:12 
а в openbsd по-умолчанию стоит bash? и он по-умолчанию предлагается в качестве shell?


Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

50. "Критическая уязвимость в bash, которая может привести к удал..."  –8 +/
Сообщение от тигар (ok) on 25-Сен-14, 00:22 
> а в openbsd по-умолчанию стоит bash? и он по-умолчанию предлагается в качестве
> shell?

есть идиоты, которые ставят bash сами, а не оно приходит депендами в комплекте к говнософту. и да, есть бОльшие идиоты, которые выставляют ЭТО шеллом, даже руту.

Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

82. "Критическая уязвимость в bash, которая может привести к удал..."  +4 +/
Сообщение от Andrey Mitrofanov on 25-Сен-14, 10:39 
> есть идиоты,
>и да, есть бОльшие идиоты

Братьев что ли ищешь, животное?

Ответить | Правка | ^ к родителю #50 | Наверх | Cообщить модератору

93. "Критическая уязвимость в bash, которая может привести к удал..."  –4 +/
Сообщение от тигар (ok) on 25-Сен-14, 12:25 
>> есть идиоты,
>>и да, есть бОльшие идиоты
> Братьев что ли ищешь, животное?

ты был первым из отозвавшихся, судя по кол-ву минусиков на то-самое-сообщение, их больше. да. а почему ты спросил?

Ответить | Правка | ^ к родителю #82 | Наверх | Cообщить модератору

68. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от бедный буратино (ok) on 25-Сен-14, 07:07 
И сколько же? Такие заявления нужно начинать с примеров, а не с голословных обвинений.
Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

152. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Аноним (??) on 02-Окт-14, 00:01 
> И сколько же? Такие заявления нужно начинать с примеров, а не с
> голословных обвинений.

Тебе нужно - ты и начинай.

Ответить | Правка | ^ к родителю #68 | Наверх | Cообщить модератору

39. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 24-Сен-14, 23:19 
Не, ну конечно экранирование в шелле всегда вымораживало. Но чтоб настолько?!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

63. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Michael Shigorin email(ok) on 25-Сен-14, 04:02 
> Не, ну конечно экранирование в шелле всегда вымораживало. Но чтоб настолько?!

Безотносительно: http://git.altlinux.org/people/legion/packages/?p=libshell.g...

Ответить | Правка | ^ к родителю #39 | Наверх | Cообщить модератору

116. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 25-Сен-14, 19:27 
> Безотносительно: http://git.altlinux.org/people/legion/packages/?p=libshell.g...

Настолько злобный код вымораживает даже видавшего виды сишника/ассемблерщика. А потом вы еще удивляетесь за что я недолюбливаю шеллскрипты...

Ответить | Правка | ^ к родителю #63 | Наверх | Cообщить модератору

126. "Критическая уязвимость в bash, которая может привести к..."  +3 +/
Сообщение от arisu (ok) on 26-Сен-14, 03:53 
> вы еще удивляетесь за что я недолюбливаю шеллскрипты...

потому что ты дурак, извини.

Ответить | Правка | ^ к родителю #116 | Наверх | Cообщить модератору

142. "Критическая уязвимость в bash, которая может привести к..."  +/
Сообщение от Аноним (??) on 26-Сен-14, 23:18 
> потому что ты дурак, извини.

Сабж показывает что бывает и горе от ума... :)

Ответить | Правка | ^ к родителю #126 | Наверх | Cообщить модератору

160. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Michael Shigorin email(ok) on 02-Окт-14, 03:32 
> Настолько злобный код вымораживает даже видавшего виды сишника/ассемблерщика.

Регэксами или eval'ом? :)

Ответить | Правка | ^ к родителю #116 | Наверх | Cообщить модератору

83. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Andrey Mitrofanov on 25-Сен-14, 10:40 
>экранирование в шелле всегда вымораживало

Это не экранирование.

Ответить | Правка | ^ к родителю #39 | Наверх | Cообщить модератору

120. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 25-Сен-14, 19:31 
> Это не экранирование.

Но похоже по общему смыслу.

Ответить | Правка | ^ к родителю #83 | Наверх | Cообщить модератору

44. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 24-Сен-14, 23:35 
Звучит эпично, но где, собственно, "уязвимость"? Если я могу выполнить любую команду в баше, зачем заморачиваться и засовывать её в какую-то переменную, чтобы она выполнилась, если вместо этого можно тупо выполнить саму команду?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

48. "Критическая уязвимость в bash, которая может привести к удал..."  +4 +/
Сообщение от Xasd (ok) on 25-Сен-14, 00:07 
> Звучит эпично, но где, собственно, "уязвимость"? Если я могу выполнить любую команду
> в баше, зачем заморачиваться и засовывать её в какую-то переменную, чтобы
> она выполнилась, если вместо этого можно тупо выполнить саму команду?

часто бывает ситуация когда ты можешь повлиять на переменные окружения (ты делаешь некоторые действия которые изменяют переменные окружения). но не можешь выполнять любые команды в BASH.

а теперь (с этой уязвимость) получилось так что если ты можешь поменять переменные окружения, то значит и команды тебе теперь тоже можно выполнять.. :-)

Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

57. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 25-Сен-14, 02:19 
> часто бывает ситуация когда ты можешь повлиять на переменные окружения (ты делаешь
> некоторые действия которые изменяют переменные окружения). но не можешь выполнять любые
> команды в BASH.

Что-то ни одна ситуация не приходит в голову... Можно хоть какой-нибудь пример?

Ответить | Правка | ^ к родителю #48 | Наверх | Cообщить модератору

84. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Andrey Mitrofanov on 25-Сен-14, 10:44 
> Что-то ни одна ситуация не приходит в голову... Можно хоть какой-нибудь пример?

Навирху же! =Solar Disigner написал про обход прибитого к ключу command=.

Ждём продолжения в Новостях, конечно.

Ответить | Правка | ^ к родителю #57 | Наверх | Cообщить модератору

121. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от AlexAT (ok) on 25-Сен-14, 22:47 
CGI
Ответить | Правка | ^ к родителю #57 | Наверх | Cообщить модератору

132. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от XoRe (ok) on 26-Сен-14, 13:58 
>> часто бывает ситуация когда ты можешь повлиять на переменные окружения (ты делаешь
>> некоторые действия которые изменяют переменные окружения). но не можешь выполнять любые
>> команды в BASH.
> Что-то ни одна ситуация не приходит в голову... Можно хоть какой-нибудь пример?

DHCP сервер может передать переменную в ответе
DHCP клиент в *nix её схавает и _выполнит от рута_
Поднимаешь в локалке DHCP сервер и ждешь, когда кто-то клюнет (или когда провайдер отрубит).

Ответить | Правка | ^ к родителю #57 | Наверх | Cообщить модератору

135. "Критическая уязвимость в bash, которая может привести к удал..."  +2 +/
Сообщение от Andrey Mitrofanov on 26-Сен-14, 14:39 
>в локалке
>DHCP сервер
>когда провайдер отрубит).

Садись, два. //Ох, чего-то препод из меня...

Ответить | Правка | ^ к родителю #132 | Наверх | Cообщить модератору

167. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от XoRe (ok) on 04-Окт-14, 12:47 
>>в локалке
>>DHCP сервер
>>когда провайдер отрубит).
> Садись, два. //Ох, чего-то препод из меня...

Ничего, это уже давно так - кто-то умеет, а кто-то преподает)
Или вы думаете, что по всей России в локалках стоят умные свичи, которые автоматом гасят порт, если замечают DHCP-серверные пакетики?

Ответить | Правка | ^ к родителю #135 | Наверх | Cообщить модератору

59. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Аноним (??) on 25-Сен-14, 02:46 
Надо ещё и чтобы с этими изменёнными переменными окружения ещё и bash бы стартанул.
Поскольку он редко когда применяется кроме как в качестве шелла - то конфигурация должна быть весьма экзотической.
Ответить | Правка | ^ к родителю #48 | Наверх | Cообщить модератору

133. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от XoRe (ok) on 26-Сен-14, 13:59 
> Надо ещё и чтобы с этими изменёнными переменными окружения ещё и bash
> бы стартанул.
> Поскольку он редко когда применяется кроме как в качестве шелла - то
> конфигурация должна быть весьма экзотической.

Он по дефолту на многих серваках, особенно в случае CGI

Ответить | Правка | ^ к родителю #59 | Наверх | Cообщить модератору

117. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 25-Сен-14, 19:28 
> Звучит эпично, но где, собственно, "уязвимость"?

А уязвимость в том что немало софта получает переменные окружения "снаружи".

Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

45. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 24-Сен-14, 23:37 
Мде.. OS X 10.9.x
таже беда :)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

46. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 24-Сен-14, 23:45 
bash уязвим, а вот через *ssh не получилось даже себя запывнить.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

47. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от asavah (ok) on 25-Сен-14, 00:02 
ктулху благослови unattended-upgrades в дебиановых
полез проверять на всякий есть ли дырко на серверах, а они уже все пропатченные и хвостиком виляют )
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

49. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Аноним (??) on 25-Сен-14, 00:11 
А все запущенные bash перезапустились?
Я так тоже обновлися от heartbleed автоматом, а nginx надо было перезапускать руками.
Ответить | Правка | ^ к родителю #47 | Наверх | Cообщить модератору

52. "Критическая уязвимость в bash, которая может привести к удал..."  +2 +/
Сообщение от Stax (ok) on 25-Сен-14, 00:38 
А в уже запущенном bash эту уязвимость не выйдет эксплуатировать. Только в новом сабшелле. Так что обновления достаточно, перезапускать ничего не нужно.
Ответить | Правка | ^ к родителю #49 | Наверх | Cообщить модератору

58. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Etch on 25-Сен-14, 02:22 
unattended-upgrades умеет перезапускать сервер после обновлений при необходимости. И в случе heartbleed он это сделал, если был настроен на это.
Ответить | Правка | ^ к родителю #49 | Наверх | Cообщить модератору

55. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от emg81 (ok) on 25-Сен-14, 01:37 
а куда писать-то тест?
в любую открытую консоль? что-то не работает.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

67. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от бедный буратино (ok) on 25-Сен-14, 07:05 
в OpenBSD - ksh.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

69. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Адекват (ok) on 25-Сен-14, 07:41 
Вы все идиоты, чтобы применить данную "уязвимость" на удаленной машине, на ней нужно сначала авторизоваться, попробуйте сами:

env x='() { :;}; echo *'  bash -c "ssh openssh.com"

Это не уязвимость, я не знаю что это, это какая-то хе...фигня, нет разницы между командам
env x='() { :;}; echo *'  bash -c "ssh openssh.com"
и
echo *
echo * - выводит список файлов в текущей директории.

То есть чтобы заюзать данную багу, нужно:
1. авторизоваться
2. прменять ее можно только к процессам с тем же id что и у вас.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

70. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 25-Сен-14, 08:44 
> Вы все идиоты, чтобы применить данную "уязвимость" на удаленной машине, на ней
> нужно сначала авторизоваться, попробуйте сами:

По ssh не только пользователи работают, но и удалённо запускаются разные агенты, конфигурации, мониторинга и бэкапа.

Ответить | Правка | ^ к родителю #69 | Наверх | Cообщить модератору

72. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Адекват (ok) on 25-Сен-14, 09:25 
> По ssh не только пользователи работают, но и удалённо запускаются разные агенты,
> конфигурации, мониторинга и бэкапа.

Без авторизации ?

Ответить | Правка | ^ к родителю #70 | Наверх | Cообщить модератору

80. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Andrey Mitrofanov on 25-Сен-14, 10:30 
>> По ssh не только пользователи работают, но и удалённо запускаются разные агенты,
>> конфигурации, мониторинга и бэкапа.
> Без авторизации ?

Без пароля по незашифрованному ключу, с _жёстко заланной (command= для ключа) командой. А тут опа -- досвидания "_жёстко заланная". Провелил -- на моём ssh входе на el6 исполнил [вместо того скрипта на bash-е] этот самый id...

Ответить | Правка | ^ к родителю #72 | Наверх | Cообщить модератору

89. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Адекват (ok) on 25-Сен-14, 12:00 
> ssh входе на el6 исполнил [вместо того скрипта на bash-е] этот
> самый id...

ну значит работает, но для очень редких случаев.

Ответить | Правка | ^ к родителю #80 | Наверх | Cообщить модератору

102. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Andrey Mitrofanov on 25-Сен-14, 13:49 
>> ssh входе на el6 исполнил [вместо того скрипта на bash-е] этот
>> самый id...
> ну значит работает, но для очень редких случаев.

Второй же вариант уже: cpanel (), GGI на bash и транслирование (апачем?) http-заголовков в окружение CGI-йя. Лучше?

И _продолжение будет, полюбому.

Ответить | Правка | ^ к родителю #89 | Наверх | Cообщить модератору

118. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 25-Сен-14, 19:29 
> А тут опа -- досвидания "_жёстко заланная".

ssh да и shell столько всего умеют что надо быть завзятым оптимистом чтобы предполагать что это будет только 1 команда.

Ответить | Правка | ^ к родителю #80 | Наверх | Cообщить модератору

77. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Moomintroll (ok) on 25-Сен-14, 10:06 
> По ssh не только пользователи работают, но и удалённо запускаются разные агенты, конфигурации, мониторинга и бэкапа.

man sshd_config:

AcceptEnv

The default is not to accept any environment variables.

Ответить | Правка | ^ к родителю #70 | Наверх | Cообщить модератору

100. "Критическая уязвимость в bash, которая может привести к..."  –2 +/
Сообщение от arisu (ok) on 25-Сен-14, 13:45 
> По ssh не только пользователи работают, но и удалённо запускаются разные агенты,
> конфигурации, мониторинга и бэкапа.

и им зачем-то выдают bash в качестве login shell? а почему сразу не ключи от квартиры, где деньги лежат?

Ответить | Правка | ^ к родителю #70 | Наверх | Cообщить модератору

155. "Критическая уязвимость в bash, которая может привести к..."  –1 +/
Сообщение от Аноним (??) on 02-Окт-14, 00:05 
>> По ssh не только пользователи работают, но и удалённо запускаются разные агенты,
>> конфигурации, мониторинга и бэкапа.
> и им зачем-то выдают bash в качестве login shell? а почему сразу
> не ключи от квартиры, где деньги лежат?

А что ты им предлагаешь выдавать? restricted shell? А он у вас в пингвинусах е? Немае? А, ну тоды ой...

Ответить | Правка | ^ к родителю #100 | Наверх | Cообщить модератору

158. "Критическая уязвимость в bash, которая может привести к..."  +/
Сообщение от Michael Shigorin email(ok) on 02-Окт-14, 03:13 
> А что ты им предлагаешь выдавать? restricted shell?
> А он у вас в пингвинусах е? Немае? А, ну тоды ой...

Да есть, есть.  И rbash, и более специальные.

PS: Вы там что, опять волшебного кумыса перебрали, что так в голову ударило?  Держитесь.

Ответить | Правка | ^ к родителю #155 | Наверх | Cообщить модератору

162. "Критическая уязвимость в bash, которая может привести к..."  +1 +/
Сообщение от arisu (ok) on 02-Окт-14, 07:47 
> А что ты им предлагаешь выдавать? restricted shell? А он у вас
> в пингвинусах е?

прикинь, есть. но лично тебе его использовать запрещено.

Ответить | Правка | ^ к родителю #155 | Наверх | Cообщить модератору

134. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от XoRe (ok) on 26-Сен-14, 14:01 
Что ви знаете про CGI?
Ответить | Правка | ^ к родителю #69 | Наверх | Cообщить модератору

143. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 26-Сен-14, 23:20 
> Что ви знаете про CGI?

Древний и бестолковый протокол, который должен умереть жестокой смертью.

Ответить | Правка | ^ к родителю #134 | Наверх | Cообщить модератору

147. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от QuAzI (ok) on 27-Сен-14, 13:29 
Или кто-то путает с CGA или одно из двух
Ответить | Правка | ^ к родителю #143 | Наверх | Cообщить модератору

168. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от XoRe (ok) on 04-Окт-14, 12:49 
>> Что ви знаете про CGI?
> Древний и бестолковый протокол, который должен умереть жестокой смертью.

Ну вот пока все шаред хостинги переползут с него на fastcgi и uwsgi, будут DDoS ботнеты.
Казалось бы, дыра у них, а DDoS - у вас.

Ответить | Правка | ^ к родителю #143 | Наверх | Cообщить модератору

73. "Критическая уязвимость в bash, которая может привести к удал..."  –2 +/
Сообщение от Bookman300 (ok) on 25-Сен-14, 09:33 
Бред какой-то

Он тогда не только в bash, но еще в fish shell присутствует. А это случайно ли не фейк а?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

119. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Аноним (??) on 25-Сен-14, 19:30 
> А это случайно ли не фейк а?

Ну как видим, работает. Значит не фэйк. Факты штука упрямая :\.

Ответить | Правка | ^ к родителю #73 | Наверх | Cообщить модератору

149. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от ggss on 28-Сен-14, 20:05 
Я не вижу, у меня на XUbuntu 14.04 не работает. И вообще не могу понять что авторы хотели сказать командой cat echo и как она по их мнению должна отработать. Может Вы знаете?
Ответить | Правка | ^ к родителю #119 | Наверх | Cообщить модератору

150. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от GG (ok) on 28-Сен-14, 21:25 
> Я не вижу, у меня на XUbuntu 14.04 не работает. И вообще
> не могу понять что авторы хотели сказать командой cat echo и
> как она по их мнению должна отработать. Может Вы знаете?

Пропатчили уже, больше никак не работает

Ответить | Правка | ^ к родителю #149 | Наверх | Cообщить модератору

74. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Аноним (??) on 25-Сен-14, 09:45 
Я не понял, они нашли ~/.bashrc?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

75. "Критическая уязвимость в bash, которая может привести к удал..."  –5 +/
Сообщение от Аноним (??) on 25-Сен-14, 09:52 
GNU во всей красе. Не, только zsh, только подальше от GNU.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

76. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Я (??) on 25-Сен-14, 10:04 
env x='() { :;}; echo vulnerable'  bash -c "echo this is a test"
bash: внимание: x: ignoring function definition attempt
bash: ошибка при импортировании определения функции`x'
this is a test
root@ubuntu:~# uname -a
Linux ubuntu 3.13.0-36-generic #63-Ubuntu SMP Wed Sep 3 21:30:45 UTC 2014 i686 athlon i686 GNU/Linux


Ответить | Правка | ^ к родителю #75 | Наверх | Cообщить модератору

91. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Anonimous email on 25-Сен-14, 12:13 
testuser@front:~$ env x='() { :;}; echo vulnerable'  bash -c "echo this is a test"
vulnerable
this is a test
testuser@front:~$ env X='() { (a)=>\' sh -c "echo date"; cat echo
date
cat: echo: No such file or directory
testuser@front:~$ uname -a
Linux ubuntu 3.8.0-44-generic #66~precise1-Ubuntu SMP Tue Jul 15 04:04:23 UTC 2014 i686 i686 i686 GNU/Linux
Ответить | Правка | ^ к родителю #76 | Наверх | Cообщить модератору

78. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Сергей (??) on 25-Сен-14, 10:16 
Никогда не использовал bash, точнее пытался, но изучить возможности стандартного sh оказалось быстрее и при применение его оказалось, что он покрывает нужное мне на 100%
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

94. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от www2 (??) on 25-Сен-14, 12:47 
Если бы в sh была история команд и автодополнение - пользовался бы только им. Поэтому использую bash исключительно как интерактивную оболочку, в скриптах использую только sh и тоже его возможностей для скриптов вполне хватает. Для большего есть awk или perl, в конце-концов.
Ответить | Правка | ^ к родителю #78 | Наверх | Cообщить модератору

97. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Аноним (??) on 25-Сен-14, 13:29 
За использование bash в скриптах надо вообще убивать.
Ответить | Правка | ^ к родителю #94 | Наверх | Cообщить модератору

101. "Критическая уязвимость в bash, которая может привести к..."  +2 +/
Сообщение от arisu (ok) on 25-Сен-14, 13:46 
> За использование bash в скриптах надо вообще убивать.

а за перл награждать, ага.

Ответить | Правка | ^ к родителю #97 | Наверх | Cообщить модератору

105. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Led (ok) on 25-Сен-14, 14:36 
> Если бы в sh была история команд и автодополнение - пользовался бы
> только им.

В каком "sh"?
dash можно собирать с libedit.

Ответить | Правка | ^ к родителю #94 | Наверх | Cообщить модератору

139. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Alatar (??) on 26-Сен-14, 22:18 
> Если бы в sh была история команд и автодополнение - пользовался бы только им.

Тоже изначально только из-за этого переключался на tcsh, а потом постепенно, что есть и другие полезные фичи. Сейчас в фришный sh добавили историю и дополнение, но я им на постоянной основе пользоваться уже не смогу.

Ответить | Правка | ^ к родителю #94 | Наверх | Cообщить модератору

81. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 25-Сен-14, 10:37 
Я реально не понимаю эту новость. Если я верно понял оригинальное описание уязвимости, то удаленное выполнение кода возможно только в том случае, если есть хоть какой-то удаленный шелл, не? То есть уязвимость заключается в возможности нарушения ограничений окружения bash. Или я где-то неправ?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

90. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Xaionaro email(ok) on 25-Сен-14, 12:08 
> Я реально не понимаю эту новость. Если я верно понял оригинальное описание
> уязвимости, то удаленное выполнение кода возможно только в том случае, если
> есть хоть какой-то удаленный шелл, не? То есть уязвимость заключается в
> возможности нарушения ограничений окружения bash. Или я где-то неправ?

Ну, а теперь вспомните всякие gitlab-ы (дающие доступ на запуск конкретного скрипта по ssh кому годно), всякие cgi-based сайты с использованием bash, ssh-шлюзы с restricted shell-ами и т.п.

Ответить | Правка | ^ к родителю #81 | Наверх | Cообщить модератору

95. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Аноним (??) on 25-Сен-14, 12:48 
Да это очевидно, где spawn'ится shell - там дыра. Просто написано так, как будто удаленный запуск кода доступен в любом случае.
Ответить | Правка | ^ к родителю #90 | Наверх | Cообщить модератору

109. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Xaionaro email(ok) on 25-Сен-14, 15:10 
> Да это очевидно, где spawn'ится shell - там дыра. Просто написано так,
> как будто удаленный запуск кода доступен в любом случае.

Я привёл примеры удалённых запусков произвольного кода в очень нередких ситуациях.

Ответить | Правка | ^ к родителю #95 | Наверх | Cообщить модератору

85. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 25-Сен-14, 11:12 
Может имелось виду

Вместо:
env X='() { (a)=>\' sh -c "echo date"; cat echo

Это:
env X='() { (a)=>\' sh -c "echo date"'; cat echo

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

92. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 25-Сен-14, 12:23 
эм, зачем? Чтоб сделать нерабочий скрипт еще более нерабочим ? =D
Ответить | Правка | ^ к родителю #85 | Наверх | Cообщить модератору

87. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Andrey Mitrofanov on 25-Сен-14, 11:35 
> В качестве обходного временного
> iptables using -m string --hex-string '|28 29 20 7B|'

Hex? String, говорите??

$ one() { echo 1; }
$ one
1
$ unset one; one(){ echo 2; }
$ one
2
$ unset one; one  (  )  { echo 3; }
$ one
3
$ _

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

88. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Xaionaro email(ok) on 25-Сен-14, 11:50 
Да даже без этого, идея всё равно обречена, ибо всякие https-ы с ssh-ами трафик шифруют ;)
Ответить | Правка | ^ к родителю #87 | Наверх | Cообщить модератору

136. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от 123 (??) on 26-Сен-14, 21:31 
А можете прояснить - что делает эта строка?

iptables using -m string --hex-string '|28 29 20 7B|'

Я так понимаю, она блокирует соединение, где в запросе используется строка, заданная в hex-формате. Я только не совсем понимаю: какая это строка?

Ответить | Правка | ^ к родителю #87 | Наверх | Cообщить модератору

137. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от AlexAT (ok) on 26-Сен-14, 21:51 
() {
Ответить | Правка | ^ к родителю #136 | Наверх | Cообщить модератору

138. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от AlexAT (ok) on 26-Сен-14, 21:52 
Дерьмовый метод, особенно для вёбни. Допустим

<?
function x() {

будет не залить.

Ответить | Правка | ^ к родителю #136 | Наверх | Cообщить модератору

144. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 26-Сен-14, 23:22 
> Дерьмовый метод, особенно для вёбни.

Да вообще расстреливать таких админов через повешивание. Потом будет туева хуча глюков от такого "фикса". Админы, ен вы@#$вайтесь и просто обновите уже ваш глюкавый баш.

Ответить | Правка | ^ к родителю #138 | Наверх | Cообщить модератору

156. "Критическая уязвимость в bash, которая может привести к удал..."  –2 +/
Сообщение от Аноним (??) on 02-Окт-14, 00:07 
>> Дерьмовый метод, особенно для вёбни.
> Да вообще расстреливать таких админов через повешивание. Потом будет туева хуча глюков
> от такого "фикса". Админы, ен вы@#$вайтесь и просто обновите уже ваш
> глюкавый баш.

Эй, умник! А ты примерно представляешь себе, сколько скриптов перестанет враз работать? Нет? Ты даже не думал, что этот фикс может хуже баги поломать все к чертовой матери?

Ответить | Правка | ^ к родителю #144 | Наверх | Cообщить модератору

161. "Критическая уязвимость в bash, которая может привести к..."  +1 +/
Сообщение от arisu (ok) on 02-Окт-14, 07:45 
> Эй, умник! А ты примерно представляешь себе, сколько скриптов перестанет враз работать?

ну, ты же нам расскажешь, правда? то, что ты единственный свой скрипт с «приветмиром» заставил работать только с пятого раза, когда сосед по парте помог — это в данном случае неважно. главное — ты Эксперт!

Ответить | Правка | ^ к родителю #156 | Наверх | Cообщить модератору

96. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от ODESKBY email on 25-Сен-14, 13:23 
и все равно вместо того чтобы выдать новую минорную версию мантейнер продолжает вбивать 25 патч в релиз 4.3 ))) почти юмор

ttps://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-025

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

103. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Andrey Mitrofanov on 25-Сен-14, 13:56 
> и все равно вместо того чтобы выдать новую минорную версию мантейнер продолжает
> вбивать 25 патч в релиз 4.3 ))) почти юмор

Это и есть "4.3 pl25".

> ttps://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-025

ttps://ftp.gnu.org/gnu/bash/bash-4.2-patches/bash42-048
ttps://ftp.gnu.org/gnu/bash/bash-4.1-patches/bash41-012
...
ttps://ftp.gnu.org/gnu/bash/bash-3.0-patches/bash30-017

Да! почему он ещё 2.05b не пропатчил?!!

Ответить | Правка | ^ к родителю #96 | Наверх | Cообщить модератору

123. "Критическая уязвимость в bash, которая может привести к удал..."  +2 +/
Сообщение от solardiz (ok) on 26-Сен-14, 01:12 
> Да! почему он ещё 2.05b не пропатчил?!!

Уже пропатчил: http://seclists.org/oss-sec/2014/q3/698

Ответить | Правка | ^ к родителю #103 | Наверх | Cообщить модератору

104. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Кирилл (??) on 25-Сен-14, 14:33 
Не вкурил. И где тут такая прям страшная уязвимость?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

108. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Andrey Mitrofanov on 25-Сен-14, 14:47 
> Не вкурил. И где тут такая прям страшная уязвимость?

Вот! Вот же!!1 Позитивный коментарий. </>

Ответить | Правка | ^ к родителю #104 | Наверх | Cообщить модератору

124. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Люблю арч on 26-Сен-14, 01:17 
[user@pc ~]$ env x='() { :;}; echo vulnerable'  bash -c "echo this is a test"
bash: warning: x: ignoring function definition attempt
bash: error importing function definition for `x'
this is a test
[user@pc ~]$ uname -a
Linux trader 3.16.3-1-ARCH #1 SMP PREEMPT Wed Sep 17 22:00:02 CEST 2014 i686 GNU/Linux
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

125. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 26-Сен-14, 03:53 
GNU bash, version 4.0.35(1)-release (i686-pc-linux-gnu)
# env x='() { :;}; echo vulnerable'  bash -c "echo this is a test"
vulnerable
this is a test
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

127. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Аноним (??) on 26-Сен-14, 08:59 
Спасибо.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

128. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Аноним (??) on 26-Сен-14, 09:58 
А как проверить, будет уязвимость работать через http сервер?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

145. "Критическая уязвимость в bash, которая может привести к удал..."  +1 +/
Сообщение от Аноним (??) on 26-Сен-14, 23:24 
> А как проверить, будет уязвимость работать через http сервер?

Отсылаешь такую конструкцию в хидерах и смотришь выполнилась ли команда. Если не знаешь как - тогда и более подробное описание тебе ни к чему.

Ответить | Правка | ^ к родителю #128 | Наверх | Cообщить модератору

146. "Критическая уязвимость в bash, которая может привести к удал..."  –2 +/
Сообщение от anonymous (??) on 27-Сен-14, 12:59 
Давно знал что bash "выполняет" переменные при запуске.
Из-за бывали ситуации когда у одного пользователя скрипт работает, а у другого нет.
Причем если запустить баш и вручную выполнять команды из скрипта, то работает как нужно.
Причина находилась в переменных окружения - где не работало была переменная с каким-нибудь экзотическим значением.

А вот что это может быть уязвимость в голову не приходило.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

148. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от GG (ok) on 28-Сен-14, 10:29 
Вроде пофиксили наконец.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

157. "Критическая уязвимость в bash, которая может привести к удал..."  –1 +/
Сообщение от Аноним (??) on 02-Окт-14, 00:08 
> Вроде пофиксили наконец.

А скрипты, переставшие работать, вы тоже все пофиксили?

Ответить | Правка | ^ к родителю #148 | Наверх | Cообщить модератору

163. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 02-Окт-14, 07:54 
>> Вроде пофиксили наконец.
> А скрипты, переставшие работать, вы тоже все пофиксили?

Покажите хоть один применяемый обиходе скрипт, в котором используется экспорт функций через переменные окружения ? Это давно всеми забытый bash-изм.

Ответить | Правка | ^ к родителю #157 | Наверх | Cообщить модератору

164. "Критическая уязвимость в bash, которая может привести к..."  +/
Сообщение от arisu (ok) on 02-Окт-14, 08:21 
глупость, которую изначально не надо было делать, но увы…
Ответить | Правка | ^ к родителю #163 | Наверх | Cообщить модератору

165. "Критическая уязвимость в bash, которая может привести к..."  +/
Сообщение от Andrey Mitrofanov on 02-Окт-14, 09:52 
> глупость, которую изначально не надо было делать, но увы…

Я тебе, как умнику записному скажу: в субшел определённые функции по любому _нужно как-то передавать. Если не окружение, но shmem, dbus (разбудите ленарта!), пайп(??). Если немног подумать, то разделения прав, авторизации или ещё какой безопасности там всё одно не будет никогда, шелы-то одинаково правные (да, изобретатели selinux-ов и seccomp-ов это рашат, да-да; саммоню изена со стягом jvm!). Хотя, может быть, не было бы исполнения кода с dhcp/openssh. Поди знай...

Ответить | Правка | ^ к родителю #164 | Наверх | Cообщить модератору

166. "Критическая уязвимость в bash, которая может привести к..."  +/
Сообщение от arisu (ok) on 02-Окт-14, 09:58 
>> глупость, которую изначально не надо было делать, но увы…
> Я тебе, как умнику записному скажу: в субшел определённые функции по любому
> _нужно как-то передавать.

…и делать это через envvars было глупо.

Ответить | Правка | ^ к родителю #165 | Наверх | Cообщить модератору

169. "Критическая уязвимость в bash, которая может привести к удал..."  +/
Сообщение от Аноним (??) on 07-Ноя-14, 15:32 
Люди, не могу найти пример удаленного использования.
Вот у меня bash старый и локально тест уязвимости проходит.
А вот как "по сети" сделать?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру