The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Код Ruby 1.9.3 перелицензирвован для обеспечения совместимос..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Код Ruby 1.9.3 перелицензирвован для обеспечения совместимос..."  +/
Сообщение от opennews on 03-Авг-11, 13:59 
Представлен (http://www.ruby-lang.org/en/news/2011/08/01/ruby-1-9-3-previ.../) первый тестовый выпуск интерпретатора Ruby 1.9.3, важным изменением в котором стала смена лицензии на код. Ранее Ruby распространялся под двумя лицензиями - "GPLv2" и "Ruby", начиная с версии Ruby 1.9.3 код будет распространяться под лицензиями BSD ("2-clause BSDL") и "Ruby". В качестве причины смены лицензии называется (http://www.ruby-forum.com/topic/216010) желание обеспечить совместимость кода, одновременно с лицензиями GPLv3 и BSD.


Лицензия "Ruby" ссылается  (http://www.ruby-lang.org/en/LICENSE.txt) на последний вариант GPL и полностью совместима с GPLv3, но указание GPLv2 в качестве второй лицензии ограничивало максимальную версию GPL и делало код несовместимым с GPLv3. Второй проблемой было то, что код прошлых версий Ruby не был совместим с лицензией BSD и не позволял обмениваться наработками с  проектами, распространяемыми под лицензией BSD. Начиная с выпуска Ruby 1.9.3 эти нед...

URL: http://www.ruby-lang.org/en/news/2011/08/01/ruby-1-9-3-previ.../
Новость: http://www.opennet.ru/opennews/art.shtml?num=31379

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Код Ruby 1.9.3 перелицензирвован для обеспечения совместимос..."  +/
Сообщение от codejumper on 03-Авг-11, 13:59 
отличные изменения
/ а дела лицензионные не выжны
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  –5 +/
Сообщение от Аноним (??) on 03-Авг-11, 14:39 
В конце концов весь софт перелицензируют на BSD, а про GPL забудут как страшный сон. И настанет истинная свобода.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от Аноним (??) on 03-Авг-11, 15:20 
> И настанет истинная свобода.

Свобода для кого? :)

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

13. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  –1 +/
Сообщение от 1 (??) on 03-Авг-11, 16:20 
для всех
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

37. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  –1 +/
Сообщение от Аноним (??) on 04-Авг-11, 04:04 
> для всех

... кроме пользователей.

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

21. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +2 +/
Сообщение от Аноним (??) on 03-Авг-11, 17:39 
>Свобода для кого? :)

Для Microsoft и Apple, очевидно же.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

34. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  –2 +/
Сообщение от anonymous (??) on 03-Авг-11, 21:46 
>Для Microsoft и Apple, очевидно же.

А что, свобода для них как-то мешает свободе для тебя?

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

35. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +1 +/
Сообщение от ДФ on 04-Авг-11, 01:02 
Шикарный вопрос. Вроде как хочется так много написать в ответ, про патентные войны, про их неминуемый крах в борьбе с бесплатным и свободным софтом в случае если тот получит такой же широкий доступ к продаваемому железу (предустановка, выбор альтернатив для всех программ при их первом запуске, а не только для браузера и то, когда антимонополисты пнут), когда государства будут обучать детей в школе свободному ПО для которого не надо нести дань мегакорпорациям,  про мегакорпорации кормящие золотой миллиард на вырученную дань и создающие новые мегакорпорации и скупающие особо ретивых противников. Но, рука вдруг становтся тяжелой, и не хочется в сотый раз повторять одно и то же... Тем более что разговор не получится с теми, кто скорее всего сидит в этом золотом миллиарде работая в уютном офисе мегакорпорации и хотел бы сохранить статус КВО до самого судного дня. Ух, ну вроде отлегло на сегодня...
Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

42. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от Сторонник ДФ on 04-Авг-11, 13:54 
>[оверквотинг удален]
> продаваемому железу (предустановка, выбор альтернатив для всех программ при их первом
> запуске, а не только для браузера и то, когда антимонополисты пнут),
> когда государства будут обучать детей в школе свободному ПО для которого
> не надо нести дань мегакорпорациям,  про мегакорпорации кормящие золотой миллиард
> на вырученную дань и создающие новые мегакорпорации и скупающие особо ретивых
> противников. Но, рука вдруг становтся тяжелой, и не хочется в сотый
> раз повторять одно и то же... Тем более что разговор не
> получится с теми, кто скорее всего сидит в этом золотом миллиарде
> работая в уютном офисе мегакорпорации и хотел бы сохранить статус КВО
> до самого судного дня. Ух, ну вроде отлегло на сегодня...

Друг, спасибо! Подписываюсь под каждым твоим словом!

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

36. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от Аноним (??) on 04-Авг-11, 04:03 
>А что, свобода для них как-то мешает свободе для тебя?

Более того, это сущности взаимоисключающие. Чем больше свободы у проприетарщика - тем меньше ее у пользователя.

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

14. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от zomg on 03-Авг-11, 16:28 
ересь какая
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

23. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +1 +/
Сообщение от Аноним (??) on 03-Авг-11, 17:44 
> ересь какая

Смотря для кого.
С точки зрения проприетарщика - свободе драть пользователей в любых позах копилефт-лицензии сильно мешают. И когда они умрут, наступит истинная свобода. Для проприетарщиков.

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

32. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от Below (ok) on 03-Авг-11, 20:50 
А вдруг наступит коммунизм? Китай-то не дремлет)
Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

50. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от Аноним (??) on 15-Авг-11, 15:54 
А что в Китае уже коммунизм7
Ответить | Правка | ^ к родителю #32 | Наверх | Cообщить модератору

25. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от FFASM (ok) on 03-Авг-11, 18:52 
Ага, все люди будут добрые, соблюдать законы, усердно работать и совершенно не пытаться нажиться на чужом труде....
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

31. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +2 +/
Сообщение от A on 03-Авг-11, 20:28 
Perl они вычистили ещё версии в пятой-шестой (сейчас девятка на подходе). В фре есть системные части на питоне, но больше там чтут sed и awk (причём, не gnu-awk, а unix-awk).
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

43. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от Andrey Mitrofanov on 04-Авг-11, 20:13 
Когда gcc из базы вынесут... а не "есть также возможность кое-где порой использовать как-то clang". Когда GNU binutils -- так же...

...вот тогда мы все с удовлетворением узнаем, что в этой новости никто не трогал тему freebsd, а речь шла о лицензии BSD (какой-то из -- вот развелось-то?! коре тииим "сами путаются"(тм)).

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

49. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от Анон on 05-Авг-11, 18:18 
В новости нет, в комментариях да.
Просто я задал вопрос касающийся использования скриптовых языков во FreeBSD, но его потом удалили.
Я прекрасно понимаю, что вопрос немного не по теме новости, но руби и лицензия BSD напомнили мне о вопросе который меня интересовал и я решил его задать.
Думаю, создавать целую тему на форуме, только чтобы задать такой вопрос, не совсем целесообразно.
Стиль изложения ваших мыслей просто сногсшибателен. :)
Ответить | Правка | ^ к родителю #43 | Наверх | Cообщить модератору

48. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от Анон on 05-Авг-11, 18:03 
Спасибо за ответ.
Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

6. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +1 +/
Сообщение от Савраска on 03-Авг-11, 15:15 
Объясните мне бестолковому, в чем глубинный смысл двойной лицензии BSD/GPLv3 на один и тот же продукт? Ну, ладно, допустим 1.9.3 выпустили под 2-мя лицензиями, в конце концов каждый сам себе злобный буратина. Но что будет с версией 1.9.4, куда войдет патч, допустим, от Васи Пупкина под GPLv3. И что дальше? Будет две версии 1.9.4-bsd и 1.9.4-gpl, или будем выкручивать руки Пупкину, чтоб он или опубликовал своё творение под BSD или передал права на код? "Истинная свобода", ёпт!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

9. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +1 +/
Сообщение от йопт email(??) on 03-Авг-11, 15:22 
> Ну, ладно, допустим 1.9.3 выпустили под 2-мя
> лицензиями, в конце концов каждый сам себе злобный буратина. Но что
> будет с версией 1.9.4, куда войдет патч, допустим, от Васи Пупкина
> под GPLv3. И что дальше? Будет две версии 1.9.4-bsd и 1.9.4-gpl,
> или будем выкручивать руки Пупкину, чтоб он или опубликовал своё творение
> под BSD или передал права на код?

По моим соображениям код Васи Пупкина просто не примут, пока он не согласится его отдать на условиях двойной лицензии

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

11. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от gegMOPO4 (ok) on 03-Авг-11, 16:11 
Тогда зачем там лицензия Ruby, совместимая с GPL?
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

16. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от йопт email(??) on 03-Авг-11, 16:41 
а пойди их разбери... для чего-то ж придумали так. самому немного интересно
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

10. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от Аноним (??) on 03-Авг-11, 16:03 
>или будем выкручивать руки Пупкину

зачем сразу радикализм? Если подумать, то находится еще один вариант: Вася Пупкин может не присылать патчи, если его не устраивает лицензия. И даже сделать форк со своими патчами.
И таки да, это свобода. Без "ёпт".

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

18. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от Аноним (??) on 03-Авг-11, 16:57 
свободолюбители )) часом не для того чтобы потом тупо закрыть и продавать )
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

27. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от Аноним (??) on 03-Авг-11, 18:56 
> свободолюбители )) часом не для того чтобы потом тупо закрыть и продавать
> )

Объясните пожалуйста мне, тупому:
Предположим есть продукт версии №1 под лицензией GPL.
Автор добавляет новую функцию, выпускает версию №2. Не публикует исходники этой новой функции и говорит что продукт версии №2 теперь закрыт.

Разве этими действиями автор не нарушает лицензию GPL ? Ведь новая функция - это добавление к продукту, который под GPL.

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

30. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от anonymous (??) on 03-Авг-11, 20:21 
Если №2 он опубликует не под GPL, то ничего не нарушает - автор вправе лицензировать и перелицензировать свои продукта как его душе угодно.
Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

44. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +1 +/
Сообщение от Аноним (??) on 04-Авг-11, 21:10 
> Если №2 он опубликует не под GPL, то ничего не нарушает -
> автор вправе лицензировать и перелицензировать свои продукта как его душе угодно.

Спасибо за разъяснения
   Теперь я понял, что меня интуитивно заставляло не связываться с использованием чужих программ под GPL. Ведь если я буду использовать, а значит и дорабатывать под свои проекты, то вынужден обнародовать свой труд.
   Согласен, что начальный вклад автора на порядки больше моих доработок. НО! давайте не путать "автора" - системотехника, алгоритмиста, программиста и прочая с "автором" - собственником прав. А это чаще всего совсем разные субъекты. И права, как правило у корпораций, а не отдельного программиста.
   Вот завтра автор закроет проект, поимев на халявку мой труд. А я останусь с носом. И продолжая дальше, уже без автора, поддерживать этот продукт, вынужден продолжать публиковать свои наработки. В то время как автор будет иметь возможность их видеть, но скрывать свои.
   Может у меня паранойя, но чем то этот GPL схож с "первая доза бесплатна"

Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

45. "Код Ruby 1.9.3 перелицензирован для обеспечения..."  +/
Сообщение от anonymous (??) on 05-Авг-11, 03:32 
>    Может у меня паранойя, но чем то этот GPL
> схож с "первая доза бесплатна"

то ли дело Самая Свободная BSDL, где можно просто взять себе код и пилить в подвальчике, никому не отдавая.

Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

46. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от A on 05-Авг-11, 09:20 
Вроде нет, идея gpl в том, что свои изменения ты не потеряешь
Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

19. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от анонимка on 03-Авг-11, 17:10 
>скорость работы с датами увеличилась в 5 раз

Хорошая новость. Осталось ещё раз в 10-20 увеличить скорость работы всего руби и во столько же раз сократить потребляемую память, после чего можно использовать :)

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

20. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +1 +/
Сообщение от Аноним (??) on 03-Авг-11, 17:22 
Ruby->C->gcc не?
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

39. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от анонимка on 04-Авг-11, 09:33 
Чем? Гуглится только пара-тройка дохлых проектов (http://rubytoccodeconv.sourceforge.net/, http://rubyforge.org/projects/ruby2c)
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

26. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от FFASM (ok) on 03-Авг-11, 18:56 
>>скорость работы с датами увеличилась в 5 раз
> Хорошая новость. Осталось ещё раз в 10-20 увеличить скорость работы всего руби
> и во столько же раз сократить потребляемую память, после чего можно
> использовать :)

Для вас является ключевым моментом, сколько ruby жрёт памяти когда работает с датами?

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

28. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +2 +/
Сообщение от umbr (ok) on 03-Авг-11, 19:47 
Пишите на C++ и будет Вам скорость :)
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

33. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от анонимка on 03-Авг-11, 21:13 
Так и делаю! Но вот redmine переписывать не хочется, а он штука хорошая. Но на руби.
Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

40. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от Аноним (??) on 04-Авг-11, 09:43 
Ну так вам никто не мешает, вместо того чтобы ныть тут, взяли бы уже, и написали бы свой собственный редмайн, на чем ваша религия вам позволяет.
Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

29. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от Alve on 03-Авг-11, 20:19 
Руби - язык не для жадных :) Пусть жрёт, ему всё впрок.
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

38. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от Аноним (??) on 04-Авг-11, 04:05 
> Руби - язык не для жадных :) Пусть жрёт, ему всё впрок.

Это вы про потребление памяти?

Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

47. "Код Ruby 1.9.3 перелицензирован для обеспечения совместимост..."  +/
Сообщение от A on 05-Авг-11, 09:27 
> Руби - язык не для жадных :) Пусть жрёт, ему всё впрок.

Точно, он для жадных до своего времени на разработку. Так это сразу Кац всем о говорил. Все по чесноку.

Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру