The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

форумы  правила/FAQ  поиск  регистрация  вход/выход  слежка  RSS
"Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от opennews (ok) on 09-Ноя-17, 23:12 
Доступны (https://www.postgresql.org/about/news/1801/) корректирующие обновления для всех поддерживаемых веток PostgreSQL: 10.1 (https://www.postgresql.org/docs/current/static/release-10-1....), 9.6.6 (http://www.postgresql.org/docs/current/static/release-9-6-6....), 9.5.10 (http://www.postgresql.org/docs/current/static/release-9-5-10...), 9.4.15 (http://www.postgresql.org/docs/current/static/release-9-4-15...), 9.3.20 (http://www.postgresql.org/docs/current/static/release-9-3-20...) и 9.2.24 (http://www.postgresql.org/docs/9.2/static/release-9-2-24.html), в которых представлена порция исправлений ошибок, в том числе устранены проблемы, которые могут привести к повреждению данных.  Выпуск обновлений для ветки 9.3 продлится (http://www.postgresql.org/support/versioning/)  до сентября 2018 г., 9.4 до декабря 2019 г., 9.5 до января 2021 г., 9.6 - до сентября 2021 года, 10 - до октября 2020 года. Ветка 9.2 достигла окончания своего жизненного цикла.


Из исправлений можно выделить  серьёзные проблемы с индексами BRIN (не попадание строк в индекс) и логической репликацией, маловероятный крах при обработке вложенных триггеров, крах при редком стечении обстоятельств во время параллельного выполнения одинаковых запросов, проблемы с порядком вывода конструкций GRANT в дампе pg_dump.
Кроме исправления ошибок в новых выпусках также устранены три уязвимости:  


-  CVE-2017-12172 - администратор БД может повредить системные файлы, принадлежащие пользователю root, через направления в них лога;  

-  CVE-2017-15098 - утечка содержимого памяти через манипуляцию с функциями JSON;
-  CVE-2017-15099 - при выполнении "INSERT ... ON CONFLICT DO UPDATE" не учитывалось наличие прав доступа для операции SELECT.

URL: https://www.postgresql.org/about/news/1801/
Новость: http://www.opennet.ru/opennews/art.shtml?num=47542

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +2 +/
Сообщение от кверти (ok) on 09-Ноя-17, 23:12 
Ну вот теперь можно и постгрес 10 ставить вместо 9.6)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  –1 +/
Сообщение от бедный буратино (ok) on 10-Ноя-17, 04:34 
как в народе говорили? первый баг в этом году, значит зима скоро
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

5. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  –1 +/
Сообщение от лютый жабист__ on 10-Ноя-17, 05:55 
> как в народе говорили? первый баг в этом году, значит зима скоро

Первый?! Вы новости в этом году не читали? Почти в кажом апдейте "пофиксили возможную потерю данных".

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

6. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от бедный буратино (ok) on 10-Ноя-17, 06:57 
для 10 - первый. оно месяц назад вышло :)
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

19. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +1 +/
Сообщение от rshadow (ok) on 10-Ноя-17, 15:01 
Ну дык странно в БД видеть другие баги =) Большее количество будет про данные да индексы.
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

31. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  –3 +/
Сообщение от лютый жабист__ on 11-Ноя-17, 07:54 
>дык странно в БД видеть другие баги

странно - это использовать СУБД которая тихо херит твои данные...

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

33. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от Аноним (??) on 11-Ноя-17, 12:02 
>>дык странно в БД видеть другие баги
> странно - это использовать СУБД которая тихо херит твои данные...

И тебе конечно не составит труда привести пример херенья данных или СУБД в которой никогда небыло ни одной ошибки?

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

34. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от kai3341 (ok) on 11-Ноя-17, 12:16 
> странно - это использовать СУБД которая тихо херит твои данные...

Скажи-ка, дружок, какая СУБД не может похерить твои данные?

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

36. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от Аноним (??) on 11-Ноя-17, 20:30 
> какая СУБД не может похерить твои данные?

Никакая! Никакая СУБД не может похерить его данные :)

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

3. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  –3 +/
Сообщение от лютый жабист__ on 10-Ноя-17, 05:52 
>в том числе устранены проблемы, которые могут привести к повреждению данных. Из исправлений можно выделить серьёзные проблемы с индексами BRIN (не попадание строк в индекс) и логической репликацией, маловероятный крах при обработке вложенных триггеров, крах при редком стечении обстоятельств во время параллельного выполнения одинаковых запросов, проблемы с порядком вывода конструкций GRANT в дампе pg_dump.

Мамамия... т.е. Постгрес ещё не для продакшена? С какой версии можно начинать использовать-то?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  –6 +/
Сообщение от лютый жабист__ on 10-Ноя-17, 05:54 
Мы круче Монго квакали они... 8)
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

7. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от теперь по Борщеву on 10-Ноя-17, 09:49 
в телеграме хайлоада раскрывали тему с монгочкой пострадавшие. В продакшене попробовали.
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

8. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  –3 +/
Сообщение от лютый жабист__ on 10-Ноя-17, 10:02 
Это у которых крутой хайлоад в виде мэйлру и нет другой субд кроме Тарантула? Охотно им верю :)))
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  –2 +/
Сообщение от кверти (ok) on 10-Ноя-17, 10:30 
А что нам тебе верить? У которого вместо мозга жаба?
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

11. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  –3 +/
Сообщение от лютый жабист__ on 10-Ноя-17, 11:10 
> А что нам тебе верить? У которого вместо мозга жаба?

Всё не можешь принять факт, что бизнеслогика должна быть на java сервере приложений? Тогда и СУБД можно взять попроще и побезглючнее, чем Слоник.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

16. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +2 +/
Сообщение от Аноним (??) on 10-Ноя-17, 13:27 
А зачем ты пытаешься оскорблять, у тебя комплекс какой-то? На работу не взяли?
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

21. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от _ (??) on 10-Ноя-17, 17:08 
>Всё не можешь принять факт, что бизнеслогика должна быть на java сервере приложений?

Жалко вас, это уже не лечиЦЦо :)

Ни в одном стартапе жабщиков нет, сидят они где то в тёмных норах типа-Ынерпрайза ну то есть на склад-бухгалтерии рядом с кобольшиками ... но пока в отдичии от последних - кваааакают :)

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

30. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  –2 +/
Сообщение от лютый жабист__ on 11-Ноя-17, 04:48 
>Ни в одном стартапе жабщиков нет,

Тебя на upwork за что забанили? Это если про стартапы...
А на hh про "темные норы" позырь.

Ты сам то кем будешь? Сейчас рынок труда рсубд просел, Ораклисты ещё худо-бедно питаются, а всякие бесплатные закосы под Оракел - на дoширак или свободен.

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

32. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от Аноним (??) on 11-Ноя-17, 12:01 
Ну тебя там сразу видно что давно забанили.
Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

25. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от _ (??) on 10-Ноя-17, 17:20 
>Мы круче Монго квакали они... 8)

Для сильных жабой, но слабым мозгом обхясню:

PostgreSQL - это такая RDBM. Качественная и навороченная аж ой вэй!
Mongo в кластере - это такой раздутый, с кучей свистелок и перделок заменитель /dev/null ..
Mongo же _не_ в кластере ... ну это как ох шЫт, ну не знаю я какую аналогию привести чтобы выразить всю глубину глубин моего "ненужно"! :-)

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

26. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  –4 +/
Сообщение от лютый жабист__ on 10-Ноя-17, 18:02 
КаКчественная аж уши заворачиваются, всего по несколько фатальных багов в каждом минорном релизе
Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

28. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от _ (??) on 11-Ноя-17, 00:49 
По сравнению с к примеру с жабой - просто кристально-образцово-показательное качество!
Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

10. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от Аноним (??) on 10-Ноя-17, 11:00 
9.2....
Блин а что делать с ораклом который вместо данных пустую выборку выдавал на некоторых запросах из view c рекурсией?
(да и уже на большой базе ловили разные результаты в зависимости от плана на 11.2 :) )
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

12. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  –1 +/
Сообщение от лютый жабист__ on 10-Ноя-17, 11:10 
> Блин а что делать с ораклом который вместо данных пустую выборку выдавал

Что делать, что делать. БЛ в сервер приложений переносить.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

14. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от щи on 10-Ноя-17, 11:51 
https://www.youtube.com/watch?v=BcmUOmvl1N8
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

22. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +2 +/
Сообщение от _ (??) on 10-Ноя-17, 17:12 
>>Блин а что делать с ораклом который вместо данных пустую выборку выдавал
>Что делать, что делать. БЛ в сервер приложений переносить.

Не надо нам каждым своим постом доказывать что жабшики - тyпыe дeбилы, мы как бе в курсе :)
Твоя жабья БЛ конечно с базой будет святым духом общаться а не тем же SQL-ем? :-)

  

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

27. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  –3 +/
Сообщение от лютый жабист__ on 10-Ноя-17, 18:06 
Самокритично ты. Скажу что даже при выборе рсубд язык sql в 80 процентах случаев не используется. И в более чем 50 процентах случаев рсубд уже не используют. Ну это в живых проектах, а не кульзизопских поделках

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

29. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от _ (??) on 11-Ноя-17, 00:50 
Ну то есть лечить тебя даже электричеством - уже поздно? :(
Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

13. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  –3 +/
Сообщение от iPony on 10-Ноя-17, 11:13 
> Постгрес ещё не для продакшена?

Типа того. Для продакшена есть Oracle 👍

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

18. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +1 +/
Сообщение от Аноним (??) on 10-Ноя-17, 13:34 
Это в которой при отсутствии индекса на внешний ключ появляются дедлоки? Спасибо, кушайте сами.
Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

23. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  –1 +/
Сообщение от _ (??) on 10-Ноя-17, 17:14 
А для зондофф есть ябблы <thumbsup>
Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

35. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от Аноним (??) on 11-Ноя-17, 17:45 
То-то я гляжу, как топы отрасли всеми способами силятся спихнуть его на помойку поскорей с переменным успехом.
Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

38. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от Аноним (??) on 12-Ноя-17, 23:27 
Если бы ты знал сколько стоит лицензия, ты тоже бы захотел его выкинуть из своей инфраструктуры
Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

20. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +5 +/
Сообщение от rshadow (ok) on 10-Ноя-17, 15:05 
Более того скажу, даже ваше тело и мозг не для продакшена. Куча багов (хорошо если не в прямом смысле) и когнитивный диссонанс через раз.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

37. "Обновление PostgreSQL 10.1, 9.6.6, 9.5.10, 9.4.15, 9.3.20 и ..."  +/
Сообщение от Аноним (??) on 12-Ноя-17, 23:25 
в треде топят за постгрю, помню раньше все топили за мускул, одно время топили за монгу. Вангую скоро очередь тарантула или за таракана
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2017 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor