The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"squid - TCP_MISS/401 IIS"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Настройка Squid и других прокси серверов (Squid)
Изначальное сообщение [ Отслеживать ]

"squid - TCP_MISS/401 IIS"  +/
Сообщение от Ninjatrasher (ok) on 09-Сен-14, 10:11 
Добрый день. Прошу вашей помощи в решение следующего вопроса:
есть сквид, версия 3.1.20 с керберос аунтефикацией.
Есть портал на IIS, который требует авторизацию по логину и паролю. Когда пользователи туда заходят, вводят данные и нажимают ок, авторизация не проходит и по итогу они получают "Страница недоступна"
посмотрев логи сквида обнаружил там ошибку TCP_MISS/401. Нашел эту проблемы в гугле, но решения нигде нет.
попробовал дописать в конфиг сквида

http_port 80  connection-auth=on

результат тот же.
Кто нибудь с таким сталкивался, как это дело лечить?
Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по ответам | RSS]

1. "squid - TCP_MISS/401 IIS"  +/
Сообщение от Etch on 09-Сен-14, 11:18 
дайте адрес портала для проверки
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "squid - TCP_MISS/401 IIS"  +/
Сообщение от Ninjatrasher (ok) on 09-Сен-14, 11:22 
> дайте адрес портала для проверки

http://web.hk.yusen-logistics.com/offintranet/

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "squid - TCP_MISS/401 IIS"  +1 +/
Сообщение от Etch on 09-Сен-14, 16:43 
- сквид работает в прозрачном режиме?
- если зайти напрямую (не через прокси), то авторизация проходит успешно?
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "squid - TCP_MISS/401 IIS"  +1 +/
Сообщение от Etch on 09-Сен-14, 16:47 
и покажите вывод:
squid3 -k parse 2>&1 |grep -i connection-auth
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "squid - TCP_MISS/401 IIS"  +/
Сообщение от Ninjatrasher (ok) on 09-Сен-14, 17:36 
> - сквид работает в прозрачном режиме?
> - если зайти напрямую (не через прокси), то авторизация проходит успешно?

1. нет сквид работает не в прозрачном режиме. пользователи через wpad.dat получают адрес сквида и ломятся к нему.
2. если зайти напрямую все работает

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

6. "squid - TCP_MISS/401 IIS"  +/
Сообщение от Ninjatrasher (ok) on 09-Сен-14, 17:37 
> и покажите вывод:
> squid3 -k parse 2>&1 |grep -i connection-auth


root@vs-msk00-prx05:/home/manage# squid3 -k parse 2>&1 |grep -i connection-auth
2014/09/09 17:36:46| Processing: http_port  80  connection-auth=on

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

7. "squid - TCP_MISS/401 IIS"  +1 +/
Сообщение от Etch on 10-Сен-14, 10:16 
Даже и не знаю что предположить. Можно попробовать посмотреть какие HTTP-заголовки передаёт и принимает браузер при работе напрямую и через прокси. Если различий не будет - значит возможно дело в браузере, если будут - копать дальше прокси-сервер.

Заголовки можно посмотреть либо снифером (Wireshark например), либо вот этим плагином к файрфоксу:
http://livehttpheaders.mozdev.org/installation.html

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

8. "squid - TCP_MISS/401 IIS"  +/
Сообщение от Ninjatrasher (ok) on 11-Сен-14, 15:58 
> Даже и не знаю что предположить. Можно попробовать посмотреть какие HTTP-заголовки передаёт
> и принимает браузер при работе напрямую и через прокси. Если различий
> не будет - значит возможно дело в браузере, если будут -
> копать дальше прокси-сервер.
> Заголовки можно посмотреть либо снифером (Wireshark например), либо вот этим плагином к
> файрфоксу:
> http://livehttpheaders.mozdev.org/installation.html

половил пакеты, выявил:
1. без сквида, идет запрост HTTP 1.1 NTLM и возвращается HTTP 1.1
2. со сквидом, идет запрос  HTTP 1.1, сквид возвращает HTTP 1.0

видимо не умеет сквид 3.1.20 не умеется работать с http 1.1, попробую поставить более свежий.


Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "squid - TCP_MISS/401 IIS"  +1 +/
Сообщение от Etch on 11-Сен-14, 16:19 
> видимо не умеет сквид 3.1.20 не умеется работать с http 1.1, попробую
> поставить более свежий.

Похоже на то - http://wiki.squid-cache.org/Features/HTTP11

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "squid - TCP_MISS/401 IIS"  +/
Сообщение от Ninjatrasher (ok) on 11-Сен-14, 17:48 
>> видимо не умеет сквид 3.1.20 не умеется работать с http 1.1, попробую
>> поставить более свежий.
> Похоже на то - http://wiki.squid-cache.org/Features/HTTP11

спасибо за наводку на нужное направление, разобрался, установил сквид 3.4.6 и все ок.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору


Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру