The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]



"А не было ли нехороших ситуаций с kernel.ubuntu.com недавно?"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Информационная безопасность (Обнаружение и предотвращение атак / Linux)
Изначальное сообщение [ Отслеживать ]

"А не было ли нехороших ситуаций с kernel.ubuntu.com недавно?"  +/
Сообщение от Аноним (??) on 03-Мрт-18, 01:38 
На днях заметил, что на означенном в теме ресурсе, откуда я периодически скачиваю обновления для ядра, внезапно изменилась дата релиза скаченного мной ранее 4.9.83. Т.е. у меня прямо вот перед глазами файлы с именами, оканчивающимися примерно так: "201802221530_amd64.deb", а на сайте новые файлы с окончанием "201802261609_amd64.deb", ну и сама директория, соответственно от нового числа (26.02.2018) против ранее выпущенной 22.02.2018:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.9.83/

Кроме того, добавилась новая версия ядра 4.9.85 с датой на два дня позже (28.02.2018), при этом версии 4.9.84 нет.

Но и это ещё не всё. Похожая ситуация и с некоторыми другими версиями ядра:
– у 4.4 26 февраля вышла 117, а 28 февраля – 119, нет 118;
– у 4.14 22 февраля вышла 21, а 28 февраля – 23, 22 нет;
– у 4.15 26 февраля 5, а 28 февраля – 7, 6 нет.

В связи с этим хотелось бы услышать от знающих людей, с чем может быть связано такое в принципе, стоит ли бояться, надо ли обновляться. Поиск по конкретной версии 4.9.84 (пропущенной на сайте) в числе прочего выдаёт https://lwn.net/Articles/747978/, где вполне себе чёрным по белому написано дословно "I'm announcing the release of the 4.9.84 kernel. All users of the 4.9 kernel series must upgrade."

В общем, народ, кто в теме, поясните, пожалуйста, несведущему. Спасибо.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "А не было ли нехороших ситуаций с kernel.ubuntu.com недавно?"  +/
Сообщение от Andrey Mitrofanov on 03-Мрт-18, 08:23 
>lwn.net/Articles/747978/, где вполне себе чёрным по белому написано
> дословно "I'm announcing the release of the 4.9.84 kernel. All users
> of the 4.9 kernel series must upgrade."

"All users of the XX kernel series must upgrade." _просто_ забито у Грега КХ в _габлоне_ письма.  Это написано во _всех_ его письмах о релизах стабильных ядер.  Где-то даже был... а вот оно: https://github.com/gregkh/gregkh-linux/blob/master/stable/do...опублинован git со скриптами.

> В общем, народ, кто в теме, поясните, пожалуйста, несведущему. Спасибо.

Ну, может там есть цифровые подписи?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "А не было ли нехороших ситуаций с kernel.ubuntu.com недавно?"  +/
Сообщение от Аноним (??) on 03-Мрт-18, 13:16 
> "All users of the XX kernel series must upgrade."
> _просто_ забито у у Грега КХ в _шаблоне_ письма.

ОК. С этим понятно. Спасибо.

> Ну, может там есть цифровые подписи?

Я так подумал, что если чего вдруг поломали и положили несанкционированно новое нехорошее, то и, возможно, всякие другие штуки (подписи и суммы) тоже могли подменить.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

2. "А не было ли нехороших ситуаций с kernel.ubuntu.com недавно?"  +/
Сообщение от eRIC (ok) on 03-Мрт-18, 09:46 
> На днях заметил, что на означенном в теме ресурсе, откуда я периодически
> скачиваю обновления для ядра, внезапно изменилась дата релиза скаченного мной ранее

скажите почему вы используете ядра из https://wiki.ubuntu.com/Kernel/MainlineBuilds?

>> These kernels are not supported and are not appropriate for production use.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "А не было ли нехороших ситуаций с kernel.ubuntu.com недавно?"  +/
Сообщение от Аноним (??) on 03-Мрт-18, 13:09 
> скажите почему вы используете ядра из https://wiki.ubuntu.com/Kernel/MainlineBuilds?

Эм-м-м. Ну как-то, когда встал вопрос обновления ядра без изменения всего дистрибутива, я нашёл чью-то инструкцию, так делать (через dpkg), с тех пор так и продолжаю.
Не знал до вашего комментария, что они "not supported". Как так вообще? Они ж обновляются. Обновляются, но не поддерживаются?

Возможно, это, действительно не лучший вариант обновления ядра, какой тогда следует использовать? Если старый дистрибутив (14.04), а ядро надо новее, например?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "А не было ли нехороших ситуаций с kernel.ubuntu.com недавно?"  +/
Сообщение от eRIC (ok) on 03-Мрт-18, 14:01 
> Эм-м-м. Ну как-то, когда встал вопрос обновления ядра без изменения всего дистрибутива,
> я нашёл чью-то инструкцию, так делать (через dpkg), с тех пор
> так и продолжаю.

во первых это ядра официальные с kernel.org но собранные с config под Ubuntu:

These kernels are made from unmodified kernel source but using the Ubuntu kernel configuration files.

> Не знал до вашего комментария, что они "not supported". Как так вообще?
> Они ж обновляются. Обновляются, но не поддерживаются?

во вторых они собираются для тестирования патчей Ubuntu на официальные ядра с kernel.org или выявления ошибок в официальных ядрах kernel.org

>Как так вообще?

ну и на последок, если вы используете Ubuntu LTS ветку (что рекомендовано в продакшн среде) и хотите обновить ядро(конечно было заранее проверено и протестировано под эту ветку) есть в Ubuntu понятие HWE, в котором предлагаются для конкретной ветки LTS предложения для обновления до конкретных ядер. Почитайте: https://wiki.ubuntu.com/Kernel/LTSEnablementStack

а так вообще никто не запрещает использовать любое собранное ядро, как говорится все на свой страх и риск ;D


Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

6. "А не было ли нехороших ситуаций с kernel.ubuntu.com недавно?"  +/
Сообщение от Аноним (??) on 03-Мрт-18, 16:48 
Благодарствую.
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor