The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]



"Установка Kaspersky for proxy на CentOs 7.4 х64"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на сервере (Разное / Linux)
Изначальное сообщение [ Отслеживать ]

"Установка Kaspersky for proxy на CentOs 7.4 х64"  +/
Сообщение от Dmitry (??) on 20-Фев-18, 15:15 
Добрый день всем.

Сорри. Не знаю в какую точно ветку отписать, поэтому пишу здесь.

Пытаюсь установить каспера для прокси (5.5-86) на CentOs 7.4. Но вылетают депенденсы, которые не понятно как разрешить.
=============
rpm -i kav4proxy-5.5-86.i386.rpm
error: Failed dependencies:
        libc.so.6 is needed by kav4proxy-5.5-86.i386
        libc.so.6(GLIBC_2.0) is needed by kav4proxy-5.5-86.i386
        libc.so.6(GLIBC_2.1) is needed by kav4proxy-5.5-86.i386
        libc.so.6(GLIBC_2.1.3) is needed by kav4proxy-5.5-86.i386
        libc.so.6(GLIBC_2.2) is needed by kav4proxy-5.5-86.i386
        libc.so.6(GLIBC_2.2.3) is needed by kav4proxy-5.5-86.i386
        libc.so.6(GLIBC_2.2.4) is needed by kav4proxy-5.5-86.i386
        libc.so.6(GLIBC_2.3) is needed by kav4proxy-5.5-86.i386
        libc.so.6(GLIBC_2.3.4) is needed by kav4proxy-5.5-86.i386
        libdl.so.2 is needed by kav4proxy-5.5-86.i386
        libdl.so.2(GLIBC_2.0) is needed by kav4proxy-5.5-86.i386
        libdl.so.2(GLIBC_2.1) is needed by kav4proxy-5.5-86.i386
        libm.so.6 is needed by kav4proxy-5.5-86.i386
        libpthread.so.0 is needed by kav4proxy-5.5-86.i386
        libpthread.so.0(GLIBC_2.0) is needed by kav4proxy-5.5-86.i386
        libpthread.so.0(GLIBC_2.1) is needed by kav4proxy-5.5-86.i386
        libpthread.so.0(GLIBC_2.1.1) is needed by kav4proxy-5.5-86.i386
        libpthread.so.0(GLIBC_2.2) is needed by kav4proxy-5.5-86.i386
        libpthread.so.0(GLIBC_2.3.2) is needed by kav4proxy-5.5-86.i386
        librt.so.1 is needed by kav4proxy-5.5-86.i386
============================================

Все дело в том, что все необходимы глибсы я вроде как уже установил. Даже более чем:

===============================================
rpm -qa | grep glib
glibmm24-2.50.0-1.el7.x86_64
glib2-static-2.50.3-3.el7.x86_64
ModemManager-glib-1.6.0-2.el7.x86_64
glibc-static-2.17-196.el7_4.2.x86_64
glib2-devel-2.50.3-3.el7.x86_64
glibc-headers-2.17-196.el7_4.2.x86_64
telepathy-glib-0.24.0-1.el7.x86_64
glibc-2.17-196.el7_4.2.x86_64
dbus-glib-0.100-7.el7.x86_64
glibc-devel-2.17-196.el7_4.2.x86_64
taglib-1.8-7.20130218git.el7.x86_64
glib-devel-1.2.10-41.el7.x86_64
poppler-glib-0.26.5-17.el7_4.x86_64
avahi-glib-0.6.31-17.el7.x86_64
spice-glib-0.33-6.el7_4.1.x86_64
glibmm24-doc-2.50.0-1.el7.noarch
glib-networking-tests-2.50.0-1.el7.x86_64
NetworkManager-glib-1.8.0-11.el7_4.x86_64
libvirt-glib-1.0.0-1.el7.x86_64
glibmm24-devel-2.50.0-1.el7.x86_64
glibc-utils-2.17-196.el7_4.2.x86_64
PackageKit-glib-1.1.5-1.el7.centos.x86_64
json-glib-1.2.6-1.el7.x86_64
glib-1.2.10-41.el7.x86_64
glib2-doc-2.50.3-3.el7.noarch
glib-networking-2.50.0-1.el7.x86_64
pulseaudio-libs-glib2-10.0-3.el7.x86_64
geocode-glib-3.20.1-1.el7.x86_64
glib2-2.50.3-3.el7.x86_64
glib2-fam-2.50.3-3.el7.x86_64
glibc-common-2.17-196.el7_4.2.x86_64
glib2-tests-2.50.3-3.el7.x86_64
==============================================

И требуемые либы в системе имеются быть в наличии. Вот, к примеру:

===============================================
find / -name libc.so.6 -print

/usr/lib/libc.so.6
/usr/lib64/libc.so.6

============================================

В /usr/lib/ это я перенес симлинк из /usr/lib64/ Но это тоже не помогло. В корне, ессно есть линки на указанные уср-ы -

/lib
/lib64

Подскажите, в каком направлении рыть. Ранее ставил данного каспера неоднократно, но подобных траблов не наблюдал.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Установка Kaspersky for proxy на CentOs 7.4 х64"  +/
Сообщение от lavr email(ok) on 20-Фев-18, 15:40 
>[оверквотинг удален]
>  find / -name libc.so.6 -print
> /usr/lib/libc.so.6
> /usr/lib64/libc.so.6
> ============================================
> В /usr/lib/ это я перенес симлинк из /usr/lib64/ Но это тоже не
> помогло. В корне, ессно есть линки на указанные уср-ы -
> /lib
> /lib64
> Подскажите, в каком направлении рыть. Ранее ставил данного каспера неоднократно, но подобных
> траблов не наблюдал.

В направлении установки 32bit'ных applications в CentOS 7.x x64,
ибо из вашего примера видно что kav4proxy-5.5-86.i386.rpm == 32bit приложение

типа:
# yum install glibc-devel.{i686,x86_64} libgcc.{i686,x86_64} ...
верхнее как пример, смотрите какие зависимости нужны.

Как-то так...

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Установка Kaspersky for proxy на CentOs 7.4 х64"  +/
Сообщение от kornell on 20-Фев-18, 15:44 
> Добрый день всем.
> Сорри. Не знаю в какую точно ветку отписать, поэтому пишу здесь.
> Пытаюсь установить каспера для прокси (5.5-86) на CentOs 7.4. Но вылетают депенденсы,
> которые не понятно как разрешить.
> Подскажите, в каком направлении рыть. Ранее ставил данного каспера неоднократно, но подобных
> траблов не наблюдал.

Из официальной доки:
Для запуска Антивируса Касперского 5.5 для Proxy Server на 64-битной версии СentOS и RHEL необходима библиотека glibc.i686.
https://support.kaspersky.ru/13200#block1

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Установка Kaspersky for proxy на CentOs 7.4 х64"  +/
Сообщение от Dmitry (??) on 20-Фев-18, 15:46 
>> Добрый день всем.
>> Сорри. Не знаю в какую точно ветку отписать, поэтому пишу здесь.
>> Пытаюсь установить каспера для прокси (5.5-86) на CentOs 7.4. Но вылетают депенденсы,
>> которые не понятно как разрешить.
>> Подскажите, в каком направлении рыть. Ранее ставил данного каспера неоднократно, но подобных
>> траблов не наблюдал.
> Из официальной доки:
> Для запуска Антивируса Касперского 5.5 для Proxy Server на 64-битной версии СentOS
> и RHEL необходима библиотека glibc.i686.
> https://support.kaspersky.ru/13200#block1

Сенкс. Сам нашел. См чуть ниже.


Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

3. "Установка Kaspersky for proxy на CentOs 7.4 х64"  +/
Сообщение от Dmitry (??) on 20-Фев-18, 15:45 
Вопрос снимаю. Сам нашел ответ - https://support.kaspersky.ru/13200#block2

Оказывается для каспера еще нужна была glibc.i686. Установил и все заработало.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Установка Kaspersky for proxy на CentOs 7.4 х64"  +/
Сообщение от artemrts (ok) on 02-Мрт-18, 21:52 
>[оверквотинг удален]
>  find / -name libc.so.6 -print
> /usr/lib/libc.so.6
> /usr/lib64/libc.so.6
> ============================================
> В /usr/lib/ это я перенес симлинк из /usr/lib64/ Но это тоже не
> помогло. В корне, ессно есть линки на указанные уср-ы -
> /lib
> /lib64
> Подскажите, в каком направлении рыть. Ранее ставил данного каспера неоднократно, но подобных
> траблов не наблюдал.

И накой хер тебе этот фсбэшный троян?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor