The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]



"FreeBSD и железо."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на сервере (Ядро)
Изначальное сообщение [ Отслеживать ]

"FreeBSD и железо."  +/
Сообщение от Ajavrik (ok) on 08-Дек-17, 08:00 
Приветствую всех!
Возникла такая проблема:
имеется:
система: Freebsd 10.4 amd64
мать:   GigaByte GA-B250M-D3H Socket 1151
процессор:  Intel Pentium G4400
память:  DDR4 8 GB
Установка прошла без видимых ошибок. Крутиться почтовый сервер совершенно нормально, но при команде sysctl -a процесс виснет и скинуть его kill -9 не удается. Установлен там webmin, а он при входе дает эту команду и не отрабатывает, все модули работают нормально. Через какое-то время забивается процессами sysctl и еле шевелится. shutdown -r now зависает на том, что выдает на консоль uptime и пока не нажмешь reset будет висеть. И еще, если после перезагрузки дать shutdown -r now, то перегрузится нормально, а если reboot то повиснет  так же на uptime.
Подскажите что менять, или подкрутить, или хотя бы, пока, как сбрасывать sysctl-ли.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "FreeBSD и железо."  +/
Сообщение от ыы on 08-Дек-17, 11:18 
>[оверквотинг удален]
> Установка прошла без видимых ошибок. Крутиться почтовый сервер совершенно нормально, но
> при команде sysctl -a процесс виснет и скинуть его kill -9
> не удается. Установлен там webmin, а он при входе дает эту
> команду и не отрабатывает, все модули работают нормально. Через какое-то время
> забивается процессами sysctl и еле шевелится. shutdown -r now зависает на
> том, что выдает на консоль uptime и пока не нажмешь reset
> будет висеть. И еще, если после перезагрузки дать shutdown -r now,
> то перегрузится нормально, а если reboot то повиснет  так же
> на uptime.
> Подскажите что менять, или подкрутить, или хотя бы, пока, как сбрасывать sysctl-ли.

посмотреть лог - нет ли ругани
посмотреть dmesg- нет ли ругани - может уже там видно что ему чего-то не понравилось
подключится к процессу терйсом -  посмотреть чего ждет
загрузится с лайвСВ с этим ядром - проверить есть ли эффект там.
загрузится с другим ядром - проверить есть ли эффект.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "FreeBSD и железо."  +/
Сообщение от Ajavrik (ok) on 08-Дек-17, 12:03 
>>[оверквотинг удален]
>
> посмотреть лог - нет ли ругани
> посмотреть dmesg- нет ли ругани - может уже там видно что ему
> чего-то не понравилось
> подключится к процессу терйсом -  посмотреть чего ждет
> загрузится с лайвСВ с этим ядром - проверить есть ли эффект там.
> загрузится с другим ядром - проверить есть ли эффект.

В логах ничего нет, на команду sysctl -a останавливается на этом и все, даже процесс не удается остановить
.
.
dev.apic.0.%parent: nexus0
dev.apic.0.%pnpinfo:
dev.apic.0.%location:
dev.apic.0.%driver: apic
dev.apic.0.%desc: APIC resources
dev.apic.%parent:
dev.fpupnp.0.%parent: acpi0

Трейсом, лайвсд и другое ядро, не пробовал, попробую позже, спасибо.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "FreeBSD и железо."  +/
Сообщение от lavr email(ok) on 08-Дек-17, 14:13 
>[оверквотинг удален]
> Установка прошла без видимых ошибок. Крутиться почтовый сервер совершенно нормально, но
> при команде sysctl -a процесс виснет и скинуть его kill -9
> не удается. Установлен там webmin, а он при входе дает эту
> команду и не отрабатывает, все модули работают нормально. Через какое-то время
> забивается процессами sysctl и еле шевелится. shutdown -r now зависает на
> том, что выдает на консоль uptime и пока не нажмешь reset
> будет висеть. И еще, если после перезагрузки дать shutdown -r now,
> то перегрузится нормально, а если reboot то повиснет  так же
> на uptime.
> Подскажите что менять, или подкрутить, или хотя бы, пока, как сбрасывать sysctl-ли.

- BIOS версия, в каком режиме?
- сетевая карта интегрированная, модель?
- возможно проблема с ACPI, в /etc/rc.conf -> webmin_enable="NO", перезагрузиться
a) в single user и выполнить: sysctl -a (проблемы те же?)
b) multiuser: sysctl -a (проблемы те же?)
- что покажет:
# sysctl hw.acpi.disable_on_reboot
# sysctl hint.acpi.0.disabled

- что будет если в /boot/loader.conf выставить
hint.acpi.0.disabled=1
и перезагрузиться?

ну и что показывают ps axuw, top в системе? если загрузки нет, то скорей
всего проблема в ACPI.

ps. Почему именно 10.4, а не 11.1? Как вариант, установите систему на USB Flash,
с минимальной настройкой почты, что там еще у Вас, поднимите минимальный nginx или
apache и webmin, загрузитесь с этой флешки и опробуйте работу, тот же sysctl -a

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "FreeBSD и железо."  +/
Сообщение от Ajavrik (ok) on 08-Дек-17, 15:34 

> - BIOS версия, в каком режиме?

UEFI

> - сетевая карта интегрированная, модель?

интегрированная Intel I219-V

> - возможно проблема с ACPI, в /etc/rc.conf -> webmin_enable="NO", перезагрузиться
> a) в single user и выполнить: sysctl -a (проблемы те же?)
> b) multiuser: sysctl -a (проблемы те же?)

Webmin установлен для операторов, заводить пользователей, пробовал без него, то же самое

> - что покажет:
> # sysctl hw.acpi.disable_on_reboot

hw.acpi.disable_on_reboot: 0

> # sysctl hint.acpi.0.disabled

sysctl: unknown oid 'hint.acpi.0.disabled'

> - что будет если в /boot/loader.conf выставить
> hint.acpi.0.disabled=1
> и перезагрузиться?

Попробую это все в выходные, сейчас далеко сижу.

> ну и что показывают ps axuw, top в системе? если загрузки нет,
> то скорей
> всего проблема в ACPI.

# ps axuw | grep "sysctl"
root       658   0.0  0.1  12380  4960  -  I     7:34PM    0:00.03 /sbin/sysctl -a
root      9342   0.0  0.1  12380  4960  -  I     7:23AM    0:00.03 /sbin/sysctl -a
root     13893   0.0  0.1  12380  4960  -  I    10:03AM    0:00.03 /sbin/sysctl -a
root     20452   0.0  0.1  12380  4960  0  T    11:56AM    0:03.22 sysctl -a
root     26026   0.0  0.1  12380  4960  5  T     1:50PM    0:00.74 sysctl -a
root     29420   0.0  0.1  12380  4960  6  T     3:11PM    0:00.05 sysctl -a
root     29852   0.0  0.0    392   312  6  R+    3:24PM    0:00.00 grep sysctl

# top

CPU:  0.0% user,  0.0% nice,  0.0% system,  0.0% interrupt,  100% idle
Mem: 153M Active, 277M Inact, 7061M Wired, 338M Free
ARC: 6270M Total, 1802M MFU, 4288M MRU, 16K Anon, 34M Header, 145M Other
Swap: 4096M Total, 4096M Free
20452 root             1  20    0 12380K  4960K STOP    0   0:03   0.00% sysctl
26026 root             1  52    0 12380K  4960K STOP    1   0:01   0.00% sysctl
29420 root             1  24    0 12380K  4960K STOP    1   0:00   0.00% sysctl
.
.

> ps. Почему именно 10.4, а не 11.1? Как вариант, установите систему на
> USB Flash,
> с минимальной настройкой почты, что там еще у Вас, поднимите минимальный nginx
> или
> apache и webmin, загрузитесь с этой флешки и опробуйте работу, тот же
> sysctl -a

Почему не 11.1 не знаю, было много установок на 10.4 и по привычке поставил временно, посмотреть как пойдет система, но нет ничего постояннее чем временное, пустил в продакшн, поставил webmin и увидел такую ошибку. Понимаю ошибся, буду выкарабкиваться.
Попробую с флешки 11.1 если пойдет, буду думать. Результат отпишу уже после выходных.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "FreeBSD и железо."  +/
Сообщение от lavr email(ok) on 08-Дек-17, 16:23 

>> - BIOS версия, в каком режиме?
> UEFI

версия uefi bios свежая, последняя?
как систему поставили - загрузка через UEFI или из UEFI Legacy(BIOS)?

> # top
> CPU:  0.0% user,  0.0% nice,  0.0% system,  0.0%
> interrupt,  100% idle
> Mem: 153M Active, 277M Inact, 7061M Wired, 338M Free
> ARC: 6270M Total, 1802M MFU, 4288M MRU, 16K Anon, 34M Header, 145M
> Other
> Swap: 4096M Total, 4096M Free

система не загружена, проблем нет, кроме отработки sysctl

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "FreeBSD и железо."  +/
Сообщение от Ajavrik (ok) on 08-Дек-17, 16:26 
>>> - BIOS версия, в каком режиме?
>> UEFI
> версия uefi bios свежая, последняя?

Да, последняя

> как систему поставили - загрузка через UEFI или из UEFI Legacy(BIOS)?

UEFI


>> # top
>> CPU:  0.0% user,  0.0% nice,  0.0% system,  0.0%
>> interrupt,  100% idle
>> Mem: 153M Active, 277M Inact, 7061M Wired, 338M Free
>> ARC: 6270M Total, 1802M MFU, 4288M MRU, 16K Anon, 34M Header, 145M
>> Other
>> Swap: 4096M Total, 4096M Free
> система не загружена, проблем нет, кроме отработки sysctl

Да не загружена, но при появлении таких процессов с 10-ок, начинает свопиться и тормозить.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "FreeBSD и железо."  +/
Сообщение от Ajavrik (ok) on 11-Дек-17, 08:59 
В итоге получил следующее:
11.1 грузиться и отрабатывает sysctl без проблем.
Пробовал ставить с
FreeBSD-10.4-RELEASE-amd64-memstick.img и
FreeBSD-10.4-RELEASE-amd64-uefi-memstick.img

Первый закачивает с флэшки, примерно, полчаса, потом грузиться и работает нормально, вторая все делает быстро. В обоих случаях sysctl -a не отрабатывает, зависает на том же месте.
Кроме того при загрузке выдает ошибки
ACPI Exception AE_ERROR Thread 100546 could not acquire Mutex...
ACPI Error: could not acquire  AML Interpreter mutex....

Ну и дальше ругань.
Не буду дальше разбираться, выберу денек и переставлю на 11.1.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "FreeBSD и железо."  +/
Сообщение от fantom (??) on 11-Дек-17, 15:20 
>[оверквотинг удален]
> FreeBSD-10.4-RELEASE-amd64-memstick.img и
> FreeBSD-10.4-RELEASE-amd64-uefi-memstick.img
> Первый закачивает с флэшки, примерно, полчаса, потом грузиться и работает нормально, вторая
> все делает быстро. В обоих случаях sysctl -a не отрабатывает, зависает
> на том же месте.
> Кроме того при загрузке выдает ошибки
> ACPI Exception AE_ERROR Thread 100546 could not acquire Mutex...
> ACPI Error: could not acquire  AML Interpreter mutex....
> Ну и дальше ругань.
> Не буду дальше разбираться, выберу денек и переставлю на 11.1.

А ACPI в ядре отключить? может проще получится?

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "FreeBSD и железо."  +/
Сообщение от lavr email(ok) on 11-Дек-17, 16:35 
>[оверквотинг удален]
>> FreeBSD-10.4-RELEASE-amd64-uefi-memstick.img
>> Первый закачивает с флэшки, примерно, полчаса, потом грузиться и работает нормально, вторая
>> все делает быстро. В обоих случаях sysctl -a не отрабатывает, зависает
>> на том же месте.
>> Кроме того при загрузке выдает ошибки
>> ACPI Exception AE_ERROR Thread 100546 could not acquire Mutex...
>> ACPI Error: could not acquire  AML Interpreter mutex....
>> Ну и дальше ругань.
>> Не буду дальше разбираться, выберу денек и переставлю на 11.1.
> А ACPI в ядре отключить? может проще получится?

а может и не загрузиться... :)

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "FreeBSD и железо."  +/
Сообщение от fantom (??) on 11-Дек-17, 21:03 
>[оверквотинг удален]
>>> Первый закачивает с флэшки, примерно, полчаса, потом грузиться и работает нормально, вторая
>>> все делает быстро. В обоих случаях sysctl -a не отрабатывает, зависает
>>> на том же месте.
>>> Кроме того при загрузке выдает ошибки
>>> ACPI Exception AE_ERROR Thread 100546 could not acquire Mutex...
>>> ACPI Error: could not acquire  AML Interpreter mutex....
>>> Ну и дальше ругань.
>>> Не буду дальше разбираться, выберу денек и переставлю на 11.1.
>> А ACPI в ядре отключить? может проще получится?
> а может и не загрузиться... :)

Не исповедимы пути ACPI на железе...
Как-то ловил граблю с ACPI на линухе, помогло обновление BIOS мамки....
За одно перестали глючить часы, стало нормально определяться USB и SCSI контроллер....

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "FreeBSD и железо."  +/
Сообщение от Аноним (??) on 17-Дек-17, 15:13 
НЕ ХОЧУ СОЗДАВАТЬ НОВУЮ ТЕМУ .....СПРОШУ ЗДЕСЬ

Embebed Board intel dx4 133, 32 mb

На борту IDE, floppy 3,5

Интерес спортивный, жеского диска пока нет, флоппика тоже пока нет, но наверное скоро разживусь IDE CD-ROM.

Посоветуйте что лучше поставить на такую конфигурацию, желательно с графикой, ethernet есть, ...

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "FreeBSD и железо."  +/
Сообщение от Аноним (??) on 17-Дек-17, 15:19 
> НЕ ХОЧУ СОЗДАВАТЬ НОВУЮ ТЕМУ .....СПРОШУ ЗДЕСЬ
> Embebed Board intel dx4 133, 32 mb
> На борту IDE, floppy 3,5
> Интерес спортивный, жеского диска пока нет, флоппика тоже пока нет, но наверное
> скоро разживусь IDE CD-ROM.
> Посоветуйте что лучше поставить на такую конфигурацию, желательно с графикой, ethernet
> есть, ...

Да и вообще хочу собрать этот антиквариат, корпус маленький и блок питания уже нашел ....

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "FreeBSD и железо."  +/
Сообщение от Аноним (??) on 17-Дек-17, 16:02 
>> НЕ ХОЧУ СОЗДАВАТЬ НОВУЮ ТЕМУ .....СПРОШУ ЗДЕСЬ
>> Embebed Board intel dx4 133, 32 mb
>> На борту IDE, floppy 3,5
>> Интерес спортивный, жеского диска пока нет, флоппика тоже пока нет, но наверное
>> скоро разживусь IDE CD-ROM.
>> Посоветуйте что лучше поставить на такую конфигурацию, желательно с графикой, ethernet
>> есть, ...
> Да и вообще хочу собрать этот антиквариат, корпус маленький и блок питания
> уже нашел ....

Попробую TinyCore, не получится буду из SlackWare собирать на флоппиках )))))))))))))))
Лишнее выкину

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "FreeBSD и железо."  +/
Сообщение от Аноним (??) on 17-Дек-17, 16:11 
Нашел ....


http://www.damnsmalllinux.org/486.html

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor