The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"OSPF ZEBRA FreeBSD 4.10"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Открытые системы на сервере (Маршрутизация, NAT / FreeBSD)
Изначальное сообщение [ Отслеживать ]

"OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от globus email(ok) on 16-Июн-08, 13:03 
привет все.
есть такая конфига FreeBSD 4.10 + zebra-0.95_2 с одной и с другой стороны
вот конфиг зебры

! -*- zebra -*-
!
! zebra sample configuration file
!
! $Id: zebra.conf.sample,v 1.14 1999/02/19 17:26:38 developer Exp $
!
hostname Router
password zebra
enable password zebra
!
! Interface's description.
!
!interface lo
! description test of desc.
!
interface gif0
multicast

interface rl1
multicast
!
! Static default route sample.
!
ip route 0.0.0.0/0 192.168.115.1 10
ip route 0.0.0.0/0 192.168.8.2 50
!

log file zebra.log
==================================
ospfd.conf
==================================
! -*- ospf -*-
!
! OSPFd sample configuration file
!
hostname ospfd
password zebra
enable password zebra
!
interface gif0

!
router ospf
network 192.168.10.0/24 area 0
network 192.168.8.0/24 area 0
network 192.168.115.0/24 area 1
!
redistribute connected
redistribute static

!
log file /var/log/zebra/ospfd.log
=========================================================

вот сеть

rl1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        inet 192.168.8.1 netmask 0xffffff00 broadcast 192.168.8.255
        inet6 fe80::213:8fff:fe1b:e570%rl1 prefixlen 64 scopeid 0x2
        ether 00:13:8f:1b:e5:70
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
gif0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1500
        tunnel inet 172.16.101.2 --> 172.16.101.1
        inet6 fe80::20e:2eff:fe56:e927%gif0 prefixlen 64 scopeid 0x7
        inet 192.168.115.2 --> 192.168.115.1 netmask 0xffffffff

Смотрю диагностику
show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface           RXmtL RqstL DBsmL

пусто , соседа не видет ...

дальше
show ip ospf interface
gif0 is up, line protocol is up
  OSPF not enabled on this interface
на gif интерфейсе молчок ...
куда копать ?!

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от butcher (ok) on 16-Июн-08, 13:42 
>на gif интерфейсе молчок ...
>куда копать ?!

Указать адрес соседнего роутера не пробовали?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от globus email(ok) on 16-Июн-08, 13:54 
>>на gif интерфейсе молчок ...
>>куда копать ?!
>
>Указать адрес соседнего роутера не пробовали?

пробовал ... конфиги приобритали строчки
neighbor 192.168.115.2 с одной стороны
neighbor 192.168.115.1 с другой
толку нет


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от butcher (ok) on 16-Июн-08, 15:07 
>>>на gif интерфейсе молчок ...
>>>куда копать ?!
>>
>>Указать адрес соседнего роутера не пробовали?
>
>пробовал ... конфиги приобритали строчки
>neighbor 192.168.115.2 с одной стороны
>neighbor 192.168.115.1 с другой
>толку нет

По-умолчанию, на сколько помню, интерфейсы находятся в пассивном режиме.
Попробуйте:
router ospf
no passive-interface gif0

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от globus email(ok) on 16-Июн-08, 17:41 
>[оверквотинг удален]
>>
>>пробовал ... конфиги приобритали строчки
>>neighbor 192.168.115.2 с одной стороны
>>neighbor 192.168.115.1 с другой
>>толку нет
>
>По-умолчанию, на сколько помню, интерфейсы находятся в пассивном режиме.
>Попробуйте:
>router ospf
> no passive-interface gif0

попробовал, толку нет ...

могет я туннель не правильно настроил ? хотя ... это ж поинт2поинт


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от Hammer (??) on 17-Июн-08, 08:10 
>[оверквотинг удален]
>>
>>По-умолчанию, на сколько помню, интерфейсы находятся в пассивном режиме.
>>Попробуйте:
>>router ospf
>> no passive-interface gif0
>
>попробовал, толку нет ...
>
>могет я туннель не правильно настроил ? хотя ... это ж поинт2поинт
>

interface gif0
Прописать ip address
!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от globus email(??) on 17-Июн-08, 09:00 
>interface gif0
>Прописать ip address
>!

а команду не подскажите ?

ЗЫ я и сам конечно поищу, но мало ли ...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от Hammer (??) on 17-Июн-08, 12:55 
>>interface gif0
>>Прописать ip address
>>!
>
>а команду не подскажите ?
>
>ЗЫ я и сам конечно поищу, но мало ли ...

conf t

int gif0
ip addre 192.168.1.1 255.255.255.252

end
wr

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от globus email(ok) on 17-Июн-08, 17:24 
Поменял настройки на тунели ...
теперь он выглядит так

gif0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1500
        tunnel inet 172.16.101.2 --> 172.16.101.1
        inet6 fe80::20e:2eff:fe56:e927%gif0 prefixlen 64 scopeid 0x7
        inet 192.168.116.2 --> 192.168.116.1 netmask 0xfffffffc


внес изменения в zebra.conf

теперь раздел про gif0 выглядит так

interface gif0                                    
ip address 192.168.116.2/30                        
multicast

толку нет ...  

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от globus email(ok) on 19-Июн-08, 16:21 
Ребяты Помогайте ... ум уже за разумзаходит ... толку нет ...
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от globus email(ok) on 25-Июн-08, 14:15 
>Ребяты Помогайте ... ум уже за разумзаходит ... толку нет ...

Ворос решился ... quagga 0.99.9

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

11. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от 910855 email(??) on 23-Авг-08, 13:26 
>Ворос решился ... quagga 0.99.9

Покажи как вопрос решился плиз


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

12. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от globus email(??) on 25-Авг-08, 05:34 
>>Ворос решился ... quagga 0.99.9
>
>Покажи как вопрос решился плиз

у тя какой конфиг счас ? и что стоит quagga или зебра ? выкладывай

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

13. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от sudosu (??) on 12-Янв-09, 08:55 
>[оверквотинг удален]
>router ospf
>network 192.168.10.0/24 area 0
>network 192.168.8.0/24 area 0
>network 192.168.115.0/24 area 1
>!
>redistribute connected
>redistribute static
>....
>на gif интерфейсе молчок ...
>куда копать ?!

ip ospf network point-to-point
в конфигурации ppp интерфейса в ospfd

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

14. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от Maxim_mun (ok) on 04-Июн-09, 14:58 
Подскажите есть quagga на линуксе.
В сервере 20 вланов и 10 pppoe, поднят OSPF, но почему то он посылает запросы во все интерфейсы, как ей это запретить?

Суть в том что прописывать все интерфейсы в конфиге не даёт. слишком много говорит.
Как сделать все интерфейсы по умолчанию в пассивном режиме?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

15. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от globus email(??) on 05-Июн-09, 05:07 
>Подскажите есть quagga на линуксе.
>В сервере 20 вланов и 10 pppoe, поднят OSPF, но почему то
>он посылает запросы во все интерфейсы, как ей это запретить?
>
>Суть в том что прописывать все интерфейсы в конфиге не даёт. слишком
>много говорит.
>Как сделать все интерфейсы по умолчанию в пассивном режиме?

задай на каких интерфейсах бродкастить

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

16. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от Maxim_mun (ok) on 05-Июн-09, 08:04 
>>Подскажите есть quagga на линуксе.
>>В сервере 20 вланов и 10 pppoe, поднят OSPF, но почему то
>>он посылает запросы во все интерфейсы, как ей это запретить?
>>
>>Суть в том что прописывать все интерфейсы в конфиге не даёт. слишком
>>много говорит.
>>Как сделать все интерфейсы по умолчанию в пассивном режиме?
>
>задай на каких интерфейсах бродкастить

Заданно только на одном.
А он по умолчанию вроадкастит на всех возможных, ип адреса в которых подподают под маску сети, которую он вещает.


Может можно как то изменить умолчание, то есть по умолчанию все интерфейсы пассивные или вообще отключены??

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

17. "OSPF ZEBRA FreeBSD 4.10"  +/
Сообщение от Аноним email(??) on 24-Фев-10, 09:44 
OSPF на gif: http://sysadmins.ru/topic207225.html
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру