The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Странная роблема с pppd, Dialup SLES 10 -> Windows 2003"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"Странная роблема с pppd, Dialup SLES 10 -> Windows 2003"  
Сообщение от stormf1 email(ok) on 24-Июн-07, 10:27 
Пытаюсь установить модемное соединение SLES 10 -> Windows 2003

связь устанавливается, в окошке информации kppp показывается что передаются пакеты, принятые и отправленные.
но на самом деле он даже не пингуется (имею ввиду виндовый комп по ту сторону линии)
Брандмауэр на линуксе выключен на виндовом тоже.

сетевая карточка ras сервера с win находится в диапазоне 192.168.0.0/24
ип адрес впн сервера 10.0.0.1
клиентский компьютер с sles имеет адрес сетевой карточки из диапазона 192.168.1.0/24
а при подключении к ras серверу ему выдается ип адрес 192.168.0.60 из диапазона локальной сети ras сервера


с таким конфигом устанавливается соединение нормально
sles:~ # cat /etc/ppp/options
modem
crtscts
asyncmap 0
require-mschap-v2
mppe-stateful
require-mppe
defaultroute
noipdefault
proxyarp

но ни один из ип адресов ras сервера не пингуется :(
(192.168.0.1 и 10.0.0.1)
хотя клиенту (suse) присваевается адрес из локальной сети Windows 2003 сервера 192.168.0.60

может косяк в маршрутизации? хотя по идее defaultroute из /etc/ppp/options прописывает правило в таблицу маршрутизации,
в файлах /proc/sys/net/ipv4/ip_forward и /proc/sys/net/ipv4/ip_dynaddr как и положено прописаны еденички (1)

Таблица маршрутизации до установки соединения
sles:~ # route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

Таблица маршрутизации после установки соединения
sles:~ # route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.0.0.1 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 10.0.0.1 0.0.0.0 UG 0 0 0 ppp0

sles:~ # ifconfig ppp0
ppp0 Link encap:Point-to-Point Protocol
inet addr:192.168.0.60 P-t-P:10.0.0.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1496 Metric:1
RX packets:2775 errors:4 dropped:0 overruns:0 frame:0
TX packets:4623 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:382587 (373.6 Kb) TX bytes:219205 (214.0 Kb)

лог pppd
Jun 24 01:15:15 sles pppd[4907]: Plugin passwordfd.so loaded.
Jun 24 01:15:15 sles pppd[4907]: pppd 2.4.3 started by root, uid 0
Jun 24 01:15:15 sles pppd[4907]: Using interface ppp0
Jun 24 01:15:15 sles pppd[4907]: Connect: ppp0 <--> /dev/ttyS0
Jun 24 01:15:17 sles pppd[4907]: MPPE 128-bit stateful compression enabled
Jun 24 01:15:18 sles pppd[4907]: Cannot determine ethernet address for proxy ARP
Jun 24 01:15:18 sles pppd[4907]: local IP address 192.168.0.60
Jun 24 01:15:18 sles pppd[4907]: remote IP address 10.0.0.1
Jun 24 01:15:18 sles pppd[4907]: primary DNS address 192.168.0.2
Jun 24 01:15:18 sles pppd[4907]: secondary DNS address 192.168.0.3
Jun 24 01:15:18 sles modify_resolvconf: Service pppd modified /etc/named.d/forwa rders.conf. See info block in this file
Jun 24 01:15:18 sles named[3243]: loading configuration from '/etc/named.conf'
Jun 24 01:15:18 sles named[3243]: listening on IPv4 interface ppp0, 192.168.0.60 #53
Jun 24 01:15:18 sles ip-up: Reloading name server BIND server reload successful
Jun 24 01:15:18 sles ip-up: ..done
Jun 24 01:15:18 sles pppd[4907]: script /etc/ppp/ip-up finished (pid 4918), stat us = 0x0


результаты пингов:
sles:~ # ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
и так висим до бесконечности пока Ctrl+C не нажму
--- 192.168.0.1 ping statistics ---
6 packets transmitted, 0 received, 100% packet loss, time 5003ms

sles:~ # ping 10.0.0.1
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
тут тоже самое никаких ответов
--- 10.0.0.1 ping statistics ---
127 packets transmitted, 0 received, 100% packet loss, time 126141ms

если разорвать соединение появляется:
ping: sendmsg: Network is unreachable

пробовал и вручную назначить клиенту sles ип адрес 192.168.0.60 а шлюзом 10.0.0.1 или 192.168.0.1, но безрезультатно :(
в чем дело может быть не врублюсь, уважаемые гуру направьте на путь истинный

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Странная роблема с pppd, Dialup SLES 10 -> Windows 2003"  
Сообщение от stormf1 email(ok) on 24-Июн-07, 10:56 
так же еще выяснилась одна странная вещь:
при попытке пингануть с sles другой компьютер находящийся в его локальной сети
sles:/boot # ping athlon
PING athlon.amd.local (192.168.1.3) 56(84) bytes of data.
сначала он долго думает, около 15 секунд и только потом идут пинги
64 bytes from 192.168.1.3: icmp_seq=1 ttl=128 time=0.172 ms
64 bytes from 192.168.1.3: icmp_seq=2 ttl=128 time=0.181 ms

в чем может быть причина столь странного поведения пингов?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Странная роблема с pppd, Dialup SLES 10 -> Windows 2003"  
Сообщение от stormf1 email(ok) on 24-Июн-07, 21:13 
судя по лампочкам на модеме при пинге ras сервера пакетики бегают (RD и TD лампочки перемигиваются).
запустил Ethernal посмотреть что твориться на ppp0 при пингах ras сервера, он говорит что request'ы уходят на ras сервер но reply не возвращаются. как вообще такое может быть если лампочки на модеме да и статистика kppp показывает? файрволл абсолютно выключен!
я в недоумении в чем может быть проблема :(
nodeflate nobsdcomp novjccomp добавлял, результата 0 :(
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Странная роблема с pppd, Dialup SLES 10 -> Windows 2003"  
Сообщение от stormf1 email(ok) on 24-Июн-07, 23:12 
да вот еще только что соединился с диалап провайдером убрав из /etc/ppp/options строки mschap аунтефикации:
require-mschap-v2
mppe-stateful
require-mppe.
соединение прошло отлично, шлюз провайдера и интернет сайты пинговались нормально!
думал что проблема в файрволе на ras сервере, нет там все порты для 192.168.0.60 ip адреса открыты и если попытаться установить соединение с ras сервером с виндовой машины с mschap v2 аунтефикацией соединение работает пинги проходят тоесть сам ras сервер и mail.ru пингуются с виндовой машины :(((
что то не понятное вообще, кто может подсказать в чем дело?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру